Aller au contenu

GO Print

flasher sans ouvrir le boitier de l imprimante sur une Genius


Cherok's

Messages recommandés

Bonjour,

Je souhaite flasher mon FW sans ouvrir le boitier. Je suis donc parti sur le FW Molise qui permet de couper la connexion de l’écran de manière software. J’arrive bien a flasher le TFT sans soucis mais impossible de flasher la carte mère : Le PC n’arrive pas a se connecter a l’imprimante. J’ai le même problème avec prusa slicer, Cura et ardiuno ide.

si vous avez une idée de la cause de mon problème, je suis preneur. J’aimerais éviter l’ouverture de la bête.

IMG-20201128-WA0018.jpeg

Lien vers le commentaire
Partager sur d’autres sites

Salut @Cherok's

Je crois que si tu veux Flasher la GenL tu es Obliger d'ouvrir le boitier et débrancher la Nappe de l'écran car quand l'écran est allumer et branché il occuper le port série (
utilisant l'USB).

Lien vers le commentaire
Partager sur d’autres sites

Bonsoir

De mon côté j’ai pu flasher sans aucun souci ma X1 sans l’ouvrir.
J’ai appliqué la méthode décrite sur Docarti avec le firmware Molise - Marlin 2.0.6.1
- Flash du TFT
- déconnexion de l’écran via le nouveau logiciel du TFT
- flash du firmware.

Dans un premier temps j’avais utilisé le firmware tout prêt fourni avec les fichiers car je n’avais besoin que de la commande de pause M600.
Puis ensuite j’ai compilé moi même le firmware fourni pour utiliser la fonction ABL en utilisant le capteur Z par induction de la machine à la place d’un BLtouch ou d’un Touch-Mi.
J’ai compilé avec VScode et flashé avec PrusaSlicer
Tout fonctionne très bien.
J’ai fait ça sous Mac.


Envoyé de mon iPhone en utilisant Tapatalk

  • J'aime 1
  • Merci ! 1
Lien vers le commentaire
Partager sur d’autres sites

Bonjour,
Je souhaite flasher mon FW sans ouvrir le boitier. Je suis donc parti sur le FW Molise qui permet de couper la connexion de l’écran de manière software. J’arrive bien a flasher le TFT sans soucis mais impossible de flasher la carte mère : Le PC n’arrive pas a se connecter a l’imprimante. J’ai le même problème avec prusa slicer, Cura et ardiuno ide.
si vous avez une idée de la cause de mon problème, je suis preneur. J’aimerais éviter l’ouverture de la bête.
IMG-20201128-WA0018.thumb.jpeg.40aa1731093b6bae3de6ea1a91214557.jpeg

Avant de flasher. As Tu essayé de te connecter à l’imprimante avec un outil comme Pronterface?
Lien vers le commentaire
Partager sur d’autres sites

Oui, et n’ai aucun problèmes en utilisant Pronterface.


Ton message d’erreur te dis que tu as un pb de connexion. Tu te connecte sur le port com3 à 115200 bauds.
Est-ce les mêmes ports et paramètres de connexion que tu utilises avec Pronterface quand ça fonctionne ?
Lien vers le commentaire
Partager sur d’autres sites

Il y a 2 heures, D4vi9 a dit :

 


Ton message d’erreur te dis que tu as un pb de connexion. Tu te connecte sur le port com3 à 115200 bauds.
Est-ce les mêmes ports et paramètres de connexion que tu utilises avec Pronterface quand ça fonctionne ?

 

non. Pronterface se connecte à 250000 bauds qui est la vitesse à utiliser. Mais je cherche actuellement comment modifier cette vitesse dans prusaslicer. J'ai aussi essayé dasn Cura et je ne vois pas où la modifier.

Lien vers le commentaire
Partager sur d’autres sites

non. Pronterface se connecte à 250000 bauds qui est la vitesse à utiliser. Mais je cherche actuellement comment modifier cette vitesse dans prusaslicer. J'ai aussi essayé dasn Cura et je ne vois pas où la modifier.

Au pire tu peux modifier la vitesse de connexion de l’imprimante dans le menu du TFT. J’ai jamais essayé mais j’ai vu que c’était possible.
Lien vers le commentaire
Partager sur d’autres sites

Avec ardiuno ide ca ne fonctionne pas non plus : j'ai un time out.

Sur prusaslicer, j'ai bien un fichier de config correspondant à la Genius.

Sur le lien donné par D4vi9, je n'ai pas trouver d'info intéressante. J'ai même testé avec 2 PC différents et j'ai les mêmes résultats.

Lien vers le commentaire
Partager sur d’autres sites

Désolé alors je ne sais pas quoi te dire je n'ai pas encore essayé de flasher la Genius et sur les modèle avec MKS nano robin la question ce pose pas il suffit de mettre le firmware sur la SD (je l'ai fait sur la bluer de mon pote) mais sur les GenL c'est pas possible.

Si tu a respecté la procédure du molise avec déconnexion de l'écran via le menu du tft, je ne vois rien d'autres qu'un soucis de vitesse de communication avec le port serie moi aussi.

Lien vers le commentaire
Partager sur d’autres sites

Des personnes y arrivent sans problème. J'ai un ami qui l'a d'ailleurs fait sur sa genius sans aucuns soucis. Je ne comprend pas. J'ai fini par ouvrir la bête pour déconnecter l'écran. Bien entendu avec cette méthode cela fonctionne même si la manip est plus lourde. A noter que lorsque je flashe, d'après Prusaslicer, le transfert de données se faite à 11520 bauds. Après l'avoir flashé de cette manière, j'ai retesté sans déconnecter l'écran et j'ai toujours le même souci.

Je ne sais donc pas pourquoi certains y arrivent sans d"connecter l'écran et pourquoi je n'y arrive pas.  Je me suis installé un fw qui me permet de faire du MBL car je n'ai pas de BLtouch et je vais tenter d'exploiter le linear advance .

Lien vers le commentaire
Partager sur d’autres sites

je sais que sur certaine imprimante cela est lié au contrôleur série utilisé qui pose soucis, mais ce qui m'étonne c'est que je pensais que toutes les Genius avec exactement le même hardware, y aurais t'il des V1 et V2 ?

@Cherok's tu as installé quels version celle déjà compiler du molise sans bl touch ?

Ce qui n'est pas logique est le fait que tu n'utilise la même vitesse de communication via pronterface c'est incohérent (côté IT quand je me connectais en port com a un switch avec une vitesse non adapter j'avais la même chose), logiquement si tu y arrive avec pronterface alors la vitesse utilisé par pronterface est celle qui permet la bonne communication, mais avec Arduino ide tu devrais pouvoir choisir la vitesse facilement et te connecter. 

Lien vers le commentaire
Partager sur d’autres sites

Il y a 2 heures, Cherok's a dit :

Des personnes y arrivent sans problème. J'ai un ami qui l'a d'ailleurs fait sur sa genius sans aucuns soucis. Je ne comprend pas. J'ai fini par ouvrir la bête pour déconnecter l'écran. Bien entendu avec cette méthode cela fonctionne même si la manip est plus lourde. A noter que lorsque je flashe, d'après Prusaslicer, le transfert de données se faite à 11520 bauds. Après l'avoir flashé de cette manière, j'ai retesté sans déconnecter l'écran et j'ai toujours le même souci.

Je ne sais donc pas pourquoi certains y arrivent sans d"connecter l'écran et pourquoi je n'y arrive pas.  Je me suis installé un fw qui me permet de faire du MBL car je n'ai pas de BLtouch et je vais tenter d'exploiter le linear advance .

@Cherok's, je pense comme @MrMagounet qu'il y a quelque chose du coté de la config de la communication du port. J'ai cherché sans succès comment pouvoir modifier les paramètres dans PrusaSlicer. Désolé.

C'est cool que tu y sois arrivé au final (même si tu as été obligé d'ouvrir la bête).

Tu parles du MBL. Je vois que sur la Génius il y a aussi les capteurs par induction. Je pense qu'il doit être possible d'utiliser le capteur Z pour couvrir la fonction ABL. C'est ce que j'ai fait sur ma X1. n'hésite pas si tu as des questions à ce sujet.

Lien vers le commentaire
Partager sur d’autres sites

Il y a 5 heures, MrMagounet a dit :

je sais que sur certaine imprimante cela est lié au contrôleur série utilisé qui pose soucis, mais ce qui m'étonne c'est que je pensais que toutes les Genius avec exactement le même hardware, y aurais t'il des V1 et V2 ?

@Cherok's tu as installé quels version celle déjà compiler du molise sans bl touch ?

Ce qui n'est pas logique est le fait que tu n'utilise la même vitesse de communication via pronterface c'est incohérent (côté IT quand je me connectais en port com a un switch avec une vitesse non adapter j'avais la même chose), logiquement si tu y arrive avec pronterface alors la vitesse utilisé par pronterface est celle qui permet la bonne communication, mais avec Arduino ide tu devrais pouvoir choisir la vitesse facilement et te connecter. 

Je suis d'accord avec toi. C'est bizarre cette histoire de différence de vitesse de communication.

Je découvre arduino ide. Ce weekend je tenter de trouver des docs pour savoir où je peux modifier les paramètres de la vitesse de communication.

Sinon c'est bien avec la version sans BL touch déjà compilée que j'ai testé. j'ai même testé les autres fw de docarti qui permettent de flasher sans déconnecter l'ecran.

Par ailleurs pour l'utilisation du capteur inductif du z pour l'ABL, je trouve l'idée très ingénieuse. J'y penserai si un jour je passe sur un bed metal.

Lien vers le commentaire
Partager sur d’autres sites

J'ai un bed metal moi mais je me dit que si un de ces 4 je place une autres printer a côte de la Genius et décide de mettre l'auto leveling sur la seconde avec un BL touche j'ai juste les 2 connecteur a retirer et le BL touch a désactivé et hop, récupérer le Capteur Z oblige après a le remettre. Mais l'idée de le faire avec les pièce d'origine est super maline.

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...