Aller au contenu

Filament ABS

Problème pour remettre firmware stock sur Sidewinder X1


Messages recommandés

Bonjour à tous,

J'ai passer la journée à essayer 4 firmware différents, les deux premiers ne fonctionnaient pas, le troisième qui avait l'air de fonctionner à buguer lors d'une impression de test.

Je souhaitais simplement essayer de corriger le problème de plateau bombé qui provoque des impression de qualité inférieure à ce que cela devrait être.

Après 4 firmwares et pas d'amélioration (le dernière a bien rayé mon plateau, je décide de réinstaller le stock téléchargé sur github.

Problème au niveau du flashage, il me dit :

image.png.46764ce86ef085dd41880b0232b5a54e.png

 

Le détail si cela peux aider !

avrdude-slic3r -v -p atmega2560 -c wiring -P COM6 -b 115200 -D -U flash:w:0:C:\Users\Patrice\Google Drive\Informatique\Impression3D\Sidewinder\Firmware\sidewider_stock\Marlin.ino.with_bootloader.mega.hex:i

avrdude-slic3r: Version 6.3-20160220-prusa3d, compiled on Mar 21 2020 at 12:45:57
                Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
                Copyright (c) 2007-2014 Joerg Wunsch


                Using Port                    : COM6
                Using Programmer              : wiring
                Overriding Baud Rate          : 115200
                AVR Part                      : ATmega2560
                Chip Erase delay              : 9000 us
                PAGEL                         : PD7
                BS2                           : PA0
                RESET disposition             : dedicated
                RETRY pulse                   : SCK
                serial program mode           : yes
                parallel program mode         : yes
                Timeout                       : 200
                StabDelay                     : 100
                CmdexeDelay                   : 25
                SyncLoops                     : 32
                ByteDelay                     : 0
                PollIndex                     : 3
                PollValue                     : 0x53
                Memory Detail                 :

                                         Block Poll               Page                       Polled
                  Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
                  ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
                  eeprom        65    10     8    0 no       4096    8      0  9000  9000 0x00 0x00
                  flash         65    10   256    0 yes    262144  256   1024  4500  4500 0x00 0x00
                  lfuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
                  hfuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
                  efuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
                  lock           0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
                  calibration    0     0     0    0 no          1    0      0     0     0 0x00 0x00
                  signature      0     0     0    0 no          3    0      0     0     0 0x00 0x00

                Programmer Type : Wiring
                Description     : Wiring
                Programmer Model: AVRISP
                Hardware Version: 15
                Firmware Version Master : 2.10
                Vtarget         : 0.0 V
                SCK period      : 0.1 us

avrdude-slic3r: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.01s

avrdude-slic3r: Device signature = 0x1e9801 (probably m2560)
avrdude-slic3r: safemode: hfuse reads as D8
avrdude-slic3r: safemode: efuse reads as FD
avrdude-slic3r: reading input file "C:\Users\Patrice\Google Drive\Informatique\Impression3D\Sidewinder\Firmware\sidewider_stock\Marlin.ino.with_bootloader.mega.hex"
avrdude-slic3r: writing flash (64798 bytes):
avrdude-slic3r: stk500v2_command(): command failed

Writing | ################################################## | 100% 0.00s

avrdude-slic3r: 64798 bytes of flash written
avrdude-slic3r: verifying flash memory against C:\Users\Patrice\Google Drive\Informatique\Impression3D\Sidewinder\Firmware\sidewider_stock\Marlin.ino.with_bootloader.mega.hex:
avrdude-slic3r: load data flash data from input file C:\Users\Patrice\Google Drive\Informatique\Impression3D\Sidewinder\Firmware\sidewider_stock\Marlin.ino.with_bootloader.mega.hex:
avrdude-slic3r: input file C:\Users\Patrice\Google Drive\Informatique\Impression3D\Sidewinder\Firmware\sidewider_stock\Marlin.ino.with_bootloader.mega.hex contains 64798 bytes
avrdude-slic3r: reading on-chip flash data:

Reading | ################################################## | 100% 0.00s

avrdude-slic3r: verifying ...
avrdude-slic3r: verification error, first mismatch at byte 0xe000
                0x09 != 0x0d
avrdude-slic3r: verification error; content mismatch

avrdude-slic3r: safemode: hfuse reads as D8
avrdude-slic3r: safemode: efuse reads as FD
avrdude-slic3r: safemode: Fuses OK (E:FD, H:D8, L:FF)

avrdude-slic3r done.  Thank you.

Voilà, là, je suis un peux bloqué !

Je précise qu'elle a été achetée début décembre, carte MKS V1

Merci pour votre aide.

Patrice

Modifié (le) par pat34400
Précisions
Lien à poster
Partager sur d’autres sites
  • pat34400 changed the title to Problème pour remettre firmware stock sur Sidewinder X1
  • Réponses 108
  • Created
  • Dernière réponse

Top Posters In This Topic

Salut @pat34400 Galère pour toi, je suis pas un expert du tout. Souvent ce que j'ai lu sur le web sur ce genre de soucis venait de problème de driver de soucis de communication usb.

Tu as tentez la maj via Prusa ? as tu essayé avec arduino ide ?

Désolé je suis pas d'un grand secoure je pense.

Lien à poster
Partager sur d’autres sites

Bonsoir, oui oui, j'ai l’habitude de mettre des firmwares à jour, je travaille dans l'informatique, je découvre la compilation des firmware avec Arduino, mais rien de sorcier pour un informaticien. J'ai flashé 4 fois sans problèmes, c'est juste que le comportement ne me convenait ou que cela ne fonctionnait pas correctement, du coup, j'ai récupéré le firmware normalement d'origine sur le Github de Artillery, mais bug au moment du flashage ?

Le truc que je ne savais pas, c'est que lorsque l'on compile, il y a deux fichiers qui sont générés, un avec le bootloader et l'autre non, j'ai utilisé celui avec le bootloader, mais du coup, c'est peut être l'erreur, j'ai arrêté de bidouiller en espérant trouver de l'aide sur les forum et groupe, mais pour le moment, pas de réponse à part la tienne.

Par contre, le problème de carte qui n’accepte pas le flashage du firmware d'origine, je ne sais pas encore gérer sur une imprimante 3D, je suis un peu bloqué !

Je me demande s'il ne va pas falloir racheter une carte mère !

Modifié (le) par pat34400
Lien à poster
Partager sur d’autres sites

Euuu j'ai eu le cas déjà t'as pas des librairies Arduino qui se sont mise à jour ?

Moi j'en ai une qui m'empêche de flasher marlin 1.1.9 elle ne prend que le 2xxx.

Je regarde si je retrouve la coupable en espérant que c'est bien la même chose

Lien à poster
Partager sur d’autres sites

Bon, là, cela fait plusieurs heures que je suis à la recherche d'une solution, et comme j'ai enchainé les flash, testé, reflashé et pour finir retenté de flasher le stock, je ne sais plus trop ce qu'il en était.

Je vais refaire des tests demain, en essayant de reflasher le stock, mais sans le bootloader !

Peut-être reflasher le tft avant

Lien à poster
Partager sur d’autres sites

Perso je televerse directement avec Arduino ide et j'ai jamais eu de problème à pas une librairie trop récente pour le vieux marlin une fois. 

Suis sous linux donc j'ai pas besoin de driver juste Arduino en SU. 

Le tft est bien débranché ? 

Lien à poster
Partager sur d’autres sites

Bonjour, oui, normalement le tft était bien débranché, mais vous me mettez le doute. Je vais réessayé dans la journée !

Sinon, pour le bootloader, j'ai fais des recherches hier soir et en fait, il est possible de le réinjecter à partir d'une carte Arduino ou un truc plus petit fait pour ça, un usbtinyisp.

https://www.amazon.fr/gp/product/B0785RQ766/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1

Je l'ai commandé au cas ou le problème viens vraiment de là.

Lien à poster
Partager sur d’autres sites

Ok essaye quand-même de flasher directement depuis Arduino IDE. 

Moi ça m'est même arrivé que le câble USB soit arraché pendant un flash (bien évidemment ça démarre plus). Ben juste en débranchant tout puis rebranche et nouveau flash et tout est reparti sans difficulté. 

C'est pour ça je pense que ça se tente 

Tiens nous au courant

Lien à poster
Partager sur d’autres sites
Il y a 2 heures, MrMagounet a dit :

Oui tiens nous au courant de l'évolution sa m’intéresse de savoir ce qui t'a posé soucis sur une des 2 imprimantes un de ces 4 🙂 

Hello, pour le moment, c'est juste le bed qui n'est pas droit et du coup, impossible d'avoir de beau print !

L'idée de changer de firmware, c'était juste pour résoudre ce problème de bed bombé avec le MBL.

J'ai mis les main dans le cambouis un peu plutôt qu prévu, car avant de customiser plus loin les réglages pour de meilleur print, il faut déjà apprendre à configurer correctement un slicer, gérer les filaments, régler sa machine, apprendre à dessiner ses propres pièces sur Fusion 360 ou autre, et c'est pas mal de boulot.

J'espère que je vais m'en sortir assez rapidement, car là, je suis en panne et c'est plutôt frustrant.

Aujourd'hui, j'aurais pas le temps de retenter le flash, mais par précaution, j'ai commandé un usbtinyisp qui devrait me permettre de réinstaller un bootloader sur la carte mère si c'est ça le problème.

Modifié (le) par pat34400
Correction
Lien à poster
Partager sur d’autres sites

J'avoue. Que le plateau bombé c'est bien pourri pour démarrer. T'as essayé de lui faire des cycles chauffe a 100 pendant 15 minutes puis refroidissement complet 3 ou 4 fois d'affilée voir si ça travaille pas un peu dans le bon sens? Pour certains ça a pas mal aidé

Lien à poster
Partager sur d’autres sites
il y a 9 minutes, M1K3D0 a dit :

J'avoue. Que le plateau bombé c'est bien pourri pour démarrer. T'as essayé de lui faire des cycles chauffe a 100 pendant 15 minutes puis refroidissement complet 3 ou 4 fois d'affilée voir si ça travaille pas un peu dans le bon sens? Pour certains ça a pas mal aidé

Malheureusement, non, je ne savais pas que c'était possible, j’essaierai lorsque j'aurai fais redémarré la machine 😪

Lien à poster
Partager sur d’autres sites
il y a 39 minutes, MrMagounet a dit :

M1K3D0 Cela fonctionne mieux sur des bed alu que boro (cela étonnerais qu'il arrive a quelques chose de probant sur du boro)

Alors l'astuce c'estque les vis qui maintiennent le plateau en verre sont collés avec de la colle époxy s'ils sont pas collés parfaitement droit avec la chauffe ça tire sur le vert et ça vient à créer des contraintes qui peuvent ou le rendre bombé ou creux.

L'astuce de faire chauffer plusieurs cycle avec bien évidemment les ressorts détendu pour ne pas rajouter de contraintes ça permet juste dans le cas pose le défaut et bien lié au fixation des vis de rattraper un petit peu le défaut.

Le verre borosilicate se déforme aussi même avec ces épaisseurs je l'ai vu de mes yeux vu lol. 

Par contre j'ai trouvé nulle part dans la doc si c'était du verre borosilicate ou du verre trempé quoi qu'il en soit et deux peuvent travailler avec les contraintes et la chauffe.

Juste pour l'info un plateau en alu comme le mien par exemple ne bouge pas du tout avec la chauffe il fait 5 mm d'épaisseur c'est de l'aluminium de fonte et là ça bouge pas à la chauffe d'ailleurs les supports des  plaquettes pour la fabrication composants électroniques comme les puces des CB sont aussi fait en fonte d'aluminium et c'est soumis à des températures bien au-delà de ce que feront nos imprimante 3D.

Lien à poster
Partager sur d’autres sites

Pour la fonte d'alu je dit pas mais les plateau de ender 3 n'en sont pas par exemple et il peuvent bien plus facilement reprendre ne compte une bonne forme a la chauffe.

Mais je note ton info autant l'alu je connais bien (j'ai bosse un peux dedans), autant le verre je connais pas super bien toutes les caractéristique des différentes catégorie je te fait donc confiance 😉 

Lien à poster
Partager sur d’autres sites

Et en plus ça coûte rien d'essayer 😁 enfin si .. du temps et un peu électricité. Ça a marché pour certains

un exemple vite fait (j'ai pas cherché partout où j'avais chercher à l'époque) sgt taz donne la manip plus précisément

https://www.thingiverse.com/groups/artillery-sidewinder-x1-evnovo/forums/artillery-swx1/topic:48731#comment-5001116

Modifié (le) par M1K3D0
petit oubli
Lien à poster
Partager sur d’autres sites
il y a 2 minutes, MrMagounet a dit :

Pour la fonte d'alu je dit pas mais les plateau de ender 3 n'en sont pas par exemple et il peuvent bien plus facilement reprendre ne compte une bonne forme a la chauffe.

Mais je note ton info autant l'alu je connais bien (j'ai bosse un peux dedans), autant le verre je connais pas super bien toutes les caractéristique des différentes catégorie je te fait donc confiance 😉 

A oui l'alu des plateaux d'origine comme creality tu le plis comme un rien. Js tech a fait une vidéo pour sa CR10. Moi le mien j'ai essayé pour voir ben même en sautant dessus a pied joint de mes 75kg ben il a pas bougé 😁

Je suis pas expert mais j'ai 2 verres borosilicate un 3mm et un 4 j'ai fait le test d'y mettre quelques épaisseurs de papier au centre ou sur les côtés ben les 2 suivent la déformation. C'est pas très scientifique j'avoue mais pour moi c'est parlant. Après en 5mm comme il le semble nos plateaux d'origine j'ai trouvé que du verre trempé et lui déforme en chauffant ( même si c'est minime) et si il a des contraintes encore pire.

Un bon verre borosilicate de 4mm ça coûte un bras et un œil en France (entre 90 et 120€ chez une spécialiste du verre) et même en Chine un bon 3mm c'est 30€ sans l'expédition. Du coup je doute fortement que sur la sidewinder ça soit pas plutôt un verre trempé (on le trouve à 25€-30€ livré chez Ali ou banggood) surtout vu le nombre de plateaux non plans que beaucoup de monde rapporte. (Pure déduction personnelle vu que j'ai rien trouvé de chez artillery qui donne le type de verre utilisé)

Lien à poster
Partager sur d’autres sites

Bonjour à tous,

TOUT VA BIEN, ouf !

J'ai eu le temps de me coller à l'imprimante aujourd'hui, et j'ai pu flashé le stock carte mère + tft que j'avais récupéré sur le Github d'Artillery.

Plus de peur que de mal, mais j'y est passé une journée au total, ce qui me dérange le plus, c'est d'avoir rayé mon plateau.

Pour le reste, flashé 5 fois sa machine en une journée, c'est formateur.

Pour le stock, comme me la suggéré M1K3D0, j'ai téléversé directement avec Arduino IDE et cela à fonctionné sans problème.

Il me reste le doute de savoir pourquoi le flashage de la X1 a bugué lors de ma précédente tentative et que cela a cassé quelque chose dans ce qui était installé, car si j'ai oublié de débrancher le TFT, rien n'aurai du se passer sur la carte mère il me semble.

Car après ce flash raté,( je rappel, tentative de remettre le stock, hex généré avec Arduino, j'ai choisi le fichier avec bootloader sans savoir qu'il y avait un autre fichier sans le bootloader), au redémarrage, le tft avait perdu la communication avec la carte mère, donc, il s'est quand même passé quelque chose.

Je dirai que c'est une super expérience, et que avant de recommencer à flasher, je vais déjà essayé de comprendre l'importance des paramètres de marlin, et du coup, une fois qu'on maitrise le processus de flash on peu s'amuser à tester ce qui marche ou ne marche pas.

Mais surtout, je vais m'installer un interrupteur 4 fils pour pouvoir déconnecter le tft sans ouvrir l'imprimante et être obligé de démonter et remonter à chaque flash, car il y a le ventilo sur la plaque du dessous et par expérience, des carte mère sans ventilo, ça peut être dangereux.

J'ai aussi commandé comme je l'ai déjà mentionné un usbtinyisp qui devrait me permettre de rechargé le bootloader si nécessaire.

Voilà un petit cube que j'ai imprimé ce matin après le reflash réussi du stock.

image.png.5f34ff1c211a281bf97c8bdc7d48026f.png

Et les dégâts sur le plateau à la suite du dernier firmware que j'avais installé. Après le réglage du MBL, j'ai voulu lancé l'impression des cinq carrés pour tester la planéité du bed, résultat, la buse était trop basse, pourquoi ?

image.png.736cfdb6d9a2123d61d7fd23367334ea.png

 

En tout cas, Merci à tous pour les conseils !

Lien à poster
Partager sur d’autres sites

C'est top si c'est reparti ! Et ça a l'air pas mal. Perso le MBL j'ai pas bien adhérer (calibrer à la feuille de papier c'est pas mon truc)

Perso je flash que comme ça et no soucis. Je flash pas non plus de firmware déjà compilé pas quelqu'un d'autre, j'ai toujours utilisé les fichiers sources pour pouvoir voir et comparer ce qui change par rapport au précédent, merci notepad++ 😁

Pour la déconnexion de l'écran j'ai installé le système de docarti car il est peu invasif et comme je compte un jour passé sur une CM 32bits je voulais pas faire de trou pour l'interrupteur. 

Je te met le lien si ça t'intéresse

https://docarti.fr/flasher-la-swx1-sans-louvrir/

Certains déconnectent que le fil rouge de l'alimentation de l'écran mais j'ai pas essayé pour être honnête

Lien à poster
Partager sur d’autres sites

Ou

il y a 7 minutes, M1K3D0 a dit :

C'est top si c'est reparti ! Et ça a l'air pas mal. Perso le MBL j'ai pas bien adhérer (calibrer à la feuille de papier c'est pas mon truc)

Perso je flash que comme ça et no soucis. Je flash pas non plus de firmware déjà compilé pas quelqu'un d'autre, j'ai toujours utilisé les fichiers sources pour pouvoir voir et comparer ce qui change par rapport au précédent, merci notepad++ 😁

Pour la déconnexion de l'écran j'ai installé le système de docarti car il est peu invasif et comme je compte un jour passé sur une CM 32bits je voulais pas faire de trou pour l'interrupteur. 

Je te met le lien si ça t'intéresse

https://docarti.fr/flasher-la-swx1-sans-louvrir/

Certains déconnectent que le fil rouge de l'alimentation de l'écran mais j'ai pas essayé pour être honnête

Oui, tu as raison pour ce qui est de compiler ces propres firmwares. Évidement, j'ai pas mal potassé le truc pendant ces deux jours, examiné les sources de plusieurs firmwares, et je commence à me faire une idée. Par contre, c'est vrai que pour l'impression 3D, il y a beaucoup de paramètres, et c'est pas simple de comprendre le fonctionnement.

Je suis tombé sur un truc cool, un firmware Marlin pour Tornado, mais traduit en français, et ça, c'est plus cool pour comprendre le rôle de chaque paramètres et éventuellement des les activés ou non et de savoir mettre les bonnes valeurs.

Le lien : https://www.thingiverse.com/thing:3823241

En tout cas, c'était un plaisir d'échanger sur ce forum et d'avoir des avis avertis !

Et merci pour le lien vers docarti et la modif pour pouvoir déconnecter le tft.

Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

  • YouTube / Les Imprimantes 3D .fr


×
×
  • Créer...