Aller au contenu

Filament ABS

  • 0

réglage du pas sur l'axe z sur Ender 5pro


Question

Bonjour tout le monde:

Je suis entrain de contrôler le réglage de mes pas pour mes moteurs, si le X et le Y sont impeccable, il n'en est pas de même pour le Z en effet lorsque je demande un déplacement de 100mm j'obtiens un déplacement de 50.5 mm, mes valeurs affichées semblent correctes, j'ai essayé de calculer le steepl qu'il faudrait programmer pour obtenir un pas correcte mais cela me parait énorme, étant un débutant dans cette discipline, ( je n'ai cette imprimante que depuis une semaine), je suis un peu perdu, une telle différence vous parait elle plausible,

D'avance merci pour vos réponses 

Lien à poster
Partager sur d’autres sites

10 réponses à cette question

Messages recommandés

  • 1
il y a 14 minutes, hymmer27 a dit :

une telle différence vous parait elle plausible,

Oui, si le firmware ne tient pas compte des «nouvelles» vis trapézoïdales.

Sur les premiers firmwares le pas de l'axe Z est de 400 (vis trapézoïdale d'un pas (pitch) de 2 mm pour une avance (lead souvent mal traduit par «plomb» 😉 ) de 8 mm),

Comme ces vis avaient tendance lorsque le moteur de l'axe Z était coupé à faire descendre seul le plateau par gravité, Creality a rectifié le tir en remplaçant cette vis par une de pas de 2 mm mais d'avance 4 mm, pour laquelle le pas est de 800 (simple au double d'où ton 50 mm pour 100 mm demandé).

Sans aller jusqu'à flasher ton firmware, tu peux forcer ce paramètre dans ton Gcode de démarrage du trancheur que tu utilises, en ajoutant simplement avant par exemple le G28, une ligne qui contient :

M92 Z800 ; estep Z de 800 pas

Ou en utilisant une option via l'écran (si elle existe toujours sur les Ender5) mais il va falloir tourner longtemps le potentiomètre pour passer de 400 à 800 😄

Un petit dessin pour une vis trapézoïdale :

vis-trapezoidale-lead-pitch(avance-pas).png.cba21bd5de849fb2c679c3270a68eeea.png

🙂

Lien à poster
Partager sur d’autres sites
  • 1

Après avoir modifié le pas via l'écran et testé si c'est bien ça le problème, n'oublie pas d'enregistrer cette valeur dans l'EEPROM via l'option « Store settings» sinon après extinction de l'imprimante il faudra que tu tournes à nouveau le potentiomètre 😉

Lien à poster
Partager sur d’autres sites
  • 0

Ha yessss... en effet zarbi... et il ne fait pas de bruit ? Peut être ton reglage de vref qui fait que ton moteur saute des pas mais c'est quand même beaucoup pour une imprimante neuve...
Que dit le sav ?

Envoyé de mon SM-N960F en utilisant Tapatalk



Lien à poster
Partager sur d’autres sites
  • 0

Je n'ai pas encore contacté le sav, j'espère trouver la solution sur le net, faute de quoi je les contacterai. en espérant qu'il y en ait un et qu'ils parlent français, l'imprimante m'a été offerte par mes enfants et je n'ai pas encore la facture ce qui fait que je ne sais pas ou ils l'ont achetée 

salutations jean marie

Lien à poster
Partager sur d’autres sites
  • 0

Bonjour et merci pour ta réponse:

Effectivement j'ai cette possibilité de modifier la pas via le petit écran mais effectivement c'est un peu casse pieds, j'avais commencé a le faire mais je n'ai pas osé aller jusqu'au bout car cela ma semblait énorme une telle différence mais après ton explication je commence a mieux comprendre, je vais donc essayer d'aller jusqu'à 800 et voir ce qui se passera.

PS: j'ai relevé toutes les valeurs d'origine comme cela en cas de problème je pourrais plus facilement revenir en arrière

 

J'ai vérifié ma vis effectivement j'ai bien une avance de 4 mm pour un tour, il se pourrait bien que le problème vienne de là,

Je vais régler ma machine et faire un essai après quoi je vous recontacterai pour vous donner le résultat.

encore merci salutations jean marie

Lien à poster
Partager sur d’autres sites
  • 0

@hymmer27

N'oublie pas d'ajouter le modèle de ton imprimante dans ton profil.

En haut à droite de la page, tu accèdes à ton profil en cliquant sur ton pseudo:

acces_1.thumb.png.06ffa2b12098ec373aac4db42898f5b9.png

Tu choisis la ligne "profil", puis l'option "Modifier le profil":

acces_2.png.912ab58cd55fbb21d012aa220b7edc9d.png    acces_3.png.21e858f3216e12b0adf31be3baecdeda.png

Tu effectues toutes les modifications que tu veux mais surtout la ligne "Imprimantes" que tu complètes:

acces_4.thumb.png.ce87d4f10d2e7669c63a8c4ecdea4842.png

Et tu n'oublies pas de valider en cliquant sur "Enregistrer":

acces_5.png.3e3e2f5b37da166999a1b2edbfe1a7ea.png


Bon réveillon et à l'année prochaine.

🙂

Lien à poster
Partager sur d’autres sites
  • 0

Bonjour et bonne année:

Le réglage à été effectué, maintenant le fonctionnement des trois axes est correcte, il n'y aura plus qu'à essayer cela dès que j'aurai un peu de temps libre.

Encore un grand merci et à plus

salutations jean marie

Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à cette question…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

  • YouTube / Les Imprimantes 3D .fr

×
×
  • Créer...