Aller au contenu

Filament ABS

Picaboubx

Retour d'instal Ecran DiscOLED by Dumnac + Impression Multi Couleur by Inteloide

Messages recommandés

Bonjour,

Voici mon retour d'expérience suite à l'installation de la Box by @dagoma DiscOLED by @Dumnac en conservant l'option d'impression multi couleur de @inteloide tel que proposé ici .

De plus, comme j'ai équipé ma Dago de LED d'éclairage en pied du portique Z, il m'était impossible d'utiliser la fixation proposé dans la Box de l'écran, j'ai du adapter ma propre version du support pour l'intégrer en face avant de la Dago devant le moteur Y.

Pour commencer, Avertissement sur le montage de la carte écran dans le boîtier à imprimer :

 Au moment du montage de la face arrière du boîtier, l'ergo demi-rond du capo arrière passe très très très prés de l'un des composants de la carte. Hors si vous n'avez pas suffisamment (comme moi) ébavuré celui-ci, il va appuyer sur le composant (entouré sur la photo) et il sera dessoudé. composant écran dézingué.jpg

J'ai du le ressouder, et croyez moi j'ai eu très très chaud sur ce coup car c'est petit, très petit :-( J'ai même un doute sur la qualité de cette réparation…

Cet accident réparé, pas de problème pour le reste du montage.

Seul la fixation du boitier écran n'était pas compatible avec ma machine, j'ai donc adapté une fixation spécifique que je vous met ici : Bras Modif.zip 

(Nota : le fichier joint à depuis été adapté pour éviter les 2 rondelles)

Une vis M3 de 10mm + écrou permet l'ensemblage des 2 morceaux

IMG_4641.jpg

 

Le passage des fils se fait sur le coté du moteur Y.

 

Concernant la mise à jour du Firmware, il suffit de suivre le Manuel fournis avec l'écran.

Seulement dans mon cas j'avais installé et je voulais conservé l'option impression multi-couleur de @inteloide , et suite à ma question, il a bien voulu ici me donner les infos de modif du Marlin pour avoir au final le beurre et l'argent du beurre ;-)

 

Résultat, pour le moment, cela fonctionne parfaitement.

Mon premier test est concluant

IMG_4642.jpg

 

Quelques remarques et points à prendre en compte :

- La position en Z sur l'écran ne s'affiche pas : Soit la modif du multi couleur pose problème, soit il y a un pb avec ma réparation/soudure, soit il y a un bug dans la mise à jour du Marlin.IMG_4634.jpg

- Le déplacement de la carte Melzi qui recule à l'intérieur de la machine pour pouvoir brancher le cablage, oblige au démontage de cache latéral droit (coté ports USB/CarteMicroSD) car il devient impossible d'accédé au port SD trop profond. Ou alors il faudra rajouter un rallonge sur ce port.

 

Coté qualité d'impression tout semble bon.

J'espère que cela vous sera utile.

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour ma part j'ai la barre d'avancement qui ne fonctionne pas toujours... je confirme donc qu'il y a encore des bugs dans le firmware.

Un estimatif du temps d'impression restant aurait été le bienvenu mais je crois que cette info n'est pas dans le fichier gcode. A mes heures perdues, je regarderai.

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut, pour l'affichage de l'axe Z il faut aller a la ligne 373 du firmware et changer "true" par "false" : #define DISABLE_Z false

J'ai eu le même souci, et j'ai trouver la solution sur le forum dans un post ou Dumnac rencontrer le même problème ;) par contre ca désactive l'arrêt automatique des moteurs apparemment, mais ca ne gêne en rien le fonctionnement de l'imprimante ^^ il y a peut être une autre solution mais mes connaissances en programmation son assez limité.

Pour la barre d'avancement j'ai le même souci et j'ai lu dans ce meme post que ca viendrai du logiciel que l'on utilise pour imprimer. Ca fonctionne avec ripitier, mais pas avec Cura par exemple :)

Ah et t'inquiète Picaboubx moi aussi j'ai dessouder partiellement un petit composant, j'ai eu peur sur le coup mais c'est réparer et ca fonctionne ;)

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut @PoïzUNK et merci pour cette info sur l'axe Z.

Aurait tu le lien du post de Dumnac correspondant ?

Quand tu dit que cela désactive l'arrêt automatique des moteurs, ça veut dire quoi ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut, @Picaboubx,

Ca ne désactive pas l' arret automatique des moteurs, ca force le maintien magnetique en position du moteur,pour justement lui permettre de connaitre sa position, l' option est désactivé par défaut dans le marlin Dagoma pour une simple raison: ca évite de faire chauffer les moteurs qui sont sous dimensionnés pour cela (les moteurs Z sont plus petits que les autres).Je trouve étrange qu' aucune mise en garde, ou avertissements, n' ai été fait à ce sujet, puisque si l' option à été désactivée dans le marlin, c' est justement que quelqu'un, à un moment, à du s' apercevoir de la chose ....

Tu verras que si tu lances une impression, sans forcément qu' elle soit d'une durée trop longue, tu auras une temperature de contact des moteurs bien supérieur qu' avant avoir fait la modif,ce qui aura des conséquences (saut de pas des moteurs pas à pas avec l' augmentaion de la température) et réduira l' espérance de vie de tes moteurs.

L' avantage c' est que pour un peu, tu n' auras pas besoin d' installer un lit chauffant, les moteurs se chargeront de maintenir la température ......:P

C'est juste pour te permettre de faire la modif en connaissance des contre-parties que cela entrainerai potentiellement,à toi de voir si ca chauffe plus, ou pas, et tu pourras toujours revenir à l'option d' origine du marlin si c' est le cas....

Partager ce message


Lien à poster
Partager sur d’autres sites

@Dal merci pour cette information que je vais m'empresser de mettre en balance avec l'intérêt d'avoir l'info de hauteur Z sur l'écran.

Il faut que je fasse le test comparatif des températures des moteurs avant et après. on verra en fonction du résultat. J'ai déjà une alimentation sur laquelle j'ai collé 2 profils Alu en guise de dissipateur thermique , j'aimerai éviter de cramer les moteurs ;-)

@PoïzUNK merci pour le lien, c'est très instructif.

Partager ce message


Lien à poster
Partager sur d’autres sites

En utilisant l'option palpeur, les moteurs en Z sont sous tensions non stop. Donc ca revient au même et ca ne pose pas trop de problème vu que tout le monde le fait ;D donc je ne croit pas que ce soit un problème de laisser les moteur Z sous tension pour l'écran. Ceci dis, je vais m'empresser d'aller acheter cette box. Ca me manque de voir l'avancée,...

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 8 heures, Tibus a dit :

En utilisant l'option palpeur, les moteurs en Z sont sous tensions non stop. Donc ca revient au même et ca ne pose pas trop de problème vu que tout le monde le fait ;D donc je ne croit pas que ce soit un problème de laisser les moteur Z sous tension pour l'écran. Ceci dis, je vais m'empresser d'aller acheter cette box. Ca me manque de voir l'avancée,...

C'est pas tout à fait pareil,d'ailleurs tu peux tres bien faire un G29 en ayant l' option du marlin désactivé.

Avec le G29 ton moteur est en mouvement (donc sous tension) pendant la compensation, et donc change de phase, là tu lui demande de faire un blocage magnétique des phases (donc sous tension mais pour empecher le mouvement cette fois), totalement l' inverse donc.A la limite, le G29 diminuera l'effet joules sur les moteurs qui chaufferont moins vite, perso je me contente du G28 meme sur le Z donc je peux pas te dire si le fait ou pas.

Tu prends un moteur lambda tu alimentes pas, pas de chauffe, tu alimentes, il tourne et chauffe normalement, tu le bloques et il monte direct en temperature(faut bien que l' energie se dissipe). Mais suivant plusieurs parametres :sa taille, la tension appliquée mais il chauffera plus quoi qu'il arrive.....pour les moteurs de X et Y, ils absorbent sans "trop" de pb (rien qui risque de les endommager) par contre, les moteurs Z sont pas à meme de pouvoir le faire aussi sereinement à cause de leur taille.Ce choix de la désactivation de l' option dans le marlin, se justifie, par la conception de la machine.D'origine, elle est fonctionnelle, et même mieux, il fallait que l' option soit désactivée pour pouvoir regler la hauteur de tete par rapport au plateau.... on est loin d' un affichage de la hauteur....

Ceci dit, J' ai installé aussi un afficheur (pas celui la mais le principe reste le même) sur ma machine et oui c' est pratique,mais pas sur une config de base.

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut @Picaboubx,

Merci pour ton retour !

Je vais faire une nouvelle version de la façade en réduisant la largeur de la patte de maintient  pour éviter le problème.

Concernant l'affichage du Z, il faut bien désactiver le DISABLE_Z. Ca fonctionne bien pour moi.

Pour le cache latéral, c'est vrai qu'il n'est plus adapté. Je vais rajouter une note dans le manuel et voir si je peux faire un autre cache qui va bien.

@+

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

 

Sans avoir désactivé le DISABLE_Z, avec le nouveau firrmware pour l'écran LCD, il me semble que je ne peux plus tourner les tiges de l'axe Z durant l'impression (vu lors d'une impression cette après midi). Ce qui prouve que même sans le désactiver le firmware maintient les moteurs de l'axe Z sous tension.

Quelqu'un a-t-il fait le même constat ?

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 13 heures, inteloide a dit :

Bonjour,

 

Sans avoir désactivé le DISABLE_Z, avec le nouveau firrmware pour l'écran LCD, il me semble que je ne peux plus tourner les tiges de l'axe Z durant l'impression (vu lors d'une impression cette après midi). Ce qui prouve que même sans le désactiver le firmware maintient les moteurs de l'axe Z sous tension.

Quelqu'un a-t-il fait le même constat ?

A priori ici c'est la même chose. impossible de tourner les tiges Z.

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 18/06/2016 at 23:49, inteloide a dit :

Bonjour,

 

Sans avoir désactivé le DISABLE_Z, avec le nouveau firrmware pour l'écran LCD, il me semble que je ne peux plus tourner les tiges de l'axe Z durant l'impression (vu lors d'une impression cette après midi). Ce qui prouve que même sans le désactiver le firmware maintient les moteurs de l'axe Z sous tension.

Quelqu'un a-t-il fait le même constat ?

même constat ici.

j ai aussi je pense un autre problème niveau température.

pour du pla octofiber sur c.b.dagoma, j ai 210 °C, alors que sur l ecran j ai 230°C a l impression O.o

Modifié (le) par fragator

Partager ce message


Lien à poster
Partager sur d’autres sites

Le firmware a de gros problème. Généralement l'écran se freeze après qqn minutes d'utilisation (on voit le symbole du ventilateur qui ne tourner plus).

Pour ma part en changeant le DISABLE_Z, c'est encore pire, je ne vois même plus la montée en température jusqu'au bout...

Je suis un peu déçu...

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 27 minutes, inteloide a dit :

Le firmware a de gros problème. Généralement l'écran se freeze après qqn minutes d'utilisation (on voit le symbole du ventilateur qui ne tourner plus).

Pour ma part en changeant le DISABLE_Z, c'est encore pire, je ne vois même plus la montée en température jusqu'au bout...

Je suis un peu déçu...

Pas de problème de freeze pour moi… pour l'instant. Mais je n'ai pas encore changer le DISABLE_Z

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 14/06/2016 at 05:35, PoïzUNK a dit :

Voici le lien du post ;)

merci @Dal pour cette précision importante !

sur la photo de l écran du liens, il et indiquez le temps restant de l impression... pas sur le miens. Mois, ces plutot en chronometre...

idem pour vous ??? 

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 12 minutes, fragator a dit :

sur la photo de l écran du liens, il et indiquez le temps restant de l impression... pas sur le miens. Mois, ces plutot en chronometre...

idem pour vous ??? 

De mon côté c'est le temps écoulé qui s'affiche 

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×