Aller au contenu

Filament ABS

Bug de l'axe Z : Cr-10 V3 + BLtouch


Messages recommandés

Bonjour à tous,

Hier j'ai décidé d'installer le BLtouch sur ma cr-10 V3. Seulement, à chaque fois que je flash le firmware, j'ai un gros soucis (après le flash).

Lorsque j'essai de paramétrer le bestiaux, l'axe Z ne fait que monter, il ne descend pas. Level bed test, move Axe Z, rien n'y fait. 

Le seul moyen est de remettre l'ancien firmware. 

Pensez-vous que c'est dû au BL touch? Ou à une erreur dans la compilation du firmware?

J'ai utilisé les firmware des sites officiels de creality et également celui d'un groupe facebook, mais toujours le même pb 😕

Des idées?

Edit: Après la réinstallation du FW du site créality + BLtouch, impossible de refaire de maj. Cura ne détecte pas l'imprimante et créality slicer me sort un beau: "Aucune machine trouvée pour ce firmware. Est-elle connectée à votre pc?

Si j'allume l'imprimante, j'ai accès à tous les menus...

J'y comprend plus rien 😕 

Merci 🙂

Modifié (le) par Stheno001
Lien à poster
Partager sur d’autres sites

Salut,

Le 18/03/2021 at 10:55, Stheno001 a dit :

l'axe Z ne fait que monter

Il faut commencer par faire une prise d'origine (homing / auto-home ou G28) pour pouvoir descendre la buse.

Mais avant, il faudrait que tu testes ton BLtouch pour t'assurer que le câble est compatible avec le firmware, en suivant ces instructions par exemple.

Pour le flashage du firmware: d'après ce sujet, ta carte-mère est une V2.5.2. As-tu essayé d'allumer l'imprimante avant de brancher le câble USB? Pour le transfert de firmware, Xloader est un peu plus efficace que Cura (il peine toujours à scanner les ports USB 😡...).

Sinon, en ligne de commande, dans la console Windows:

Pour le flasher, tu copies les fichiers ci-dessous dans C:\temp (dossier vide que tu devras créer)
1- tu copies le firmware dans ce dossier
2- tu ouvres une console Windows (touche Windows + "x" et tu cliques sur console). Pour mémoire, tu peux faire des copié-collé dans la console
3- tu envoies (pour te placer dans C:\temp):cd c:\temp
4- tu envoies (pour flasher le firmware):

avrdude -p atmega2560 -c arduino -P COM3 -b 115200 -v -U flash:w:firmware.hex:i
ATTENTION: il faut spécifier le bon numéro du port COM. C'est celui que tu choisis dans Arduino IDE -> outils -> Port et le bon nom du firmware (ici firmware.hex)

avrdude.conf avrdude.exe XLoader.zip

Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Créer...