Aller au contenu

Filament ABS

Problèmes en cascade sur une Genius (mais c'est probablement de ma faute) : Thermal Runaway et plus de mesure de température extrudeur [résolu]


Messages recommandés

Bonjour,

Je n'arrive plus à utiliser mon imprimante depuis quelques jours. Au bout d'environ 1/2heure d'impression, elle s'arrête sur une erreur : Thermal Runaway, system stopped! Heater_ID: 0

(la buse est bloquée sur la pièce qui a fondu à son contact)

J'ai soupçonné que la buse était colmatée (ce qui est vrai). Après l'avoir remplacée par une neuve, j'ai probablement cassé quelque chose car la température de l'extrudeur est maintenant fixée à -15. Au multimètre, je mesure environ 100kohm à température ambiante, ce qui me fait penser que la thermistance est encore bonne mais que la carte mère n'est plus connectée à cette dernière.

Avez-vous une idée de ce que je peux tester pour me sortir de ces problèmes ?

Merci d'avance

Modifié (le) par etil
Lien à poster
Partager sur d’autres sites

Bonjour et bienvenu parmi nous,

Un thermal Runaway, veut dire en gros "Emballement Thermique". A un moment donnée pour éviter de mettre le feu ta machine s'est arrêté car elle voyant la température augmenter sans arrêt et de façon incohérente.

Ce message n'indique pas si c'est c'est un emballement thermique du bed ou du corp chauffant, ca je ne sais pas!

Ce type d'erreur n'a rien a voir avec un buse bouché. 

Question: Si tu lance un préchauffage de ta buse, et du bed, est-ce que tu arrive a voir sur ton ecran les température monter et se stabiliser?

Si oui alors ca doit être un faux contact quelque part entre la sonde et la carte mère. Si dès le départ ca se met en erreur, ca doit erreur un panne franche, dans ce cas un fil coupé et un connecteur débranché.

Pour savoir si c'est le bed ou le corp de chauffe, essaye de préchauffer l'un apres l'autre pour voir lequel provoque une erreur!

Modifié (le) par Jonathan06
Lien à poster
Partager sur d’autres sites

A priori c'est le corps de chauffe car le bed donne la bonne température.

Avant que je change la buse, l'extrudeur montait bien en température et se stabilisait (j'ai fait un test de préchauffage avant de lancer l'impression). Depuis que j'ai changé la buse, je n'ai plus la température de l'extrudeur (l'afficheur est bloqué à -15°C ce qui doit signifier que j'ai cassé quelque chose : soit il y a un contact foireux vers la thermistance ou la care mère a un soucis.)

Bref, je creuse...

Lien à poster
Partager sur d’autres sites
il y a une heure, etil a dit :

Bonjour,

Je n'arrive plus à utiliser mon imprimante depuis quelques jours. Au bout d'environ 1/2heure d'impression, elle s'arrête sur une erreur : Thermal Runaway, system stopped! Heater_ID: 0

(la buse est bloquée sur la pièce qui a fondu à son contact)

J'ai soupçonné que la buse était colmatée (ce qui est vrai). Après l'avoir remplacée par une neuve, j'ai probablement cassé quelque chose car la température de l'extrudeur est maintenant fixée à -15. Au multimètre, je mesure environ 100kohm à température ambiante, ce qui me fait penser que la thermistance est encore bonne mais que la carte mère n'est plus connectée à cette dernière.

Avez-vous une idée de ce que je peux tester pour me sortir de ces problèmes ?

Merci d'avance

Sur le Thermal Runaway tu as eu des réponses au dessus, tu peux avoir un soucis de faux contact de câblage ou de soucis avec la MKS GenL.

La Température de l'extrudeur fixé a -15°c indique qu'il n'y a pas de retour de la sonde de température de la tête, si tu as testé et que a température ambiante tu as environs 100kohm alors elle est bonne, les Epcos 3950 et 104gt-2 sont toutes des thermistance de 100kohm pour environ 28°c.

Reste donc le câblage dans ce cas tu as 2 nappes a controler une de 30pins qui remonte le long du poteau Z de gauche, et une nappes 24pins (oui la Genius c'est 24 pin et la X1 20pins) qui parcours l'axe des X de la gauche jusque la tête d'impression, vérifie que les nappes sont bien enfiché et pas endommage ou cramer.

  • J'aime 1
Lien à poster
Partager sur d’autres sites

Je vais regarder au testeur de continuité. J'ai raté plusieurs impressions à cause de l'erreur thermal runaway, je me demande effectivement si la connectique est ok.

Lien à poster
Partager sur d’autres sites
il y a 1 minute, etil a dit :

Je vais regarder au testeur de continuité. J'ai raté plusieurs impressions à cause de l'erreur thermal runaway, je me demande effectivement si la connectique est ok.

Moi comme beaucoup on place un bloqueur de nappe sur la tête pour éviter qu'elle bouge durant les impression cela a conduit a plusieurs soucis de nappe qui bouge voir qui crame carrément.

Lien à poster
Partager sur d’autres sites

Est ce qu'il y a une solution de datalogger (peut être octoprint ?) pour surveiller son imprimante ?

Une fois que j'aurai résolu mon problème de mesure de température de corps de chauffe, je pense que je vais avoir encore le thermal runaway. La nappe est bloquée avec du scotch mais j'aimerai pouvoir rejouer le film de l'impression jusqu'à l'erreur et ainsi me donner une piste pour résoudre le problème.

Lien à poster
Partager sur d’autres sites

Octoprint te permet en effet visualiser certaines données comme la stabilité de la température du bed et de la buse, et certaine autres information après de la a te dire si tu aurais un historique de log je ne sais pas. De plus octoprint nécessitant que le port serie soit libre et comme sur la MKS GenL le port série est utilisé par le TFT tu sera obligé de débranché l'ecran TFT et de tous commande via octoprint.

  • J'aime 1
Lien à poster
Partager sur d’autres sites
Il y a 1 heure, MrMagounet a dit :

De plus octoprint nécessitant que le port serie soit libre et comme sur la MKS GenL le port série est utilisé par le TFT tu sera obligé de débranché l'ecran TFT et de tous commande via octoprint.

Alors ça c'est couillon...

Lien à poster
Partager sur d’autres sites

Je pense avoir trouvé ce qui cloche :

c'est la soudure du connecteur de la thermistance (cf. photo)

Après avoir refait la soudure, l'imprimante reporte la température comme il faut (depuis au moins 3h en tout cas...)

Je pense que la connexion était intermittente et que ça finissait par ne plus remonter la température avec les vibrations dues à l'impression. Dans ce cas, la MKS GenL interprétait la température comme -15°C ce qui engendre une erreur MINTEMP et arrête l'impression. La buse reste en place, surchauffe et finit par faire une erreur Thermal Runaway. C'est ma thérorie (pour ce qu'elle vaut).

 

IMG_2116.JPG

  • J'aime 1
Lien à poster
Partager sur d’autres sites

Bonjour,

J'ai aussi un message d'erreur de type Thermal Runaway ... sur ma sidewinder X1 d'origine sur laquelle je n'ai rien ajouter ou modifier (je sais pas comment faire de toute faocn ^^)

J'ai foiré deja 3 impressions au bout d'1 ou 2 h a chaque fois 😞

Comment vérifier le problème ? Je suppose que j'ai comme toi un faux contact.

Note: on voit pas bien sur la photo le problème 😕 tu parles de la pin qui ressort le plus au fond a gauche ?

Merci pour votre aide. 

Lien à poster
Partager sur d’autres sites
  • etil changed the title to Problèmes en cascade sur une Genius (mais c'est probablement de ma faute) : Thermal Runaway et plus de mesure de température extrudeur [résolu]
Il y a 1 heure, etil a dit :

Je pense avoir trouvé ce qui cloche :

c'est la soudure du connecteur de la thermistance (cf. photo)

Après avoir refait la soudure, l'imprimante reporte la température comme il faut (depuis au moins 3h en tout cas...)

Je pense que la connexion était intermittente et que ça finissait par ne plus remonter la température avec les vibrations dues à l'impression. Dans ce cas, la MKS GenL interprétait la température comme -15°C ce qui engendre une erreur MINTEMP et arrête l'impression. La buse reste en place, surchauffe et finit par faire une erreur Thermal Runaway. C'est ma thérorie (pour ce qu'elle vaut).

 

IMG_2116.JPG

Oui en effet elle est vraiment pourrie la soudure, a tout les coup la dilatation des matériaux fait que a une certaine temp ambiante cela fait contact et a d'autre moment pour la temp est plus basse le contact ne ce fait plus.

La c'est simple un peux de soudure (pas ROHS) et tu pourras vérifié.

Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Créer...