Aller au contenu

Filament ABS

Zoffset


michel34

Messages recommandés

Merci pour ton aide, j'ai appliqué ta procédure   et un store setting a la fin ,j'ai fais une impression mais la buse est au moins a 8mm du plateau j'ai éteint et rallumé l'imprimante et le Z est a 10 sa position d'origine. NB sur tous les tutos consultés aucun ne parle du probe offset! c'est sympa de vouloir faire évoluer sa bécane mais galère.

Lien vers le commentaire
Partager sur d’autres sites

  • Réponses 50
  • Created
  • Dernière réponse

Top Posters In This Topic

Hello @michel34, fait attention tu as créé un nouveau sujet au lieu de répondre au précédent que tu as créé dans lequel je t’avais répondu. Je te laisse copier coller ton message et le mettre dans l’autre sujet pour que la discussion soit plus lisible

Lien vers le commentaire
Partager sur d’autres sites

Merci pour ton aide, j'ai appliqué ta procédure   et un store setting a la fin ,j'ai fais une impression mais la buse est au moins a 8mm du plateau j'ai éteint et rallumé l'imprimante et le Z est a 10 sa position d'origine. NB sur tous les tutos consultés aucun ne parle du probe offset! c'est sympa de vouloir faire évoluer sa bécane mais galère.

bizarrement je n'avais pas l'option envoyer la réponse ! je suis inscrit de ce jour donc un peu de rodage.

Lien vers le commentaire
Partager sur d’autres sites

Bonjour,

en suivant ta procédure par le probe offset je n'ai plus le message d'erreur, par contre  l'auto home qui se positionnait à 10 d'origine se positionne maintenant à 13,2  (soit 10+3,2 ) ce 3,2 correspond au réglage pour affleurer le plateau mais comme c'est du moins pourquoi il vient s'additionner? de ce fait l'impression est encore plus décalée de ce  chiffre un point positif le réglage et bien sauvegardé, pour mémoire le bl touch est raccordé directement au port dédié 5 broches de la carte 4 2 7 TMC 2225 sur beaucoup de tutos il est raccorde a ce port via 3 broches noir rouge jaune et les 2 autres au port Z de la carte est ce que ceci à une incidence?

encore merci pour ton  aide, bien qu'ayant visionné beaucoup de tutos il est difficile de sortir une vérité pour les réglages Zoffset, le matériel changeant en permanence et avec les upgrades chacun a sa propre configuration c'est un mélange de matériels anciens et récents. Cordialement

Lien vers le commentaire
Partager sur d’autres sites

Je vais préciser un petit point pour être sûr de bien comprendre. Quand tu dis que après le auto home la tête va en 13.2, il s’agit juste de la position finale après home pour éloigner la tête du plateau.
Ce qui compte c’est ou est ton 0.
Essaye après le auto home de faire un move axis et descendre ton z a 0 pour voir.
Regarde à quelle distance se trouve maintenant la tête de ton plateau. Est-ce que la distance est correcte ? (Genre une feuille de papier gratte légèrement) où la tête est carrément aux fraises ou un peu trop haut ou même carrément dans le plateau ?

Lien vers le commentaire
Partager sur d’autres sites

Comme indiqué sur le boitier de contrôle après réglage la buse se trouve effectivement à 13,2 mm , pendant la procédure de réglage après auto home premier palier descente de 10mm pour un z à 0 après dans le probeoffset descente de 3,2 pour effleurer le plateau et sauvegarde cette procédure se déroule normalement.

phase de contrôle j'éteins la bécane je fais un auto home et la la buse se trouve effectivement à 13,2mm comme indiqué sur le boitier de commande,

étonnament les 3,2mm en descente donc négatif ce retrouve additionnés au réglage initial du firmware qui est de 10mm,j'ai testé une impression et la buse est dans les choux à environ 7mm du plateau

le bilan: le bl touch fonctionne parfaitemenr(nb: j'ai essayé un deuxième il fonctionne à l'identique)  ,le firm war d'origine est le bon sauf que le réglage Z offset est impossible et que se positionnement d'origine à 10mm du plateau m'interroge? ayant l'habitude d'un auto home à 0mm sans BL.

Le plaisir de faire évoluer sa bécane est parfois frustrant, mais bon l'essentiel est d'y arriver. Cordialement

Lien vers le commentaire
Partager sur d’autres sites

Le truc qui me chagrine c’est que je vois mal Creality release un firmware avec un si gros bug... c’est possible mais ça m’étonne. Pourrais tu me dire comment tu as branché ton bltouch ?
Via les ports de la carte mère ou via les 5 ports mais en utilisant que 3 et en utilisant le contacteur z pour les 2 restants ?

Lien vers le commentaire
Partager sur d’autres sites

J'ai monté le BL  directement sur le port dédié 5 broches, car je ne voyais pas la logique de certains tutos de faire 3 et 2 sur le Z  alors que le port existe sur la carte 4 2 7,devant mes soucis de réglages j'ai eu la tentation de faire ce genre de montage mais la carte mère est retournée sur ender pro plus câbles dupont attention aux risques de faux contacts  

Cordialement 

Lien vers le commentaire
Partager sur d’autres sites

il y a 34 minutes, michel34 a dit :

J'ai monté le BL  directement sur le port dédié 5 broches, car je ne voyais pas la logique de certains tutos de faire 3 et 2 sur le Z  alors que le port existe sur la carte 4 2 7,devant mes soucis de réglages j'ai eu la tentation de faire ce genre de montage mais la carte mère est retournée sur ender pro plus câbles dupont attention aux risques de faux contacts  

Cordialement 

Bon alors on va faire un truc, il se trouve que je dois recompiler marlin pour mon imprimante (ender 3 pro) avec mon bltouch que je vais brancher de la meme manière que toi, du coup je t'enverrai ma version qui devrait fonctionner pour toi aussi.

Si entre temps quelqu'un passe par ici avec une solution ou une idée ca serait top.

Modifié (le) par Angelbast
Lien vers le commentaire
Partager sur d’autres sites

Salut

Tu as pris quel firmware?

Pas grave si c'est une Ender5 la mienne, j' ai la même carte que toi 4.2.7, mon BLtouch est branché sur le port dédier ( les 5 fils sur le port, pas de Z séparé ), comme toi au démarrage c ' était du n' importe quoi, j' ai vu sur configuration.h de Marlin ( je compile moi même mon firmware ) la "boulette", il y a 2 port, évidemment je n' étais pas sur le bon:

 

Capture.PNG

 

J' ai commenté celui-ci: 

//#define USE_PROBE_FOR_Z_HOMING
 
Modifié (le) par Invité
Lien vers le commentaire
Partager sur d’autres sites

@michel34A tout hasard aurais tu un octoprint connecté a ton imprimante ou la possibilité de connecter un pc avec pronterface ?

Si tu peux est-ce que tu pourrais envoyer la commande M503 et me donner le contenu qui s'affiche stp ?

Lien vers le commentaire
Partager sur d’autres sites

Je te remercie pour cette proposition, en attendant je repasse sans BL au moins çà marche, et petite pause dans cette prise de tète .

Cordialement

 

je viens de lire ton message, non je n'ai pas octoprint et pronteface je ne suis pas dans une démarche aussi pointue que vous! 

Lien vers le commentaire
Partager sur d’autres sites

" without support " ok, mais avec les 2 câbles Z séparés et non pas tous les câbles sur le port de la carte!

Pour garder la config avec tous les câbles sur le port faut que tu le compile, pour le moment il n' existe pas ( chez Creality ), peu être un membre avec la même Ender et config que toi pourrait te dépanné.

Modifié (le) par Invité
Lien vers le commentaire
Partager sur d’autres sites

Bonjour, merci pour ton éclairage donc ender vend  une carte mère 4 2 7 avec un port dédié 5 broches mais le firmware n'existe pas! donc nous sommes obligés de passer par  3 broches au dédié et  2 broches au Z standard, j'ai été tenté par cette modification mais la carte ender pro est retournée avec un espace très encombré(montage d'origine) avec les cables dupont que je possède  ce n'est pas logique ni l'idéal sauf collage pour la fiabilité et éviter les faux contacts de ce fait j'ai fait marche arrière.

Je suis étonné qu'Ender ne soit pas informé de ce problème car je ne sui pas l'unique utilisateur de cette  carte et du firmware que je considère comme une amélioration, car beaucoup de personnes ne maitrise pas visual studio, arduino etc... pour coder un firmware perso.

Cordialement

20210427_100826453_iOS.jpg

Lien vers le commentaire
Partager sur d’autres sites

Ce sont les fichiers conf de l’imprimante ?

Quand je rentre je te compile ça .

Dans 1 h environ ne déconnecte rien.

Lien vers le commentaire
Partager sur d’autres sites

Ce sont les fichiers conf de l’imprimante ?
Quand je rentre je te compile ça .
Dans 1 h environ ne déconnecte rien.

J’ai déjà fourni le bin mais merci quand meme
Lien vers le commentaire
Partager sur d’autres sites

Encore merci pour ton aide, donc je réinstalle le BL Touche mais par contre confirme moi le bon firmware à installer.Cordialement

Entre temps j'ai reçu une procédure d'Ender  c'est l'usine a gaz qu'en penses-tu?

Thank you for supporting our product.

Sorry to reply you now.

Please follow the steps below:
1.Back to origin--turn off the motor to manually level the print platform--return to origin--select control--initialize EEPROM--select the moving axis--click to move the Z axis until the distance between the nozzle and the print platform is about 0.1mm--remember to move the Z axis -Return to the initial page and select control-Motor-Z off set-Enter the value of the previous moving Z axis into Z off set-Return to the control interface and select store settings-Select bed leveling
Please try to print after the operation is complete
2.Video tutorial: https://www.cxsw3d.com/Ender3/129-3931.html
If the above operation still cannot be solved, please attach the operation video for further analysis and processing, thank you

Looking forward to your reply

Lien vers le commentaire
Partager sur d’autres sites

il y a 17 minutes, michel34 a dit :

Encore merci pour ton aide, donc je réinstalle le BL Touche mais par contre confirme moi le bon firmware à installer.Cordialement

Entre temps j'ai reçu une procédure d'Ender  c'est l'usine a gaz qu'en penses-tu?

Thank you for supporting our product.

Sorry to reply you now.

Please follow the steps below:
1.Back to origin--turn off the motor to manually level the print platform--return to origin--select control--initialize EEPROM--select the moving axis--click to move the Z axis until the distance between the nozzle and the print platform is about 0.1mm--remember to move the Z axis -Return to the initial page and select control-Motor-Z off set-Enter the value of the previous moving Z axis into Z off set-Return to the control interface and select store settings-Select bed leveling
Please try to print after the operation is complete
2.Video tutorial: https://www.cxsw3d.com/Ender3/129-3931.html
If the above operation still cannot be solved, please attach the operation video for further analysis and processing, thank you

Looking forward to your reply

En condensé c'est la procédure normale c'est juste pas super lisible.

Et sinon le firmware que je te disais de tester c'est celui-là.

Avec celui là normalement la procédure est un peu plus simple :

Tu commences par un auto-home, ensuite un move axis z tu descend a 0. ensuite tu vas dans configuration, z probe offset et là tu descend la buse jusqu'au bon niveau, tu fais un bed level et un store settings et on est bon normalement.

firmware-20210428-143638.bin

Modifié (le) par Angelbast
Lien vers le commentaire
Partager sur d’autres sites

il y a 1 minute, michel34 a dit :

Bonjour, j'ai donc installe ton firmaware  et suivi ta procédure d'installation tout se passe bien  mais au au print de test la buse est toujours a environ 5mm du plateau;

Cordialement

J'ai du coup exactement le meme firmware que toi et j'imprime depuis hier sans aucun soucis avec.

Aurais tu la possibilité de filmer la procédure que tu suis pour regler l'imprimante, y a peut etre quelque chose qui va pas dedans ou alors de détailler tres précisement ce que tu fais pour qu'on trouve l'erreur ?

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×
×
  • Créer...