Aller au contenu

Filament ABS

Probleme fin de course Y


maccaire

Messages recommandés

Bonjour a tous

Apres avoir upgrader ma vielle imprimante copie chinoise de l'anet A 8 avec arduino 2560 et ramps 1.6 j'ai le fin de course Y qui coupe en sens inverse. J'ai inverser le sens de rotation du moteur avec le connecteur sans resultat, j'ai inverser dans le firware marlin #define INVERT_Y_DIR true  j'ai trouver ceci sur un forum :

Il faut penser que l’imprimante puisse rejoindre sa position de référence à partir de n’importe quel emplacement possible. Comme les interrupteurs de fin de course se situent aux extrémités, il reste à définir dans quelle direction l’imprimante devra se déplacer pour atteindre les trois que l’on aura choisi.

-1 pour un déplacement en direction négative et 1 en direction positive

Cela me donne une erreur de compilation.

Peut etre avez vous une solution; merci

Lien vers le commentaire
Partager sur d’autres sites

Salutation !

Sur les dernières version de marlin si tu change le sens d'un axe, le connecteur (MIN ou MAX) du endstop  

// Specify here all the endstop connectors that are connected to any endstop or probe.
// Almost all printers will be using one per axis. Probes will use one or more of the
// extra connectors. Leave undefined any used for non-endstop and non-probe purposes.
#define USE_XMIN_PLUG
#define USE_YMIN_PLUG
#define USE_ZMIN_PLUG

//...
//#define USE_XMAX_PLUG
//#define USE_YMAX_PLUG
//#define USE_ZMAX_PLUG

doit être cohérente avec les

// Direction of endstops when homing; 1=MAX, -1=MIN
// :[-1,1]
#define X_HOME_DIR -1
#define Y_HOME_DIR -1
#define Z_HOME_DIR -1

 

cf https://marlinfw.org/docs/configuration/configuration.html#motor-direction ou câblage du/des moteur a modifier pour créer cette inversion en physique ...

 

Après il faut aussi vérifier la logique des endstop. 

// Mechanical endstop with COM to ground and NC to Signal uses "false" here (most common setup).
#define X_MIN_ENDSTOP_INVERTING true // Set to true to invert the logic of the endstop.
#define Y_MIN_ENDSTOP_INVERTING true // Set to true to invert the logic of the endstop.
#define Z_MIN_ENDSTOP_INVERTING true // Set to true to invert the logic of the endstop.

Si tu arrive a te connecter en USB via pronterface ... Selon les résultat de la commande g-code M119 https://marlinfw.org/docs/gcode/M119.html  si quand tu déclenche manuellement les endstop cela change de statue mais que tu a "TRIGGERED" quand non déclenché on lieu de "open" alors il faut modifier la logique du/des endstop  https://marlinfw.org/docs/configuration/configuration.html#endstop-inverting ...

 

Mais je peux aussi être complètement a coté ... sans un copier coller de l'erreur de compilation pas simple de vraiment savoir.

Modifié (le) par PPAC
Lien vers le commentaire
Partager sur d’autres sites

oui merci pour votre reponse tout est en coherence  prontterface me renvoi bien "TRIGGERED"  quand je le ferme manuellement mais cela bloque le bed en mouvement  arrière  au lieu de l'avant c'est pour cela que j'avais modifier Marlin par #define Y_HOME_DIR  1 ce qui me met l'erreur de compilation

In file included from C:\Users\chris\Desktop\Marlin anet maison\Marlin\MarlinConfig.h:42:0,
                 from C:\Users\chris\Desktop\Marlin anet maison\Marlin\I2CPositionEncoder.cpp:31:
SanityCheck.h:1284:8: error: #error "Enable USE_YMAX_PLUG when homing Y to MAX."
       #error "Enable USE_YMAX_PLUG when homing Y to MAX."
        ^~~~~
In file included from C:\Users\chris\Desktop\Marlin anet maison\Marlin\MarlinConfig.h:42:0,
                 from C:\Users\chris\Desktop\Marlin anet maison\Marlin\M100_Free_Mem_Chk.cpp:49:
SanityCheck.h:1284:8: error: #error "Enable USE_YMAX_PLUG when homing Y to MAX."
       #error "Enable USE_YMAX_PLUG when homing Y to MAX."
        ^~~~~
In file included from C:\Users\chris\Desktop\Marlin anet maison\Marlin\MarlinConfig.h:42:0,
                 from C:\Users\chris\Desktop\Marlin anet maison\Marlin\G26_Mesh_Validation_Tool.cpp:27:
SanityCheck.h:1284:8: error: #error "Enable USE_YMAX_PLUG when homing Y to MAX."
       #error "Enable USE_YMAX_PLUG when homing Y to MAX."
        ^~~~~
In file included from C:\Users\chris\Desktop\Marlin anet maison\Marlin\MarlinConfig.h:42:0,
                 from C:\Users\chris\Desktop\Marlin anet maison\Marlin\MarlinSerial.cpp:36:
SanityCheck.h:1284:8: error: #error "Enable USE_YMAX_PLUG when homing Y to MAX."
       #error "Enable USE_YMAX_PLUG when homing Y to MAX."
        ^~~~~
exit status 1
#error "Enable USE_YMAX_PLUG when homing Y to MAX."


Comment inverser le role du fin de course qui devrai couper vers le mouvement avant et non arriére ?

J’utilise Marlin bug fixe 1.1 car ne n'ai jamais reussi a compiler Marlin2.2 avec arduino ide.

Lien vers le commentaire
Partager sur d’autres sites

Le fait de modifier le sens d'un axe permute le min et le max pour le endstop

donc là marlin avec l'erreur 

"Enable USE_YMAX_PLUG when homing Y to MAX."

demande d'utiliser (car tu définie le endstop en position min, avec un sens d'axe inversé donc au final en max ... ) USE_YMAX_PLUG au lieu de USE_YMIN_PLUG ou alors il faut modifier #define Y_HOME_DIR -1 ... (oui c'est pas forcement intuitif cette histoire...)

Sinon pourquoi la bug fix tu cherche les bug ? plutôt prendre une version "release" stable  ... https://github.com/MarlinFirmware/Marlin/releases

Enfin pour marlin 2.x il faut utiliser VSCode + PlatformIO et AutoBuildMarlin  qui gère automatiquement les lib cf  https://marlinfw.org/docs/basics/install.html#build-and-install

Modifié (le) par PPAC
Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...