Aller au contenu

Anycubic Kobra 3 Combo

problème lors du 1er calibrage avant chaque impression


electro179

Messages recommandés

Bonjour à tous

J'ai dû démonter mon extrudeur car le filament avait cassé.
Je l'ai déjà fait 30 fois auparavant

Avant chaque impression ou chaque nivellement, .. il fait une calibration en x y z

1)il va d'abord devant et à gauche

2)revient au centre pour calibrer son Z.

Maintenant :
Il saute la 1er étape et il se déplace en arrière et à droite.

Qu'importe ou il se trouve il va en à droite et en arrière et donc il se retrouve en dehors du plateau.

 

voici une vidéo qui montrera le problème

https://photos.app.goo.gl/JQCaDb7Yw3j6V2gp6

merci si vous avez des suggestions

Lien vers le commentaire
Partager sur d’autres sites

Salut,

Il y a 9 heures, electro179 a dit :

Il saute la 1er étape et il se déplace en arrière et à droite.

Rectificatif: pour moi, il va à l'avant et il veut se diriger vers le milieu du plateau. Ça veut dire que ton détecteur de fin de course X est "fermé" en permanence ( HS ?). Lorsque tu lances la prise d'origine ( Home), il considère que le x=0 est là où il est puis il fait son origine en Y et en Z. En attendant de trouver l'origine du défaut ( revoir le branchement du détecteur ou le remplacer?) Tu peux lancer le Home après avoir poussé à la main le chariot X complètement à gauche. 

Pour le bruit effrayant à la fin, si c'est le moteur Z, alors c'est peut-être que le bltouch est débranché. 🤔 Je dirais que la machine pense que la touche est sortie et qu'il faut descendre jusqu'à ce que le bltouch envoie le signal qui n'arrive jamais. 😰 

Edit: la conclusion de @MrMagounet est plus réaliste 😅. La touche se déploie dans le vide. Du coup le BLTouch n'envoie jamais le signal pour arrêter la descente 😰

Modifié (le) par pommeverte
  • +1 1
Lien vers le commentaire
Partager sur d’autres sites

ton endstop x semble en effet être la cause de ton soucis comme la dit @pommeverte. du coup ton 3Dtouch est hors plateau lors de la descente en Z.

  • +1 1
Lien vers le commentaire
Partager sur d’autres sites

merci

 

encore un mystère

si je l'enlève il va bien vers la gauche et dès que je le mets il s'arrête=> je vais en commander un nouveau

second problème, après qu'il  été à gauche il va au milieu pour faire son axe z avec le bl touch sauf qu'il ne l'active pas mais au démarrage de l'imprimante il fonctionne bien

 

voici la vidéo

 

https://photos.app.goo.gl/wfLxYKzraT34rGJ18

Lien vers le commentaire
Partager sur d’autres sites

il y a 14 minutes, electro179 a dit :

si je l'enlève il va bien vers la gauche et dès que je le mets il s'arrête=> je vais en commander un nouveau

Sauf erreur de ma part, le détecteur est à effet hall (détection magnétique). Tu n'auras pas ajouté un aimant pour maintenir une pièce, sur ta machine?

il y a 14 minutes, electro179 a dit :

second problème, après qu'il  été à gauche il va au milieu pour faire son axe z avec le bl touch sauf qu'il ne l'active pas mais au démarrage de l'imprimante il fonctionne bien

lorsque la touche sort 2 fois à la mise sous tension, c'est juste pour dire que le XXTouch est alimenté en 5V. La sortie n'est pas pilotée par la carte-mère à ce moment.

Finalement, je pense que j'étais pas loin de la vérité 😅:

Il y a 21 heures, pommeverte a dit :

Pour le bruit effrayant à la fin, si c'est le moteur Z, alors c'est peut-être que le bltouch est débranché. 🤔 Je dirais que la machine pense que la touche est sortie et qu'il faut descendre jusqu'à ce que le bltouch envoie le signal qui n'arrive jamais. 😰 

Il faudrait revoir la connectique entre le XXtouch et la carte-mère. Si le problème persiste, tu peux faire des tests en envoyant des Gcodes via Pronterface installé sur un ordinateur relié en USB:

  • sortir la touche M280 P0 S10
  • rentrer la touche M280 P0 S90
  • envoyer M119 pour voir l'état des fins de course

si la led clignote, c'est qu'il y a un défaut que tu peux réinitialiser avec un M280 P0 S160

Si rien ne fonctionne, il faudra faire chauffer la carte bleue 😬

Modifié (le) par pommeverte
Lien vers le commentaire
Partager sur d’autres sites

bonjour

 

Pour la fin de course x j'ai changé le capteur maintenant c'est ok

par contre pour le BL touch

j'arrive a bien lever et descendre le capteur  avec les commandes 
 

  • sortir la touche M280 P0 S10
  • rentrer la touche M280 P0 S90

 

mais quand il faut sa calibration et ne sort pas son capteur

j'ai trouvé

j'avais remis un mauvais firmware qui ne supportait probablement pas le bl touch

Lien vers le commentaire
Partager sur d’autres sites

il y a 11 minutes, electro179 a dit :

bonjour

 

Pour la fin de course x j'ai changé le capteur maintenant c'est ok

par contre pour le BL touch

j'arrive a bien lever et descendre le capteur  avec les commandes 
 

  • sortir la touche M280 P0 S10
  • rentrer la touche M280 P0 S90

 

mais quand il faut sa calibration et ne sort pas son capteur

La pin sort bien lorsque tu tape le M280 mais pas quand l'imprimante fait son Home en Z ?

La c'est étrange car lors du Home en Z le firmware va justement envoyé la même commande pour sortir la pin.

Lien vers le commentaire
Partager sur d’autres sites

il y a 29 minutes, MrMagounet a dit :

La pin sort bien lorsque tu tape le M280 mais pas quand l'imprimante fait son Home en Z ?

La c'est étrange car lors du Home en Z le firmware va justement envoyé la même commande pour sortir la pin.

j'avais récupéré un fichier hex de la sw2 et un fichier bin le fichier hex n'a pas fonctionné mais pas de problème pour le fichier bin

Lien vers le commentaire
Partager sur d’autres sites

il y a 39 minutes, electro179 a dit :

j'avais récupéré un fichier hex de la sw2 et un fichier bin le fichier hex n'a pas fonctionné mais pas de problème pour le fichier bin

oui normale les Fichier .bin sous obligatoire avec les carte 32bit comme sur la X2, les .hex sont plus des fichier pour du 8bit comme les X1.

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
  • Sur cette page :   0 membre est en ligne

    • Aucun utilisateur enregistré regarde cette page.
  • YouTube / Les Imprimantes 3D .fr

×
×
  • Créer...