Aller au contenu

Anycubic Kobra 3 Combo

Comment tester le second ventilateur qui refroidi le filament ?


Invité

Messages recommandés

Bonjour à toutes et tous,

Pour mettre hors de cause le ventilateur lui même, j'ai permuté les deux ventilateur sur ma carte
et le ventilateur de refroidissement fonctionne correctement.
Ce qui n'est pas le cas en impression.

Quelle commande G-Code faut-il exécuter pour tester si ma carte n'est pas HS sur cette sortie.

Merci pour votre aide.

Lien vers le commentaire
Partager sur d’autres sites

Salut,

Pour faire tourner ton ventilateur à 100%: M106 S255

Pour l'arrêter: M107 ou M106 S0

Comme je pense que tu n'as qu'1 tête d'impression, tu n'as pas à spécifier le n° de la tête avec l'option P. 😉

Edit: désolé, j'me suis fait grillé par @Kachidoki 😅

Modifié (le) par pommeverte
  • Haha 1
Lien vers le commentaire
Partager sur d’autres sites

@Kachidoki et @pommeverte  merci pour vos suggestions.
Comment indiquer le ventilateur à piloter ?

C'est sans doute indiqué dans le lien, mais comme je ne suis pas très violent en anglais, je voudrais pas faire de fausse manip et du coup, je souhaiterais la commande en clair. 😉

Modifié (le) par Alain06
Lien vers le commentaire
Partager sur d’autres sites

Sur une imprimante "standard" à une seule tête, tu ne peux piloter que le ventilateur qui souffle sur la pièce.

L'autre ventilateur est soit alimenté en permanence, soit ne démarre que lorsque la température est >50°C, ça dépend des imprimantes.

il y a 13 minutes, Alain06 a dit :

C'est sans doute indiqué dans le lien, mais comme je ne suis pas très violent en anglais, je voudrais pas faire de fausse manip et du coup, je souhaiterais la commande en clair. 😉

M106 S255 comme indiqué. Tu ne risques rien à lancer cette commande, si ce n'est d'allumer ton ventilo... ou pas. 🥴

Lien vers le commentaire
Partager sur d’autres sites

il y a 43 minutes, Kachidoki a dit :

Sur une imprimante "standard" à une seule tête, tu ne peux piloter que le ventilateur qui souffle sur la pièce.

J'ai deux ventilateurs :

1 - Le ventilateur principal qui souffle en permanence, pour refroidir le moteur de l'extrudeur et le haut du dissipateur thermique.

2- Le ventilateur secondaire pour refroidir le filament qui a été déposé.

C'est pour ce ventilateur "2" que je souhaite connaitre la commande G-Code. Est-ce possible ?

il y a 43 minutes, Kachidoki a dit :

M106 S255 comme indiqué. Tu ne risques rien à lancer cette commande, si ce n'est d'allumer ton ventilo... ou pas. 🥴

Effectivement, je tente cette commande et je reviens

Bon, impeccable avec cette commande, il tourne bien et avec M107 S255 il s'arrête.
Mais alors pourquoi, il ne fonctionne pas pendant l'impression ? 🤔

Modifié (le) par Alain06
Lien vers le commentaire
Partager sur d’autres sites

il y a 29 minutes, Alain06 a dit :

Bon, impeccable avec cette commande, il tourne bien et avec M107 S255 il s'arrête.

M107 tout court pour l'arrêter. 😉

Pour la culture, S pour speed ou vitesse, et le chiffre va de 0 à 255 pour 0% à 100%. Pourquoi 255, c'est historique, c'est la valeur maximale d'un entier de 8 bits. Une fois que tu connais ce détail, c'est plus facile à comprendre. M106 S127 = Allumer le ventilateur à 50% et M106 S0 = Arrêter le ventilateur = M107 qui est un "raccourci".

 

il y a 32 minutes, Alain06 a dit :

Mais alors pourquoi, il ne fonctionne pas pendant l'impression ? 🤔

Il fonctionnait avant ? Tu as changé quelque chose dans tes paramètres du trancheur ?

Lien vers le commentaire
Partager sur d’autres sites

il y a 35 minutes, Kachidoki a dit :

Il fonctionnait avant ? Tu as changé quelque chose dans tes paramètres du trancheur ?

Pertinent !

J'ai la nouvelle version de Cura, mais j'ai aussi essayé avec Prusa sans succès d'où ma sollicitation au Forum 🤨

Lien vers le commentaire
Partager sur d’autres sites

Bon, @pommeverte tu me rassures, je re-essayerais demain pour confirmer, mais j'avais essayé moult fichiers et autres slicers sans succès.

Déjà un grand pas en avant, la commande G-Code sans fichier fonctionne. Donc le ventilateur et à la carte sont OK.

Lien vers le commentaire
Partager sur d’autres sites

Il y a 12 heures, pommeverte a dit :

Le ventilateur tourne-t-il lorsque tu envoies le gcode M106 S85 (que tu as dans ton fichier)?

Effectivement il y a bien cette commande dans le fichier et elle ne déclenche pas le ventilateur.
Par contre,

Il démarre immédiatement avec M106 S255 et s’arrête parfaitement avec M106 S0 (j'utilise Pronterface pour envoyer les G-Ccodes).
---------------------------------------------------------------------------------------------------------------------------

Suite à un problème , j'ai dû restaurer une ancienne version de mon système et je me demande si Marlin n'est pas altéré...

Ou si il faut lubrifier ce ventilateur, ou le changer...

 

Marlin.rar

Modifié (le) par Alain06
Lien vers le commentaire
Partager sur d’autres sites

Ca ne me parait pas anormal, 30% c'est la limite basse en général pour qu'un ventilo démarre. Il vaut mieux le lancer d'abord à pleine vitesse puis ensuite descendre. C'est ce qui est fait sur les Prusa.

Je pense que si tu lui donne une petite pichenette avec le doigt, il se mettra à tourner, à 30% il n'a pas assez de couple pour s'arracher à sa position statique. Mais s'il est déjà lancé, il tiendra le régime.

 

Tu peux déterminer par essais successifs à partir de combien ton ventilo accepte de démarrer tout seul, 40, 50% peut-être, et ajuster en conséquence le réglage du minimum de ventilation dans le slicer.

Modifié (le) par Kachidoki
  • +1 1
Lien vers le commentaire
Partager sur d’autres sites

On va chercher bien loin les problèmes technique on en oublie le plus élémentaire en mécanique.
Il suffit parfois simplement de lubrifier et tout repart.

Correctement c'est autre chose. Le ventilateur se déclenche maintenant d'une manière aléatoire, il ne fonctionne pas en continu.
Aurai-il des points durs, une sous alimentation, une commande elle aussi aléatoire ?

Bref, ma dernière question est de savoir si une fois déclenché, il doit fonctionner jusqu'à la fin de l'impression ?

En tous cas, cette discussion n'aura pas été inutile, j'aurai appris à manipuler les G-codes concernant le ventilateur.
Encore merci @pommeverte et @Kachidoki

Modifié (le) par Alain06
Lien vers le commentaire
Partager sur d’autres sites

Salut,

il y a une heure, Alain06 a dit :

ma dernière question est de savoir si une fois déclenché, il doit fonctionner jusqu'à la fin de l'impression ?

jusqu'à maintenant, je n'ai jamais arrêté le ventilateur en cours d'impression. Une fois qu'il a atteint la vitesse demandée, ça reste jusqu'à la fin.

il y a une heure, Alain06 a dit :

Aurai-il des points durs, une sous alimentation, une commande elle aussi aléatoire ?

il faudrait surtout savoir si c'est un moteur à courant continu ou un brushless. J'ai l'impression que c'est le dernier cas. Si c'est vérifié, c'est normal qu'il n'apprécie que moyennement le signal PWM de la carte. Il est conçu pour être alimenté par une tension continue et proportionnelle à la vitesse souhaitée. Qu'est ce que tu dirais si on te nourrissait à la petite cuillère et qu'on mettait 1 heure entre chaque béquée, tu serais pas vraiment content toi aussi 🤣.

La conclusion comme l'a dit @Kachidoki c'est de trouver la vitesse mini à laquelle tu peux lancer la rotation du ventilateur. L'idée du coup de boost au démarrage (M106 S85) serait l'idéal mais pas facile à automatiser... 🤔 sauf apparemment si tu utilises PrusaSlicer? info à vérifier si c'est dans le trancheur ou dans le firmware: 🤨

Il y a 9 heures, Kachidoki a dit :

Il vaut mieux le lancer d'abord à pleine vitesse puis ensuite descendre. C'est ce qui est fait sur les Prusa.

Modifié (le) par pommeverte
Lien vers le commentaire
Partager sur d’autres sites

il y a 23 minutes, pommeverte a dit :

info à vérifier si c'est dans le trancheur ou dans le firmware: 🤨

C'est dans le firmware, mais la Prusa possède un ventilateur à trois fils, et contrôle le signal de retour de vitesse. Elle peut ainsi savoir si le ventilo tourne correctement et le booster si nécessaire. A défaut, elle met l'impression en pause et alerte l'utilisateur que le ventilo est en panne. Vécu sur une impression de 8h, à 9 min de la fin le fil du retour de vitesse s'est cassé à force de flexion. L'imprimante s'est mise en pause une bonne partie de la nuit et au petit matin, j'ai désactivé le check du ventilo puis repris l'impression comme si de rien n'était. 😀

1673746113_Capturedcran2022-09-06202624.thumb.jpg.4c01d23b59762446c360558ce87d098b.jpg

Au moment de la photo j'avais tenté de reprendre une première fois l'impression sans rien toucher, d'où la buse encore chaude.

  • Merci ! 1
Lien vers le commentaire
Partager sur d’autres sites

Le 06/09/2022 at 20:32, Kachidoki a dit :

j'ai désactivé le check du ventilo

Quelle est la correction à faire dans Marlin ?

Je sais, je pourrais rechercher... au risque de m'égarer et générer d'autres problèmes.
D'avance merci.

Modifié (le) par Alain06
Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...