Aller au contenu

Anycubic Kobra 3 Combo

[RÉSOLU] Plus de tactile PiTFT50


David590

Messages recommandés

Bonjour à tous,

Ca faisait pas mal de temps que je n'avais plus utilisé mon imprimante et après plusieurs mise à jour j'avais plein d'erreurs, du coup j'ai décider de tout réinstaller.

J'utilise Klipper, j'ai donc réinstaller Mainsail ainsi que klipperscreen, j'ai bien un affichage correct sur le PiTFT50 mais pas de tactile, je vois pas ce qu'il peut y avoir, il n'y a qu'un connecteur à brancher... un paramètre peut être ? 

Lien vers le commentaire
Partager sur d’autres sites

Vérifie que l'I2C est toujours activé (sudo raspi-config en ssh sur le RPi, Interfacing options) => https://www.raspberrypi.com/documentation/computers/configuration.html

🙂

  • J'aime 1
Lien vers le commentaire
Partager sur d’autres sites

Que contient le fichier /boot/config.txt ?

J'ai cet écran, PiTFT5 (v1), (également un 7") avec un RPi4 totalement fonctionnel (écran + tactile). Klipper, Moonraker, Klipperscreen, … tous à jour :

logiciels-a-jour-mainsail.jpg.070d3101e31f2500d8218e6521f81355.jpg

Mon fichier config.txt :

Citation

pi@pseudopad:/boot $ cat config.txt


# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
dtparam=i2c_arm=on
#dtparam=i2s=on
dtparam=spi=on

# Uncomment this to enable infrared communication.
#dtoverlay=gpio-ir,gpio_pin=17
#dtoverlay=gpio-ir-tx,gpio_pin=18

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

# Automatically load overlays for detected cameras
##camera_auto_detect=1

# Automatically load overlays for detected DSI displays
display_auto_detect=1

# Enable DRM VC4 V3D driver
dtoverlay=vc4-fkms-v3d
max_framebuffers=2

# Run in 64-bit mode
arm_64bit=1

# Disable compensation for displays with overscan
disable_overscan=1

[cm4]
# Enable host mode on the 2711 built-in XHCI USB controller.
# This line should be removed if the legacy DWC2 controller is required
# (e.g. for USB device mode) or if USB support is not required.
otg_mode=1

[pi4]
# Run as fast as firmware / board allows
arm_boost=1
# touch driver BTT PiTFT
dtoverlay=rpi-ft5406
gpu_mem=256

[all]
start_x=1
gpu_mem=128
dtoverlay=vc4-kms-dpi-panel
dtoverlay=gpio-fan,gpiopin=14,temp=50000


[pi3]
gpu_mem=256


[pi0]
gpu_mem=160

 

Tu as bien un «overlay» pour le pilote tactile (rpi-ft5406) ?

🙂

  • J'aime 1
Lien vers le commentaire
Partager sur d’autres sites

Oui tout est bien à jour de mon coté

il y a 31 minutes, fran6p a dit :

Tu as bien un «overlay» pour le pilote tactile (rpi-ft5406) ?

Heu... non, enfin je sais pas..🙄 c'est quoi?

J'ai juste installé klipperscreen, je n'ai jamais rien installé d'autre, il faut ajouter un pilote ? 

edit: pour voir le fichier de config il faut aller directement sur la carte sd ? N'y avait-il pas un autre moyen il me semble ?

Modifié (le) par David590
Lien vers le commentaire
Partager sur d’autres sites

Klipperscreen n'est en «gros» qu'un serveur X (affichage) mais il ne gère pas tous les affichages matériels. Pour certains, il faut que l'OS gère le matériel, en gros l'équivalent de pilotes via un «overlay» pour un Rapsberry Pi .

Klipperscreen dans sa documentation indique également comment rétablir le tactile si la distribution est une Bullseye :

Changer

dtoverlay=vc4-kms-v3d

par

dtoverlay=vc4-fkms-v3d

La différence est subtile fkms au lieu de kms (je n'entrerai pas dans les détails car ça prendrai trop de temps et n'intéresserai que peu de monde… La fondation Raspberry fournit une abondante documentation pour ceux qui souhaiteraient savoir le pourquoi du comment).

🙂

Modifié (le) par fran6p
  • J'aime 1
Lien vers le commentaire
Partager sur d’autres sites

Mon config.txt:

Citation

# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable infrared communication.
#dtoverlay=gpio-ir,gpio_pin=17
#dtoverlay=gpio-ir-tx,gpio_pin=18

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

# Automatically load overlays for detected cameras
camera_auto_detect=1

# Automatically load overlays for detected DSI displays
display_auto_detect=1

# Enable DRM VC4 V3D driver
dtoverlay=vc4-fkms-v3d
max_framebuffers=2

# Disable compensation for displays with overscan
disable_overscan=1

[cm4]
# Enable host mode on the 2711 built-in XHCI USB controller.
# This line should be removed if the legacy DWC2 controller is required
# (e.g. for USB device mode) or if USB support is not required.
otg_mode=1

[all]

[pi4]
# Run as fast as firmware / board allows
arm_boost=1

[all]

####################################################
####     MainsailOS specific configurations     ####
####################################################
####      DO NOT CHANGE SECTION BELOW !!!       ####
####   UNLESS YOU KNOW WHAT YOU ARE DOING !!!   ####
####################################################

## For more options and information see
## https://www.raspberrypi.com/documentation/computers/config_txt.html
## Some settings may impact device functionality. See link above for details

## For additional information about device filters see
## https://www.raspberrypi.com/documentation/computers/config_txt.html#model-filters


[pi0]
## This affects Pi Zero(W) and Pi Zero2
## Due lag of RAM, limit GPU RAM
gpu_mem=128

[pi2]
gpu_mem=256

[pi3]
## Use 256 if 1Gb Ram Model!
gpu_mem=128
# gpu_mem=256

[pi4]
## Do not use more than 256Mb on Pi Model 4, it uses its own Management.
gpu_mem=256

[all]

## SPI Interface is enabled by default for Input Shaper
## This colides with Hyperpixel Display!
## Hyperpixel Screen uses the same Pin for Backlight.
dtparam=spi=on


## Enable Hardware UART for Serial Communication
## This also disables Bluetooth!
enable_uart=1
dtoverlay=disable-bt

## Enable I2C by default.
## This is used by Klipper's Host MCU
## See https://www.klipper3d.org/RPi_microcontroller.html#optional-enabling-i2c
## for destails.
## For MPU Accelrometer please use
## dtparam=i2c_arm=on,i2c_arm_baudrate=400000
dtparam=i2c_arm=on

## Disable libcamera (interferes with ustreamer, when using raspicams)
camera_auto_detect=0

## Enable VideoCore at boot, needed for Crowsnest (Raspicams and DSI devices).
start_x=1


### EXPERIMENTAL - Enable 64bit Kernel
### The 64-bit kernel will only work on:
### Raspberry Pi 3, 3+, 4, 400, Zero 2 W and 2B rev 1.2
### and Raspberry Pi Compute Modules 3, 3+ and 4.
# arm_64bit=1

####################################################

[all]
 

J'ai bien ajouter le f à "dtoverlay=vc4-fkms-v3d" en utilisant vscode.

Je serai pas dire si le tactile fonctionne car depuis j'ai plus l'interface sur l'écran !

image.jpeg.f83735dcbfb9b81773a5a0403fd28c74.jpeg

 

Modifié (le) par David590
Lien vers le commentaire
Partager sur d’autres sites

Quel modèle de Raspberry PI? Quelle distribution (OS) ?

Tu as bien redémarré le RPi après avoir modifié le config.txt ?

As-tu (après avoir sauvegardé le contenu de ton config.txt) testé en copiant le contenu du mien ?

… ?

🙂

  • Merci ! 1
Lien vers le commentaire
Partager sur d’autres sites

il y a 51 minutes, fran6p a dit :

Quel modèle de Raspberry PI? Quelle distribution (OS) ?

Raspberry Pi 3 Model B Plus Rev 1.3
MainsailOS 1.1.1 (bullseye)

 

il y a 55 minutes, fran6p a dit :

Tu as bien redémarré le RPi après avoir modifié le config.txt ?

Oui

 

il y a 56 minutes, fran6p a dit :

As-tu (après avoir sauvegardé le contenu de ton config.txt) testé en copiant le contenu du mien ?

Alors j'ai retesté avec dtoverlay=vc4-kms-v3d , l'interface revient mais pas de tactile

avec dtoverlay=vc4-fkms-v3d, pas d'interface 

et avec ton config.txt... ca fonctionne 😀

mais alors pourquoi ?

Lien vers le commentaire
Partager sur d’autres sites

La différence est là :

# touch driver BTT PiTFT
dtoverlay=rpi-ft5406

Je ne sais plus où j'avais trouvé cette «astuce» (github Klipperscreen, github Raspberry, github Bigtreetech ???) mais ça m'avait permis d'avoir le tactile quand j'avais préparé ce «pseudo» Pad (il y a déjà plusieurs mois 😉 ).

Puisque ça fonctionne, amuse-toi bien avec Klipper et consorts

J'ajoute «résolu» au titre du sujet pour faciliter l'aide d'autres utilisateurs rencontrant ce même soucis.

🙂

Modifié (le) par fran6p
  • Merci ! 1
Lien vers le commentaire
Partager sur d’autres sites

  • fran6p changed the title to [RÉSOLU] Plus de tactile PiTFT50

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
  • Sur cette page :   0 membre est en ligne

    • Aucun utilisateur enregistré regarde cette page.
  • YouTube / Les Imprimantes 3D .fr

×
×
  • Créer...