Aller au contenu

Filament ABS

vivi54

autolevelling avec servo besoin d'aide SVP

Messages recommandés

Bonjour, 

Après mainte et mainte recherche je ne trouve pas la solution pour faire fonctionner mon servo et l'auto bed levelling, j'ai l'impression d'avoir tout essayer, je dois passer a coté de quelque chose...

J'avais réussi a faire fonctionner mon servo via repetier mais j'ai modifier des éléments sur marlin d’après un tuto sans faire attention et depuis il veut plus bouger et je me retrouve avec une imprimante qui fonctionne plus, ça fais 3 jours que je suis après ça ... si quelqu'un pourrais m'aider ? 

Il vous faut quoi comme élément ? 

En vous remerciant d'avance.

Partager ce message


Lien à poster
Partager sur d’autres sites

itopie faite maison ?

 systeme d'autolevel : servo g9 avec switsh mécanique 

ramps 1.4 et arduino 

Faut d'autre renseignement ? 

Modifié (le) par vivi54

Partager ce message


Lien à poster
Partager sur d’autres sites

De mémoire une sortir PWM (pour le servo moteur) est dispo sur AUX-1 de la RAMP 1.4.

Les sortie et monté du servo-moteur (si je peux dire comme ça) se feront via la commande GCode M42.

Partager ce message


Lien à poster
Partager sur d’autres sites

le servo est brancher sur le pin d11 avec un cavalier pour le 5v, mais ça viens pas de ça puisque ça marchais avant que je modifie marlin ... j'ai fais un peu au hasard et je ne m'y retrouve plus (dans marlin)..

ramps-auto-bed-leveling.png

Modifié (le) par vivi54

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai repris mon Marlin à zéro, j'ai trouvé ce qui clocher, j'ai bien le servo qui se déploie et se rétracte comme il faut maintenant et je peut faire g28 z : le servo se déploie, ça descend jusqu'à ce que le switch fasse contact remonte de 2 et rétracte le servo. 

En revanche si je fais g 29, ça devrais palper si j'ai bien compris mais pour l'instant ça fais rien.... 

Quel paramètres rentre en compte pour ça ? si quelqu'un a des idées.

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai repris mon Marlin à zéro, j'ai trouvé ce qui clocher, j'ai bien le servo qui se déploie et se rétracte comme il faut maintenant et je peut faire g28 z : le servo se déploie, ça descend jusqu'à ce que le switch fasse contact remonte de 2 et rétracte le servo. 

En revanche si je fais g 29, ça devrais palper si j'ai bien compris mais pour l'instant ça fais rien.... 

Quel paramètres rentre en compte pour ça ? si quelqu'un a des idées.

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×