Aller au contenu

Anycubic Kobra 3 Combo

G-code de début d'impression, Wanaho d12/230 double extrudeur


Messages recommandés

Bonjour

J'ai la Duplicator D12 230 de chez Wanaho en double extrudeur depuis plus de 1 an et j'utilise le logiciel Ideamaker

Quand j'utilise le 2eme extrudeur pour lancer une impression, la buse ne chauffe pas automatiquement et je dois le faire manuellement.

Je soupçonne le G-code de début d'en être la cause mais je ne sais pas quoi modifier ou rajouter.

Voici mon G-code de début:

G21 ;metric values

G90

M107

G28 X0 Y0

G28 Z0

G1 Z15.0 F350

G28 X0 Y0

T0

G92 E0

G1 F800 E-80

T1

G92 E0

G1 F350 E80

T1

G92 E0

G1 F800 E-80

T0

G92 E0

G1 F350 E80

G92 E0

G1 F

M117

G28 ; home all axes

M83 ; set extrusion to relative

G1 Z5 F3000 ; raise Z

G1 X5 Y5 Z0.2 F6000 ; go intro start pos

G1 X60 E9 F800 ; thick line

G1 X90 E5 F1000 ; medium line

G1 X120 E3.5 F1200 ; slim line

G1 X118 E-0.4 Z0.5 F1500 ; wipe

G92 E0 ; reset extruder

Aurez vous une solution pour mon problème ? 

Merci d'avance.

Modifié (le) par Pilsou
Lien vers le commentaire
Partager sur d’autres sites

 

Salutation !

Si sous un dérivé de Ultimaker Cura, je dirais d'ajouter une ligne 

 

M109 S{material_print_temperature_layer_0} ; attente chauffe de la tête

 

Pour le détail du g-code M109 voir M109: Wait for Hotend Temperature

et pour la liste de mots de remplacement de Ultimaker Cura voir https://files.fieldofview.com/cura/Replacement_Patterns.html

 

Si sous un autre trancheur la syntaxe et le mot de remplacement/nom de variable de la température d'impression, peut changer

genre sous PrusaSclicer voir  https://help.prusa3d.com/article/list-of-placeholders_205643

Modifié (le) par PPAC
  • +1 1
Lien vers le commentaire
Partager sur d’autres sites

Salut @Pilsou et bienvenue sur le forum,

Pour compléter la réponse de @PPAC: je ne sais pas où tu as trouvé ton Gcode de démarrage mais son auteur, en plus d'être complètement bourré, était sous extasie 😩. La version fournie par Wanhao pour Cura est largement plus cohérente. En voici une version corrigée pour Ideamaker:

Citation

; -- START GCODE --
G21 ;metric values
G90 ;absolute positioning
M82 ; absolute extrusion
M107 ;start with the fan off
M140 S{temperature_heatbed} ; set bed temp
M190 S{temperature_heatbed} ; wait for bed final temp
G28 ;home all
G0 F2400 Z2.0 ;raise the nozzle 2mm
M104 S{temperature_extruder1} ; set extruder final temp
M109 S{temperature_extruder1} ; wait for extruder final temp
T0 ;Switch to Extruder 1
G0 X0.1 Y20 Z0.2 F5000.0 ; Move to start position
G92 E0 ;reset extrusion distance
G1 X0.1 Y200.0 Z0.2 F1500.0 E8 ; Draw the first line
G0 X0.5 Y200.0 Z0.2 F5000.0 ; Move to side a little
G1 X0.5 Y20 Z0.2 F1500.0 E16 ; Draw the second line
G92 E0 ;reset extrusion distance
; -- end of START GCODE --

à priori, ton Gcode de fin doit être du même acabit. Donc voici  une nouvelle version:

Citation

; -- END GCODE --
G91 ;set to relative positioning
G1 E-4 F2700 ;Retract a bit
G0 Z0.2 F2400 ;Raise Z
G0 X3 Y3 F3000 ;Wipe out
G90 ;set to absolute positioning
M104 S0  ;hotend off
M140 S0  ;bed off
G92 E0
G1 F2000 E-80  ;retract filament 80mm
G92 E0
G0 F3000 X0 Y220  ;move bed for easy part removal
M84  ;disable steppers
; -- end of END GCODE --

 

Modifié (le) par pommeverte
  • Merci ! 1
Lien vers le commentaire
Partager sur d’autres sites

il y a 21 minutes, PPAC a dit :

 

Salutation !

Si sous un dérivé de Ultimaker Cura, je dirais d'ajouter une ligne 

 

M109 S{material_print_temperature_layer_0} ; attente chauffe de la tête

 

Pour le détail du g-code M109 voir M109: Wait for Hotend Temperature

et pour la liste de mots de remplacement de Ultimaker Cura voir https://files.fieldofview.com/cura/Replacement_Patterns.html

 

Si sous un autre trancheur la syntaxe et le mot de remplacement/nom de variable de la température d'impression, peut changer

genre sous PrusaSclicer voir  https://help.prusa3d.com/article/list-of-placeholders_205643

J'ai essayé de rajouter cette line de code mais cela ne fonctionne toujours pas.

il y a 3 minutes, pommeverte a dit :

Salut @Pilsou et bienvenue sur le forum,

Pour compléter la réponse de @PPAC: je ne sais pas où tu as trouvé ton Gcode de démarrage mais son auteur, en plus d'être complètement bourré, était sous extasie 😩. La version fournie par Wanhao pour Cura est largement plus cohérente. En voici une version corrigée:

à priori, ton Gcode de fin doit être du même acabit. Donc voici  une nouvelle version:

 

Merci, je vais essayer avec c es G-codes, mais j'avais oublié de préciser que j'utiliser Ideamake.

Je vais quand même essayer avec ce G-code, Merci

Lien vers le commentaire
Partager sur d’autres sites

il y a 4 minutes, Pilsou a dit :

j'avais oublié de préciser que j'utilise Ideamaker.

ça tombe bien puisque c'est ce que j'ai fourni par erreur 😅.

Je l'ai donc précisé dans mon message et légèrement modifié (ajout de 2 lignes facultatives)

  • Merci ! 1
Lien vers le commentaire
Partager sur d’autres sites

il y a 19 minutes, pommeverte a dit :

Salut @Pilsou et bienvenue sur le forum,

Pour compléter la réponse de @PPAC: je ne sais pas où tu as trouvé ton Gcode de démarrage mais son auteur, en plus d'être complètement bourré, était sous extasie 😩. La version fournie par Wanhao pour Cura est largement plus cohérente. En voici une version corrigée pour Ideamaker:

à priori, ton Gcode de fin doit être du même acabit. Donc voici  une nouvelle version:

 

J'ai essayé avec le g-code mais cela fonctionne toujours pas.

De plus, il me met un message d'erreur sur les lignes de chauffes (ligne 5,6,9 et 10).

 

Lien vers le commentaire
Partager sur d’autres sites

Je ne sais pas si vous utilisez Ideamaker mais où devrait je placer le G-code donné ?

En effet, sur Idemaker je peux choisir si le G-code démarre avec l'extrudeur 1:

Capturedcran2024-05-20143634.thumb.png.9216aefa90baab29f97bd387bc5dffd0.png

ou l'extrudeur 2:

Capturedcran2024-05-20144025.thumb.png.9247be619ba424bc6a39ee46beb9b58d.png

Apres vérification, le logiciel selectionne le G-code 1 alors que mon imprimante est configuré avec 2 extrudeurCapturedcran2024-05-20144720.thumb.png.dea5e5d69c937aa45bf03ba5bc2c2c66.png

Auriez vous une solution 

Merci

il y a 1 minute, pommeverte a dit :

Désolé, j'ai corrigé les Gcodes

D'accord, je vais essayer

il y a 10 minutes, pommeverte a dit :

Désolé, j'ai corrigé les Gcodes

Cette fois ci, le message d'erreur ne s'affiche pas mais la buse ne chauffe toujours pas 

Lien vers le commentaire
Partager sur d’autres sites

à l’instant, pommeverte a dit :

il faut décocher la case "insérer automatiquement le Gcode de chauffage dans le Gcode de début" sous la fenêtre du Gcode de début

ok

C'est bon, cette fois-ci ca a fonctionné 🤩🤩!!!!!

Merci beaucoup  😀

  • J'aime 1
  • Wow 1
Lien vers le commentaire
Partager sur d’autres sites

Il y a 5 heures, pommeverte a dit :

Salut @Pilsou et bienvenue sur le forum,

Pour compléter la réponse de @PPAC: je ne sais pas où tu as trouvé ton Gcode de démarrage mais son auteur, en plus d'être complètement bourré, était sous extasie 😩. La version fournie par Wanhao pour Cura est largement plus cohérente. En voici une version corrigée pour Ideamaker:

à priori, ton Gcode de fin doit être du même acabit. Donc voici  une nouvelle version:

 

Et vu que vous m'avez dis que mes Gcode était incorrecte, serait il possible d'en avoir cette fois ci pour l'extrudeur 1

Merci

Lien vers le commentaire
Partager sur d’autres sites

Salut,

Je n'ai jamais eu l'occasion d'utiliser une imprimante avec 2 extrudeurs. Je ne pourrais donc pas te donner de réponse clé en main.

Cependant, j'ai fait quelques tests dont je n'ai pas toujours compris la logique 😅. Pour moi, il faudrait:

  1. par défaut imprimer avec l'extrudeur 1. Dans ce cas, les Gcodes de démarrage pour l'extrudeur 1 et 2 seraient identiques à ce que j'ai proposé. Il faudrait peut-être extruder plus de filament au cas où il soit très rétracté ( Gcode de fin)
    Citation

    ; -- START GCODE --
    G21 ;metric values
    G90 ;absolute positioning
    M82 ; absolute extrusion
    M107 ;start with the fan off
    M140 S{temperature_heatbed} ; set bed temp
    M190 S{temperature_heatbed} ; wait for bed final temp
    G28 ;home all
    G0 F2400 Z2.0 ;raise the nozzle 2mm

    M104 S{temperature_extruder1} ; set extruder final temp
    M109 S{temperature_extruder1} ; wait for extruder final temp
    T0 ;Switch to Extruder 1
    G0 X0.1 Y20 Z0.2 F5000.0 ; Move to start position

    G92 E0 ;reset extrusion distance

    G1 F1500.0 E75 ; extrude le filament pour compenser la rétraction du Gcode de fin
    G1 X0.1 Y200.0 Z0.2 F1500.0 E8 ; Draw the first line
    G0 X0.5 Y200.0 Z0.2 F5000.0 ; Move to side a little
    G1 X0.5 Y20 Z0.2 F1500.0 E16 ; Draw the second line
    G92 E0 ;reset extrusion distance
    ; -- end of START GCODE --

     

  2. ajouter le Gcode suivant dans l'onglet "Gcode de commutation des buses", en commentant ou non l'avant dernière ligne:
    Citation

    ; EXTRUDER SWITCH

    M83; extrusion relative

    T{old_extruder}

    G1 E-80 F2400

    T{new_extruder}

    G1 E80 F2400

    ;M82; à commenter / décommenter si l'impression est en extrusion absolue

    ;end of EXTRUDER SWITCH

    La longueur de 80mm est à ajuster en fonction de la tête d'impression (distance entre la buse et le Y d'entrée). Cette valeur apparait aussi dans le Gcode de fin

    Citation

    ; -- END GCODE --
    G91 ;set to relative positioning
    G1 E-4 F2700 ;Retract a bit
    G0 Z0.2 F2400 ;Raise Z
    G0 X3 Y3 F3000 ;Wipe out
    G90 ;set to absolute positioning
    M104 S0  ;hotend off
    M140 S0  ;bed off
    G92 E0
    G1 F2000 E-80  ;retract filament 80mm
    G92 E0
    G0 F3000 X0 Y220  ;move bed for easy part removal
    M84  ;disable steppers
    ; -- end of END GCODE --

     

  3. décocher le paramètre "refroidir l'extrudeur inactif" dans l'onglet température

Modifié (le) par pommeverte
Lien vers le commentaire
Partager sur d’autres sites

Il y a 11 heures, pommeverte a dit :

Salut,

Je n'ai jamais eu l'occasion d'utiliser une imprimante avec 2 extrudeurs. Je ne pourrais donc pas te donner de réponse clé en main.

Cependant, j'ai fait quelques tests dont je n'ai pas toujours compris la logique 😅. Pour moi, il faudrait:

  1. par défaut imprimer avec l'extrudeur 1. Dans ce cas, les Gcodes de démarrage pour l'extrudeur 1 et 2 seraient identiques à ce que j'ai proposé. Il faudrait peut-être extruder plus de filament au cas où il soit très rétracté ( Gcode de fin)

     

  2. ajouter le Gcode suivant dans l'onglet "Gcode de commutation des buses", en commentant ou non l'avant dernière ligne:

    La longueur de 80mm est à ajuster en fonction de la tête d'impression (distance entre la buse et le Y d'entrée). Cette valeur apparait aussi dans le Gcode de fin

     

  3. décocher le paramètre "refroidir l'extrudeur inactif" dans l'onglet température

Merci beaucoup 

je vais essayer pour voir 

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
  • Sur cette page :   0 membre est en ligne

    • Aucun utilisateur enregistré regarde cette page.
  • YouTube / Les Imprimantes 3D .fr

×
×
  • Créer...