Aller au contenu

Filament ABS

jericho63

extrusion pendant l'autolevel = agglomera au moment de l'impression

Messages recommandés

Bonsoir,

j'ai un soucis la tête d'impression extrude pendant la commande d'autlevel ce qui fait qu'au moment ou l'impression commence de la matière s''est aggloméré sur le buse et l'impression foire .

j'ai pensé que cela pouvait venir du gcode mais celui n'est pas très différent de ce que je peux trouver sur internet.

pour info mon a8 est équipée d'une tête e3dv6 clone.

voici le gocde start

 

;Sliced at: {day} {date} {time}

G21 ;metric values

G90 ;absolute positioning

M107 ;start with the fan off

G28 X0 Y0 ;move X/Y to min endstops

G28 Z0 ;move Z to min endstops

G29 ; Auto Bed Levelling

G1 Z15.0 F{travel_speed} ;move the platform down 15mm

G92 E0 ;zero the extruded length

G1 F200 E3 ;extrude 3mm of feed stock

G92 E0 ;zero the extruded length again

G1 F{travel_speed}

M117 Printing...

 

 

j'utilise cura 3.1

 

merci

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est quoi les 3mm extrudé ?

essai ça..

G21 ;valeurs métriques

G90 ;positionnement absolu

M82 ;mettre l'extrudeuse en mode absolu

M107 ;commencez avec le ventilateur éteint

G28 X0 Y0 ;déplacer X / Y à des butées min

G28 Z0 ;déplacez Z en butées min

G29

G0 X0 Y15 F9000 ;Lit en avant

G0 Z0.15 ;Déposer au lit

G92 E0 ;zéro la longueur extrudée

G1 X60 E10 F500 ;Extruder 10 mm de filament sur 4 cm

G92 E0 ;zéro la longueur extrudée

G1 E-1 F500 ;Rétracter un peu

G1 X100 F4000 ;Essuye rapidement la ligne de filament

G1 Z0.3 ;Levez et commencez à imprimer.

G1 F{travel_speed}

M117 Impression...

 

Avant d'imprimer, l'imprimante  va essuyer la buse sur le bord du plateau. Soit prêt  a tout arrêter au démarrage de la premier impression .

Partager ce message


Lien à poster
Partager sur d’autres sites

Moi j'utilise çà:
G21 ;metric values
G90 ;absolute positioning
M82 ;set extruder to absolute mode
M107 ;start with the fan off
G28; Home Axis
;G29; Z-Probe the bed (requires Z-Probe!)
G1 Z5.0 F9000 ;move the head 5mm up for CYA clearance
G92 E0 ;zero the extruded length
M117 Cleaning...;Put Cleaning message on screen
G1 X100 Y0 F4000 ; move half way along the front edge
G1 Z1 ; move nozzle close to bed
G4 P10000 ; wait 10 seconds for nozzle length to stabilize
G1 E10 ; extrude 10 mm of filament
G1 z15 F12000 E5 ; move 15 mm up, fast, while extruding 5mm
G92 E0 ; reset extruder
M117 Impression...;Put printing message on LCD screen

Jamais eu de filament qui adhère au bloc, par contre çà laisse un petit blob sur l'avant du plateau avant de se déplacer vers la zone d'impression.

Pendant que j'y suis voici mon end gcode (avec mise en position du plateau vers l'avant pour faciliter le décollage de l'impression).
M104 S0 ;extruder heater off
M140 S0 ;heated bed heater off (if you have it)
G91 ;relative positioning
G1 E-1 F300  ;retract the filament a bit before lifting the nozzle, to release some of the pressure
G1 Z+0.5 E-5 X-20 Y-20 F9000 ;move Z up a bit and retract filament even more
G28 X0 Y0 ;move X/Y to min endstops, so the head is out of the way
G1 Y150 F5000 ;move completed part out
M84 ;steppers off
G90 ;absolute positioning

Modifié (le) par Maeke

Partager ce message


Lien à poster
Partager sur d’autres sites

Là je me demande si il n'y a pas un défaut. Tu pourrais joindre une photo ou une vidéo?.

Partager ce message


Lien à poster
Partager sur d’autres sites

j’essaierai ce soir mais le truc c'est qu'a partir du moment ou la tête est chaude du filament coule de la buse sans que l'extrudeur ne soit en fonction, du coup le temps que la tête fasse l'autolevel une certain quantité de filament est sortie et lorsque l'impression et que la buse descend prés du plateau l’aggloméra est toujours accroché à la buse et lorsqu'il fini pas durcir, il s’accroche au début du print et le décolle.

les gcode de nettoyage que vous m'avez indiquer ne font tomber l'aggloméra qu'une fois sur trois et pas toujours correctement.

avec la tête d'origine j'avais un soucis similaire que j'avais réglé avec le paramètre de rétractation mais dans le cas de l'e3dv6 une rétractation de plus de 2mm n'est problématique.

la je suis a 0.8 j'avais mis cette valeur avec l'extrudeur stock, j’essaierai de la passer a 1.5 ce soir pour voir.

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai aussi ce léger problème parfois, j'arrive à le résoudre en tirant un peu en arrière le fil depuis l'extrudeur quand ça commence le G29. Tu retire environ 2/3mm  et j'ai plus le nez qui coule durant les 6 points

Modifié (le) par babounx

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour gérer çà j'utilises une petite pince courbée d'électronicien, je tire sur le bout de filament extrudé quand les g-codes n'ont pas suffit.
Ce plastique fondu pendant la chauffe, c'est totalement normal il en reste toujours dans le tube fileté et quand le bloc chauffe il fond.
Marlin a mis en place une fonction de nettoyage physique de la buse avant impression, en utilisant une brosse spéciale fixée sur le côté du plateau.
https://www.thingiverse.com/thing:2355355

Si tu veux essayer attention à ce que la brosse ne soit pas trop dure ou elle risque d'user tes buses.

Modifié (le) par Maeke

Partager ce message


Lien à poster
Partager sur d’autres sites

merci pour l'info concernant l'option de nettoyage,je vais creuser la question, en attendant je vais essayer de choper à la main les bavures avant le début de l'impression.

Partager ce message


Lien à poster
Partager sur d’autres sites

euh, si tu fais çà à la main, on risque de t'entendre chanter à des kilomètres, s'cho.

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant


×