Aller au contenu

Filament ABS

Modifier le marlin pour un soucis d'extrudeur.


dan44410

Messages recommandés

Bonjour, suite à une modif, allongement de Y, j'ai du faire une co....rie. Le moteur de l'extrudeur ne tourne plus. Sur la carte, il y a une connexion pour un deuxième extrudeur, comme je ne pense pas en acheter un deuxième,donc je désirerai "forcer" le marlin à reconnaitre cette prise pour me dépanner. Donc où & quoi changer ds le marlin pour l'aiguiller sur ce connecteur. Merci de votre aide. (J'ai une machine avec écran, sans détecteur de fin de fil.)

Modifié (le) par dan44410
Lien vers le commentaire
Partager sur d’autres sites

Bonjour, avant toute chose , il faut savoir si c'est le moteur ou ta carte qui pose un soucis ?

As tu essaye de brancher un des autre moteurs à la place de l'extrudeur et de lancer l'extrusion via pronterface par exemple pour voir si ca tourne ?

Peut être juste le cable de ton moteur qui est coupé ?

Lien vers le commentaire
Partager sur d’autres sites

ok, alors voila ce que tu peux essayer:

Dans le fichier pins_RAMPS_14.h :

Remplacer :

#define E0_STEP_PIN        26
#define E0_DIR_PIN         28
#define E0_ENABLE_PIN      24

#define E1_STEP_PIN        36
#define E1_DIR_PIN         34
#define E1_ENABLE_PIN      30

par :

#define E0_STEP_PIN        36
#define E0_DIR_PIN         34
#define E0_ENABLE_PIN      30

#define E1_STEP_PIN        26
#define E1_DIR_PIN         28
#define E1_ENABLE_PIN      24

ça devrait inverser les sorties des 2 extrudeurs , et considerer la 2eme comme étant extrudeur 0 .

Lien vers le commentaire
Partager sur d’autres sites

desolé 😞

par contre 80 balles ca fait cher ! tu veux prendre quelle carte ? une MKS base V1.4 ou V1.5 fonctionne très bien , ca doit se trouver aux alentours de 40€ sur Amazon voire moins cher chez les chinois ...

Lien vers le commentaire
Partager sur d’autres sites

@Snakesrules Salut, j'ai trouvé ça :

https://fr.aliexpress.com/item/3D-components-integrated-motherboard-BIQU-BASE-V1-0-MKS-BASE-V1-5-compatible-Mega2560-RAMPS1-4/32742624022.html?spm=a2g0s.9042311.0.0.302c6c377fLRRv

Merci pour tes conseils. Bonne journée.

P.S. Où peut-on mettre résolu sur ce forum?

Modifié (le) par dan44410
Lien vers le commentaire
Partager sur d’autres sites

  • 2 weeks later...

Bonsoir, je reviens vers vous car je suis au bord de la crise. Je viens de recevoir ma nlle carte. Branchements effectués. Flashage fait(Par Arduino, car DagApp ne donne rien). Avec l'ecran ou Proterface, test de home, les 3 axes font bien leurs tafs. Et ce p#@#n de moteur ne veut tjrs pas bougé. A tout hasard, j'ai recroisé fils & moteur --> fils & moteur : OK. HELP!!!!!!

Lien vers le commentaire
Partager sur d’autres sites

Dan,

 

Il y a une sécurité pour éviter le Cold extrude. Si la buse n'est pas chaude, et que tu demandes un mouvement du E, Pronterface t'indique que ce n'est pas possible dans le terminal.

 

cdlt

Lien vers le commentaire
Partager sur d’autres sites

Salut, avec pronterface, tu peux desactiver la sécurité :

 

M302 P0      ; enable cold extrusion checking
M302 P1      ; disable cold extrusion checking

 

bien entendu , il ne faut pas que le filament soit engagé dans la buse, sinon ...

Après , faire chauffer à 180° et tester l'extrusion est aussi une bonne solution 🙂

Lien vers le commentaire
Partager sur d’autres sites

Slt, c’était bien une dépendance au chauffage de la buse qui me bloquait.

J'ai un nouveau soucis, avec l'affichage de "Error : Temp min", je ne peux plus démarrer par l’écran, ni par Pronterface. Cela peut-il venir du fait que lors de la compil', avant téléversement, le prog. Arduino me signale une erreur ds la « température.cpp".

Modifié (le) par dan44410
Lien vers le commentaire
Partager sur d’autres sites

Version Marlin ds l’entête de celui-ci :

/**
 * Marlin 3D Printer Firmware
 * Copyright (C) 2016 MarlinFirmware [https://github.com/MarlinFirmware/Marlin]
 *
 * Based on Sprinter and grbl.
 * Copyright (C) 2011 Camiel Gubbels / Erik van der Zalm

**/

Et ça c'est la seul info que me donne le prog Arduino :

"Error while detecting libraries included by C:\Users\Daniel\AppData\Local\Temp\arduino_build_689444\sketch\temperature.cpp".

Je ne sais plus comment créer un fichier log des erreurs!! Et où il est.

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
  • Sur cette page :   0 membre est en ligne

    • Aucun utilisateur enregistré regarde cette page.
  • YouTube / Les Imprimantes 3D .fr

×
×
  • Créer...