Aller au contenu

Filament ABS

CTZen

- autre - Problème 3DTouch et Z_PROBE_OFFSET_FROM_EXTRUDER

Messages recommandés

Bonjour à tous !

Je ne sais pas si je suis sur le bon forum ... mais je tente quand même !

J'ai beau faire le tour de tous les forum FR et EN, je n'ai pas trouvé la solution (et le pire c'est que je suis déjà tombé sur quelqu'un qui a dit avoir trouvé et qui n'a pas dit comment ... 😩).


Bon en gros :
          - Imprimante Reprap Prusa i3
          - Carte Arduino GT2560 Pro B Rev A+
          - Marlin 1.0.2

Ayant un capteur 3DTouch monté sur l'imprimante lors de son achat à un très sympathique membre de ce forum (qui m'a prévenu ne pas avoir terminé la configuration), j'ai continué l'installation de ce capteur.

Tout fonctionne bien, le capteur s'allume, et la descente en Z se stop bien au moment où la tige du 3DTouch est "aspirée" par l’électroaimant.

Le soucis c'est que le Nozzle se trouve alors à environ 1 mm de mon plateau. Et à partir de là, impossible de faire quoi que ce soit pour que cette distance soit plus petite.

J'ai beau mettre n'importe quelle valeur dans marlin sur "Z_PROBE_OFFSET_FROM_EXTRUDER", positive ou négative ... le Nozzle reste à environ 1mm du bed.

Je vous joint mon fichier configuration.h ...

Si quelqu'un à la réponse ... ça serait génial parce que j'ai déjà passé au moins 10 heures de recherche et de test ... et impossible de trouver ! #déprime 😤

 

Mille merci d'avance pour vos réponses ! 😘

Configuration.h

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut tu change de valeur avec le configuration.h en televersent ??? essayeg avec pronterface par exemple M851 Z-1.5   (tu mets la valeur que tu veux a la place de -1.5) tu fais un M500 et M501 et la dis moi ce que ca fait

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

Merci pour ta réponse.
Oui je change la valeur dans le configuration.h et je téléverse (après avoir sauvegardé, on ne sait jamais).

Du coup si je fais ta manipulation M851 Z-1.5 + M500 + M501 ...

Visuellement sur la machine ça ne change rien, peut importe la valeur du "M851 Z".
Le M501 retourne ces valeurs :

Stored settings retrieved
Steps per unit:
M92 X80.00 Y80.00 Z1600.00 E93.00
Maximum feedrates (mm/s):
M203 X400.00 Y400.00 Z2.00 E45.00
Maximum Acceleration (mm/s2):
M201 X5000 Y5000 Z50 E5000
Acceleration: S=acceleration, T=retract acceleration
M204 S1000.00 T2000.00
Advanced variables: S=Min feedrate (mm/s), T=Min travel feedrate (mm/s), B=minimum segment time (ms), X=maximum XY jerk (mm/s),  Z=maximum Z jerk (mm/s),  E=maximum E jerk (mm/s)
M205 S0.00 T0.00 B20000 X20.00 Z0.40 E5.00
Home offset (mm):
M206 X0.00 Y0.00 Z0.00
PID settings:
M301 P22.20 I1.08 D114.00
ok

 

Une idée ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Juste pour savoir si j'ai tout compris ta buse reste a 1mm du plateau quand tu lance une impression donc ca imprime pas

Partager ce message


Lien à poster
Partager sur d’autres sites

C’est ça, la première couche ne se colle pas sur le plateau du coup ça imprime « dans le vide »

Partager ce message


Lien à poster
Partager sur d’autres sites

Et t'es step/mm sur le Z son bon je veux dire si tu monte de 10cm (100) tu monte de la bonne valeur

sinon j'ai regarder ton configuration.h mais j'ai commencer avec un marlin bcp plus recent et c'est pas du tout pareil mais y'a une ligne qui m'interpelle

essaye de la modifier pour voir

#define Z_MIN_POS -0.69

c'est peu etre la le probleme mais je suis pas sur du tout desolé

Partager ce message


Lien à poster
Partager sur d’autres sites

J'avais mis le Z_MIN_POS à -0,69 afin de pouvoir lancer une impression en descendant manuellement le Z à -0,69 pour que ma première couche soit écrasée. 

Mais ça ne fonctionne pas tout le temps, le Start G-CODE (G1 Z-0.69 que j'ai mis dans CURA ne semble pas être pris en compte).
 

Je viens de vérifier que le Z montait bien de 10cm, et à plus ou moins 0,1mm près c'est bon (mesure au pied à coulisse).

Partager ce message


Lien à poster
Partager sur d’autres sites

désole je séche mais je ne suis pas le plus grand des experts après si tu connais la configuration d'un  marlin tu pourrais essayer une version plus récente qui gére plutôt bien le 3D Touch/BL touch car je vois pas y'a pas mal de modif a faire mais c'est assez compréhensible

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour @CTZen 

Quand tu demandes un home de la tête (G28), la buse se trouve au niveau du plateau ou elle est 1 mm au-dessus?

Es-tu certain des valeurs données pour indiquer où se trouve ton BLTouch par rapport à ta buse dans ton Marlin (lignes 398 à 402)

Citation

  // these are the offsets to the probe relative to the extruder tip (Hotend - Probe)
  // X and Y offsets must be integers
  #define X_PROBE_OFFSET_FROM_EXTRUDER 4
  #define Y_PROBE_OFFSET_FROM_EXTRUDER -43
  #define Z_PROBE_OFFSET_FROM_EXTRUDER 1.5

Si ton Z_probe_offset_from_extruder est bien 1,5 mm au-dessus de la pointe de la buse alors, je ne sais pas où se situe le problème.

Lignes 506+, à quoi sevent les "#define Z_probe_offset_range_min|max" ? Et pour information, 0 est aussi bien positif que négatif 😉 .

Citation

// Custom M code points
#define CUSTOM_M_CODES
#ifdef CUSTOM_M_CODES
  #define CUSTOM_M_CODE_SET_Z_PROBE_OFFSET 851
  #define Z_PROBE_OFFSET_RANGE_MIN -20
  #define Z_PROBE_OFFSET_RANGE_MAX -0

#endif

 

Il y a une différence notable entre les versions du Marlin concernant la commande M851 (en rouge ci-dessous)

Citation

M851: Set Z-Probe Offset

Support FiveD Teacup Sprinter Marlin Repetier Smoothie RepRapFirmware Machinekit MakerBot grbl Redeem MK4duo
??? ??? ??? Yes ??? ??? Use G31 ??? ??? ??? ??? Yes

Sets the Z-probe Z offset. This offset is used to determine the actual Z position of the nozzle when using a probe to home Z with G28. This value may also be used by G29 to apply correction to the Z position.

This value represents the distance from nozzle to the bed surface at the point where the probe is triggered. This value will be negative for typical switch probes, inductive probes, and setups where the nozzle makes a circuit with a raised metal contact. This setting will be greater than zero on machines where the nozzle itself is used as the probe, pressing down on the bed to press a switch. (This is a common setup on delta machines.)

This setting is saved in the EEPROM by M500 and restored by M501. The default (as reset by M502) is set by the Z_PROBE_OFFSET_FROM_EXTRUDER setting in Configuration.h.

Note that in Marlin 1.1.0 and later M851 sets the value literally as given, while Marlin 1.0.2 negates the absolute value.

The examples below will set the Z-probe Z offset to -4mm (below the nozzle):

M851 in Marlin 1.0.2

M851 Z4 ; Set the Z probe offset to -4
M851 in Marlin 1.1.0

M851 Z-4 ; Set the Z probe offset to -4

En espérant avoir utile...

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut @fran6p 

 

Le 10/10/2018 at 18:22, fran6p a dit :

Quand tu demandes un home de la tête (G28), la buse se trouve au niveau du plateau ou elle est 1 mm au-dessus?

Quand je fais un Home avec G28 la buse se trouve (environ) à 1 mm au dessus du plateau.

Le 10/10/2018 at 18:22, fran6p a dit :

Si ton Z_probe_offset_from_extruder est bien 1,5 mm au-dessus de la pointe de la buse alors, je ne sais pas où se situe le problème.

C'était la dernière valeur que j'avais mise avant d'envoyer le fichier. Ce que je disais dans mon message initial, c'est que peut importe la valeur que je rentre sur cette ligne, ça ne change strictement pas le résultat.

Le 10/10/2018 at 18:22, fran6p a dit :

Lignes 506+, à quoi sevent les "#define Z_probe_offset_range_min|max" ? Et pour information, 0 est aussi bien positif que négatif 😉 .

Je ne les connaissais pas ces lignes ... 😄 mais elles ne changent rien non plus... 😪

Le 10/10/2018 at 18:22, fran6p a dit :

Il y a une différence notable entre les versions du Marlin concernant la commande M851 (en rouge ci-dessous)

Merci pour l'information !

J'ai fais un essai interessant ... j'ai changé mon M851 via Marlin3DPrinterTool ... et la valeur reste à Zero même si je la change que je save que je read (M500 M501).

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon nouvelle chose interessante.

J'ai désactivé les Eeprom (en commentant les lignes //#define EEPROM_SETTINGS et //#define EEPROM_CHITCHAT).

Quand je fais Home, mon LCD m'indique à la fin de la procédure, un Z de la valeur de mon Z_PROBE_OFFSET_FROM_EXTRUDER du fichier config.h.
Par exemple si je donne #define Z_PROBE_OFFSET_FROM_EXTRUDER à 0.69, il m'affichera un Z=0.69 à la fin de mon G28.
Ma buse reste cependant toujours à 1mm de mon bed. Cependant je peux la descendre a Z=-0.68

Du coup si je met par exemple Z_PROBE_OFFSET_FROM_EXTRUDER à Z=1.4, je peux descendre manuellement mon Z à Z=-1.39 ...

Si ça peut donner une piste ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Tu penses bien à remettre à zéro ton EEPROM? Via lecture des données contenues dans le configuration.h par un M502 puis sauvegarde par un M500, vérification via un M503 (la série des M500-503 ici).

Sinon, ce sont les valeurs stockées en EEPROM ( M501) qui prennent le pas et donc même quand tu fais des modifications dans configuration.h puis que tu charges ton nouveau Marlin.

il y a 26 minutes, CTZen a dit :

Quand je fais un Home avec G28 la buse se trouve (environ) à 1 mm au dessus du plateau.

C'est que les valeurs de positionnement du BLtouch sont incorrectes par rapport à la pointe de la buse (es-tu certain qu'il est 1,5mm au-dessus de cette pointe?                     

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 1 minute, fran6p a dit :

Tu penses bien à remettre à zéro ton EEPROM? Via lecture des données contenues dans le configuration.h par un M502 puis sauvegarde par un M500, vérification via un M503 (la série des M500-503 ici).          

@fran6p

oui oui je fais bien tout ça mais ça ne change rien. Comme si les eeprom ne fonctionnaient pas, même quand activés.

il y a 2 minutes, fran6p a dit :

C'est que les valeurs de positionnement du BLtouch sont incorrectes par rapport à la pointe de la buse (es-tu certain qu'il est 1,5mm au-dessus de cette pointe?                     

le 1.5 c'était un test que j'avais fait avant l'envoi.

Changer la valeur ne changer rien à mon Home. J'ai mettre -2, +5, -999, +5555555555, ma buse sera toujours à la même position.

Partager ce message


Lien à poster
Partager sur d’autres sites

Désolé mais là je sèche 😞 .

Quelqu'un aura peut-être d'autres idées / solutions.

La commande M504, je crois permet de valider / vérifier une EEPROM.

Partager ce message


Lien à poster
Partager sur d’autres sites

Tu ne gagnerais pas ton temps a passer sur une version récente de Marlin. Le debug de ton 3Dtouch sera presque facile ensuite

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut Hidus !

c’est rigolo que tu viennes de répondre j’etais en train de télécharger ta version 1.1.8 !

J’espere que ça va régler le soucis 🙂

Modifié (le) par CTZen

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon et bien problème réglé grâce à ton Firmware Hidius ! (compilé avec Arduino 1.6.7)
Je repartage ton lien de téléchargement pour la version 1.1.8 >>> Geee-i3proB_Marlin-1.1.8-3DTouch-20180121.zip

On retiendra de ce post que la version 1.0.2 de Marlin n'est pas adaptée pour le 3dTouch.

 

Merci à tous !!

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×