Aller au contenu

Filament ABS

probleme gcode demarrage sur repetier


Messages recommandés

bonjour tout le monde j'ai un probleme avec mon gcode de demarrage

 

; Default start code
G28 ; Home extruder
g29; bed Z probe
G1 Z15 F{Z_TRAVEL_SPEED}
M107 ; Turn off fan
G90 ; Absolute positioning
M82 ; Extruder in absolute mode
{IF_BED}M190 S{BED}
; Activate all used extruder
{IF_EXT0}M104 T0 S{TEMP0}
; Wait for all used extruders to reach temperature
{IF_EXT0}M109 T0 S{TEMP0}
g00 x0 y0 z40; deplacement dans le coin
g01 e30 f200; extrusion
G92 E0 ; Reset extruder position

 

il n execute pas cette ligne:

g01 e30 f200; extrusion

Lien vers le commentaire
Partager sur d’autres sites

il y a 25 minutes, v tec a dit :

il n execute pas cette ligne:

g01 e30 f200; extrusion

Bonjour,

@v tec ,tu as essayé en définissant la vitesse puis la trajectoire ?

G1 F200

G1 E30

voir l'exemple sur la page

 https://reprap.org/wiki/G-code/fr#G0_.26_G1:_Move

Modifié (le) par Tfou57
Lien vers le commentaire
Partager sur d’autres sites

Hello,

il y a 59 minutes, v tec a dit :

il n execute pas cette ligne:

g01 e30 f200; extrusion

Tout simplement parce que la commande g01 n'existe pas. 😁

il faut écrire   G1 E30 F200 ; extrusion

il y a une heure, v tec a dit :

g00 x0 y0 z40; deplacement dans le coin

idem pour g00

il faut écrire   G0 X0 Y0 Z40 ; déplacement dans le coin

il y a une heure, v tec a dit :

g29; bed Z probe

je mettrais une majuscule pour le G

G29 ; bed Z probe

Lien vers le commentaire
Partager sur d’autres sites

Il y a 3 heures, trotro a dit :

Tout simplement parce que la commande g01 n'existe pas. 😁

Je pensais que le "0" de G01 serait ignoré à l'exécution.

Merci de l'avoir signalé

Il y a 4 heures, v tec a dit :

{IF_BED}M190 S{BED}
; Activate all used extruder
{IF_EXT0}M104 T0 S{TEMP0}
; Wait for all used extruders to reach temperature
{IF_EXT0}M109 T0 S{TEMP0}

J'avais hésiter sur ces lignes avec des "IF" et des variables

Je viens de découvrir que le start code ou le end code dans le slicer peut utiliser de nombreuses variables.

La liste de ces variables est-elle la même dans tous les slicers ?

variables.thumb.png.b1d8fdfd8a77ca7ca25567edbc4934c1.png

296621427_variable2.png.3a6adbc99b7bfaec94e72c0a1baebc36.png

Avez vous en référence, un lien décrivant la totalité variables utilisables (autres que celles utilisées dans l'illustration ci-dessus) ?

L'utilisation des "IF" est pour pouvoir imprimer sur toutes imprimantes 3D avec le même Gcode ?

Modifié (le) par Tfou57
Lien vers le commentaire
Partager sur d’autres sites

franchement je dois etre super con:

 

; Default start code
G28 ; Home extruder
G29
G1 Z15 F{Z_TRAVEL_SPEED}
G1 X0 Y20 F{Z_TRAVEL_SPEED}
M107 ; Turn off fan
G90 ; Absolute positioning
M82 ; Extruder in absolute mode
{IF_BED}M190 S{BED}
; Activate all used extruder
{IF_EXT0}M104 T0 S{TEMP0}
G1 E20 F100
G92 E0 ; Reset extruder position
; Wait for all used extruders to reach temperature
{IF_EXT0}M109 T0 S{TEMP0}
G1 Z0 F{Z_TRAVEL_SPEED}

 

 

au debut j'avais mis G0 X0 Y20 

 

resultat le deplacement pour cette ligne etait mega mega lent

 

j ai donc mis

G1 X0 Y20 F{Z_TRAVEL_SPEED}

 

idem....

Lien vers le commentaire
Partager sur d’autres sites

Le 29/10/2018 at 20:46, v tec a dit :

G1 X0 Y20 F{Z_TRAVEL_SPEED}

idem....

Z_TRAVEL_SPEED  est la vitesse de déplacement de ton axe Z (vitesse qui est mega lente 😁)

Je mettrais plutôt :

G1 X0 Y20 F{travel_speed}     comme ligne 20 de ton tableau.

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...