Aller au contenu

Filament ABS

sfersystem

TLTouch, fausse bonne idée ? (Ender3)

Messages recommandés

Bonjour,

Cela fait quelques mois que j'utilise mon Ender 3, c'est top et les impressions de bonne qualité, je n'ai rien à déplorer de ce coté là.

Le seul souci, c'est le plateau concave. Du coup j'ai testé avec un miroir, mais la colle, la laque et le nettoyage on eu raison de moi, le track d'origine accroche si bien .. 

Alors j'ai commandé un TLTouch que j'ai installé et qui fonctionne à merveille quand on regarde faire, mais en réalité il ne fait pas du tout le job. je règle mon Z offset à la manière d'un tuto trouvé sur youtube, la procédure me paraît logique.

Avec Marlin 1.1.9 modifié pour l'Ender 3 et dans l'ordre :
-----------------------------
Home
M851 Z0
M500
M501
M503

G28 Z
G1 F60 Z0
M211 S0

Mettre le papier sous la buse et régler la hauteur de cette dernière

Récupérer la valeur sur le LCD -1.1 (par exemple)
M851 Z-1.1
M211 S1

M500
M501
M503

Tout fonctionne bien, mais lorsque je lance une impression dans cura ou simplify, elle n'est pas ajustée au plateau (trop écrasée d'un coté, limite on voit pas la matière, et à d'autres endroits bien trop haut, le filament n'accroche pas)

J'ai tenté à plusieurs reprises l'ordre G29 et les résultats dans pronterface sont à chaque fois différents. (comme si l'axe Z avait du jeu ou si mon plateau bougeait d'une impression à l'autre)

Sur certaines calibrations, la buse vient même en butée et appuie le plateau et à d'autres endroits je vois bien que je suis à plus d'un mm du plateau.. j'ai cherché sur Github dans la config de Marlin, mais j'ai l'impression d'avoir fait le tour.

Nota : j'ai tenté de lancer un M48 P4 X100 Y100 V2 E L2 mais je n'ai pas de réponse à cet ordre. (unknow command .. )

Voici le G-Code que j'utilise

G28 ; home all axes

M420 S1

M140 S[bed0_temperature] ; bed temp

G29 ; BLTOUCH mesh generation

M104 S[extruder0_temperature] T0 ; nozzle temp

G28 X Y ; home X and Y axes

M190 S[bed0_temperature] ; wait for bed temp

M109 S[extruder0_temperature] T0 ; wait for nozzle temp

M117 Purge extruder

G92 E0 ; reset extruder

G1 Z1.0 F3000 ; move z up little to prevent scratching of surface

G1 X0.1 Y20 Z0.3 F5000.0 ; move to start-line position

G1 X0.1 Y200.0 Z0.3 F1500.0 E15 ; draw 1st line

G1 X0.4 Y200.0 Z0.3 F5000.0 ; move to side a little

G1 X0.4 Y20 Z0.3 F1500.0 E30 ; draw 2nd line

; G1 E27 F3000 ; retract filament 3mm

G92 E0 ; reset extruder

; done purging extruder

G1 Z1.0 F3000 ; move z up little to prevent scratching of surface

M117 sfersystem design !

Merci pour votre aide.

Partager ce message


Lien à poster
Partager sur d’autres sites
youtube drone débutant

Nouvelle calibration + M500 pour sauver.

Test 1st layer n'est pas concluant.
(J'aurais bien aimé lancer le test de précision M48 P4 X100 Y100 V2 E L2 )

Mais il m'indique que la commande est inconnue, faut-il l'activer sous Marlin ?

Edit : Trouvé

// Enable the M48 repeatability test to test probe accuracy
//#define Z_MIN_PROBE_REPEATABILITY_TEST

Merci.

IMG_20181216_142115.jpg

Modifié (le) par sfersystem

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai l'impression que les résultats sont pas géniaux

0.45 veut bien dire que j'ai une fluctuation d'un demi mm ?

1er test

Finished!
Mean: -0.648125 Min: -1.205 Max: -0.162 Range: 1.042
Standard Deviation: 0.454421

2ème test (beaucoup mieux)

Finished!
Mean: 0.238125 Min: 0.140 Max: 0.360 Range: 0.220
Standard Deviation: 0.098479

3ème test

Finished!
Mean: -0.813750 Min: -1.415 Max: -0.380 Range: 1.035
Standard Deviation: 0.414180

Partager ce message


Lien à poster
Partager sur d’autres sites

Après entretien avec le vendeur, il semblerait qu'il s'agisse d'un problème connu. En effet, les vibrations de l'imprimante auraient tendance à faire légèrement pivoter l'aiguille, ce qui aurait pour cause de fausser la prise de mesure d'un test à l'autre.

Cela me semble logique car effectivement mon imprimante souffre tremblements. Ils sont perceptibles qu'à certains moments du déplacement de la buse mais c'est bien le cas.

quelqu'un aurait une idée de la provenance de ces vibrations ?

Merci

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

j'ai une ender3 j'ai installé un capteur 3d touch acheté 10 E sur gearbest

quant je fait la commande G28  G29 dans un terminal il fait c'est 6 point de mesure.

mais a chaque fois sur un des 6 points au hazard il enfonce le bed.

es que le capteur est nulle ou c'est le bonhomme qui sait pas s'en servir ?

mauvais câblage ? mauvais paramètre Marlin ?

j'ai utilisé cette doc Ender 3 BLtouch vanilla Marlin guide https://www.youtube.com/watch?v=sUlqrSq6LeY

bonne soirée

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir Ciscolyon,

Je ne pourrait t'aider avec le BLtouch, je n'en ai pas... désolé 😞
Par contre j'ai le même soucis de vibration qui apparaît de temps en temps. J'ai l'impression que cela viens des moteurs X Y 
Par moment, le bruit des moteurs changent, et une légère vibration apparais. Cela n'affecte pas la géométrie des pièces, mais cela ce voie sur les surfaces planes.

Je m'en suis rendu compte le week-end dernier quand je regardais la première couche d'une pièce.
Dans le cadre vert, bruit normal.
Dans le cadre rouge, le bruit différent avec des vibrations.

IMG_20181230_141046.thumb.jpg.7d58910d43bfe6cdc766dfcced6094ec.jpg

 

image.png.9d8fd425411302dd87aa88666df8a874.png

 

Cela ne me dérange pas plus que cela, mais si quelqu'un une idée du pourquoi du comment 🙂

Merci!

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

 

J'utilise un bltouch sur mes deux imprimantes PRUSA  et hypercube.

Je confirme que le BLTOUCH n'aime pas les vibrations et qu'il faut deux palpages sur chaque point avec une vitesse du Z plus lente.

Pour améliorer la precision du palpage je suis même passé sur des drivers DRV8825 avec smoother sur le z en 1/32 pas.

Il faut aussi bien régler son  plateau sans forcer sur les vis avec ressort qui occasionnent une déformation du plateau.

Le ( M48 P4 X100 Y100 V2 E L2 ) est effectivement la bonne solution au quatre coin.

Pour les vibrations réduire la vitesse X et Y lors du palpage

pour exemple sur mon hypercupe

image.thumb.png.19e52d37c76b4b474bfb0403a606a987.png

Je profite du réglage du plateau ci dessus pour décrire ma méthode du réglage de l'offset Z sur mon hypercube

Donc une fois mon plateau bien réglé comme ci dessus je  lance un Z-10 dans le menu " contrôle des molettes" SIMPLIFY 3D

Mesure à faire une seule fois pour connaitre la distance entre la buse et le plateau.

(Je rappelle que dans configuration.h j'ai  "#define Z_PROBE_OFFSET_FROM_EXTRUDER 0")

Mesure faite avec le plateau et la buse en température d'impression.

je lance la commande M851 Z-(la distance entre la buse et le plateau mesurée ci dessus) pour moi Z-1.2

M500 et vérification avec M851.

je lance une première impression et en fonction du résultat je répète le réglage en augmentant la valeur z- pour écraser un peu plus ou je diminue la valeur z- si trop écrasé.

M851 Z-.......

M500

M851

Je peaufine le réglage de 1/10 en 1/10 voir 5/100 du z- en fonction de l'aspect de la première couche, aspect  lisse sans effet patte d’éléphant le réglage est correct

Patte d’éléphant = trop écrasé = un petit 1/10 ou 5/100 en plus

Si les ligne d'impression sont visibles même légèrement pas assez écrasé = un petit 1/10 ou 5/100 en moins

Voilà je n'utilise jamais le réglage avec la feuille de papier.



lion02

Modifié (le) par lion02
  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×