Aller au contenu

Filament ABS

Free66

Bonjour ! Octoprint problème de communication

Messages recommandés

Voici l'exposé de mon problème, 

J'utilise octoprint dans sa dernière version, je n'ai jamais eu de soucis jusque là, mais depuis un moment j'ai l'impression qui stoppe, obligé de forcer le ack dans Octoprint.

j'ai donc depuis changé de raspberry, re-injecté le firm 2.16A de la Alfawise.

Et dernièrement en fouillant sur des forums Anglo-saxons qui ont parfois le même problème semble venir d'un 'Ok' reçu n'importe comment, j'ai donc regarder dans les logs et j'ai découvert ceci :

Send: N2148 M105*24
Recv: ok T:205/205 B:55/55
Send: N2149 G1 X166.283 Y133.680 E0.1695*96
Recv: ok
Send: N2150 G1 X166.649 Y133.680 E0.1841*109
Recv: ok
Send: N2151 G1 X166.649 Y133.200 E0.2033*110
Recv: ok
Send: N2152 G1 X166.177 Y133.200 E0.2221*102
Recv: ok
Send: N2153 G1 X166.157 Y133.125 E0.2252*101
Recv: ok
Send: N2154 G1 X165.968 Y132.721 E0.2430*100
Recv: ok
Send: N2155 G1 X166.649 Y132.720 E0.2703*104
Recv: ok
Send: N2156 G1 X166.649 Y132.240 E0.2894*105
Recv: ok
Send: N2157 G1 X165.597 Y132.240 E0.3314*105
Recv: ok
Send: N2158 G1 X166.266 Y147.164 F3600*118
Recv: ok
Recv: ok
Send: N2159 G1 X166.463 Y148.948*30
Send: N2160 G1 X166.493 Y150.000*23

J'ai donc 2 "Recv: ok' l'un derrière l'autre, du coup Octoprint stoppe l'envoie des commandes suivantes...ceci arrive de temps en temps, surtout en débout d'impression, après plus de soucis, j'utilise S3D, dans le fichier Gcode je ne vois rien de particulier, j'ai bien le retour chariot 'CR-LF' à chaque ligne...

Si vous voyez un début de piste, merci infiniment, car moi je sèche un peu.

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 09/03/2019 at 11:13, Free66 a dit :

Voici l'exposé de mon problème, 

J'utilise octoprint dans sa dernière version, je n'ai jamais eu de soucis jusque là, mais depuis un moment j'ai l'impression qui stoppe, obligé de forcer le ack dans Octoprint.

j'ai donc depuis changé de raspberry, re-injecté le firm 2.16A de la Alfawise.

Et dernièrement en fouillant sur des forums Anglo-saxons qui ont parfois le même problème semble venir d'un 'Ok' reçu n'importe comment, j'ai donc regarder dans les logs et j'ai découvert ceci :


Send: N2148 M105*24
Recv: ok T:205/205 B:55/55
Send: N2149 G1 X166.283 Y133.680 E0.1695*96
Recv: ok
Send: N2150 G1 X166.649 Y133.680 E0.1841*109
Recv: ok
Send: N2151 G1 X166.649 Y133.200 E0.2033*110
Recv: ok
Send: N2152 G1 X166.177 Y133.200 E0.2221*102
Recv: ok
Send: N2153 G1 X166.157 Y133.125 E0.2252*101
Recv: ok
Send: N2154 G1 X165.968 Y132.721 E0.2430*100
Recv: ok
Send: N2155 G1 X166.649 Y132.720 E0.2703*104
Recv: ok
Send: N2156 G1 X166.649 Y132.240 E0.2894*105
Recv: ok
Send: N2157 G1 X165.597 Y132.240 E0.3314*105
Recv: ok
Send: N2158 G1 X166.266 Y147.164 F3600*118
Recv: ok
Recv: ok
Send: N2159 G1 X166.463 Y148.948*30
Send: N2160 G1 X166.493 Y150.000*23

J'ai donc 2 "Recv: ok' l'un derrière l'autre, du coup Octoprint stoppe l'envoie des commandes suivantes...ceci arrive de temps en temps, surtout en débout d'impression, après plus de soucis, j'utilise S3D, dans le fichier Gcode je ne vois rien de particulier, j'ai bien le retour chariot 'CR-LF' à chaque ligne...

Si vous voyez un début de piste, merci infiniment, car moi je sèche un peu.

Salut,

Le sujet a déjà été évoqué de différentes façons. Le problèmes est hardware. Tu as des pertes de synchros entre ton PI et l'imprimante. Problème imputable au convertisseur USB/Serial de la machine.

Le problème semble s'aggraver avec le temps. De même, le débit d'origine est bien insuffisant selon la vitesse et la complexité de nos impressions.

Modifié (le) par CacaoTor
  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 2 heures, Free66 a dit :

merci @CacaoTor, mais c'est pas très rassurant comme nouvelles !

Oui et non.

Je cherche une solution de contournement pérenne sur un sujet dédié.

Partager ce message


Lien à poster
Partager sur d’autres sites

Je reviens sur mon problème, après une lecture d'un autre post, j'ai décidé de faire un peu le ménage dans les plugins d'Octoprint qui ne servent pas/plus ou sont superflue, j'ai donc éliminé "astroprint", "octoprint Anywhere" et "virtual printer", c'est ma 4éme impression est plus de soucis de "Ack".

si ça peut aussi donner une piste à d'autres.

@+

Partager ce message


Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.


  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...