Aller au contenu

Filament ABS

  • 0

[Résolu] Gcode pour l'extrusion des fils


Question

Bonjour,

 

Je pense avoir cherché partout mais je n'ai rien trouvé.

Ayant plusieurs sortes de filaments, pla, petg, abs ect... je me retrouve confronté a chaque fois au soucis du calcul de la quantité d'extrusion pour 100mm.

Alors oui, je pourrais faire le calcul 1 fois puis le marquer quelque part. Je l'ai deja fait mais j'ai perdu le quelque part 😛

Du coup je me suis demandé si en creant des profils de fils dans mes slicers, je ne pouvais pas integrer un gcode dans le gcode de demarrage, qui mettrait automatiquement l'extrusion au bon chiffre.

 

Merci d'avance 🙂

 

EDIT : Juste apres avoir validé la question je tombe sur un post qui parle du M92 E..

J'ai donc resolu mon probleme 🙂

Modifié (le) par Stef67
Lien à poster
Partager sur d’autres sites

7 réponses à cette question

Messages recommandés

  • 0

Oui tu as juste à ajouter la ligne M92 E... Avec ta valeur de steps.

Attention, quand tu consultes les valeurs sur l'imprimante, elle te sort plein de valeur sur la ligne M92 

Par contre pour donner les valeurs il ne faut en donner qu'une à la fois, donc en ce qui te concerne, uniquement le E...

Stef.

Lien à poster
Partager sur d’autres sites
  • 0
Il y a 2 heures, Titouvol a dit :

Par contre pour donner les valeurs il ne faut en donner qu'une à la fois, donc en ce qui te concerne, uniquement le E...

Tu es sûr ?

J'ai pourtant une ligne comme M92 X79.4 Y80 Z1200 E95,25 dans mon gcode de démarrage pour ma CR10 et ça fonctionne bien (carte et firmware d'origine pas de M500 possible).

🙂

Lien à poster
Partager sur d’autres sites
  • 0

Peut être une différence entre le gcode et l'entrée manuelle des commandes dans le firmware l'imprimante.

J'ai vu passer un message récemment parlant de lancer cette commande avec une valeur à la fois. Mais c'était pour la stocker définitivement dans le firmware. Et perso quand j'ai modifié les steps de l'extrudeur, j'ai du mettre uniquement la valeur de E.

A tester donc (sauf si quelqu'un peut trancher).

Lien à poster
Partager sur d’autres sites
  • 0
Il y a 21 heures, Titouvol a dit :

A tester donc (sauf si quelqu'un peut trancher).

Inutile de se faire des nœuds au cerveau. La «Bible» du Marlin pour la commande M92 le dit, On peut le faire pour un ou plusieurs axes à la fois :

M92.jpg.9f32dd3380c902fa5cdd4efc6a1b0277.jpg

🙂

Lien à poster
Partager sur d’autres sites
  • 0
Il y a 18 heures, Titouvol a dit :

Curieux, j'avais peut être fait une faute de frappe quand j'avais mis toute la ligne complète.

L'erreur la plus fréquente est de mettre une virgule au lieu du point décimal anglo-saxon. Dans ce cas, Marlin ne prend pas en compte les directives suivantes de la commande (la différence n'est pas toujours facile à voir entre . et , ) 😉

🙂

Lien à poster
Partager sur d’autres sites
  • 0

C'est possible, comme je l'ai dit j'avais peut etre une faute de frappe ...
Le point/virgule, c'est possible aussi, cependant j'ai saisie une valeur avec une décimale pour le E ...
Donc il me l'aurait refusé meme avec 1 seule valeur.

Lien à poster
Partager sur d’autres sites
Invité
Ce sujet ne peut plus recevoir de nouvelles réponses.
  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

  • YouTube / Les Imprimantes 3D .fr

×
×
  • Créer...