Aller au contenu

Filament ABS

offset negatif inoperant


augier

Messages recommandés

salut

reprise de mon activité après 8 jours , le semaine derniere impression sans pb

ce matin impossible d imprimer ( l imprimante est a la meme place dans la meme configuration)

apres le mise en marche

la buse lors de l impression se positionne a 1 mm de la surface et ne descend pas plus

malgres différents réglages de l offset

curieusement si je demande un offset a +10 mm la buse se place a 10 mm du plateau

si je demande un offset negatif quelque soit la valeur saisie, la buse descend et reste a 1 mm au dessus du plateau

une idee ? merci

Lien vers le commentaire
Partager sur d’autres sites

Tu regles ou cet offset ? CbD ou Gcode ?

Regarde dans le Gcode, il faut un

G01 Z0

G92 Zx

avant la descente de l'offset...

X representant une vleur quelquonque mais positive qui permettra a l'imprimante de descendre car le marlin n'autorise pas la descente en valeur negative. Donc on triche en faisant croire a l'imprimante que Z est a +10 a la position 0 relevée par le palpeur lors du G28/G29..

Lien vers le commentaire
Partager sur d’autres sites

voila mon fichier genere

avec CbD, sctoch bleu , offset a -0.16

 

G91  ;relative positioning
G1 Z7
G90  ;absolute positioning
G28 X
M109 S220
G28 X
G28 Y
G01 X20 Y100
G28 Z
M104 S220
;bloc palpeur
G29
;bloc Offset
G92 Z10
G91  ;relative positioning
G1 Z-0.91
G90
G92 Z0
G1 Z3
G1 X100 Y200 F3000
G1 Z2
M106  ;start fan full power
M109 S220
M82 ;set extruder to absolute mode
M107 ;start with the fan off
G92 E0 ;zero the extruded length
G1 F200 E3 ;extrude 10mm of feed stock
G92 E0 ;zero the extruded length again
G1 F9000

Lien vers le commentaire
Partager sur d’autres sites

Et donc tu coches bien "autre" dans surface ? Si tu coche Buildtak la case offset est inop..

Verifie dans ton Gcode generé si tu as bien le G92 Zx avant la descente de l'offset. Sinon il faudra le rajouter dans ton Gcode start.

Lien vers le commentaire
Partager sur d’autres sites

mistere et boule de gomme !!

apres le post ci dessus

je repasse ce fichier a  l imprimante

palpage 5 fois

4 doubles , 1 simple

la buse se positionne a 1/2 mm de la surface

et l impression démarre normalement

allez y comprendre qq chose !!!!!

Lien vers le commentaire
Partager sur d’autres sites

il y a 7 minutes, iCedric a dit :

Et donc tu coches bien "autre" dans surface ? Si tu coche Buildtak la case offset est inop..

Verifie dans ton Gcode generé si tu as bien le G92 Zx avant la descente de l'offset. Sinon il faudra le rajouter dans ton Gcode start.

je coche sctoch bleu pourtant

et si je verifie le g code j ai bien la modif qui se fait

j ai essaye avec plusieurs valeurs et elles sont pris en compte

(currieusement le log rajoute -0.75 ) j avais rentre -0.16 et j obtient -0.91 ( -0.16 + -0.75 = -0.91 )

Lien vers le commentaire
Partager sur d’autres sites

On ne le vois pas dans le G code.

Dans CbD ou cura, tu peux mettre à plat ta pièce, une petite icône en bas à gauche avec mettre à l'échelle et rotation. Ça colle ta piece au plateau.

si elle n'est pas sur le plateau.....baisé...

clic droit maintenu et tu peux orienter ta vue en 3d

Lien vers le commentaire
Partager sur d’autres sites

J'ai eu aussi la buse qui ne voulait pas descendre

j'ai du modifier le marlin pour autoriser de descendre en dessous de 0

#define min_software_endstops false

par défaut c'est à true et ça protège des mouvements qui dépasseraient les butées

Mais avec le capteur on est obligé de desendre en dessous de zéro car la buse est plus haute que le point de détection du capteur

Par défaut il y a un probe offset qui décale de 2.5mm ce qui fait que certains n'ont pas le pb

Modifié (le) par Huggy
Lien vers le commentaire
Partager sur d’autres sites

Il y a 23 heures, piccolini a dit :

Dans CbD ou cura, tu peux mettre à plat ta pièce, une petite icône en bas à gauche avec mettre à l'échelle et rotation. Ça colle ta piece au plateau.

si elle n'est pas sur le plateau.....baisé...

clic droit maintenu et tu peux orienter ta vue en 3d

y a de ca !

Lien vers le commentaire
Partager sur d’autres sites

  • 3 weeks later...

bon je reprends

a la suite de ses pb tout était rentre dans l ordre sans rien faire

impressions correctes la semaine derniere

ce matin je reprends l impression  avec un fichier test (qui marchait normal la semaine derniere)

je n ai rien touche depuis

impossible d imprimer >> la buse se positionne a 2 mm au dessus du plateau

cables verifies > ras

j ai l impression que la carte fait n importe quoi mais aleatoirement

Lien vers le commentaire
Partager sur d’autres sites

et le palpage fait n importe quoi aussi

descente rapide normal mais pas de descente lente apres

et le 4 eme point la machine ne descent meme pas jusqu au plateau elle arrete le palpage a 2 mm

greeeeeeeeeeeeeeeuuuuuuu !!!

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...