Aller au contenu

Filament ABS

Messages recommandés

Bonjour,

J'ai reçu ma SKR Pro V1.2 que j'ai déjà flashée via la carte SD, mais je souhaite la connecter à Octoprint pour faire le flashing ; mais manifestement c'est pas comme sur les MKS Gen L ; le STM32 ne se programme pas de la même manière que les Atmel2560.

J'ai vu qu'il y a plusieurs method de flashing dans le plugin Octoprint, mais je ne sais pas trop quoi choisir et comment le configurer :

* Méthode STM32, semble demander le chemin faire stm32flash ???

* Sur certain forum chez cru comprendre que BTT avez mis un custom bootloader pour pouvoir programmer les SKR PRO comme les SKR classique via LCP1760, mais là encore, je ne sais pas comment configurer le plugin

Je sollicite votre aide pour m'aider et m'accompagner pour configurer le plugin "Octoprint Firmware Updater" afin que je puisse flasher la SKR Pro directement via OctoPrint, et me passer de la carte SD.

 

Méthode : LPC1768

image.thumb.png.a94cbc7d0889753e27b15d8f2fc8435f.png

 

Méthode : STM32

image.thumb.png.a43e2fa30a454796fa95ec874f851b0a.png

 

Ma configuration (mode laboratoire pour le moment)

GOPR0030.thumb.JPG.0c543f8ffca642230f555bd68fc5ecb3.JPG

 

Cordialement.

Lien à poster
Partager sur d’autres sites

Pour le moment, je partage ma compréhension du fonctionnement :

Il faut installer 'usbmount' sur le raspberry, ce qui devrait permettre de monter le lecteur de carte SD présent sur la carte SKR.
On pourra alors depuis le Pi accéder à la carte SD présente sur la SKR (il faut laisser la µSD dans la SKR).
Dans le plugin Octoprint, on renseigne alors le chemin vers le point de montage de cette carte SD à priori '/media/usb' et lors du flash par Octoprint, il va copier le firmware.bin dans la µSD présente sur la carte SKR, puis au reboot de la carte, celle-ci ce mettra à jour automatiquement et renommera le fichier en .cur.

Donc j'ai bien compris le fonctionnement ; mon problème est alors que usbmount ne fonctionne par ... j'ai suivi les instructions ici, mais un `ls -lR /media` donne 0Kb sur tous les points de montage

Je pense que usbmount ne fonctionne pas car, a minima, je devrai retrouver la carte SD du Pi.

Lien à poster
Partager sur d’autres sites

@belfaigore

bonjour,

As-tu essayé ce qui est dit dans cette remontée de problème : https://github.com/OctoPrint/OctoPrint-FirmwareUpdater/issues/137

🙂

Lien à poster
Partager sur d’autres sites

oui, j'ai essaye mais sans succes. Je pense que le souci vient de la configuration de usbmount pourtant j'ai bien suivi les tuto. Je sais pas ce que je fais de pas bien. Je vais suivre la piste sur l'installation de usbmount je verrai bien ou ca meme.

Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

  • YouTube / Les Imprimantes 3D .fr

×
×
  • Créer...