Aller au contenu

Filament ABS

commander une anet A8 depuis le PC


Messages recommandés

j'ai fais le tour du forum mais je n'ai pas trouvé de réponse, alors je pose la question.

pour que vous puissiez m'aider voici ce que je peut vous dire :

je suis sous  Windows 10 Famille
Version    20H2
Installé le    ‎09/‎03/‎2021
Build du système d’exploitation    19042.985
Expérience    Windows Feature Experience Pack 120.2212.2020.0

j'utilise freecad pour modéliser mes pièces a imprimer
Word size of FreeCAD: 64-bit
Version: 0.19.24276 (Git)

j'utilise ultimaker cura 4.9.1 comme trancheur

et j'ai une anet A8 pour imprimer

j'ai fini le montage de l'anet A8 que je viens d'acquérir depuis quelques jours et malheureusement je crois que la carte mère doit être changer car la carte SD n'est pas reconnu. Je précise que la carte SD n'est pas celle fourni par le constructeur car elle est absente de l'emballage. j'ai fait un reformatage de la carte en Fat 32 comme indiquer sur un post, mais rien y fait. du coup je me dit je vais me connecter directement sur mon PC ...

câble branché, l'ordinateur détecte une connexion USB/ com 3, mais a partir de la je bloque.......

sur cura j'ai enregistré mon imprimante, mais je ne peux que faire des enregistrement de fichier pour ma carte SD.

voila ou j'en suis je crois avoir donner le maximum d'info, si vous avez besoin de plus , demandez moi.

merci d'avance

PS ; soyez indulgent avec un novice qui découvre un nouveau monde et qui ne connais pas son langage

Lien à poster
Partager sur d’autres sites

Salutation !

il y a 14 minutes, alfagtv916 a dit :

j'ai fait un reformatage de la carte en Fat 32

Une carte SD de qualité de moins de 32GB formaté en "Fat32" avec des block de 4096 ?

il y a 14 minutes, alfagtv916 a dit :

câble branché, l'ordinateur détecte une connexion USB/ com 3, mais a partir de la je bloque.......

Tu a trouvé le port COM via le gestionnaire de périphériques ? tu vois bien un nouveau périphérique dans le gestionnaire de périphériques quand tu connecte le câble USB ? un périphérique sans un "!" dessus et avec un numéro de port COM du genre Serial COM36 ? une capture d'écran ! Merci !

 

il y a 14 minutes, alfagtv916 a dit :

sur cura j'ai enregistré mon imprimante, mais je ne peux que faire des enregistrement de fichier pour ma carte SD.

Arrive tu aprés découpage a sauver le fichier .gcode sur ton disque ? vois tu la carte SD dans l’explorateur de fichiers Windows ?

image.png

Modifié (le) par PPAC
Lien à poster
Partager sur d’autres sites

la care est reformater en 32 kilo-octets

le contrôleur PCI de communication simplifier est noté "!"

depuis cura j'arrive a enregistrer les fichier g code et ma carte SD apparait dans l'explorateur windows

Lien à poster
Partager sur d’autres sites
il y a 6 minutes, alfagtv916 a dit :

le contrôleur PCI de communication simplifier est noté "!"

Si il y a un "!" sans numéro de port alors il faut installé un driver pour Windows : tu trouvera des explications et le driver via cette page https://www.geeetech.com/forum/viewtopic.php?t=60612

Edit mais cela devrait plus etre un "Serial qq" chose qu'un "controleur PCI ..."

 

  

il y a 6 minutes, alfagtv916 a dit :

la care est reformater en 32 kilo-octets

 

Heu quoi ? formater en "FAT32" pour le type de partition ...unité de block 4096 et pour le 32ko là je suis perdu fait longtemps que je format plus avec l'outil de windows ...

Modifié (le) par PPAC
Lien à poster
Partager sur d’autres sites
il y a 8 minutes, alfagtv916 a dit :

je viens de suivre les instructions et je viens de voir apparaitre

 

Capture d’écran 2021-05-15 135940.jpg

Parfait donc tu a bien le driver et il faut donc utiliser le COM3 pour la connexion (mais de temps en temps (redémarrage de Windows utilisation d'un autre connecteur USB ...) cela peut changer de numéro de port COM alors souvient toi d'allez regarder là le gest. de périphe. si tu a un problème ...) . Il reste a savoir si tu utilise la bonne vitesse et si ton câble USB n'est pas parasité si il n'est pas blindé ...

Aussi, une seul application peut utiliser le port COM en même temps, il faut la fermer pour quelle le libère pour une autre ...

(de temps en temps il faut redémarrer Windows si le port COM n'est pas libre alors qu'il n'y a pas d'application qui l'utilise.)

Edit : attention éviter le multipost il existe la possibilité d'éditer un message ...
https://www.lesimprimantes3d.fr/forum/topic/41764-explication-multipost-a-éviter/

Modifié (le) par PPAC
Lien à poster
Partager sur d’autres sites

Voila alors tu utilise un carte de plus de 16 GB donc l'outil de formatage de windows ne permet pas d'utiliser le Système de fichier "Fat32" il te propose "exFAT" pas le même truc !

Et donc qd tu aura une carte SD de moins de 32 GB tu pourra choisir le Système de fichier "Fat32" avec des taille d'unité de 4096.

et là l'imprimante devrais arriver a lire une carte SD de moins de 32 GB  si correctement formaté.

Mais pas un carte de 64 GB ... surtout si pas formaté en "FAT32" ... 
Enfin il y a peut etre a tester avec https://www.sdcard.org/downloads/formatter/ et créant éventuellement une partition de 16GB mais je pense que cela ne fonctionnera pas l'imprimante 3d ne saura surement pas utiliser une carte de plus de 16GB ... enfin a tester et dit moi si cela fonctionne

Modifié (le) par PPAC
  • J'aime 1
Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)
il y a 13 minutes, PPAC a dit :

Edit : attention éviter le multipost il existe la possibilité d'éditer un message ...
https://www.lesimprimantes3d.fr/forum/topic/41764-explication-multipost-a-éviter/

ok je prend note 

 

Citation

Voila alors tu utilise un carte de plus de 16 GB donc l'outil de formatage de windows ne permet pas d'utiliser le Système de fichier "Fat32" il te propose "exFAT" pas le même truc !

Et donc qd tu aura une carte SD de moin de 32 GB tu poura choisir le Système de fichier "Fat32" avec des taille d'unité de 4096.

et là l'imprimante devrais arriver a lire cette carte correctement formaté.

Modifié (le) par alfagtv916
complement
Lien à poster
Partager sur d’autres sites

Regarde mon précédent message je l'ai édité il y a peut être un truc a tester mais prendre une nouvelle carte SD de 16GB ou moins semble plus sûr et simple comme solution !

Bonne suite de journée !

Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)

bon c'est fait j'ai une nouvelle carte SD de 16 GB est elle est reconnu 🤩

je peux charger une pièce, mais avant de démarrer, j'ai l'impression que mon extruder n'est pas centré. je m'explique ; après avoir regardé plusieurs vidéo j'ai remarqué que lors d'un retour en position de démarrage , l'extruder ce positionne sur le bord et a l'angle du plateau chauffant; or le mien reste en buter sur les 3 axes, donc totalement hors du plateau.

j'ai chercher des tuto ou des vidéo mais pour le moment je n'ai rien trouver pour régler ce problème.... ou des vidéo qui parle de tout et de rien, voir même qui parle pas.

PS: du coup peut on changer le titre du post ? vu que je peux utiliser un carte SD 😜

Modifié (le) par alfagtv916
Lien à poster
Partager sur d’autres sites
il y a 10 minutes, alfagtv916 a dit :

j'ai une nouvelle carte SD de 16 GB est elle est reconnu 🤩

Cool ! 🙂

il y a 10 minutes, alfagtv916 a dit :

l'extruder ce positionne sur le bord et a l'angle du plateau chauffant; or le mien reste en buter sur les 3 axes, donc totalement hors du plateau.

Alors tu a plusieurs possibilité pour bien replacer le plateau

Là si la machine vient d’être monté, il faut commencer par le placement des endstop / capteur de fin de courses (s'il y en a ...) et vérifier que tu n'a pas mal monté le plateau ... il peut y avoir un sens (j'ai déjà croisé un utilisateur sur se forum qui l'avais tourné a 180° ...)

Sinon avec M206 https://marlinfw.org/docs/gcode/M206.html pour modifier/déplacer l'origine

 

Aussi prend le temps d’appliquer cela :

Modifié (le) par PPAC
Lien à poster
Partager sur d’autres sites
il y a 25 minutes, alfagtv916 a dit :

un retour en position de démarrage

Tu veux dire le home ?

Sur l'Anet A8, la position home n'est pas 0,0,0. Tu dois avoir -33 pour X, -10 pour Y et 0 pour Z.

Ces valeurs doivent être visibles sur l'afficheur.

Modifié (le) par jmarie3D
  • Merci ! 1
Lien à poster
Partager sur d’autres sites
il y a 3 minutes, jmarie3D a dit :

Tu veux dire le home ?

Sur l'Anet A8, la position home n'est pas 0,0,0. Tu dois avoir -33 pour X, -10 pour Y et 0 pour Z.

Ces positions doivent être visibles sur l'afficheur.

le home .c'est bien de ca que qu'il s'agit mais sur mon afficheur j'ai-45 pour X, -5 pour Y, et -3.99 pour Z

Lien à poster
Partager sur d’autres sites

Ou moins prise de tête, utiliser un raspberry pi pour commander l'imprimante (cherches "octoprint" et "octopi"), qui en plus de faciliter le contrôle de l'imprimante, donne accès à d'autres options, et permet de s'affranchir de certains ennuis provoqués par l'usb sur pc (genre l'imprimante qui reboot en pleine impression parce que tu viens d'allumer ou de brancher un autre périphérique usb).

  • J'aime 1
Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...