Aller au contenu

Filament ABS

Cura 4.9.1 avec Dagoma Ultimate bicolore gcode inexploitable


Messages recommandés

Bonjour à tous, lorsque j'utilise Cura 4.91  pour découper un STL en ayant choisi un extructeur (1 ou 2), le fichier généré est inexploitable, par exemple :

un grand nombre d'instructions T0 et/ou T1,

également un grand nombre d'instruction "G1 E-60.0 F10000" et "G1 E60.0 F3000".

Je n'ai pas de problèmes avec Cura by Dagoma, mais avec CbD on n'a pas d'action sur le réglages des supports.

Quelqu'un a-t-il eu ce problème et l'a-t-il réglé ?

Si vous pouvez m'aider, je vous remercie.

Lien vers le commentaire
Partager sur d’autres sites

Salutation !

Il semble que les 

il y a 29 minutes, Pasqualini a dit :

"G1 E-60.0 F10000" et "G1 E60.0 F3000"

soient dans le g-code de démarrage et de fin des extrudeurs ... (contruit dépuis les fichiers de définition https://github.com/Ultimaker/Cura/blob/master/resources/extruders/dagoma_discoultimate_extruder_0.def.json lors de l'ajout de l'imprimante) pour modifier cela sous cura, il faut allez regarder dans les "Paramètres de la machine" sur les onglets des "Extruder ..." (je pense que tu doit pouvoir utiliser les version de g-code de démarrage et de fin des extrudeurs de la version "Cura By Dagoma" ... voir peut etre y récupérer les fichiers .def.json pour ton imprimante et le copier dans le répertoire local de config de Cura 4.* pour lors de l'ajout d'une imprimante utiliser leurs définitions ...( il y en a plusieurs dans plusieurs répertoires et cela n'est pas forcement simple de les trouver ...) 

Le plus simple éditer les paramètres de la machine :

Ex  Sous cura 4.10.0 : bar de menu : "Paramètres" -> "Imprimante" -> "Gérer les imprimantes..."

Tu sélectionne alors ton imprimante dans la liste,( clique "Activer" si besoin,) et là tu clic "Paramètres de la machine" qui te donne normalement qq chose comme cela :

image.png.4be9a19104257c7a5580d56a3f3eb6c9.png

Et si je clic sur l'onglet "Extruder 1" j'obtiens (Il faudra regarder/modifier pour les deux extrudeurs ...)

image.png.239710115edecdf472ff0e4670492ab3.png

Là tu y trouve le "G-Code de démarrage" et aussi le "G-Code de fin"

si il y a un ";" en début ou dans une ligne alors se qui suit le ";" est considéré comme un commentaire.

si tu veux comprendre ce que fait une commande g-code et les paramètre qu'elle accepte, regarde sur : https://marlinfw.org/meta/gcode/

Modifié (le) par PPAC
Lien vers le commentaire
Partager sur d’autres sites

La version 4.10 est sortie.

Je pensais qu'elle résoudrait mon problème.

Elle me pose un nouveau problème, elle affiche le message :

"Impossible de découper

Impossible de couper avec les paramètres actuels Les paramètres suivant comportent des erreurs : Z Hop Speed."

Savez vous comment éliminer cette erreur ?

Merci.

Lien vers le commentaire
Partager sur d’autres sites

Salut, 

DEFAULT_MAX_FEEDRATE est à 4mm/s sur Z dans le firmware de la Disco Ultimate.. il est donc logique de ne pas pouvoir utiliser des vitesses supérieures pour le déplacement de Z. 

631144778_Screenshot-16_07_202116_00_20.png.918d2ae64dc0d8ea4f7568290a897954.png

Dans Cura 4.10 la 'vitesse du décalage en Z' (Z Hop Speed) sur le profil par défaut de la disco ultimate bi color est à 10mm/s.

Passe à 4mm/s sur les 2 extrudeurs et tout rentrera dans l'ordre ^^

1830522223_Screenshot-16_07_202116_41_25.png.d0f4901d1711da3b3335861d0570493d.png 

278881145_Screenshot-16_07_202116_42_03.png.d91f6f91374d94ef4c0bb91b8b48d2e1.png

663185672_Screenshot-16_07_202116_43_00.png.35598df78c55d386235ff3a9cbc8551c.png

532352501_Screenshot-16_07_202116_43_40.thumb.png.d93e012dde2f6af7b8d24300e6228a18.png

1232818145_Screenshot-16_07_202116_43_51.thumb.png.7fb34c41f925a9747dfde1461ae60b0d.png

Lien vers le commentaire
Partager sur d’autres sites

Merci, maintenant l'extructeur 2 fonctionne parfaitement. Aucue erreur dans le fichier généré.

J'ai encore des soucis avec l'extructeur 1.

Je vais essayer de comprendre ce qui se passe.

 

Le 17/07/2021 at 12:30, Pasqualini a dit :

Merci, maintenant l'extructeur 2 fonctionne parfaitement. Aucue erreur dans le fichier généré.

J'ai encore des soucis avec l'extructeur 1.

Je vais essayer de comprendre ce qui se passe.

La version 4.10 est sortie.

Je pensais qu'elle résoudrait mon problème.

Elle me pose un nouveau problème, elle affiche le message :

"Impossible de découper

Impossible de couper avec les paramètres actuels Les paramètres suivant comportent des erreurs : Z Hop Speed."

Savez vous comment éliminer cette erreur ?

Merci.

 

Je crois avoir trouvé le processus à respecter.

Je vais tester à nouveau et vous informerai.

Lien vers le commentaire
Partager sur d’autres sites

  • fran6p changed the title to Cura 4.9.1 avec Dagoma Ultimate bicolore gcode inexploitable
  • 2 weeks later...

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...