Aller au contenu

Filament ABS

Gros défaut d'impression en mode concentrique CURA 11.0


Messages recommandés

Bonjour, 

J'essaie désespérément d'imprimer ce fichier (origine Heliox ), mais j'observe de gros défauts. Si j'imprime en mode ligne pour la surface supérieure j'observe un délitement des couches visibles sur la photo #1. Est-ce un problème de température ? Le trajet est très long et la couche inférieure est froide, donc pas de collage ?

Si j'utilise le mode concentrique, c'est la catastrophe, comme vous pouvez le constater sur la photo #2. 3 défauts sont manifestes : Un effet "peau de crocodile", un  effet "cicatrice" et un effet "moirure".  Sur la photo 5 on voit apparaître des "boutons" et sur la photo 7 un effet de vagues.

Mon imprimante est une Creality CR10S PRO, nivellement du plateau au mieux, plus mesure de la planéité (photo #3). Le filament est du PLA  GEEETECH Silk Copper. Buse à 210 °C et plateau à 60 °C

Paramètres Cura version 11.0 : hauteur couche 0.2 mm, largeur 0.36 mm, ventilateur OFF jusqu'à la couche 8, puis 100%

Avez-vous une idée du problème et comment le corriger. 

Merci pour votre aide.

Photo1.png

photo2.png

Photo5.png

photo7.png

Photo3.jpg

Lien vers le commentaire
Partager sur d’autres sites

Bonjour,

Je pense que ton problème vient de plusieurs choses : les boutons peuvent être le signe d'un filament légèrement trop humide (bulle d'eau qui éclate mais ne peut s'échapper). Le délitement est pour moi le signe évident d'une buse trop haute, le filament tombe plus qu'il n'est déposé. De plus l'imprimante est-elle posée dans un endroit stable ?

En espérant apporter un éclaircissement 😉

  • J'aime 1
Lien vers le commentaire
Partager sur d’autres sites

Il y a 9 heures, jr620 a dit :

largeur 0.36 mm

et tu a une buse de combien paramétré et un réel ?

Lien vers le commentaire
Partager sur d’autres sites

Merci pour vos réponses. 

@Gasast  J'ai utilisé une bobine neuve tout juste sortie de son emballage, puis placée dans une boîte de déshydratation (Sunlu Fila Dryer) que j'utilise pour toutes mes impressions. Pourquoi le délitement n'apparait-il que sur la dernière couche ? Les autres sont "parfaites". Je peux sans aucune difficulté enlever la dernière couche, mais plus profond, ce n’est pas possible, ça tient très bien. C'est cela qui m'interpelle !

@PPAC. J'utilise une buse standard Creality de 0.4 mmIMAG5740.thumb.jpg.343f1516b7fabedc1e69ec4494e5158b.jpg

Lien vers le commentaire
Partager sur d’autres sites

Pour moi c'est étrange d'utiliser une largeur de 0.36 avec une buse de 0.4 mm mais cela ne doit pas être le problème.

Comme je n'ai pas acheté le fichier .stl je en peux pas valider se que je pense être le problème.

Mais dans la vidéo Heliox parle d'une épaisseur de 1.5 mm pour la couverture donc si tu la tranche en hauteur de couche de 0.2mm c'est peut être là le truc. car 1.5 / 0.2 = 7.5 couches est ce n'est pas une valeur entière ... soit faire une hauteur de couche initial de 0.3 et pour le reste, rester en hauteur de couche 0.2mm pour tomber juste (1.5 - 0.3) /0.2 = 6 couches (+1 couches pour l'initial que l'on a soustrait) et bien un nombre entier. soit trancher en hauteur de couche initial et le reste en 0.1 mm (1.5 / 0.1 = 15 couches) ou autre mais qui te donne une valeur entière pour ne pas avoir une couche plus ou moins là car éventuellement tronqué ...)

Tiens nous au jus !

Ou alors vérifie avec PrusaSlicer GcodeViewer les débits  d'une aperçu du fichier .gcode que tu utilise cela confirmera peut être mon histoire ... si cette couche ne s'imprime pas avec le même débit que celle d'avant.

Edit Ou sinon offre moi le model (si la licence le permet )en P.M. 😉 et je fait des tests ...

Modifié (le) par PPAC
Lien vers le commentaire
Partager sur d’autres sites

Pour les autres lecteurs, des extraits de messages privé.

En résumé

Pour le délitement, en motif lignes, un bug du post traitement de changement de filament (reprise une couche plus haut)

Pour la sur extrusion en motif circulaire, un débit de couche du dessus a 105%.

A faire valider par @jr620 ( que je remercie pour m'avoir offert le stl. )

Il y a 21 heures, jr620 a dit :

Tu trouveras en pièce jointe le gcode ( Livre_Boite.gcode Cura 10 ) avec lequel j'ai observé les délitements. et celui qui produit les effets peau de crocodile -CCR10SPRO_Livre_Boite-C11.gcode cura 11 )

Changement de filament à z=1.6 mm, soit couche 6 dans le premier ficher et à la couche 9 dans le second.

Réponse à tes questions :

1 - pas ventilation tant que la couverture du bouquin n'a pas été imprimée. Objectif obtenir une meilleure adhérence entre les couches. Ce qui semble être le cas sauf pour la dernière !

2 - Je ne me souviens plus exactement pourquoi j'ai pris une valeur de 0.36 pour la largeur. Je crois me rappeler avoir vu un tuto ou lu sur un blog que cela améliorait la qualité et la solidité de l'objet.

Les effets de vague observés sur la seconde impression ont peut-être pour cause un mauvais réglages du drivers de l'extrudeur. Il faut que je voie comment contrôler cela. La peau de crocodile est peut-être due à une buse trop basse. Je referais un essai en levant la buse de 0.1 mm. 

Je mettrai tout cela dans le POST dès que possible.

Merci pour l'aide. 

 

  

Il y a 13 heures, PPAC a dit :

J'ai une piste ! 

image.png.cc0dd7aecd27f4ec3a9803921cc467d2.pngimage.png.921b9b27b0219f631619fd266abd0aab.png

Pour la couche de surface, pas la même hauteur mais même débit = pb ...

Le script de changement de filament semble être la source du problème. Etrangement pour Livre_Boite.gcode, il se croit une couche plus haut ... et donc se repositionnable 1 couche trop haut en fin de changement se qui dans la prévisualisation du gcode donne une couche de 0.4mm. avec le même débit volumétrique que pour des couches de 0.2mm.

image.png.eed03fd0e94630351553835b23aeff4a.png

D’où le délitement de cette couche.

Comme c'est un post-traitement, cela ne se vois pas dans l'apercu de cura sauf si tu le charge via un glissé/déposé du fichier .gcode dans cura où sous un autre logiciel d'apercu ...

Quand je regarde le .gcode avec un éditeur de texte tout s'explique, il y a bien un défaut. Si tu recherche les " Z"

a la ligne 80888 Z1.4

puis 

;added code by post processing
;script: PauseAtHeight.py
;current z: 1.6
;current height: 1.6
M83 ; switch to relative E values for any needed retraction
G1 F300 Z2.6 ; move up a millimeter to get out of the way
G1 F9000 X190 Y190
G1 F300 Z15 ; too close to bed--move to at least 15mm
M104 S210 ; standby temperature
M117 CHANGE FILAMENT
M300 S440 P200
M0 ; Do the actual pause
M300 S440 P200
M109 S210 ; resume temperature
G1 F300 Z2.6
G1 F9000 X126.496 Y51.845
G1 F300 Z1.6 ; move back down to resume height
G1 F1500 ; restore extrusion feedrate
M82 ; switch back to absolute E values
G92 E603.81318
;LAYER:6

..

 

Bien remarque que dans le fichier .gcode la numérotation des ;LAYER commence a 0. donc là LAYER:6 c'est en fait la 7eme couche.

 

Ici la solution serai de modifier le .gcode 

G1 F300 Z1.6 ; move back down to resume height

en 

G1 F300 Z1.4 ; move back down to resume height

 

 

Pour l’autre fichier "CCR10SPRO_Livre_Boite-C11.gcode" il ne semble pas y avoir ce problème là

;MESH:NONMESH
G0 F300 X258.719 Y93.76 Z2
G0 F9000 X172.035 Y94.107
G0 X170.978 Y94.071
G0 X44.786 Y145.319
G0 X44.254 Y146.24
G0 X41.812 Y146.434
G0 X41.467 Y146.525
G0 X40.035 Y147.133
;TIME_ELAPSED:26512.260551
;TYPE:CUSTOM
;added code by post processing
;script: PauseAtHeight.py
;current layer: 9
M83 ; switch to relative E values for any needed retraction
G1 F1500 E-100.0
G1 F300 Z3 ; move up a millimeter to get out of the way
G1 F9000 X190 Y190
G1 F300 Z15 ; too close to bed--move to at least 15mm
M104 S200 ; standby temperature
M117 JRF-CHANGER FILAMENT
M300 S440 P200
M0 ; Do the actual pause
M300 S1000 P200
M109 S210 ; resume temperature
G1 F1500 E100.0
G1 F1500 E-100.0
G1 F300 Z2
G1 F9000 X40.035 Y147.133
G1 F300 Z2 ; move back down to resume height
G1 F1500 E100.0
G1 F2700 ; restore extrusion feedrate
M82 ; switch back to absolute E values
G92 E3223.4213
;LAYER:9

 

Le Z et cohérent aprés le changement.

Là c'est peut être un ajustement de débit car tu te trouv peut etre simplement en légére sur extrusion hors tu imprime de grande surface pleine donc cela se cumul (pas comme quand il y a du remplisage a 20% ...) ou un truc spécifique au motif concentrique.

 

Sinon j'ai tenté de faire une impression d'un de mes tranchage mais là mon imprimante me fait des caprices ...

1er couche mal ajusté, obstruction de la tête ... 🙃

 

Il y a 12 heures, PPAC a dit :

le problème sur CCR10SPRO_Livre_Boite-C11.gcode

Quand je fait "Importer" dans les profils, du fichier .gcode, le profil qui en résulte a un "Débit du dessus/dessous" a 105%. c'est, il me semble la raison du rendu en sur-extrusion de la surface pour cette impression. (car il n'y a pas de remplissage dans les couche précédente, c'est "plein" en dessous ...et donc aucun jeux, aucune "absorption du sur plus". Donc pour cette impression là remettre cela a 100%)

Edit : tu avais du le modifier pour compenser le délitement du au pb de filament change sur l'imrpession d'avant en remplisage motif lignes. mais là comme il n'y a plus de défaut due au filament change et le filament change se trouve plus tard, cela sur-extrude ...)

image.png.6cf7c296ff7c09b0318ed28ee59de3f9.png

Modifié (le) par PPAC
Lien vers le commentaire
Partager sur d’autres sites

@PPAC Merci pour ton analyse approfondie. Je n'avais pas vu le problème de la couche 6 ou se fait le changement de filament. Je vais refaire un tranchage avec les paramètres std de Cura 11' (qualité standard) en changeant seulement le motif de la première couche ( concentrique au lieu de ligne) comme le recommande Héliox.

Le débit 105% sur la première couche, c'est pour améliorer le collage du modèle.

Je vous dirais ce que ça donne.

Tu m'as fait découvrir PursaSlicer Viewer, il faut que j'installe cet outil, ça à l'air puissant.

Lien vers le commentaire
Partager sur d’autres sites

Il y a 3 heures, jr620 a dit :

Le débit 105% sur la première couche, c'est pour améliorer le collage du modèle.

Pour CCR10SPRO_Livre_Boite-C11.gcode tu a d’après le profil extrait, "Débit de la couche initial" a 105% et aussi "Débit du dessus/dessous" a 105%. Je pense que c'est  "Débit du dessus/dessous" a 105% qui créer le défaut.

 

Pour PrusaSlicer GcodeViewer je l'utilise surtout car je n'ai pas de carte graphique assez a jours pour avoir les vues différente dans l'aperçu avec Ultimaker Cura. Mais il a des trucs en plus qui sont sympa.

Le seul reproche c'est qu'il n’interprète pas les g-code G2/G3 G2-G3: Arc or Circle Move (Repetier Host lui oui ...)

Donc quand on utilise le plugin  ArcWelder https://github.com/fieldOfView/Cura-ArcWelderPlugin sous Cura (voir Its like magic to improve your 3D Print quality. - YouTube pour comprends se qu'il fait ) les prévisualisation sont étrange mais comme avec Ultimaker Cura quand tu relis le .gcode !

ex :

Aperçu après tranchage sous Ultimaker Cura avec ArcWelder activé (jusque là c'est bon car il ne recharge pas le .gcode qui a etait post traité par ArcWelder)

image.png.a8e2bcf858039eecc277855620c7de95.png

Aprés rechargement de .gcode sous Ultimaker Cura ( ne rend pas bien car ArcWelder et un post traitement qui permet d'utiliser de G2/G3 pour les mouvements sur des trajectoire d'arc. Or Ultimaker Cura ne sais pas bien interpréter les G2/G3 du post traitement ArcWelder ) Il faut glisser / déposer le .gode pour avoir :

image.png.5b2769478e53ff21c313f64e5713f4b5.png

Même .gcode sous PrusaSlicer GCodeViewer (n’interprète pas correctement les G2/G3 ):

image.png.8a760e4efad4c0cf10a35e6675cce40b.png

Même .gcode sous Repetier Host (là c'est correcte) :

image.thumb.png.74f22abb269c105d180ed128bf980302.png

Même .gcode sous IdeaMaker (n’interprète pas correctement les G2/G3 )

image.thumb.png.f3e07973b239bb715713305a1f25ac89.png

Voila je suis donc a jongler avec plusieurs trancheur pour juste utiliser leur aperçu 😉

Dommage j'ai pas de Matter Control sous linux, car je me dit que lui il doit peut être y arriver.

Lien vers le commentaire
Partager sur d’autres sites

  • fran6p changed the title to Gros défaut d'impression en mode concentrique CURA 11.0

@PPAC

Avec des visualiseurs de Gcode en ligne ça donne quoi ?

https://ncviewer.com/

ou

https://gcode.ws/

🙂

Lien vers le commentaire
Partager sur d’autres sites

il y a 17 minutes, fran6p a dit :

Avec des visualiseurs de Gcode en ligne ça donne quoi ?

https://gcode.ws/ pas d'interprétation des G2/G3 :

image.png.a500c55a2a2b59ff18009c8e43c480a5.png

 

https://ncviewer.com/ là bonne interprétation des G2/G3 mais je ne sais pas où définir ma taille de plateau ni l'origine (tranché pour une K8206 x=200*y=400 mm donc il se trouve affiché hors plateau.

image.thumb.png.95a16dd88a1bcf50fc9edf2b5c928d08.png

 

http://chilipeppr.com/tinyg là bonne interprétation des G2/G3 mais je ne sais pas où masquer les déplacements

image.thumb.png.081e2c0cdc51149df7f61b32f5b6716e.png

https://buildlog.net/gview/  là je n'arrive pas a bien voir ... car je ne sais pas où masquer les déplacements, et le contrôle de la camera n'est vraiment pas simple ...

image.thumb.png.8fd69e05ecabdb06bcb689ad4a0afbb3.png

 

Et je ne retrouve plus un en ligne où il y avais des mise en couleur acrs en ciel ...

Pour tester sur d'autre application de prévisualisation de .gcode le fichier que j'ai utilisé :

CFFFP_BridgeTest_ArcWelder_H02_I15_S60_F110_6g_0h43min_2021-09-13_01:42:51.gcode

car j'ai pas fait toute la liste https://wiki.shapeoko.com/index.php/Previewing_G-Code 🙂

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

  • YouTube / Les Imprimantes 3D .fr

×
×
  • Créer...