Aller au contenu

Anycubic Kobra 3 Combo

[RÉSOLU] Nouvelle carte mère 4.2.7 !


PsYkObOuM

Messages recommandés

Bonjour tout le monde !

J'ai une ender 3 pro depuis le moi d'avril et comme je l'ai dis sur ma présentation tout roule avec cette super machine d'apprentissage ...

J'ai reçu ma nouvelle carte mère 4.2.7 silencieuse que j'ai monter aussitôt ... plus de bruit on entends plus que le ventillo ! super !
Mais j'ai un problème de sous extrusion 😞 je ne comprends pas pourquoi mais a un moment (qui est toujours le même sur la même pièce ) il n'envoi plus de matière et reprends tranquillement quelques lignes plus loin nickel ...

Ma machine marchais nickel avec l'autre CM 4.2.2 je me dis que c'est surement le firmware a mettre a jour ... j'ai donc télécharger le firmware creatily sur leurs site ... et je me retrouve avec un Marlin 1.5.1 ... qui d'après se que j'ai compris n'est pas du tout le dernier ! ... si j'ai bien suivi pour avoir le dernier Marlin il faut le compiler soit même ... J'ai pris des infos a droite a gauche pour me compiler un firmware avec VSC mais j'ai du faire une erreur il ne veut pas se compiler ...

Donc je voudrais votre aide dans un premier temps pour se problème de sous extrusion qui viens peut être d'une nouvelle option de cette carte mère que je n'avais pas sur l'ancienne et qu'il faut régler ??? (style linear advance) 

Et j'ai peut être mal chercher mais je ne trouve pas de tuto pour créer et compiler sont firmware pour la CM 4.2.7 sur une Ender 3 pro ...
Est ce vraiment utile de compiler soit même sont firmware sachant que je n'ai aucun module (bltouch ...) sinon je me pencherais dessus pour le changement de fils ... 🙂 
N'existe t il pas un .bin avec le dernier Marlin pour l'Ender 3 pro ??

J'utilise FreeCAD pour la modélisation et Cura pour le découpage 😉 

En l'attente de vos réponses je ne remonte pas mon ancienne CM 😄 😄 

Merci de m'avoir lu 🙂 

Lien vers le commentaire
Partager sur d’autres sites

Merci pour ta réponse 🙂 qu’appelles tu un test extrudeur ? ma machine a 4 mois et un kit d'extrudeur tout neuf qu'il m'ont envoyé du a un problème de thermistance ...

Le problème est je penses plus logiciel que matériel ... je n'avais aucun problème avec mon ancienne carte mère ... 

Sur l'exemple d'un rond a remplir entièrement il me fait 4 ou 5 ligne sans matière et reprends normalement et quand elle fait ses ligne dans l'autre sens il manque une bande de quelques ligne sans matière ...
Cette carte mère 4.2.7 a plein de nouveaux paramètres que je ne connais pas ... 
Dois je activer Marlin volumetrique dans Cura ?

 

Je suis un peu perdu ^+^

Lien vers le commentaire
Partager sur d’autres sites

Bonjour,

@Papagalak lors qu'il te disait de faire un  test de l'extrudeur, c'est de reprendre la calibration de celui-ci (les step/mm et le réglage du débit),.

Pour la suite, si tu vas sur le GitHub de Marlin, la dernière version est 2.1, tu trouves également sur le GitHub des fichiers d'exemples de config et pour la ender 3 pro tu as les fichiers de conf. (je ne pense pas que le Blt soit activé dans cette conf puisque conf d'origine), ensuite tu compiles ton firm et tu essaies. En PJ en pdf tu trouveras des infos sur Marlin, c'est ce que j'utilise comprendre les fonction de Marlin.

Cordialement.

Aldo

image.png.a5147d3e77e26c1b2b986ff352cf0481.pngimage.png.d85c33da4dcf7dfaf4a7d0a8b1cb762f.pngimage.png.4d536e444eb10dbb17d63b3e2452dfb6.png

Configuration de Marlin.pdf

  • Merci ! 1
Lien vers le commentaire
Partager sur d’autres sites

Merci pour les précision 😉 

J'ai trouver se tuto pour le test extrudeur TUTO de Fran6p j'ai essayé de sortir 3 files en extrudant 100mm mais je ne suis pas sur d'être a 2mm/s et les fils sortie font juste 30cm a 35cm je ne comprends donc pas comment obtenir un résultat dans les 100mm 

Mon Esteps/mm est a 93 d'origne ...

 

Et pour Malin je m'y attarderais après résolution de mon soucis 🙂 j'ai tout ses fichier je reprendrais a 0 après ... 
De passer de Marlin 1.0.1 a 1.5.1 ne m'a pas corriger le problème ...

Modifié (le) par PsYkObOuM
Lien vers le commentaire
Partager sur d’autres sites

PsYkObOuM, la longueur extrudée se mesure a l'entrée de l'extrudeur pas à la sortie.

Tu connecte ta machine sous pronterface, tu fait chaufer la buse à 60] (si tu travailles avec du PLA), tu mesure une longeur de 110 mm sur ton filament et tu place un repère précisement (scotch papier), ensuite tu fais un M503 pour avoir les valeurs qui sont stockées dans l'EEprom, tu fais un M83 pour passer ta machine en mode relatif, ensuite tu fait un G1 F10 pour régler la vitesse d'extrusion à 50mm/m, puis un G1 E100 pour extruder 100 mm de matière.

Ton imprimante vas extruder 100mm de filament puis va arrêter (environ 2min pour l'extrusion), tu mesure ce qui reste de filament et tu fais un règle de 3, tu obtiens la nouvelle valeur du Estep, ensuite tu fais un M92 E (avec la nouvelle valeur de Estep), un M500 pour stocker cette nouvelle valeur dans m'eeprom puis un M503 pour controler que la nouvelle valeur est bien en mémoire.

Le calcul c'est (valeur de consigne)/((valeur repère)-(valeur restante))*(valeur de Estep d'origine).

Les fichiers en PJ sont ceux du GitHub de Marlin pour une Ender 3 pro avec une carte 4.2.7

Pour ton soucis de compile, c'est peut-être à cause de l'environnement (en général ce problème se trouve dans le fichier platformio.ini le chipset de la carte mère n'est pas implémenté), je me souviens de ce même soucis lorsque j'ai commencé à mettre les mains dans le cambouis.

Cordialement.

Aldo

_Bootscreen.h _Statusscreen.h Configuration.h Configuration_adv.h platformio.ini

Pour les infos, vas sur le site de KaminoKgy, tu trouveras ton bonheur.

Cordialement.

Aldo

  • Merci ! 1
Lien vers le commentaire
Partager sur d’autres sites

Merci pour ces info mais la je patauge complètement o0

JE N'EST JAMAIS CONNECTER MA MACHINE A MON ORDI ... quel idée MDR 😄 
Je suis vraiment novice dans la 3D pour le moment je me contenter de modéliser 2 ou 3 trucs et les mettre sur ma SD pour que la machine le fasse 😄 
Avec cette nouvelle CM je rencontre plein de nouvelle options que je n'avais pas eu besoin de voir avant ... 😄 😄 

Cette CM a un botloader qui me permet de faire les flash depuis la SD ... je n'avais encore pas d'utilité de brancher ma machine au PC ...
Je fait tout avec l'écran LCD ...

 

Du coup je ne comprends pas toutes ces commandes 😢 il faut que je créer un Gcode pour faire le test ?

Je peux régler la vitesse d'extrusion via le LCD ??? mais je ne suis pas sur ... est ce le Esteps/mm que je dois mettre a 50 ?

 

Désoler mais je navigue en eaux trouble 😮 

    ----------------------------------------------------------------------------------------------------

Bon je retanter le test de l'extrudeur je penser avoir mieux compris mais non ... 😄

J'ai donc déconnecter le tube PTFE de l’extrudeur, dévisser le raccord pneumatique juste après la pièce avec les engrenage et le ressort ...
J'ai couper le filament au ras de la ou j'ai sortis le raccard pneumatique et demander a l'extrudeur 100mm et quand je mesure se qui est passer il n'y a que 50 mm a peut prés ...

J'ai fait le test en allant par l'écrant LDC dans => prépare => move axis => extrudeur => 10mm ...

Je continue de chercher ou je bug ... 😞 

    ----------------------------------------------------------------------------------------------------

Bon je penses avoir passer le test ! 😄 mais peut être pas a la bonne vitesse ... je n'ai rien changer a se niveau ... 

MAIS quand je demande 100mm a l'extrudeur il de sort 100mm 😄 plutôt positif ! 😄 

J'ai trouver se site pour calibrer l'extrudeur plutôt cool 🙂 => https://kaminokgy.com/fr/outils/calibrator (Merci Aldo007)

Mon reglage Esteps/mm est passer de 93 a 229.8 😄 😄 😄 

Et .... Fausse joie la première couche me sembler bien mais le problème est toujours la ... 😢 

 

20220813_180801.jpg

 

-------------------------------------------------Encore un Edit --------------------------------------

 

Bon encore un merci a @Aldo007 grâce a tes fichier joint j'ai réussi a compilé mon firmware ! ! ! Du premier coup j'avais bien changer l'environement mais je n'avais pas les fichiers de la bonne version ... bref cela fonctionne j'ai Marlin 2.1.1 ! ! ! 

Bah du coup ça a résolu mon problème de sous extrusion ... va savoir pourquoi ... Plug And Play qui disaient ... 😄 😄 😄 
Ça m'aura au moins appris a calibrer mon extrudeur ! 😄

 

------------------------------------------------Encore un Edit----------------------------------------

 

Un grand merci a vous pour votre temps ! 
Je suis content de m’être inscrits sur se forum 😉 

Bon petite précision mes Esteps/mm sont revenu a 93 🙂 

C'est donc bien la version de Marlin qui n'allait pas ... je vais le signaler sur le commentaire amazon et faire de la pub pour le forum 😉 

Encore merci je passe le sujet en résolut 😉  (reEdit => je peux pas le faire 😄 )

Modifié (le) par PsYkObOuM
Lien vers le commentaire
Partager sur d’autres sites

Bonsoir,

Je suis ravi pour toi que cela fonctionne.  L'entraide est l'essence même d'un forum. Il suffit d'un petit coup de pouce pour que la solution soit trouvée. Il te restes à faire le réglage du débit. Si tu veux une explication ou la méthodologie n'hésites pas.

Pour les commandes Gcodes tu les lancés depuis proterface bien sûr imprimante connectée au PC.

Bonne impressions.

Cordialement.

Aldo

  • Merci ! 1
Lien vers le commentaire
Partager sur d’autres sites

Le 13/08/2022 at 17:20, PsYkObOuM a dit :

reEdit => je peux pas le faire

Hier c'était la journée des gauchers, ça m'a mis de bonne humeur donc je passe ton sujet en résolu 😉

  • Merci ! 1
Lien vers le commentaire
Partager sur d’autres sites

  • fran6p changed the title to [RÉSOLU] Nouvelle carte mère 4.2.7 !

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
  • Sur cette page :   0 membre est en ligne

    • Aucun utilisateur enregistré regarde cette page.
  • YouTube / Les Imprimantes 3D .fr

×
×
  • Créer...