Aller au contenu

Anycubic Kobra 3 Combo

"PARK" apres pause sous klippler et commande M600


Messages recommandés

bonjour

j'utilise klipper sous une SKR1.3 et un combo octoprint+octoklipper coté host

quand je déclenche une pause via octoprint la commande fonctionne correctement mais la tête reste sur la pièce ce qui provoque une déformation de la pièces

Je recherche donc la possibilité d'effectuer un PARK juste âpres la pause pour éviter ce problème.

Second problème pour la détection de filament j'utilise la commande m600 (que je trouve très pratique si un jour j'ai besoin de faire un changement de couleur directement depuis le slicer)

j'ai un phénomène plutôt étrange qui se produit quand je déclenche la détection de filament, la pause est bien exécuté, la tete va a l'emplacement voulu et le Z monte bien de 10mm comme prévu, cependant la tete repart immédiatement au-dessus de la pièces et attend la pause ici ( a 10mm au-dessus) .

Quand je lance la commande reprendre, l'impression reprend ou elle c'était arrêté mais a 10mm au-dessus de la pièces, au prochain changement de couche elle fini pas déscendre au bon niveau et l'impression continue normalement

voici mon Gcode

[filament_switch_sensor my_sensor]
pause_on_runout: False
runout_gcode: M600
event_delay: 1.0
pause_delay: 0.5
switch_pin: !P1.28


[pause_resume]


[gcode_macro M600]
#default_parameter_X: 50
#default_parameter_Y: 0
#default_parameter_Z: 10
gcode:
    SAVE_GCODE_STATE NAME=PAUSE_state
    PAUSE
    G91
    G1 E-2 F2700 #rétract
    G1 Z10 #+10mm sur Z
    G90
    G1 X10 Y10 F3000 #emplacement pour le PARK

 

merci

 

Lien vers le commentaire
Partager sur d’autres sites

La documentation de Mainsail n'est pas / plus vraiment à jour 😞 . Maintenant, il est plutôt recommandé d'utiliser un fichier mainsail.cfg bien plus complet mais plus «complexe» à analyser, voir ici. C'est la configuration, en tout cas, que j'utilise pour ma CR10V2 avec un Pad BTT RPi5 + CM4 (que du bonheur par rapport à mon SonicPad 😄).

@windaube, ta macro M600 est incomplète (pas de RESUME et pas de récupération des coordonnées de reprise).

🙂

Lien vers le commentaire
Partager sur d’autres sites

bonjour

Merci de vos réponses. Je vais regarder cela à tête reposée ce week-end.

Je constate tout de même un comportement anormal à partir de la deuxième pause. Pour mes essais, je vais être obligé de redémarrer à chaque nouvelle tentative.

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
  • Sur cette page :   0 membre est en ligne

    • Aucun utilisateur enregistré regarde cette page.
  • YouTube / Les Imprimantes 3D .fr

×
×
  • Créer...