Aller au contenu

GO Print

Réglages Pilote TMC2208 pour carte Lerdge


Messages recommandés

Bonjour,

J'ai les deux pilotes des moteurs X et Y de ma carte Lerdge qui sont tombés en panne.
J'en ai donc commandé :
https://www.amazon.fr/dp/B081JNK7VQ?psc=1&ref=ppx_yo2ov_dt_b_product_details

J'ai réglé la tension sur 0.9V et j'ai tout de même un dysfonctionnement +X et +Y fonctionnement bien.
Mais lorsque j'essaye -X le bloc se déplace en +Y et quand je clique sur -Y j'ai -X.

Ah oui l'imprimante est une CoreXY DIY

Je ne trouve pas beaucoup d'infos sur les réglages des pilotes.

Si quelqu'un aurait des pistes, d'avance merci.

Manu

Modifié (le) par ManuBGeek
Lien vers le commentaire
Partager sur d’autres sites

Merci pour les infos, je me suis un peu arraché les cheveux sur les explications, mais c'était instructif et j'ai pu ajuster les réglages de mes pilotes, mais ça n'a rien changer.
je vais reposter la rubriques DIY.

 

Lien vers le commentaire
Partager sur d’autres sites

Salut,

Ton problème ressemble à une erreur d'interprétation de coordonnées relatives et absolues. Après avoir placé la buse au centre du plateau avant la mise sous tension, que se passe-t-il si tu envoies ces instructions:

  • G90
  • G0 X50 Y50 F1200
  1. G0 X55
  2. G0 X45
  3. G0 Y55
  4. G0 Y45

Est-ce que tu peux indiquer dans quel sens se déplace la buse lors de l'exécution des points 1 à 4. En théorie, ce devrait être +X, -X, +Y, -Y

il y a 18 minutes, ManuBGeek a dit :

je vais reposter la rubriques DIY

ça ne sert à rien 😉

Lien vers le commentaire
Partager sur d’autres sites

Avec un G28 en préalable des commandes proposées par @pommeverte ça devrait être «mieux» 😉

Lien vers le commentaire
Partager sur d’autres sites

Je le déconseille fortement puisque le problème se situe justement au niveau du sens de déplacement.

C'est pour ça que j'ai bien indiqué cette procédure:

il y a 51 minutes, pommeverte a dit :

Après avoir placé la buse au centre du plateau avant la mise sous tension,...

l'origine sera alors au centre du plateau et les mouvements se feront uniquement dans le sens positif (X+ et Y+)

 

Lien vers le commentaire
Partager sur d’autres sites

Dans ce cas, les points 2 et 4 ne pourront pas être effectués, non ? Le (0,0) étant en fait en (50,50) 🤔

Lien vers le commentaire
Partager sur d’autres sites

il y a 25 minutes, fran6p a dit :

Le (0,0) étant en fait en (50,50) 🤔

par quel tour de sorcellerie 🤨?

il y a 16 minutes, ManuBGeek a dit :

Ok je fait ça sur un fichier Gcode en tapant juste ca ?

non, il faudrait envoyer chaque ligne depuis un ordinateur, avec Pronterface, repetier host,... relié en USB ou peut-être via l'écran, si tu as un menu pour envoyer des Gcodes.

L'important, c'est de noter le sens de déplacement de la buse lors de l'envoi des lignes 1, 2, 3 et 4

Lien vers le commentaire
Partager sur d’autres sites

il y a 34 minutes, pommeverte a dit :

par quel tour de sorcellerie

Pas faux mais la sorcellerie n'a rien à voir ici 😉 Lecture trop rapide de ma part.

Quand on allume l’imprimante, la position de la buse pour le firmware est considérée comme étant l'origine (raison pour laquelle elle ne peut se déplacer que dans le sens positif tant qu'un G28 n'a pas été fait). Le G90 passe en déplacement absolu donc de la position «centrée» considérée comme l'origine, on peut effectivement se déplacer en (50,50), puis (55,50), (45,50), …

Lien vers le commentaire
Partager sur d’autres sites

Il y a 3 heures, ManuBGeek a dit :

La tête se décale en oblique puis fait un X+ et Y+ c'est tout

J'aurais préféré une réponse plus précise 😜 (sens du déplacement pour les 4 commandes), mais bon, on va faire avec, ou sans.🤪
D'après ce résultat, je pense que tu t'es trompé dans ton 1er message:

Le 06/02/2024 at 15:38, ManuBGeek a dit :

quand je clique sur -Y j'ai -X.

ce ne serait pas plutôt: quand je clique sur -Y se déplace suivant +X, non? 🤔

Cela devrait signifier que l'un des 2 moteurs ne tourne que dans un sens. Pour le valider, il suffit d'observer le sens de rotation des moteurs lorsque tu cliques sur:

  • X+ les moteurs devraient tourner dans le même sens
  • X- les moteurs devraient tourner dans le même sens mais à l'inverse du test précédent

(Peut-être qu'en fonction du trajet des courroies, ce sera plutôt Y+ et Y- 😅.)

L'origine du problème peut être:

  • entrée DIR du nouveau pilote HS -> remplacer le pilote
  • sortie DIR du microcontrôleur HS -> réparation ou remplacement de la carte-mère
Lien vers le commentaire
Partager sur d’autres sites

Merci à tous pour vos réponses.

Effectivement c'étaient les drivers qui étaient HS. J'ai dû faire une mauvaise manip en les branchant.

J'ai appris à paramétrer des pilotes et que je pouvais connecter et testé mon imprimante direct en USB

Merci encore pour vos suggestions

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
  • Sur cette page :   0 membre est en ligne

    • Aucun utilisateur enregistré regarde cette page.
  • YouTube / Les Imprimantes 3D .fr

×
×
  • Créer...