Aller au contenu

Filament ABS

shaunOFTD

Problème axe Z Anet A8

Messages recommandés

Bonjour à tous !

J'ai un problème que je n'arrive pas à résoudre depuis plusieurs jours, voici ce qu'il en est :

Je possède une Anet A8, tout est monté/branché correctement. Cependant, lorsque je fais le "homing", l'axe Z monte de quelques mm mais ne descend pas pour toucher le endstop z (c'est le endstop d'origine. Aucun problème pour x et y).

Lorsque sous repetier je fais M119, je m'aperçois que le endstop z est sur "triggered" en permanence (que j'appuie dessus avec mon doigt ou pas).

J'ai tenté d'inverser le sens de déplacement de l'axe z (via "invert z dir" dans config.h) et dans ce cas là, l'axe z descend mais ne s'arrête pas lorsqu'il touche le endstop z et force dessus (normal vous me direz, vu qu'il est bloqué sur triggered).

 

A noter que j'ai installé Marlin 1.1.4 ainsi qu'un clone E3D V6 et que le problème n'existait pas avant que je fasse ces changements. Si vous avez une solution, je suis preneur parce que je commence à devenir fou :13_upside_down: .

 

Merci de votre aide.

Partager ce message


Lien à poster
Partager sur d’autres sites

Je pense que ça vient de Marlin, d'après ce que j'ai pu lire Marlin est surtout utilisé pour les possesseurs d'un autoleveling sensor du style de : https://www.gearbest.com/3d-printer-parts/pp_591321.html?wid=21&lkid=10643194

Il sert a remplacer le endstop de base donc logiquement Marlin le désactive

Modifié (le) par Baltringue

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 7 heures, -=biosuz=- a dit :

salut,

contrôle tes branchements, contrôle le sens de tes branchements, tu aurais pas inverser 2 connecteurs?

quand tu appuis sur le endstop avec le doigts il fait "clic" ?

J'ai vérifié plusieurs fois les branchements, tout est OK. Le endstop fait bien "clic".

Il y a 3 heures, Baltringue a dit :

Je pense que ça vient de Marlin, d'après ce que j'ai pu lire Marlin est surtout utilisé pour les possesseurs d'un autoleveling sensor du style de : https://www.gearbest.com/3d-printer-parts/pp_591321.html?wid=21&lkid=10643194

Il sert a remplacer le endstop de base donc logiquement Marlin le désactive

J'ai un auto level sensor de ce type sauf que je ne l'ai pas installé, je voulais attendre de maîtriser l'imprimante avant de le faire. Du coup si c'est Marlin le problème, où puis-je trouver le firmware de base?

J'ai trouver un truc ici  : http://anet3d.en.made-in-china.com/custom-detail/xmQExQndGJUQxmQExQndGJUQ/The-Firmware-Links-You-May-Need.html

Sauf que le logiciel "avrdude" m'indique un .dll manquant alors que je l'ai téléchargé et installé dans win 32. Y'a-t-il un autre logiciel pour remettre ma carte avec son firmware d'origine ?

 

Merci de votre aide.

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai remis le firmware de base mais le problème persiste. Lorsque je fais "Home", l'axe Z monte légèrement mais ne descend jamais percuter le endstop. Je ne sais plus quoi faire...

Partager ce message


Lien à poster
Partager sur d’autres sites

as tu changé le endstop? il fait peut etre contact (électriquement) en permanence donc pour marlin il est déjà en home Z

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 14 heures, thsrp a dit :

as tu changé le endstop? il fait peut etre contact (électriquement) en permanence donc pour marlin il est déjà en home Z

J'ai inversé les endstop et lorsque je mets celui qui était sur l'axe z sur un autre axe, il fonctionne correctement. Par contre, peu importe le endstop que je branche sur l'axe z, il est toujours indiqué "triggered".

Modifié (le) par shaunOFTD

Partager ce message


Lien à poster
Partager sur d’autres sites

quand tu fait un M119 il te dis quoi ?

Citation

Exemple: M119

Retourne l'état actuel X, Y, Z des capteurs de fin de courses. Prends en compte les paramétrages d'inversion du sens de butée des capteurs fin de courses, on peut donc grâce à cette commande savoir si le paramétrage des capteurs de fin de course a été correctement effectué dans le firmware.

Si le retour de cette commande indique 'trigered' pour le X-min alors que celui ci n'est pas censé être enclenché indique qu'il faut changer la logique du fin de course dans le firmware.

ce serais juste que le switch et mal déclaré, donc suivant la réponse à la fonction M119, il suffit juste d’édité ton fichier MARLIN, changé l'option et téléversé le nouveau marlin dans ta carte

Modifié (le) par -=biosuz=-

Partager ce message


Lien à poster
Partager sur d’autres sites

Quand je fais M119, les axes X et Y indiquent soit "open", soit "triggered" selon leur position. Donc tout est OK pour ces axes. Par contre l'axe Z indique "triggered" peu importe qu'il touche le endstop ou non. J'ai tenté de modifier le fichier Marlin et le endstop Z reste toujours en "open" au lieu de "triggered". Du coup l'axe Z descend mais ne s'arrête pas lorsqu'il percute  le endstop.

 

La partie que j'ai modifié est celle-ci : #define Z_MIN_ENDSTOP_INVERTING true 

Je l'ai passée en "false".

 

Quelle partie du fichier MARLIN dois-je modifier? Car vu le résultat que j'ai obtenu, je n'ai pas dû modifier le bon code.

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut les amis j'ai exactement le même problème l'axe z et constamment triggered est ce que tu a réussi à régler ton problème si oui comment a du fais ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci de ta réponse pour ma part j'ai réussi à rediriger le endstop du z sur une pin qui n'était pas utiliser et sa a fonctionner impeccable

Envoyé de mon SM-G955F en utilisant Tapatalk

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant


×