Aller au contenu

Filament ABS

ewaca

flow a 3/4 bon ...

Messages recommandés

Bonjour,

comme je souhaite principalement imprimer des objets type, boitiers, structures qui s'assemblent etc ... je cherche a avoir un flow qui me permet vraiment d'avoir les bonnes dimensions sur les pieces imprimés par rapport a mes modèles.

Je suis sur du PLA et j'imprime un cube creux avec une paroi de 0.8mm d'épaisseur (buse de 0.4).

Avec un flow de 90%, c'est bon .... sur 3 des 4 cotés du cube ...

IMG_20180623_135132.thumb.jpg.d63494be2fdb13e621e1353b29e2e008.jpgIMG_20180623_135237.thumb.jpg.727805088c16a51384d89e0dd384b895.jpgIMG_20180623_135248.thumb.jpg.5bf32d302d7d56d8805f854e342aaefa.jpgIMG_20180623_134929.thumb.jpg.84e4faa02fb6a84146b65bd24e71a4ef.jpg

 

je ne voit pas comment expliquer ce phénomène. Si ça venait d'un axe, on aurait une symétrie, là non ... 

En écrivant ce message, je dis que ça peut etre une idée d'imprimer le cube avec un angle de 45° par rapport aux axes, voir comment ça réagit.

 

 

 

 

IMG_20180623_134929.jpg

IMG_20180623_135132.jpg

IMG_20180623_135237.jpg

IMG_20180623_135248.jpg

Modifié (le) par ewaca

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 7 heures, ewaca a dit :

Si ça venait d'un axe, on aurait une symétrie, là non ... 

Bonsoir @ewaca
Pas sûr... Il y a peut être un phénomène de sur-extrusion quand la tête ralentie et de sous-extrusion quand la tête accélère.
Je ne connais pas ta machine, ni le firmware qu'elle utilise, mais je viens de découvrir le linear advance dans Marlin, cela permet de gérer finement l'extrusion et je trouve le gain de qualité qui en découle très visible.

Partager ce message


Lien à poster
Partager sur d’autres sites

Les implémentations du linear advance varient suivant les firmwares. Dans Marlin 1.1.8 il y a une implémentation en version 1.0 et dans la branche 1.1.8 (bugfix) c'est une version 1.5 qui est utilisée.
C'est la 1.5 que j'utilise, je n'ai même pas cherché à tester la version 1.0 car elle est réputée très gourmande en puissance calcule pour la carte de l'imprimante, et ma melzi est déjà utilisée au max de ses possibilités.
La vidéo semble présenté le paramétrage pour un marlin avec linear advance en version 1.0 car les valeurs de K en V1.5 varie entre 0 et 2 typiquement alors que cela peut aller de 0 à plusieurs centaine avec la V1.0.
Le principe pour déterminer la valeur de K reste le même.
Mais il faut une première couche avec un bed leveling irréprochable pour mener le test sinon on ne voit strictement rien entre les différentes lignes.
 

  • Merci ! 1

Partager ce message


Lien à poster
Partager sur d’autres sites

bonjour,

 

Merci pour ces précisions @r2d2

 

lion02

Modifié (le) par lion02

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est un joyeux bordel quand meme tout ça ...

J'ai pris le gcode de la premiere vidéo, voici ce que j'obtiens :

IMG_20180630_002511.thumb.jpg.0fa825c9fba87b4047c022882ad2e913.jpg

il n'y a pas une ligne mieux qu'une autre, et je ne vois meme pas d'évolution, c'est plutot totalement random ...

Me suis dis, je vais essayer les autres liens postés, je génère un gcode avec le lien de @lion02 et je vois que l'expression du facteur K est pas la meme ..

- premier lien : M900 K10

- deuxieme lien : M900 K0.2 ; set K-factor

A priori c'est bien un float qu'il faut mettre. Je teste donc le 2e gcode, et pareil, quelque chose de random ... (je l'ai balancé, je l'ai meme pas pris en photo).

 

Je me dis que peut etre que mon firmware ne prend pas en charge cette fonction, sur mon imprimante c'est marqué "version 1.1.0" aucune idée de ce a quoi ça correspond . Je vais sur le site d'anycubic je prend le firmware qui se nome "Mega.hex_ULTRABASE_V1.1.2_2018.3.15", je flash ça avec Xloader, j'ai la petit loupiote verte qui clignote, l'imprimante redémarre ... et je suis toujours en 1.1.0 ... -_-'

j'y pige plus rien...

 

 

"

Modifié (le) par ewaca

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 7 heures, ewaca a dit :

Je me dis que peut etre que mon firmware ne prend pas en charge cette fonction, sur mon imprimante c'est marqué "version 1.1.0" aucune idée de ce a quoi ça correspond . Je vais sur le site d'anycubic je prend le firmware qui se nome "Mega.hex_ULTRABASE_V1.1.2_2018.3.15", je flash ça avec Xloader, j'ai la petit loupiote verte qui clignote, l'imprimante redémarre ... et je suis toujours en 1.1.0 ... -_-'

j'y pige plus rien...

 

 

"

La version 1.1.0 que tu vois dans le menu est celle de l'écran. J'ai eu la même réflexion que toi aux débuts.

Si ton upload de firmware s'est bien passé avec clignotement et petite musique de redémarrage, tu as bien la dernière version.

Partager ce message


Lien à poster
Partager sur d’autres sites

bonjour à vous.
En 1.1.2 c'est l'algo linear advance 1.0 qui est utilisable. Donc K n'a pas besoin d'être un chiffre à virgule sa valeur pouvant aller de 0 à plusieur centaines.
Attention comme toutes les fonctionnalités avancées le linear advance doit être explicitement activé dans Marlin. Si ce n'est pas le cas il est vain de chercher à l'utiliser en fixant une valeur pour K dans le gcode de démarage ou en le positionnant dans l'eeprom.
Dans Configuration_adv.h (marlin 1.1.2) on trouve
 

/**
 * Implementation of linear pressure control
 *
 * Assumption: advance = k * (delta velocity)
 * K=0 means advance disabled.
 * See Marlin documentation for calibration instructions.
 */
//#define LIN_ADVANCE

#if ENABLED(LIN_ADVANCE)
  #define LIN_ADVANCE_K 75

  /**
   * Some Slicers produce Gcode with randomly jumping extrusion widths occasionally.
   * For example within a 0.4mm perimeter it may produce a single segment of 0.05mm width.
   * While this is harmless for normal printing (the fluid nature of the filament will
   * close this very, very tiny gap), it throws off the LIN_ADVANCE pressure adaption.
   *
   * For this case LIN_ADVANCE_E_D_RATIO can be used to set the extrusion:distance ratio
   * to a fixed value. Note that using a fixed ratio will lead to wrong nozzle pressures
   * if the slicer is using variable widths or layer heights within one print!
   *
   * This option sets the default E:D ratio at startup. Use `M900` to override this value.
   *
   * Example: `M900 W0.4 H0.2 D1.75`, where:
   *   - W is the extrusion width in mm
   *   - H is the layer height in mm
   *   - D is the filament diameter in mm
   *
   * Example: `M900 R0.0458` to set the ratio directly.
   *
   * Set to 0 to auto-detect the ratio based on given Gcode G1 print moves.
   *
   * Slic3r (including Prusa Slic3r) produces Gcode compatible with the automatic mode.
   * Cura (as of this writing) may produce Gcode incompatible with the automatic mode.
   */
  #define LIN_ADVANCE_E_D_RATIO 0 // The calculated ratio (or 0) according to the formula W * H / ((D / 2) ^ 2 * PI)
                                  // Example: 0.4 * 0.2 / ((1.75 / 2) ^ 2 * PI) = 0.033260135
#endif

#define LIN_ADVANCE ne doit pas être en commentaire.

Personnellement j'ai utilisé l'outils de génération du gcode de test dont @lion02 à donné le lien plus haut.
Il ne faut pas oublier de préciser la version 1.0 pour marlin 1.1.2, et l'interval de valeur de l'on veux tester pour K

   

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut à tous,

vous oubliez que les firmwares d'Anycubic pour la méga I3 Ultrabase sont TOUS basés sur la version 1.0RC8 de Marlin et la numérotation 1.1x ne correspond à rien, sauf en interne à Anycubic.

et comme le dit @dexter43, la version renvoyé sur l'écran est TOUJOURS 1.1.0 (c'est en hard dans le firmware de l'écran) peut importe la version de Marlin qui tourne sur la trigorilla.

de plus quand on regarde les sources de Marlin_TFT_CR_V1.1.1, la ligne LIN_ADVANCE est commentée, donc pas de linear advance sur les firmware Anycubic de base.

 

pour ceux qui sont sur un firmware alternatif, amusez vous !

Modifié (le) par stef_ladefense

Partager ce message


Lien à poster
Partager sur d’autres sites

Je suis allé à la peche aux infos, déja pour etre sur de ce que j'ai dans l'imprimante, parce que des V2, y en a avec des cartes 8 et 32 bits.

Donc j'ai une trigorilla 8 bits, et si j'ai bien compris, sur ce forum niveau firmware je n'ai vu que celui de murdock pour une une carte MKS, donc ça ne me concerne pas.

Du coup j'ai cherché un peu ce qu'on pouvait trouvé comme firmware marlin le plus "stock" possible pour une I3 mega, et au final je tombe dans la branche i3 mega du gihub de marlin ( https://github.com/derhopp/Marlin-with-Anycubic-i3-Mega-TFT )

si je comprends bien, je remplace le configuration.h par celui qui qui va bien (dossier Marlin-with-Anycubic-i3-Mega-TFT-1.1.x\Marlin\example_configurations\Anycubic\i3_Mega_Ultrabase )

Dans

j'ouvre le marlin.ino dans Arduino, je configure ma carte en ATmega 2560 et je compile ?

 

Dans Configuration_adv.h  le #define LIN_ADVANCE est pas commenté, mais sur lesl ignes qui suivent le K est égale à 0.

#if ENABLED(LIN_ADVANCE)
  #define LIN_ADVANCE_K 0

La valeur pourra etre modifiée par un gcode par la suite ?

 

Un truc qui me questionne aussi, c'est :

#if ENABLED(HAVE_TMC2130)

si j'ai des 2208, ça pose pas de soucis ?

 

Merci d'avance.

 

(Avec un peu de recule, je me dis "tout ça pour 0.08mm" ... ^^ )

Modifié (le) par ewaca

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 30/06/2018 at 10:30, stef_ladefense a dit :

quand on regarde les sources de Marlin_TFT_CR_V1.1.1, la ligne LIN_ADVANCE est commentée, donc pas de linear advance sur les firmware Anycubic de base.

Bonjour @stef_ladefense
cela semble un peu contradictoire de dire que le paramétrage est prévu dans les sources du firmware et de conclure que la fonctionnalité n'est pas utilisable.
Je suppose que tu veux plutôt dire que tel que sont livrées les imprimantes le lineare advance n'est pas activé (c'est ce qui découle en effet du fait que la ligne soit en commentaire).
Mais si les sources sont bien ceux du marlin qui tourne sur les imprimantes (c'est là la vraie question) il suffit précisément de décommenter la ligne pour activer la fonctionnalité, en recompilant et téléversant ce firmware modifié dans la carte. Du moins si les ingés d’anycubic ne sont pas tordus au point de laisser un paramétrage et d'avoir supprimé la fonctionnalité !
Par contre il est à craindre que ces manipes sont propres à annuler une garantie, et aux risques et périls de celui qui les fait.
je ne connais qu'une seule imprimante, ma Discovery 200. Elle vient aussi de base avec un marlin 1.0RC8, aujourd'hui je l'utilise avec un marlin en 1.1.8 (bugfix) qui n'a plus rien à voire avec l'originale, mais je conviens que j'avais beaucoup moins à perdre en changeant de marlin puisque ma disco n'offrait alors aucune options que j'aurais pu regretter de perdre avec un marlin générique reprap.
 

Le 01/07/2018 at 00:08, ewaca a dit :

si je comprends bien, je remplace le configuration.h par celui qui qui va bien (dossier Marlin-with-Anycubic-i3-Mega-TFT-1.1.x\Marlin\example_configurations\Anycubic\i3_Mega_Ultrabase ) 

Dans

j'ouvre le marlin.ino dans Arduino, je configure ma carte en ATmega 2560 et je compile ? 

@ewaca
 je ne peux pas vraiment t'assister pour tous ce qui concerne ta machine, trouver le firmware qui convient modifier son paramétrage, flasher la carte ou sauvegarder  la version présente dans ta carte (je sais qu'en tous cas sur les cartes arduino il est possible de récupérer la version binaire compilé de l'eeprom)
Si tu ne pratiques pas couramment ce genre d'opérations je t'invite à consulter les connaisseurs en la matière d'anycubic.
Ce serait dommage de ne plus pouvoir utiliser ton imprimante.

Le 01/07/2018 at 00:08, ewaca a dit :

La valeur pourra etre modifiée par un gcode par la suite ?

oui mais je ne sais pas à partir de quelle version de marlin, avec un

M900 K<la valeur>

cf  : http://marlinfw.org/docs/gcode/M900.html

Le 01/07/2018 at 00:08, ewaca a dit :

Un truc qui me questionne aussi, c'est :


#if ENABLED(HAVE_TMC2130)

si j'ai des 2208, ça pose pas de soucis ?

les lignes qui commence par un # sont des directives de compilation ce ne sont pas des lignes de codes à part entière mais des instructions qui permettent au compilateur de faire des choix et d'inclure ou pas telle ou telle partie de code.
Cette ligne ne se comprend qu'associée à une autre qui doit se trouver avant,  qquchose comme  :
//#define HAVE_TMC2130
ou
#define HAVE_TMC2130
et elle signifie ajouter le code qui suit jusqu'au #else ou au #endif suivant si la variable HAVE_TMC2130 est définie.
Si elle n'est pas définie ou en commentaire alors le code n'est pas inclus.
Donc si tu n'a pas de TMC2130 laisse #define HAVE_TMC2130 en commentaire càd. précédé de //

Le 01/07/2018 at 00:08, ewaca a dit :

(Avec un peu de recule, je me dis "tout ça pour 0.08mm" ... ^^ )

 

Well, en ce qui me concerne le linear advance V1.5 améliore mes impressions, je ne sais pas ce que donne la V1.0 du marlin 1.0RC8, ni si cela aura un impact sur tes 0.08 mm...
Perso je flash ma melzi pour un oui ou pour un non, mais la première fois je n'en menais pas large, et je ne me suis lancé que parce que d'autre le faisaient avant moi et que la procédure était bien documentée. Avec une imprimante qui répondrait globalement à mais attentes et qui vaudrait deux fois plus chère que ma discovery je ne sais pas je ferais le pas. 
 

Partager ce message


Lien à poster
Partager sur d’autres sites

Surtout que

il y a 25 minutes, r2d2 a dit :

Well, en ce qui me concerne le linear advance V1.5 améliore mes impressions, je ne sais pas ce que donne la V1.0 du marlin 1.0RC8, ni si cela aura un impact sur tes 0.08 mm...
Perso je flash ma melzi pour un oui ou pour un non, mais la première fois je n'en menais pas large, et je ne me suis lancé que parce que d'autre le faisaient avant moi et que la procédure était bien documentée. Avec une imprimante qui répondrait globalement à mais attentes et qui vaudrait deux fois plus chère que ma discovery je ne sais pas je ferais le pas. 
 

 

Surtout qu'on est parti sur cette hypotèse, mais j'ai meme pas vérifié s'il y avait bien une différence de vitesse entre ce coté et les 3 autres... Normalement la vitesse d'impression est sensée etre la même sur tous les cotés et surtout on a que du wall, parce que le wallthickness dans cura est 0.8 pour ce print. Donc normalement aucun changement de vitesse sur toute l'impression (sauf la premiere couche)

Ca ne me dérange pas de flasher tout ce qui peut l'etre, mais la premiere fois, j'essaye juste d'etre sur de ne pas faire de conneries. (après j'ai la confiance, et généralement c'est là où j'en fait ^^ mais rien d’irrécupérable jusqu'a maintenant)

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 8 heures, ewaca a dit :

Normalement la vitesse d'impression est sensée etre la même sur tous les cotés et surtout on a que du wall, parce que le wallthickness dans cura est 0.8 pour ce print. Donc normalement aucun changement de vitesse sur toute l'impression

La vitesse de base est fixe mais marlin joue autour pour respecter des contraintes physique. De même le slicer a put introduire des subtilités.
Je ne connais que cura, il propose moults réglages pouvant faire varier la vitesse, il y a même des tentatives d'amélioration du flux d'extrusion en moins efficasse que le linear advance (et incompatible avec celui-ci : à ne pas utiliser en même temps).
As tu essayé une impression de ton modèle en mode "spirale" ou "vase" (je ne suis pas sûr que tu puisse alors régler l'épaisseur, je crois que tu doit être limité à la largeur de la buse). Dans ce mode il n'y a pas de saut en Z aprés chaque couche car la tête monte progressivement en permanance. Je pense à ca parce que peut être qu'avant de changer de couche, de monter sur l'axe Z, la vitesse diminue et si cela se produit toujours au même endroit couches aprés couches tu peux voire apparaître un surépaisseur. Il y a aussi dans cura une option pour que l'endroit ou la tête monte pour changer de couches ne soit pas aligné.  J'utilise toujours la dernière version de cura téléchargé directement chez ultimaker, je ne sais pas dans quelles versions ces options apparaissent.

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 02/07/2018 at 00:09, r2d2 a dit :

Bonjour @stef_ladefense
cela semble un peu contradictoire de dire que le paramétrage est prévu dans les sources du firmware et de conclure que la fonctionnalité n'est pas utilisable.
Je suppose que tu veux plutôt dire que tel que sont livrées les imprimantes le lineare advance n'est pas activé (c'est ce qui découle en effet du fait que la ligne soit en commentaire).

Citation

de plus quand on regarde les sources de Marlin_TFT_CR_V1.1.1, la ligne LIN_ADVANCE est commentée, donc pas de linear advance sur les firmware Anycubic de base

c'est bien ce que j'ai écris ! dans les sources de la version 1.1.1 pour la méga i3 ultrabase que fournit Anycubic sur son github, la fonction est commenté

je n'en conclu pas que la fonction est inutilisable comme tu permets de me le faire dire, mais que la fonction lineare advance n'est pas activée dans les firmware livrés avec nos mega I3.

je parle bien de la version du firmware de base et d'origine livré avec l'imprimante , la mega i3 n'as pas lineare advance !

 

maintenant libre de modifier les sources, de compiler et d'injecter le firmware anycubic avec LA active, ou d'utiliser une version 1.1.8 de marlin, plein d'exemple existe, aussi bien avec l'ecran d'origine, qu'avec un mks

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon ben n'ayant pas de confirmation sur la manip' a faire, je me suis lancé !

J'ai essayé d'enlever les commentaire sur la partie TMC2208, mais j'avais une erreur sur le stepperx2 non déclaré, J'ai pas trouvé comment réglé ça, mais apparemment c'est pas obligatoire de l'activer.

J'ai pas eu de redémarrage de l'imprimante ... je le fait manuellement ... plus de musique, ... carte SD qui fait planter l'imprimante ... une formatage de la carte résout le souci.

je vérifie avec pronterface, un M115 me dit bien que la version est 1.1.8.

Qu'a cela ne tienne ! je règle mon extrudeur ... et je passe au linear advance ... et je vois pas de différence ...

(K augmente vers le haut de la feuille... et on est a 100 en haut)

IMG_20180703_232647.thumb.jpg.8fa3c6dd8dd77d7f1f8103e684979b86.jpg

 

Je viens de voir que ça peut etre au dela de 100 pour les extrudeur "bowden" ( Bowden setups may be higher than 100 ).

On est bien sur ce type d'extrudeur ?

Modifié (le) par ewaca

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 22 heures, ewaca a dit :

Je viens de voir que ça peut etre au dela de 100 pour les extrudeur "bowden" ( Bowden setups may be higher than 100 ).

On est bien sur ce type d'extrudeur ?

Bonsoir @ewaca un extrudeur est dit "bowden" quand le moteur de l'extrudeur n'est pas sur la tête mais qu'il est déporté, et qu'il pousse le filament à travers un long tube, par opposition il y a le direct drive où le moteur est sur la tête d'impression.
Il n'y a pas de règles à priori pour la valeur de K, cela dépend du matériau du filament de la température d'extrusion.
Globalement avec un "bowden" le K est plus élevé qu'en direct drive.

Avec l'outil en ligne cité par @lion02 un peu plus haut tu peux générer un gcode de test en précisant l'intervalle à tester pour K, et l'écart entre les valeurs de chaque ligne.
Ce Gcode m'a l'aire meilleur que celui que tu utilises, en tous cas je n'avais pas de gros patés en début de ligne.

la 8ᵉ ligne en partant du bas (en contant celle incomplète) n'est-elle pas un poil meilleur que les autres ?

 

  • Merci ! 1

Partager ce message


Lien à poster
Partager sur d’autres sites

@r2d2 Je sais qu'il n'y a pas de regle, c'est là le problème ...

J'ai refais des test a partir de 100, et un pas de 10 ... toujours la même forme ...

pour tester quand meme si ce foutu linear advance fonctionne, j'ai mis des valeurs abérantes en commençant a 100 avec un pas de 50, et là enfin j'ai le schema qui s'inverse (bombé sur la partie rapide, donc surcompensée). Avec ça j'ai trouvé que K = 300 était le moins pire, mais j'ai toujours un bourlet quand ça décelère

J'ai tester des pas plus fins autour de cette valeur (250 a 350 avec un pas de 10 ) avec le générateur de gcode ... et je vois pas vraiment de différence, même si le trait sur la partie accélérée est pas vraiment plus fine, j'ai toujours un bourlet quand ça décelère....

Je tester mon cube avec K a 300

Partager ce message


Lien à poster
Partager sur d’autres sites

BINGO !!!!!!!!!!!!!!!!!!

j'ai mes 4 coté a 0.80 +/- 0.01

Merci @r2d2 d'avoir lancé l'idée du linear advance.

En fait l'imprimante commençait par ce coté après avoir changé en Z, du coup la tete devait etre un peu plus lente et déposait plus de matière sans le linear advance.

 

En tout cas avec un extrudeur type bowden, quand on cherche son K il faut vraiment y aller gras dans les step jusqu'a avoir + de matiere sur la partie rapide, et descendre petit a petit. Et j'ai pas l'impression qu'on soit a à la dizaine près.

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×