Aller au contenu

Filament ABS

Kalemth

Rendre mon AM8 silencieuse

Messages recommandés

Hello les amis,

après passage en AM8 et même s'il me reste des trucs à revoir, j'aimerai rendre ma bécane un peu moins bruyante.

Du coup, avant d'envisager le plus dur, TMC2130, j'aimerai déjà changer les 2 ventilos, le 40x40x10 et le 5015.

https://www.amazon.fr/gp/product/B009NQLT0M/ref=crt_ewc_img_oth_2?ie=UTF8&psc=1&smid=A38F5RZ72I2JQ

https://www.gearbest.com/other-pc-parts/pp_657803.html

Du coup, que pensez-vous de ces 2 ventilos ?

Merci pour votre aide et bons prints.

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut 😃 

Pour rendre tes ventilos plus silencieux, surtout celui du hotend, il y a @Janpolanton qui à fait un circuit qui fonctionne du tonnerre de brest ! 😛

J'en ai un pour le ventilo du hotend, il démarre et s'arrête tout seul suivant la température que l'on règle avec deux potentiomètre 😃 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

les noctua 40mm sont top, ca passe aussi sur une E3D avec un adaptateur, fait juste gaffe à commander la version 12 ou 5v en fonction de ton setup.

les ventillos pour refroidir l'impression par contre, tu peux déjà essayer de réduire le %; en imprimant du PLA / PET / PETG avec un fanduct "demi U" je dépasse rarement 50% et ca fait du bien aux oreilles. Tu peux les commander sur amazon, c'est +/- tous les mêmes, même si le lien gearbest indique "ultra quiet" :^)

J'ai une AM8 et des tmc2130, et le mode silencieux "stealthchop" chez moi fait du layershift de manière un peu aléatoire, du coup mon X/Y est en "spreadcycle" et le problème (et le silence) disparait. C'est possiblement un bug qui arrive que sous marlin 2.x mais je préfère le mentionner, les tmc2208 ont le stealthchop V2 (plus de torque en mode silence) et normalement pas le problème de layer shift, c'est peut-être plus judicieux de chopper des 2208 (les tmc2130 ont que le stallguard / le homing sensorless pour eux, c'est pas ouf).

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 17 heures, Heatcreep a dit :

J'ai une AM8 et des tmc2130, et le mode silencieux "stealthchop" chez moi fait du layershift de manière un peu aléatoire, du coup mon X/Y est en "spreadcycle" et le problème (et le silence) disparait. C'est possiblement un bug qui arrive que sous marlin 2.x mais je préfère le mentionner, les tmc2208 ont le stealthchop V2 (plus de torque en mode silence) et normalement pas le problème de layer shift, c'est peut-être plus judicieux de chopper des 2208 (les tmc2130 ont que le stallguard / le homing sensorless pour eux, c'est pas ouf). 

Salut @Heatcreep,

De combien sont tes décalage layershift ? C'est des gros décalages ?

Comment sont cablé tes steppers ? standalone, UART ou SPI ?

Je me demande si j'ai pas le même soucis ! Pas de gros décalages mais mes parois ne sont pas "lisse" du tout.

Voilà ma config hardware :

  • Anet A8
  • Carte RAMPS 1.4
  • TMC2130 cablé en mode SPI

Pour la configuration Marlin (v1.1.9) :
 

#define R_SENSE           0.11
#define HOLD_MULTIPLIER    0.5
#define INTERPOLATE       true
#define STEALTHCHOP
#define MONITOR_DRIVER_STATUS
//#define HYBRID_THRESHOLD
//#define SENSORLESS_HOMING
//#define TMC_DEBUG
//#define TMC_Z_CALIBRATION

 

Après il est possible que mon problème soit mécanique mais j'ai du mal à définir la source du problème.

Je vais peut-être tester en spreadCycle (en commentant "STEALTHCHOP") pour voir si j'ai une différence.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a une heure, obi_one a dit :

Salut @Heatcreep,

De combien sont tes décalage layershift ? C'est des gros décalages ?

Comment sont cablé tes steppers ? standalone, UART ou SPI ?

Je me demande si j'ai pas le même soucis ! Pas de gros décalages mais mes parois ne sont pas "lisse" du tout.

Voilà ma config hardware :

  • Anet A8
  • Carte RAMPS 1.4
  • TMC2130 cablé en mode SPI

Pour la configuration Marlin (v1.1.9) :
 


#define R_SENSE           0.11
#define HOLD_MULTIPLIER    0.5
#define INTERPOLATE       true
#define STEALTHCHOP
#define MONITOR_DRIVER_STATUS
//#define HYBRID_THRESHOLD
//#define SENSORLESS_HOMING
//#define TMC_DEBUG
//#define TMC_Z_CALIBRATION

 

Après il est possible que mon problème soit mécanique mais j'ai du mal à définir la source du problème.

Je vais peut-être tester en spreadCycle (en commentant "STEALTHCHOP") pour voir si j'ai une différence.

Ca dépend, en imprimant par exemple les "Y rod mounts" pour l'AM8, j'avais du shift de ~0.5mm a facile 1-2mm sur plusieurs étages, ca ressemble fortement à un manque de torque ou à un problème d’accélération (un bug de marlin 2.x possiblement), mais comme ça se produit sur X et Y, j'ai surtout l'impression que l'hypothèse du bug est la plus probable.

hardware SPI sur une ramps (en soudant sur les pins spi du lecteur SD) ici 😉

Pas mal de gens rapportent ne pas avoir le soucis en repassant sous marlin 1.1.x, mais j'avais la flemme de refaire ma config, pour ton problème vérifie que t'as pas activé le S_CURVE_machin, les TMC aiment pas trop.

Si tes murs ne sont pas lisses, vérifie les ressorts de ton lit (ressorts trop desserré = vibrations), la tension des courroies, resserre les vis de ton cadre et baisse ta vitesse d'impression, l'acrylique de l'anet a8 est trop souple pour imprimer des murs "lisses" rapidement, l'AM8 c'est de loin l'une des meilleurs améliorations en terme de qualité 😉

Si tu souhaite utiliser le mode spreadcycle que sur X/Y, marlin 2.x le permet avec une option de config, sinon sous 1.x tu peux utiliser l'option TMC_ADV dans config_adv.h et désactiver le stealthchop que sur X et Y (le Z est tellement bruyant en spreadcycle :') ).

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 38 minutes, Heatcreep a dit :

pour ton problème vérifie que t'as pas activé le S_CURVE_machin, les TMC aiment pas trop. 

Je l'avais activé durant un temps et j'en étais arrivé à la même conclusion que toi.

il y a 39 minutes, Heatcreep a dit :

Si tes murs ne sont pas lisses, vérifie les ressorts de ton lit (ressorts trop desserré = vibrations), la tension des courroies, resserre les vis de ton cadre et baisse ta vitesse d'impression, l'acrylique de l'anet a8 est trop souple pour imprimer des murs "lisses" rapidement, l'AM8 c'est de loin l'une des meilleurs améliorations en terme de qualité

Je vais regarder de plus prêt car je soupçonne sérieusement le bed.

Merci pour tous ces conseils.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 10 minutes, obi_one a dit :

Je l'avais activé durant un temps et j'en étais arrivé à la même conclusion que toi.

Je vais regarder de plus prêt car je soupçonne sérieusement le bed.

Merci pour tous ces conseils.

Pour le bed, serre tout à fond, baisse ton Z endstop jusqu'a ce que ton nozzle soit à 1 - 2mm au dessus du lit, et met à niveau en desserrant les ressorts. En bonus pour être sur que tes smooth rods ne "bougent" dans leurs emplacement, j'avais eu pas mal d'améliorations en imprimant 4 de ces petits trucs : https://www.thingiverse.com/thing:2404708/files

Sinon pense aussi à correctement vissé les boulons des tiges filetés Y, ceux du fond, du milieu, puis les boulons qui tiennent la plaque de devant, l'imprimante bien à plat pour éviter de rendre concave ces tiges, et de "tordre" l'assise de l'imprimante. 

  • Merci ! 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.


  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...