Aller au contenu

Filament ABS

Octoprint + SmartPlug


neor

Messages recommandés

Bonjour, apres pas mal de rechercher j'ai reussi a faire fonctionner un smartplug avec octoprint

 

il faut installer le plugin TuyaSmartPlug

sur votre téléphone il faut installer Packet Capture et l'application Tuya Smart qui gère la plupart des smartplug

associer votre prise a l'application TuyaSmart sur votre téléphone

lancer Packet Capture

Screenshot_20190403-225336.thumb.png.ceb7d2ffb0d188c7f55ed2d60cb31f33.png

choisir le programme tuya pour capturer les trames

dans tuya allumer et eteindre la prise

Screenshot_20190403-225129.thumb.png.3562c75804c392789f50922937ec4962.png

Vous allez avoir ceci

dans un des fichier SSL vous devriez trouver votre ID et votre localkey

Screenshot_20190403-225037.thumb.png.8c342b65309939690ed6c4c39cea9cbd.png

plus qu'a les mettre dans votre plugin sous octoprint

Screenshot_20190403-225111.png

Lien vers le commentaire
Partager sur d’autres sites

Salut,

Super, merci pour les info!

De mon côté, et pour compléter tes infos car ça peut intéresser les membres du forum, je l'ai fait plus simplement (de mon point de vue):

-Installation de Kasa (app officielle de TPlink) sur le tel et paramétrage de la prise

-Installation du plugin "TP-link SmartPlug" sur octoprint (juste à indiquer l'adresse IP de la prise)

-Contrôle de l'imprimante avec Printoid premium (4€) sur le tel (gestion de la prise en automatique), tu peux le faire avec la version gratuite de printoid mais il faut taper une ligne de code (le code à taper est donné sur le site de l'app). L'app est tellement bien que j'ai préféré prendre la version payante pour soutenir le développeur (un français).

Vraiment très facile et fait en 10 min sans connaissance technique.

De plus le plugin sur octoprint te permet de gérer l'allumage et l'extinction (ainsi qu'une tempo pour éteindre l'imprimante après refroidissement du hotend) directement dans le Gcode avec M80/M81 (il suffit d'intégrer ça dans le slicer au niveau des scripts démarrage/arrêt). 

Tuto octoprint/printoid

Tuto printoid/smartplug

Le seul bémol pour certains est que printoid est réservé à Android.

Quand je fais la démo de lancer une impression à 10 000Km de l'imprimante avec mon téléphone plus la vidéo en direct ça fait tjs son petit effet 😉

Cdt

 

LC

Lien vers le commentaire
Partager sur d’autres sites

  • 2 weeks later...
Le 04/04/2019 at 08:06, miserovitch a dit :

Salut,

Super, merci pour les info!

De mon côté, et pour compléter tes infos car ça peut intéresser les membres du forum, je l'ai fait plus simplement (de mon point de vue):

-Installation de Kasa (app officielle de TPlink) sur le tel et paramétrage de la prise

-Installation du plugin "TP-link SmartPlug" sur octoprint (juste à indiquer l'adresse IP de la prise)

-Contrôle de l'imprimante avec Printoid premium (4€) sur le tel (gestion de la prise en automatique), tu peux le faire avec la version gratuite de printoid mais il faut taper une ligne de code (le code à taper est donné sur le site de l'app). L'app est tellement bien que j'ai préféré prendre la version payante pour soutenir le développeur (un français).

Vraiment très facile et fait en 10 min sans connaissance technique.

De plus le plugin sur octoprint te permet de gérer l'allumage et l'extinction (ainsi qu'une tempo pour éteindre l'imprimante après refroidissement du hotend) directement dans le Gcode avec M80/M81 (il suffit d'intégrer ça dans le slicer au niveau des scripts démarrage/arrêt). 

Tuto octoprint/printoid

Tuto printoid/smartplug

Le seul bémol pour certains est que printoid est réservé à Android.

Quand je fais la démo de lancer une impression à 10 000Km de l'imprimante avec mon téléphone plus la vidéo en direct ça fait tjs son petit effet 😉

Cdt

 

LC

mais tu a une prise tp link ?

Lien vers le commentaire
Partager sur d’autres sites

  • 1 month later...

Bonjour , je rencontre quelques soucis pour suivre se tuto ... tout les ssl qui se trouve dans l’application Packet capture sont vide. Du coup impossible de voir le localkey... Dans les autres fichier avec l'apdresse ip de la prise , j'y trouve bien une ligne : "devid" :" xxxxxxxxxx" ,"dps":.................................

mais rien de plus ... j'y vois aussi un gwId qui correspond à la meme choses que le devid , j'ai testé mais rien a faire ... 

Si vous auriez une idée ??? 

Se sont des prises alfawise PE1004T compatible smartlife et tuya. 

Lien vers le commentaire
Partager sur d’autres sites

bonjour, je suis quasiment au meme point que fabian a une difference pret c'est que je trouve le productid ainsi que la localkey mais lorsque je rentre cela dans le plugin octopie j'ai un message d'erreur a la connection ( voir photo) du coup je sais pas si le souci vient de l'id product de la local key ou de l'ip produit.... si j'avais envore des cheveux je pense que je me les arracherai

image.thumb.png.c8aa3ab90f8f304c28bc22c8ea722fdc.png

Lien vers le commentaire
Partager sur d’autres sites

installation finalisée. soucis d'ip et reboot total du pi. maintenant tout est ok reste plus qu'à trouver comment configurer l'auto shutdown en fin de print

Modifié (le) par spacerabbit37
Lien vers le commentaire
Partager sur d’autres sites

  • 1 month later...

Bonjour à vous tous, 

je suis toujours sur mes prises connectées 🙂  j'ai bien réussi à configurer la prise alfawise pe1004t , mais l'occasion a fait que j'ai trouvé une multiprise connectée 4 plug et j'ai craqué dessus. Pourquoi? et bien toujours pour commander à distance l''imprimante, mais également pour mettre un éclairage synchronisé avec l'imprimante. En gros l'imprimante se coupe, la lumière se coupe également. ( je sais une simple multiprise aurai été plus simple, mais pourquoi faire simple quand on peut faire compliqué??)

J'ai réussi à configurer les deux prises sur tuya, je réussis à les commander depuis la page principale d'octoprint, ( voir screen ). jusqu'à la tout est ok.

Il faut savoir que le bloc multiprise a une ip (192.168.1.12), mais que chaque plug en sont dépourvu ( suivant packet capture, les plug ont un "numéro fille" en gros la première à le numéro 1, la seconde le 2 etc...)

les "soucis" ou plutôt inconvénients viennent quand je print.... En effet ( et la c'est un coup de change) en fin de print, via la commande M81 192.168.1.12 (ip du bloc) l'imprimante se coupe en fin de print suivant le timer saisi dans tuya, mais la lumière reste définitivement allumée.... 

Je pense que pour parvenir à commander les deux je dois saisir une information complémentaire ( je pense le numéro attribué à la prise)  mais rien n'y fait. Je pense très fortement que je n'ai pas la syntaxe convenable.

J'ai tenté les commandes suivantes:

M81 192.168.1.12 (coupe uniquement l'imprimante) ==> Send: M81 192.168.1.12
Recv: ok

M81 192.168.1.12  1 ( ne coupe plus rien)

M81 192.168.1.12 :1 ( ne couple plus rien)

M81 192.168.1.12 ;1 (ne coupe plus rien)

M81 192.168.1.12 @1 (ne coupe plus rien)

M81 192.168.1.12  @1(ne coupe plus rien // il y a un espace entre le 12 et le @)

M81 192.168.1.12 @:1 ( ne coupe plus rien )

M81 192.168.1.12  @:1 ( ne coupe plus rien )

je ne sais pas si c'est la syntaxe ou alors qu'il faut que je mettes les id ( cf screen tuya 2) mais dans tous les cas je n'ai pas la syntaxe :'(((((((

Aussi, si une bonne ame avait une idée voir la solution se serait fooorrmmiiddaabbllee 

Je vous remercie par avance 

prise octo 2.png

prise octo 3.png

prise octo 4.png

prise octo.png

tuya 1.png

tuya 2.png

Lien vers le commentaire
Partager sur d’autres sites

  • 1 month later...

Hello,

Je réponds sur ce thread car je me suis battu il y a quelques jours avec une tuya cheap d'amazon donc j'ai du investiguer un peu le sujet.

Octoprint contrôle bien le smartplug mais la fiabilité est variable et clairement, je ne recommencerais pas et je me tournerai plutôt vers une solution octoprint + relai à l'avenir.

L'idée de base du contrôle des tuya est de récupérer un identifiant et une clée de chiffrement lors de l'enrollement de la prise dans le cloud Tuya/SmartLife, la fameuse paire productId/localKey. Visiblement @spacerabbit37 a réussi sous Android avec la méthode du proxy SSL. Je n'avais pas exactement la même app mais je n'ai pas réussi de cette façon. J'ai trouvé deux outils qui permettent l'extraction de la clé, tuyapi en nodeJs et pytuya en python. Le plugin TuyaSmartplug d'Octoprint dépend de pytuya.

Les différentes approches sont documentées ici. J'ai tenté via les logs Android mais je n'y récupérais que le productId, la localKey restait introuvable. J'ai finalement réussi à récupérer une paire correcte avec cette méthode, sous Linux. J'imagine que c'est faisable sur Windows aussi mais comme c'est en ligne de commande ... Evidemment, ça ne suffit plus XD (mais ça devrait bientôt arriver). A ce moment, le plugin ne contrôle toujours pas la prise. En testant la prise avec mon smartphone, j'aurai déclenché une mise à jour (silencieuse) du firmware du smartplug qui change le protocole de communication. Les devs de tuyapi ont clairement identifié la cause du problème https://github.com/codetheweb/tuyapi/issues/175 et pytuya a mergé le support du nouveau protocole https://github.com/clach04/python-tuya/commit/bee5b97e726425059c32b8191f7147e01bf0c3c2 après coup.

TuyaSmartplug dans mon octoprint tire pytuya 7.0.2. Le support du nouveau protocole est dans pytuya 7.0.4 qui n'est visiblement pas arrivé dans pipy et pour le moment le plugin n'en a pas connaissance.

Au bout d'un long moment, partant d'un Octoprint sans TuyaSmartplug d'installé :

* ssh octoprint
* git clone 
https://github.com/ziirish/OctoPrint-TuyaSmartplug
* git clone https://github.com/clach04/python-tuya
* source oprint/bin/activate
* pip install -e . dans le dossier cloné de pytuya
* 2 lignes de code à modifier pour un support basique (setup.py et octoprint_tuyasmartplug/__init__.py voir patch). C'est du python, attention à l'indentation.
* pip install -e . dans le dossier cloné de TuyaSmartplug
* reboot
* It works. Bon c'est brutal, ça va casser le support des prises avec une autre version du protocole mais dans mon cas je n'en avais qu'une qui ne marchait pas.

Vu l'avancement du sujet, j'imagine que c'est une question de semaines/mois avant que tuyasmartplug ne supporte correctement le protocole. Mais bon, vu que ce n'est pas encore le cas et qu'il suffit d'une mise à jour silencieuse pour se retrouver coincé ...

diff --git a/octoprint_tuyasmartplug/__init__.py b/octoprint_tuyasmartplug/__init__.py
index 068aea2..2cfb3d3 100644
--- a/octoprint_tuyasmartplug/__init__.py
+++ b/octoprint_tuyasmartplug/__init__.py
@@ -209,6 +209,7 @@ class tuyasmartplugPlugin(octoprint.plugin.SettingsPlugin,
                self._tuyasmartplug_logger.debug('Sending command: %s to %s' % (cmd, plugip))
                plug = self.plug_search(self._settings.get(["arrSmartplugs"]), "ip", plugip)
                device = pytuya.OutletDevice(plug['id'], plug['ip'], plug['localKey'])
+                device.set_version(3.3)

                commands = {
                        'info': ('status', None),
diff --git a/setup.py b/setup.py
index fa8e00b..d537e0d 100644
--- a/setup.py
+++ b/setup.py
@@ -34,7 +34,7 @@ plugin_license = "AGPLv3"

 # Any additional requirements besides OctoPrint should be listed here
 plugin_requires = [
-       'pytuya==7.0'
+       'pytuya'
 ]

 ### --------------------------------------------------------------------------------------------------------------------
Modifié (le) par MoMotte
  • J'aime 1
Lien vers le commentaire
Partager sur d’autres sites

  • 10 months later...

Salut,

 

Je relance ce topic car j'ai acheté une prise TECKIN pilotée par l'appli Smart life de Tuya, pour piloter l'allumage/extinction de mon imprimante avec Octopi.

J'ai bien suivi les tutos et réussi à récupérer l'iD et la Key associée à la prise, dont l'adresse IP est figée au niveau du routeur.  

J'ai installé le plugin tuya SmartPlug avec du mal, obligé d'installer manuellement le module PYAES mais à priori c'est bon maintenant.

La prise fonctionne bien depuis l'appli tuya, mais impossible de la faire fonctionner depuis Octopi.

J'ai bien coché l'option V3.3 maintenant dispo pour le nouveau protocole (j'espère qu'il n'y en a pas un autre!) mais l'icone reste grisé.

Savez-vous si cela peut venir de l'installation manuelle de PYAES? 

J'ai vu qu'il fallait bien couper tuya smart life pour qu'il n'y ai pas de conflits, ce que j'ai fait... Comment vérifier que la prise ne reste pas associée à une autre appli ?

Je ne sais pas non plus comment exploiter les logs d'octopi?

Mon octopi est connecté sur un réseau wifi 5g, et la prise en 2.4... mais elle fonctionne bien depuis mes appareils android qui sont aussi sur le réseau 5g, est-ce un pb?

Y a-t-il une appli windows pour vérifier l'id et la key de la prise?

 

Sinon je crois que pendant les vacances je vais regarder comment faire pour passer par IFTTT, j'ai vu que quelqu'un a réussi a piloter une prise d-link avec!

Lien vers le commentaire
Partager sur d’autres sites

  • 9 months later...

Salut @Fificap, je dispose de prises TECKIN également et je m'arrache les cheveux à les intégrer dans Octoprint. J'ai bien récupéré l'ID et la Key mais pour autant, comme toi, le bouton en forme d'éclair reste grisé. As-tu finalement réussi à trouver une solution ?

Lien vers le commentaire
Partager sur d’autres sites

Il y a 3 heures, Belokan a dit :

Salut @Fificap, je dispose de prises TECKIN également et je m'arrache les cheveux à les intégrer dans Octoprint. J'ai bien récupéré l'ID et la Key mais pour autant, comme toi, le bouton en forme d'éclair reste grisé. As-tu finalement réussi à trouver une solution ?

Oui j'ai trouvé une solution qui fonctionne sans aucun soucis depuis juillet dernier:

Ca peut paraitre long mais ce n'est pas compliqué et d'autre on fait pareil depuis!

 

Bon courage.

  • J'aime 1
Lien vers le commentaire
Partager sur d’autres sites

Merci @Fificap pour ton retour ! 👍

 

J'avais continué mes tests entre temps et j'ai finalement réussi à faire marcher 3 prises sur les 4 dont je dispose. La seule différence que je constate avec cette 4ème prise est que je l'ai mise à jour en v1.21 cet après midi, les 3 autres sont restés dans une version précédente (mais aucune idée laquelle ni comment le vérifier). Je suppose fortement que le problème vienne donc de cette maj, je vais alors laisser ces 3 prises dans leur version actuelle. 

  • J'aime 1
Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

  • YouTube / Les Imprimantes 3D .fr

×
×
  • Créer...