Aller au contenu

Filament ABS

Morreale

Besoin d'aide pour premiere imprimante 3D

Recommended Posts

Bonjour, je me suis lancé dans la construction de la Vulcanus 2 qui commence à prendre forme.

Pour l'électronique je suis parti sur une MKS Sbase 1.2 et un écran MKS TFT 28 1.2

Je me heurte à quelques problèmes :

- je n'arrive pas à faire fonctionner les moteurs à partir du moment où au moins 2 sont branchés : dans ce cas ca fait du bruit et vibre. indépendamment, ils fonctionnent tous chacun piloté par sont driver.

Mon alim est une 12V 30A et les moteurs sont des 17HS4417 1.7A

- je ne trouve pas comment indiquer au firmware de la MKS Sbase que mon imprimante est une core XY

Est ce que vous sauriez d'où ce la peut venir?

Nicolas

 

 

IMG_1455_1.jpg

IMG_1456_1.jpg

IMG_1457_1.jpg

IMG_1458_1.jpg

IMG_1459_1.jpg

Partager ce message


Lien à poster
Partager sur d’autres sites

Ta fabrication semble très propre, bravo.

En complément de lv-esad :

Concernant ta question, les sondes sont t-elles branchées, quel sont tes paramètres Marlin coté température ?

/ The minimal temperature defines the temperature below which the heater will not be enabled It is used
// to check that the wiring to the thermistor is not broken.
// Otherwise this would lead to the heater being powered on all the time.
#define HEATER_0_MINTEMP 24
#define HEATER_1_MINTEMP 24
#define HEATER_2_MINTEMP 24
#define BED_MINTEMP 30

// When temperature exceeds max temp, your heater will be switched off.
// This feature exists to protect your hotend from overheating accidentally, but *NOT* from thermistor short/failure!
// You should use MINTEMP for thermistor short/failure protection.
#define HEATER_0_MAXTEMP 300
#define HEATER_1_MAXTEMP 300
#define HEATER_2_MAXTEMP 300
#define BED_MAXTEMP 150

Si ta tempèrature ambiante n'est pas en adéquation aux paramètres du Marlin rien ne risque de fonctionner.

Partager ce message


Lien à poster
Partager sur d’autres sites

hello.

Comme dit précédemment : réglage des drivers avec le petit potentiomètre dessus.

de plus je te conseil VIVEMENT de ventiler des drivers (sinon ils vont passer en sécurité et surtout un gros risque de les griller ...)

Pour le core XY je laisse les spécialistes répondre =)

 

En tout cas belle réalisation B|

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci pour vos aides.

je n'ai pas trop le temps de regarder mon imprimante là mais dès que je peux je m'y remet.

je ne crois pas que ma carte ait des potars.

c'est celle la : 

Partager ce message


Lien à poster
Partager sur d’autres sites

Alors là ... il semble effectivement que ce ne soit pas possible car effectivement d'après les images y-a pas / semble pas y avoir moyen de réglage.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

@nicephore tu n'y est pas du tout. La MKS Base est une autre carte. Ici c'est la Sbase, un clône de la Smoothieboard qui tourne sous Smoothieware. La MKS Base est basé sur la Mega/Ramps en une seule carte.

@MorrealeJ'espère que ça va t'aider à aller te présenter ;) (c'est très apprécié sur ce forum) :

http://smoothieware.org/hbot

Sur la MKS Sbase le réglage de la tension des drivers se fait par le firmware :

alpha_current                                1.68             # X stepper motor current

++JM

Modifié (le) par J-Max.fr

Partager ce message


Lien à poster
Partager sur d’autres sites

Ha OK SBase ... désolé pour mon ignorance :$

Je viens de regarder ton liens, elle semble super cette carte, mais pas donnée.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Si tu compares avec une Ramps chinoise, peut-être. Mais compare avec le prix des autres cartes 32 bits de meilleure qualité : 
- Smoothieboard X5 : 200€ livrée
- Duet : 120€
- Radds : 70€ (+ arduino Due 20€)
- AZSMZ mini : 55€ (+ drivers 10€)
- Azteeg X3 : 100€ (+ drivers 10€)
- ...

Tu verras qu'elle n'est pas si mal placée que ça cette MKS Sbase ;)

++JM

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui exactement, c'est la réflexion qui m'a amené à la sélectionner pour mon projet.

je n'ai tjs pas eu le temps de réessayer mais dans le précédents tests j'avais déjà essayé de jouer avec les *_current dans le config.txt (qui soit dit en passant est tres pratique pour les mises à jours des paramètres de config)

d'apres vous quelles devraient être mes réglages de courants pour mes différents axes et l'extrudeur?

Partager ce message


Lien à poster
Partager sur d’autres sites

Bah pas grand chose à dire, je m'appelle Nicolas, 35 ans

J'adore l'esprit DIY à la fois pour le résultat qu'on arrive souvent à atteindre avec un un peu d'investissement personnel et la connaissance qu'on en retire.

Met je vois dans cette imprimante à la fois le côté fun d'aboutir ce projet et aussi les perspectives que ca m'ouvrira pour de multiples autres petits délires : console DIY à base de rpi zéro, un bouton domotique à base de esp8266, ...

L'imprimante que j'essaie de monter s'inspire de la vulcanus v2. En fait c'est exactement celle ci niveau mécanique (design des pièces 3D de l'auteur de l'instructable http://m.instructables.com/id/Vulcanus-V2-Reprap-3D-Printer/) mais j'ai sélectionné une autre électronique (mks sbase 1.2 qui est 32bits)

voilà :)

Partager ce message


Lien à poster
Partager sur d’autres sites

Je viens de tester avec *_current = 0.85

si je branche unitairement le moteurs, ils tournent vraiment bien : pas de bruit ni vibration et c'est fluide.

En revanche c'est exactement le même problème dès que j'en branche au moins 2.

pour l'instant je sèche, vais continuer de chercher

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour, je déterre mon sujet que j'avais mis de coté manque de temps.

J'ai sorti le bousin du carton, dépoussiéré l'imprimante et commencé à reprendre ou j'en étais resté en mai 2016...

Je bloque complet et me rends compte que je m’étais peut être attaqué à trop compliqué pour moi. Néanmoins je n'arrive pas à me résoudre à acheter un kit d'imprimante et quel que sera le résultat d’impression de mon montage, j'aimerai le voir s'animer.

J'en suis à :

je ne regarde que la partie électronique avec l'alim -> SBASE 1.2 -> 1 Moteur le tout connecté sur le PC en USB

Dès que j'essaie de piloter le moteur, j'entends un petit bruit, celui ci semble tourner d'un pas (d'ailleurs a ce moment là le ventilateur de l'Alim fait un truc bizarre, comme une chute de tension) , puis plus rien.

Je dispose d'un alternative qu'il faut que je teste : une carte arduino due avec une ramps FD.

Savez vous s'il existe des clubs ou rassemblements région parisienne, dans le 77 où je pourrais trouver une expertise pour me faire avancer?

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant


×