Aller au contenu

Filament ABS

Seuil de démarrage des ventilateurs de pièce


Messages recommandés

Bonjour à tous,

Jusque-là, j'imprimais que du PLA, du coup pour les ventilateurs de pièce (les 2 latéraux) je ne me posais pas de questions : 100% dès la 3ème couche.

Depuis quelques mois j'imprime aussi du PETG : j'avais pas changé la ventilation par rapport au PLA. Sauf que d'après ce que j'ai lu en conseils sur le PETG, il recommandé de baisser la ventilation. Ce que j'ai essayé de faire, mais je fais face aux problèmes suivants :

  • A moins de 75% les ventilateurs ne tournent plus
  • Entre 75% et 80% ils tournent mais de façon irrégulière
  • Mais surtout : impossible de les faire démarrer si la commande est pas à 99%/100%...

Du coup le seuil de démarrage me parait extrêmement élevé. Et même le seuil de mini de rotation... J'ai bien une option dans S3D qui si je la comprend bien permet de démarrer les ventilateurs à 100% avant de réduire la vitesse, mais elle ne fonctionne pas (je vois aucun changement dans le gcode avec cette option activée ou non). Bref, à part régler manuellement la ventilation une fois le print lancé pour la réduire de 100% à 80%, je n'ai pas trop d'autres options.

Mais ce qui me semble vraiment bizarre ce sont les seuils de démarrage et rotation min très élevé que j'ai sur mes ventilateurs. Est-ce que vous avez constaté la même chose ? Ou est-ce que les miens commencent à être fatigués ?

Merci d'avance pour vos retours.

Math

Lien à poster
Partager sur d’autres sites

Hello, ça vient en partit de tes ventilo et en partit de marlin, tout les ventilateurs ne fonctionnent pas de la même façon et Marlin est configurer pour fonctionner avec la majorité dont les tiens ne font pas partie (les miens non plus je te rassure).

De tête car sa fait longtemps que j'ai pas eu à toucher marlin, tu peux subdiviser le signal de gestion des ventilateurs (c'est ce que j'ai fait pour les miens) pour que quand tu fais varier la puissance de 0% à 100% tu ait un vrai contrôle continue du ventilateur.

edit: c'est le paramètre "#define soft_pwm_scale 0" qui permet de faire ça dans configuration.h .

Modifié (le) par Poisson21
Lien à poster
Partager sur d’autres sites

Le souci des ventilateur qu'il n'est pas possible de reguler  vient généralement du fait que ce ne sont plus les originaux de la machine et que les remplaçant ne sont pas à modulation. 

Il  existe un module électronique fabriqué par une membre  du forum qui permet la régulation des ventilateur 

Lien à poster
Partager sur d’autres sites

Salut,

Merci pour vos retours.

Le 16/10/2020 at 00:56, Poisson21 a dit :

Hello, ça vient en partit de tes ventilo et en partit de marlin, tout les ventilateurs ne fonctionnent pas de la même façon et Marlin est configurer pour fonctionner avec la majorité dont les tiens ne font pas partie (les miens non plus je te rassure).

La MicroDelta Rework fonction avec une carte dérivée de la Smoothieboard, il me semble que le firmware n'est pas Marlin (sauf si je me trop). Du coup je ne pense pas que ça soit applicable.

Le 16/10/2020 at 08:00, Titi78 a dit :

Le souci des ventilateur qu'il n'est pas possible de reguler  vient généralement du fait que ce ne sont plus les originaux de la machine et que les remplaçant ne sont pas à modulation. 

Mes ventilateurs sont ceux d'origine de la MicroDelta Rework. Aucune modification dessus, jamais changé depuis l'acquisition de la machine. Donc normalement il devrait être régulés sans problèmes.

Math

Lien à poster
Partager sur d’autres sites

Si ils n'ont jamais tournés c'est peut-être qu'ils sont bloqués par les poussières ou résidus de filament ou que l'axe du ventilateur manque de lubrification.  Sur certains modèles ont peut accéder à l'axe en enlevant l'autocollant.  Un huile très fluide est à utiliser 

Lien à poster
Partager sur d’autres sites

@Math51: les ventilateurs de la mdr démarrent assez tard (50% environ)

Dans le config.txt, dans la section "Switch module for fan control" tu dois avoir un truc dans le style :

Citation

switch.fan.enable                            true             #
switch.fan.input_on_command                  M106             #
switch.fan.input_off_command                 M107             #
switch.fan.output_pin                        2.11             #
switch.fan.output_type                       pwm              # pwm output settable with S parameter in the input_on_comand

switch.fan.max_pwm                         255              # && set max pwm for the pin default is 255

 

Tu peux essayer de rajouter la ligne pour forcer un démarrage au max.

switch.fan_extruder.startup_value               255

Lien à poster
Partager sur d’autres sites
Il y a 3 heures, cmatec a dit :

les ventilateurs de la mdr démarrent assez tard (50% environ)

Salut.

Les miens c'est beaucoup plus tard !

  • Démarrage faut que je soit à au moins 95%, sinon ils démarrent pas
  • A moins de 80% ils tournes mais de façon irrégulière. En dessous de 75% c'est extinction.

Je vais essayer ton astuce, mais je me demande si ils n'ont quand même pas un problème...

Math

Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

  • YouTube / Les Imprimantes 3D .fr

×
×
  • Créer...