Aller au contenu

Filament ABS

- autre - carte arduino mega r3 ramps1.4 lcd 12864


Messages recommandés

bonjours a tous,

j'ai acheter une deuxièmes imprimantes qui ressemble a une pursa i3 avec une carte arduino mega r3 ramps 1.4 , il y avait pas d'écran LCD.

je me suis acheter un écran LCD 12865 pour mettre dessus , l'écran reste allumé et bleu 

je n'y connais rien en arduino quelqu'un pourrais m'aider svp  

merci

Lien à poster
Partager sur d’autres sites
  • fran6p changed the title to carte arduino mega r3 ramps1.4 lcd 12864

Ajouter un écran, c'est bien mais encore faut il que le firmware de la carte mère le gère 😉

Donc passage par une compilation de firmware avec activation dudit écran puis téléversement sur la carte afin d'avoir autre chose qu'un écran bleu.

🙂

Lien à poster
Partager sur d’autres sites

bonjours merci pour ta réponse 

je n'y connais rien en arduino , je trouve le firmware sur le site arduino ?

 ( compilation de firmware avec activation dudit écran puis téléversement sur la carte afin d'avoir autre chose qu'un écran bleu ) ?

Lien à poster
Partager sur d’autres sites
Il y a 17 heures, sarsarote a dit :

je trouve le firmware sur le site arduino ?

Non, le firmware tu le trouveras sur le site de Marlin 😉

Pour ta carte, la version 1.1.9.1 devrait fonctionner. Tu pourras le compiler avec le logiciel Arduino.

Si c'est pour la CTC A8, il n'y a pas d'exemple de configuration. Peut-être que partir sur une base Anet A8 te permettrait de «débroussailler» le paramétrage des fichiers configuration.h et configuration_adv.h.

Dans tous les cas, il faudra que tu connaisses toutes les caractéristiques de ta machine pour saisir les bons paramètres. C'est un beau défi pour un total débutant qui n'a pas peur de mettre les mains dans le cambouis 😉

🙂

  • J'aime 1
Lien à poster
Partager sur d’autres sites

bonjours merci pour ta réponse

oui j'aime relevé des défis et beaucoup bricolé 

j'ai réussis a paramétré un petit peut la carte Arduino maintenant j'ai quelque chose qui s'inscris a l'écran ,  il y a plus ka comme on dit 😅 a paramètre les reste , mais je me suis lancé sur la Discovery easy 200 la , j'imprime les pieces , je vous tiens au courant .

bonne journée

Lien à poster
Partager sur d’autres sites

Dans Marlin, tu actives ton écran en enlevant les // devant "define" :

Citation

// RepRapDiscount FULL GRAPHIC Smart Controller
// http://reprap.org/wiki/RepRapDiscount_Full_Graphic_Smart_Controller
//
#define REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER

Et tu en mets devant ce "define" là pour désactiver l'écran basique :

Citation

// RepRapDiscount Smart Controller.
// http://reprap.org/wiki/RepRapDiscount_Smart_Controller
//
// #define REPRAP_DISCOUNT_SMART_CONTROLLER // 

Lien à poster
Partager sur d’autres sites

Je confirme la solution de Jean Claude. J'ai paramétré Marlin 2.0 avec une Arduino méga associé une RAMP 1.4. Je peux t'envoyé les fichiers de config. Tu peux également t'inspiré de cette vidéo Présentation détaillée du Firmware Marlin V1.1.9 3h00 hyper instructives même si Marlin à déjà évolué entre ta version et la 2.0.

Pour info, j'ai testé avec les pins correspondants entre la Mega et la RAMP 1.4

 

J'ai oublié, j'ai également ajouté du wifi avec un ESP8266 et l'utilisation de ESP3D sur Android (smartphone, tablette)

Lien à poster
Partager sur d’autres sites

bonjour se serais super car je galere pour la carte arduino 

j'ai presque fini d'imprimé ma Discovery easy 200

vous en pensé quoi ?

 

IMG_20210130_170458[1].jpg

IMG_20210130_170350[1].jpg

IMG_20210130_170505[1].jpg

IMG_20210130_170516[1].jpg

Lien à poster
Partager sur d’autres sites

Bonjour,

Je joins un début de configuration qui vous permettra de jouer avec l'écran.

Lisez le message jusqu'au bout avant de flasher votre carte arduino Mega vous risque de griller vos drivers si ce ne sont pas les mêmes que ceux que j'ai configuré le mieux étant de les retirer de la carte.

Les fichiers sont à dézipper puis copier/coller en lieu et place de ceux que vous avez à cet endroit Marlin-bugfix-2.0.x\Marlin.

Ne plugger pas les drivers sur votre RAMP, j'ai configuré avec des A4988 qui ne sont peut être pas ceux que vous avez. Il faudra donc changer pour le modèle que vous avez. J'ai commenté par // A redefinir par SARSAROTE les lignes qui seraient à revoir dans les deux fichiers configuration.h et configuration adv.h

Lorsque vous aurez flasher la mega, le redémarrage se fait dans la foulée et vous devez arriver directement sur l'écran d'information.

Pour accéder au menu, appuyez une fois sur le  bouton rotatif, vous arrive alors sur d'autres menus, je vous laisse explorer mais sachez que j'ai mis une tempo de 5 seconde avant un retour à l'écran de surveillance quelque soit l'endroit où vous êtes dans les menus et sous menu.

Pour activer la carte SD, il faut se rendre sur le menu "Exéc. auto.gcode" et valider par un appui sur le bouton, ensuite descendre un peu plus bas et rentrer dans un autre menu qui permet de lire la carte et les fichiers contenus. Il suffit de sélectionner un fichier et de valider avec appui sur le bouton. S'ouvra alors un autre écran qui demande une validation pour imprimer ou alors abandonner.

Je n'ai pas testé tout ce qui touche au homing, bed level auto et fin de course, ma carte n'étant pas raccordée à une machine. Pour cela le lien de la vidéo est plus que satisfaisante.

Il  a aussi d'autres possibilités que je n'ai pas exploré et à la vue du fichier Marlin-bugfix-2.0.x\Marlin\src\lcd\language il y a de quoi fouiller un peu.

Tout cela reste assez intuitif, il faut juste tester les menus. Vous ne risquer rien faire des tests à vide avec ma config SAUF POUR LES DRIVERS si ce ne sont pas les bons.

Je ne suis pas expert en imprimante 3D, moi c'est plutôt la CNC métal, mais les fonctionnements restent les mêmes à part le coté chauffe et extrusion. Cela ne m'empêche d'admirer votre Discovery easy 200, je suis toujours émerveillé par ce monde de machines qui nous fabriquent toute seule presque tout ce que l'on veut. Je suis cependant toujours très attentif à la rigidité de la machine qui reste toujours le point faible et particulièrement sur les hauteurs. Plus on monte, plus ça bouge même si ce n'est pas visible à l'œil nu. La Discovery easy 200 ayant un bâti en forme de cône avec un inter-assemblage, ça ne devrait pas poser de problèmes, d'autant que les châssis tubulaires sont bien plus résistants, sinon Ducatti n'aurait jamais fait de moto avec cette méthode.

Nous pouvons échanger autrement que par messagerie si vous le souhaitez.

Bon courage.

 

Config RAMP14 EFB.zip

Lien à poster
Partager sur d’autres sites

bonjours 

merci pour ton aide .

je vais trifouiller pour trouvé les bon paramètre qu'il me faut .

merci pour le fichier , je vais regardé a ça , mais pas tout de suite , je vous tiens au courant des évolutions .

pour les échanges il y a pas de soucis , je suis débutant dans l'impression 3D

encore merci a vous 

Lien à poster
Partager sur d’autres sites
Il y a 20 heures, sarsarote a dit :

bonjour se serais super car je galere pour la carte arduino 

j'ai presque fini d'imprimé ma Discovery easy 200

vous en pensé quoi ?

Salut, 

Tu devrais créer un nouveau sujet mais je vais quand même te répondre ici, ton message sera peut être scindé par un modo ^^

Le mélange du gris / noir / jaune fluo c'est pas mon kiff mais on fait souvent avec ce qu'on a ^^

Les 2 pièces du haut sont à l'envers il me semble :
1011422512_IMG_20210130_1704581.jpg.abab359465483313e84b94bf3142c549.thumb.jpg.826efb96f626676076392f184cb2d5ad.jpg

Ta face avant est déformée, c'est un problème courant. Il existe des modèles renforcés mais assures-toi que c'est compatible avec ton 'mod'. 

Tout comme @pascal_lb dans ce topic je te suggère de remplacer tes coupleurs flexibles par ces coupleurs rigides

Je ne suis pas sur du tout de la compatibilité de la tête de la discovery200 avec les chariots de la discoeasy200 : 
- Passage de la courroie ? 
- position du endstop de X

Bon courage 

  

Lien à poster
Partager sur d’autres sites

bonjour

non il ne sont pas déformé ils sont comme ca , j'ai téléchargé le fichier stl compatible et il vein de la meme personne qui la fait 

je mais les coupleur rigide sur le discoesay et les souple sur mon anet A8 ?

Modifié (le) par sarsarote
Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Créer...