Aller au contenu

Filament ABS

32 bits Marlin2 Rumba 32 FAN0 ne marche pas


Messages recommandés

Bonjour

Je viens de changer de carte 8 bits pour une Rumba32 bits.

J'ai un problème avec le ventilateur de refroidissement de matière (buse) connecteur FAN0 qui ne fonctionne pas.

J'ai joint les fichiers config h et adv, il dois y avoir quelque chose de mal paramétré

Je vous remercie pour votre aide

Configuration.h Configuration_adv.h

Lien vers le commentaire
Partager sur d’autres sites

Salutation !

Pas simple, cela peut venir en effet d'un truc a modifier dans le Conf*.h ( cf rechercher "FAN" ...) de marlin mais aussi des attributions des pins de la carte définie ... ( et là il faut trouver un schéma détaillé de cette nouvelle carte ...)

voir d'une inversion de polarité ou d'un mauvais branchement sur la carte ...

Qu'a tu fait comme teste pour déterminer que le connecteur FAN0 ne fonctionne pas ? via le menu ? via des commande G-code ...

contrôle via une impression après les couches initial ?

Des mesure au multimètres ?

A tu bien les même tensions de sortie pour le ventilateur ? 12v contre 24 V ?

...

Lien vers le commentaire
Partager sur d’autres sites

oui j'ai fais les essais, tension 0 a la sortie de la carte

Sur le TFT la commande ventilation ne le déclenche pas non plus

et M106 a partir de simplify idem

Cablage ok , j'avais une rumba+ mks avany et c'est le m^me branchement

Je suis sur qu'il y a un truc avec le mofset qui gère la ventil

Lien vers le commentaire
Partager sur d’autres sites

il y a 7 minutes, Frédéric95 a dit :

Je suis sur qu'il y a un truc avec le mofset qui gère la ventil

Pourquoi pas ...

Mais si l’attribution des PIN a changé pour cette version de carte ... a tu trouvé un schéma avec le détaille pour le port FAN0 ? (nom et numéros de PIN)

Lien vers le commentaire
Partager sur d’autres sites

Le github de Makerbase fournit le mappage des pins de cette carte : https://github.com/makerbase-mks/MKS-RUMBA32/blob/master/hardware/MKS RUMBA32 V1.0_002/MKS RUMBA32 V1.0_002 PIN.pdf

FAN0 -> PC9

FAN1 -> PA8

Dans ton configuration_adv.h tu outrepasses la définitions des pins « #define CONTROLLER_FAN_PIN 8        // Set a custom pin for the controller fan», désactive cette ligne pour que Marlin attribue le bon pin.

🙂

  • Merci ! 1
Lien vers le commentaire
Partager sur d’autres sites

Réactive avec «#define CONTROLLER_FAN_PIN PC9» pour connexion sur FAN0 (ou PA8 si connexion sur FAN1) et relance la compilation.

Les fichiers pins : pins_RUMBA32_MKS.h et pins_RUMBA32_common.h (./marlin/src/pins/stm32f4) effectivement ne contiennent pas le «controller_fan_pin», il doit donc être déclaré explicitement

🙂

Modifié (le) par fran6p
  • Merci ! 1
Lien vers le commentaire
Partager sur d’autres sites

J'ai besoin des 2

Fan1 pin 8 c'est pour les drivers et la tête et Fan0 c'est pour le refroidissement du filament commandé par M106

SI je fais ce que tu dis je n'aurais plus de refroidissement des drivers ?

 

actuellement dès que je déplace un axe le mofset commande le ventilation des drivers, ca marche très bien, rest le problème du ventilateur de buse

Lien vers le commentaire
Partager sur d’autres sites

il y a 16 minutes, Frédéric95 a dit :

SI je fais ce que tu dis je n'aurais plus de refroidissement des drivers ?

Si car le FAN1 (PA8)  qui pilote à la fois la ventilation des pilotes sur la carte et le radiateur est indépendant du refroidissement du filament que tu laisses connecté sur FAN0 (sans déclarer quoi que ce soit pour que Marlin le prenne en charge).

Sur ma CR30 (autre carte mère) je commande trois ventilateurs indépendamment: pilotes sur la carte, refroidissement du radiateur de la tête et refroidissement du filament car j'ai trois emplacements disponibles pour des ventilateurs PWM (et deux qui tournent tout le temps).

Pilotes et radiateur (extrait de mon configuration_adv.h) :

Citation

#define USE_CONTROLLER_FAN
  #define CONTROLLER_FAN_PIN PC1         // Set a custom pin for the controller fan
  #define CONTROLLER_FAN_EDITABLE      // Enable M710 configurable settings
#define E0_AUTO_FAN_PIN PC0

Toi tu veux utiliser le Controller_fan pour refroidir à la fois les pilotes (c'est bien) et le radiateur (c'est moins bien) car si les pilotes sont désactivés, tu n'auras plus de refroidissement du radiateur ce qui risque fortement de conduire à un colmatage de la tête :

Citation

/**
 * Controller Fan
 * To cool down the stepper drivers and MOSFETs.
 *
 * The fan turns on automatically whenever any driver is enabled and turns
 * off (or reduces to idle speed) shortly after drivers are turned off.
 */

en français :

/**
 * Ventilateur du contrôleur
 * Pour refroidir les pilotes pas à pas et les MOSFETs.
 *
 * Le ventilateur s'allume automatiquement dès qu'un pilote est activé et s'éteint (ou réduit à la vitesse de ralenti) peu après la désactivation des pilotes.
 * s'éteint (ou réduit à la vitesse de ralenti) peu de temps après la désactivation des pilotes.
 */

🙂

Lien vers le commentaire
Partager sur d’autres sites

oui c'est pourtant comme ça que c'est paramétré

Et Fan0 non déclaré 

#define USE_CONTROLLER_FAN
#if ENABLED(USE_CONTROLLER_FAN)
  #define CONTROLLER_FAN_PIN 8        // Set a custom pin for the controller fan
  //#define CONTROLLER_FAN_USE_Z_ONLY    // With this option only the Z axis is considered
  //#define CONTROLLER_FAN_IGNORE_Z      // Ignore Z stepper. Useful when stepper timeout is disabled.
  #define CONTROLLERFAN_SPEED_MIN      0 // (0-255) Minimum speed. (If set below this value the fan is turned off.)
  #define CONTROLLERFAN_SPEED_ACTIVE 255 // (0-255) Active speed, used when any motor is enabled
  #define CONTROLLERFAN_SPEED_IDLE     0 // (0-255) Idle speed, used when motors are disabled
  #define CONTROLLERFAN_IDLE_TIME   1000 // (seconds) Extra time to keep the fan running after disabling motors
  //#define CONTROLLER_FAN_EDITABLE      // Enable M710 configurable settings
  #if ENABLED(CONTROLLER_FAN_EDITABLE)
    #define CONTROLLER_FAN_MENU          // Enable the Controller Fan submenu
  #endif
#endif
 
Lien vers le commentaire
Partager sur d’autres sites

Il y a 3 heures, Frédéric95 a dit :

oui c'est pourtant comme ça que c'est paramétré

Et donc ?

Qu-est-ce qui ne fonctionne pas ? Si tu veux pouvoir utiliser le FAN1 la pin à déclarer n'est pas «8» mais d'après le fichier fourni par Makerbase «PA8» 😉

🙂

Lien vers le commentaire
Partager sur d’autres sites

Désolé 😞

Bizarre que ça fonctionne avec 8 et pas PA8 alors que les fichiers sources des «pins» utilisent la dénomination complète : pins_RUMBA32_MKS.h  pins_RUMBA32_common.h

Le refroidissement du filament est bien activé (M106 S255). Sinon pas plus d'idée.

🙂

  • +1 1
Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...