Aller au contenu

Filament ABS

Retour d'expérience sur Octoprint sur un Raspberry PI Zero WH avec la D12


Messages recommandés

Aussitôt arrivé avec mon cordon OTG micro USB qui me manquait, j'ai isolé le 5V et j'ai mis en place mon raccordement sur ce fameux Raspberry Pi Zero WH.
J'ai désactivé la gestion de la webcam sur Octoprint pour mettre toutes les chances de mon coté. La connexion s'établie et je peux contrôler l'imprimante depuis octoprint. 

Je lance une petite impression depuis PrusaSlicer : ca part bien.

Tout se déroule bien de loin, mais alors de près c'est autre chose. Et la pieuvre qui n'est pas contente du tout :

image.thumb.png.37fbf261ccb5330aad7abccdddadee59.png

En effet la pièce dégoulache.

J'ai donc sorti le Raspberry Pi 4 de secours avec la même carte SD (c'est trop cool de pouvoir faire ça) et j'ai relancé la même impression. Et il n'y a pas photo !! En fait si, la voilà :

Dans l'ordre du haut vers le bas : impression depuis la carte SD, impression via Octoprint sur Rasberry Pi 4, impression via Octoprint sur Rasberry Pi Zero WH

dRTYx6AFyw4UaQsDdf41O31Y_kLIBl27hcXh47jEfUCcirefCGz9Ji7Y4kAJHkzBfaT8yIhr9msETOxwD14NS6Hxs_Vg4BzSbzyqNKoAUmw0PTP9YnB1yf34nCnuyPZEXTwXdQVWhBx1-xY9MeDYEmIxD3tMJLK1F21SlC3pZqX3csjbTzO5GsFTPcKHiTUFrA7vY0dscnR0uEZ5LDTESREtIiipQAI-n5ppKvru71IqWSIOxLhEL4bcn8YVyiKVYwJKsLIgOv8yb4M1RyN7MP8qhpgp_fNrgikhR3OFqOWUEPCwjMnmDVPJHIHXLNepyINvddnkn7pGGmXKUlm5yuYWkKZqxzwuHF6UbK3u_CBX-nwgfu6FJdJ_YkcskI1SK20pbN9hMgylbFPV2GnEVIOb3FJ_NK9IgAAM5mtLKPCJPNU-YQu0s5HGpL0iw133NGSMTVvo_0-RRvnjusWobViAfLLStlfqOrpqYLzbXmLWHY-NBosIfIM6BK3WrjBwxqMUH5GAID7loKrPcCFLLG4GaJ8G8vh2UTIaPeoMo0caVs9_iDC25MYnXJsscxo1a-nBO0UtcsrjGDAnl675ee8cGQ9aXuNlPEyUlmKfoLa59yEiu3Ln_gfA-RRKI7OMYySEA_5GB-ZIYm9FKhB3gdN3lZeeGgVuR5kVQoMZbskBjfbQK8f9vn2ooJiXjNmLfLEio-8RCjXklbn1Sc_Q-7V9=w1087-h1240-no?authuser=0

 

Conclusion Octoprint sur Rasberry Pi Zero W (ou WH) ca ne fonctionne pas (sur ma D12 en tout cas) !

Voilà si ca peut aider certains qui tombent sur des vidéos youtube qui te disent que ça marche...

Modifié (le) par cyspak
  • J'aime 2
  • Merci ! 1
Lien à poster
Partager sur d’autres sites
  • cyspak changed the title to Retour d'expérience sur Octoprint sur un Raspberry PI Zero WH vers la D12

C'est pas faute de t'avoir prévenu.

L'auteure d'Octoprint dégage toute responsabilité quand une Pi0 est utilisée.

🙂

La Pi0 reste utilisable avec Klipper et une autre interface que Octoprint.

  • J'aime 1
Lien à poster
Partager sur d’autres sites

Pour information, toute mes imprimantes 3D de production tourne sur PI ZERO et ça fonctionne parfaitement.

Et ça fonctionne tellement bien que je propose une version de mes machine avec PI zéro intégré. 

Et pour info, sur la PRUSA MK3, il y a même un emplacement sur leur carte mère pour mettre un PI ZERO et ça fonctionne très bien aussi.

Donc oui, ça fonctionne, mais sans doute pas sur toute les machines (problème de paramétrage, de principe de connexion, de qualité de carte mère ou de firmware...) 

  • J'aime 1
  • +1 1
Lien à poster
Partager sur d’autres sites
il y a 5 minutes, cyspak a dit :

J'ai donc bien fait de préciser pour la D12 alors 🙂 

Ce n'est pas grave, j'en ferai autre chose de ce Pi Zéro (désolé @chacha007 ).

T’as utilisé le câble usb fourni d’origine ou un autre?

Lien à poster
Partager sur d’autres sites

J'en ai racheté un très court de 25 cm (USB A vers USB B). En mettant le même cordon dans le raspberry pi 4, sans le cordon OTG micro USB forcément, je n'ai plus d'erreur.

Lien à poster
Partager sur d’autres sites
il y a 25 minutes, cyspak a dit :

j'en ferai autre chose de ce Pi Zéro

C'est clair, y a de quoi bien s'amuser avec ces machins 😀

Lien à poster
Partager sur d’autres sites

Salut,

 J'avais un RPI Zero W sur ma Anet A8. Cela fonctionnait plutôt pas mal. Par contre j'alimentait directement en +5V avec le GPIO et un buck dc/dc 12V vers 5V.  Il faut bien veillez à ne pas alimenter ta carte contrôleur en USB mais via l'alim +12V (il y a un cavalier).

PS : Et tu peux utiliser l'UART du RPI Z pour te connecter à ta carte sans USB....

Modifié (le) par raoullevert
  • +1 1
Lien à poster
Partager sur d’autres sites
il y a 7 minutes, raoullevert a dit :

Salut,

 J'avais un RPI Zero W sur ma Anet A8. Cela fonctionnait plutôt pas mal. Par contre j'alimentait directement en +5V avec le GPIO et un buck dc/dc 12V vers 5V.  Il faut bien veillez à ne pas alimenter ta carte contrôleur en USB mais via l'alim +12V (il y a un cavalier).

J'ai isolé l'alimentation de l'USB au niveau du connecteur pour éviter ce soucis.

il y a 14 minutes, Greg² a dit :

Quel firmware? Y’a peut-être des réglages possibles pour la com USB

C'est le firmware perso de @Jonathan06 que j'utilise. Je n'ai pas essayé de faire des modifications de vitesse de transfert USB, mais je doute que ca vienne de cela. J'ai des impressions à faire ce WE je vais rester sur le PI 4 pour l'instant.

Lien à poster
Partager sur d’autres sites
  • cyspak changed the title to Retour d'expérience sur Octoprint sur un Raspberry PI Zero WH avec la D12

De mon côté, j'avais aussi du resend ratio important avec un RPI 3. Cela a été corrigé en changeant le cable USB par un cable de 30cm et blindé et depuis, plus de problème.

J'utilise aussi le firmware Marlin 2.0.x.

Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...