Aller au contenu

Filament ABS

Question technique - Réglage plateau, buse E3D V6 et BL touch


Ktszo

Messages recommandés

Bonjour à tous, 

 

Je vous sollicite aujourd'hui suite à la modification de mon imprimante et à quelques soucis que je rencontre. J'ai décidé d'installer une tête d'impression E3D V6 Hotend sans volcano modification sur mon Ender 3 v2 mais je me heurte à un léger soucis. 

Forcément, la buse étant différente de la buse principale je me retrouve en mode "auto-home" avec un décalage sur l'axe Z, ma buse dépasse du plateau. Auriez vous une solution ? 

De plus, j'ai également installé un Bltouch mais lorsque j'effectue le nivellement du plateau afin de le régler, je me heurte à un bug ou mon nivellement s'interrompt inopinément et fait planter mon imprimante. Auriez vous déjà eu ce problème? 

 

je précise bien que j'ai fais la dernière mise à jour firmware pour la version 4.2.2 présente sur le site de créality. 

 

dans l'attente de vous lire 

 

Cordialement 

Lien vers le commentaire
Partager sur d’autres sites

As-tu renseigné le probe pour le bltouch ?

Comment as-tu branché ton bltouch ?

Tu connectes ton imprimante à un pc et connexion avec un logiciel style pronterface pour les réglages ?

On peut déclarer dans cura un décalage de la buse si nécessaire, cela peut éviter de devoir toucher au firmware.

Lien vers le commentaire
Partager sur d’autres sites

il y a 48 minutes, Idealnight a dit :

As-tu renseigné le probe pour le bltouch ?

Comment as-tu branché ton bltouch ?

Tu connectes ton imprimante à un pc et connexion avec un logiciel style pronterface pour les réglages ?

On peut déclarer dans cura un décalage de la buse si nécessaire, cela peut éviter de devoir toucher au firmware.

le probe ? tu parles de la ligne G29 dans cura ? 

J'ai branché mon BL touch comme montré dans la doc technique. sur la Ender 3 v2 nous avons un connecteur dédié au BL Touch, seul soucis j'ai du inverser des broches car elles ne correspondaient pas à câblage du BL touch. de plus j'ai décâblé le fin de course sur l'axe Y comme montré dans les vidéos. 

Ai-je mal fais quelque chose?

j'ai inversé de mémoire les trois dernière broches ( le IN, +5v et GND n'étaient pas alignés)

Concernant la connexion de l'imprimante au pc je ne vois pas comment tu fais pourrais tu me dire ? 

Lien vers le commentaire
Partager sur d’autres sites

Via un câble USB, c'est généralement ainsi qu'il faut faire pour connecter l'imprimante à un ordinateur 😉

Lien vers le commentaire
Partager sur d’autres sites

il y a 22 minutes, fran6p a dit :

Via un câble USB, c'est généralement ainsi qu'il faut faire pour connecter l'imprimante à un ordinateur 😉

Oui ca d'accord 😉 mais l'intérêt du coup car je fonctionnais par l'intermédiaire de ma carte sd, ca m'apportera quoi de la connecter ? tu connecte via quel port sur l'imprimante ?

Lien vers le commentaire
Partager sur d’autres sites

il y a 9 minutes, Ktszo a dit :

tu connecte via quel port sur l'imprimante ?

N'importe quel port USB devrait fonctionner à la seule condition que le pilote qui gère l'USB de la carte ait été installé pour que la connexion soit reconnue comme un port série (COM). Le pilote dépend évidemment de la carte 😉

Quant à l'utilité, cela permet de piloter l'imprimante à l'aide d'un logiciel (Pronterface (Printrun), Repetier-host, Octoprint, …) et permet également via un terminal intégré à l'un de ces logiciels d'envoyer des commandes G-code à l'imprimante et donc d'avoir le retour de la commande affiché (M503 liste par exemple les données contenues dans l'EEPROM).

On peut évidemment s'en passer mais c'est se priver d'un outil bien pratique; la carte SD ne permet que d'imprimer le gcode d'un fichier enregistré sur cette carte.

🙂

Modifié (le) par fran6p
Lien vers le commentaire
Partager sur d’autres sites

il y a 34 minutes, fran6p a dit :

N'importe quel port USB devrait fonctionner à la seule condition que le pilote qui gère l'USB de la carte ait été installé pour que la connexion soit reconnue comme un port série (COM). Le pilote dépend évidemment de la carte 😉

Quant à l'utilité, cela permet de piloter l'imprimante à l'aide d'un logiciel (Pronterface (Printrun), Repetier-host, Octoprint, …) et permet également via un terminal intégré à l'un de ces logiciels d'envoyer des commandes G-code à l'imprimante et donc d'avoir le retour de la commande affiché (M503 liste par exemple les données contenues dans l'EEPROM).

On peut évidemment s'en passer mais c'est se priver d'un outil bien pratique; la carte SD ne permet que d'imprimer le gcode d'un fichier enregistré sur cette carte.

🙂

Ok Je vois, et ce driver je peux le trouver ou ?

Concernant le Bl Touch pas d'idée d'où cela pourrait venir ce problème ? 

 

Cdlt 

Lien vers le commentaire
Partager sur d’autres sites

Comme @fran6p te l'as expliqué connecter l'imprimante a un pc est fort utile pour pouvoir la paramétrer/régler.

Tu dis avoir déconnecté la fin de course Y ? j'espère que c'est une erreur de frappe et que tu voulais dire Z ?

Il arrive qu'il soit nécessaire d'inverser les fils effectivement mais je pense que tu ne maitrises pas tout a fait la technique pour l'installation d'un bltouch, je me trompe peut-être ?

Le probe on le renseigne dans le firmware, cela permet d'indiquer ou se situe la buse par rapport au bltouch, essentiel afin de centrer la buse puisque le home se fixera sur le bltouch et non sur la buse.

Enfin tu dis: j'ai un bug ; il faudrait en dire plus expliquer, montrer via une vidéo par exemple

Modifié (le) par Idealnight
Lien vers le commentaire
Partager sur d’autres sites

Oui autant pour moi il s'agit de l'axe Z 

J'ai suivis une vidéo explicative, concernant l'inversion des PIN non je pense que j'ai fais ca correctement car j'ai pas de soucis à l'allumage. 

concernant le probe effectivement j'ai pas encore fait cette partie car j'ai pas pu terminer le nivellement de mon bed.

Lien vers le commentaire
Partager sur d’autres sites

@Ktszo

Pense à ajouter le modèle de ton imprimante dans ton profil.

En haut à droite de la page, tu accèdes à ton profil en cliquant sur ton pseudo:

acces_1.thumb.png.06ffa2b12098ec373aac4db42898f5b9.png

Tu choisis la ligne "profil", puis l'option "Modifier le profil":

acces_2.png.912ab58cd55fbb21d012aa220b7edc9d.png    acces_3.png.21e858f3216e12b0adf31be3baecdeda.png

Tu effectues toutes les modifications que tu veux mais surtout la ligne "Imprimantes" que tu complètes:

acces_4.thumb.png.ce87d4f10d2e7669c63a8c4ecdea4842.png

Et tu n'oublies pas de valider en cliquant sur "Enregistrer":

acces_5.png.3e3e2f5b37da166999a1b2edbfe1a7ea.png

il y a 27 minutes, Ktszo a dit :

et ce driver je peux le trouver ou ?

Ça dépend de ton imprimante et de la carte qui y est installée d'où mon rappel pour compléter ton profil 😉. N'ayant pas cette information, cela m'a obligé à remonter à ton premier post où tu l'indiques (Ender3v2, carte v4.2.2). Le pilote à installer pour cette carte est le ch340/341ser : CH341SER.EXE

Ta carte étant la version v4.2.2, connais-tu les pilotes qui y sont soudés ? La lettre écrite au feutre sur le lecteur de carte SD permet de le savoir :

690859445_CrealityV4.2.XBoardDriverCodes.jpg.b72dfab016df25b8501594294fb9cd67.jpg

Pour ton Bltouch, le mieux est de fournir des photos de ton câblage sur la carte 4.2.2 pour être certain que tout est bien connecté comme il faut. Si tu lis / comprends l'anglais, ce site apporte toutes les informations souhaitables sur ce matériel.

🙂

Modifié (le) par fran6p
Lien vers le commentaire
Partager sur d’autres sites

il y a 57 minutes, fran6p a dit :

@Ktszo

Pense à ajouter le modèle de ton imprimante dans ton profil.

En haut à droite de la page, tu accèdes à ton profil en cliquant sur ton pseudo:

acces_1.thumb.png.06ffa2b12098ec373aac4db42898f5b9.png

Tu choisis la ligne "profil", puis l'option "Modifier le profil":

acces_2.png.912ab58cd55fbb21d012aa220b7edc9d.png    acces_3.png.21e858f3216e12b0adf31be3baecdeda.png

Tu effectues toutes les modifications que tu veux mais surtout la ligne "Imprimantes" que tu complètes:

acces_4.thumb.png.ce87d4f10d2e7669c63a8c4ecdea4842.png

Et tu n'oublies pas de valider en cliquant sur "Enregistrer":

acces_5.png.3e3e2f5b37da166999a1b2edbfe1a7ea.png

Ça dépend de ton imprimante et de la carte qui y est installée d'où mon rappel pour compléter ton profil 😉. N'ayant pas cette information, cela m'a obligé à remonter à ton premier post où tu l'indiques (Ender3v2, carte v4.2.2). Le pilote à installer pour cette carte est le ch340/341ser : CH341SER.EXE

Ta carte étant la version v4.2.2, connais-tu les pilotes qui y sont soudés ? La lettre écrite au feutre sur le lecteur de carte SD permet de le savoir :

690859445_CrealityV4.2.XBoardDriverCodes.jpg.b72dfab016df25b8501594294fb9cd67.jpg

Pour ton Bltouch, le mieux est de fournir des photos de ton câblage sur la carte 4.2.2 pour être certain que tout est bien connecté comme il faut. Si tu lis / comprends l'anglais, ce site apporte toutes les informations souhaitables sur ce matériel.

🙂

Profil rempli 🙂 

Ok pour le driver, j'installe ca de suite. 

Pour le BL touch j'ai vérifié le câblage, il est dans les règles, je la glisse dessous. Pour info, (Bleu = GND, Rouge +5V, Jaune, Signal, la fiche du haut très peu de chance de me tromper avec le détrompeur et le sens.

 

Concernant la lettre, j'ai la lettre A 

 

Cdlt 

IMG_6126.jpg

Lien vers le commentaire
Partager sur d’autres sites

Le câblage est correct :

blt-cm-creality-v42x.png.a45b986f7315c6751f3ea9bbf2f4c8e3.png

(le câble bleu est le brun sur l'image ci-dessus). Tu aurais pu «raboter» le détrompeur sur la prise «contacteur de fin de course» (noir/blanc) pour ne pas avoir à forcer pour l'implantation 😉

🙂

Lien vers le commentaire
Partager sur d’autres sites

https://we.tl/t-2ej7NFG4w0

il y a 7 minutes, fran6p a dit :

Le câblage est correct :

blt-cm-creality-v42x.png.a45b986f7315c6751f3ea9bbf2f4c8e3.png

(le câble bleu est le brun sur l'image ci-dessus). Tu aurais pu «raboter» le détrompeur sur la prise «contacteur de fin de course» (noir/blanc) pour ne pas avoir à forcer pour l'implantation 😉

🙂

oui oui le câblage est correct, j'ai mis dans le lien précédent un vidéo du soucis. 

 

Pour info quand j'essaye de connecter l'imprimante en USB ca ne fonctionne pas meme après avoir installé les driver 

Après quelques tentative, échec encore une fois ce soir, on dirait que le moteur de l'axe Y se verrouille.. et empêche la fin de l'auto levelling. Pourtant j'ai vérifié le câblage, tenté d'update le firmware comme la vidéo envoyé mais ca déconne toujours

Lien vers le commentaire
Partager sur d’autres sites

Ton firmware, tu l'as récupéré sur le site creality.com ?

bltouch-firmwares-creality_com.jpg.857fa21e5d48812ddf0db40090e7928a.jpg

Ce fichier compressé comprend trois dossiers suivant que tu as un détecteur de fin de filament ou pas choisir le bon, le seul à ne pas utiliser est celui avec adaptateur écran (méthode utilisée précédemment avec les cartes 8 bits). Autre solution, utiliser le firmware «jyers» mais n'ayant pas de Ender3V2, d'autres utilisateurs l'ayant installé sur leur imprimante devront venir en parler.

Pour la vidéo, désolé mais n'ayant pas accepté les clauses d'utilisation de Wetransfer, je n'ai pas vu celle-ci (il est préférable de mettre cette vidéo en ligne (youtube, peertube, …) et de mettre le lien pour en faciliter la lecture).

🙂

  • Merci ! 1
Lien vers le commentaire
Partager sur d’autres sites

Il y a 3 heures, fran6p a dit :

Ton firmware, tu l'as récupéré sur le site creality.com ?

bltouch-firmwares-creality_com.jpg.857fa21e5d48812ddf0db40090e7928a.jpg

Ce fichier compressé comprend trois dossiers suivant que tu as un détecteur de fin de filament ou pas choisir le bon, le seul à ne pas utiliser est celui avec adaptateur écran (méthode utilisée précédemment avec les cartes 8 bits). Autre solution, utiliser le firmware «jyers» mais n'ayant pas de Ender3V2, d'autres utilisateurs l'ayant installé sur leur imprimante devront venir en parler.

Pour la vidéo, désolé mais n'ayant pas accepté les clauses d'utilisation de Wetransfer, je n'ai pas vu celle-ci (il est préférable de mettre cette vidéo en ligne (youtube, peertube, …) et de mettre le lien pour en faciliter la lecture).

🙂

Bonsoir @Ktszo

J'utilise la version Jyers 3x3 bltouch pour 4.2.2 sur ma Ender3 v2, j'en suis très satisfait.

https://github.com/Jyers/Marlin/releases/tag/v1.3.5.b

en fin de liste tu as les sources pour le Marlin afin de pouvoir le recompiler. (Ce que j'ai fait de façon à pouvoir être capable d'apporter des modifs si nécessaire.

Il me semble qu'avec une tête E3D V6, la thermistance est différente de celle de creality. donc il faudrait que tu compiles toi même Marlin pour apporter les modifs nécessaires.

si le lien de E3D on line est bon https://e3d-online.zendesk.com/hc/en-us/articles/360017968457-Hemera-Creality-Ender-3-V2-Firmware-Bl-touch-

image.thumb.png.6c9344feeba7c5a8d86809bf3fcb17e8.png

 

https://e3d-online.zendesk.com/hc/en-us/articles/360015971538-V6-Marlin-Guide

même chose dans la doc E3d V6.

 Bon regardes cela .

si tu dois compiler un marlin en dehors des indications ci-dessus, il me semble bien que @fran6pas fait un bon tuto.

😀

Modifié (le) par hyoti
correction
Lien vers le commentaire
Partager sur d’autres sites

Il y a 14 heures, hyoti a dit :

Bonsoir @Ktszo

J'utilise la version Jyers 3x3 bltouch pour 4.2.2 sur ma Ender3 v2, j'en suis très satisfait.

https://github.com/Jyers/Marlin/releases/tag/v1.3.5.b

en fin de liste tu as les sources pour le Marlin afin de pouvoir le recompiler. (Ce que j'ai fait de façon à pouvoir être capable d'apporter des modifs si nécessaire.

Il me semble qu'avec une tête E3D V6, la thermistance est différente de celle de creality. donc il faudrait que tu compiles toi même Marlin pour apporter les modifs nécessaires.

si le lien de E3D on line est bon https://e3d-online.zendesk.com/hc/en-us/articles/360017968457-Hemera-Creality-Ender-3-V2-Firmware-Bl-touch-

image.thumb.png.6c9344feeba7c5a8d86809bf3fcb17e8.png

 

https://e3d-online.zendesk.com/hc/en-us/articles/360015971538-V6-Marlin-Guide

même chose dans la doc E3d V6.

 Bon regardes cela .

si tu dois compiler un marlin en dehors des indications ci-dessus, il me semble bien que @fran6pas fait un bon tuto.

😀

Donc Si je comprends bien, 

 

Tu utilises le firmware de Jyers directement comme ca, mais que pour le BL touch. 

Par contre moi avec mon E3D V6 je dois recompiler un nouveau firmware ok mais je dois partir de celui de Jyers ou comme tu disais de celui montré dans le lien 

https://e3d-online.zendesk.com/hc/en-us/articles/360015971538-V6-Marlin-Guide

Lien vers le commentaire
Partager sur d’autres sites

Je me permet de revenir vers vous 

J'ai effectué la mise à jours de firmware avec celui de jyers un peu modifié comme sur les précédents exemples. Cependant, lorsque je tente de faire un mesh, j'ai le la buse qui remonte de 1 cm avec le BLtouch et j'ai aucun levelling qui se fait.

 

De plus, j'ai comme l'impression que ca bloque sur un des axes et ca fait planter l'imprimante

Le 14/10/2021 at 18:41, fran6p a dit :

Ton firmware, tu l'as récupéré sur le site creality.com ?

bltouch-firmwares-creality_com.jpg.857fa21e5d48812ddf0db40090e7928a.jpg

Ce fichier compressé comprend trois dossiers suivant que tu as un détecteur de fin de filament ou pas choisir le bon, le seul à ne pas utiliser est celui avec adaptateur écran (méthode utilisée précédemment avec les cartes 8 bits). Autre solution, utiliser le firmware «jyers» mais n'ayant pas de Ender3V2, d'autres utilisateurs l'ayant installé sur leur imprimante devront venir en parler.

Pour la vidéo, désolé mais n'ayant pas accepté les clauses d'utilisation de Wetransfer, je n'ai pas vu celle-ci (il est préférable de mettre cette vidéo en ligne (youtube, peertube, …) et de mettre le lien pour en faciliter la lecture).

🙂

@fran6p je viens d'essayer de prendre le firmware tout prêt sur créality, mais arrivée en dans le carré supérieur gauche du bed... paaaf ca plante.. comme si mon moteur Z donnait l'ordre de tout stopper. et j'ai plus rien qui repars.. je reste bloqué en position autolevelling et je suis obligé d'éteindre

Lien vers le commentaire
Partager sur d’autres sites

Le 14/10/2021 at 18:41, fran6p a dit :

Ton firmware, tu l'as récupéré sur le site creality.com ?

bltouch-firmwares-creality_com.jpg.857fa21e5d48812ddf0db40090e7928a.jpg

Ce fichier compressé comprend trois dossiers suivant que tu as un détecteur de fin de filament ou pas choisir le bon, le seul à ne pas utiliser est celui avec adaptateur écran (méthode utilisée précédemment avec les cartes 8 bits). Autre solution, utiliser le firmware «jyers» mais n'ayant pas de Ender3V2, d'autres utilisateurs l'ayant installé sur leur imprimante devront venir en parler.

Pour la vidéo, désolé mais n'ayant pas accepté les clauses d'utilisation de Wetransfer, je n'ai pas vu celle-ci (il est préférable de mettre cette vidéo en ligne (youtube, peertube, …) et de mettre le lien pour en faciliter la lecture).

🙂

Merci @fran6p

Je n'avais pas pensé à aller voir dans acessory firmware.

je pensais qu'il y avait tout dans  (bon j'utilise ceux de Jyers) dans le répertoire download pour la ender3v2 (c'est un peu short chez creality !)

image.thumb.png.5a2a8b0b26a3d2ca998908ca3665386f.png

Effectivement certaines versions avaient disparues du répertoire download cet été. !!!

🙂

Lien vers le commentaire
Partager sur d’autres sites

Il y a 9 heures, hyoti a dit :

Merci @fran6p

Je n'avais pas pensé à aller voir dans acessory firmware.

je pensais qu'il y avait tout dans  (bon j'utilise ceux de Jyers) dans le répertoire download pour la ender3v2 (c'est un peu short chez creality !)

image.thumb.png.5a2a8b0b26a3d2ca998908ca3665386f.png

Effectivement certaines versions avaient disparues du répertoire download cet été. !!!

🙂

J'ai pas compris ton commentaire du coup, tu veux dire par la qu'il manque des éléments ? 

Lien vers le commentaire
Partager sur d’autres sites

Il y a 3 heures, Ktszo a dit :

J'ai pas compris ton commentaire du coup, tu veux dire par la qu'il manque des éléments ? 

Je pense qu'ils ont du déplacer certaines versions de firmware pour E3V2 de la section Ender3 v2 vers acessory firmware. voilà je n'avais pas été voir cette rubrique acessory. ( mais sous Jyers donc!)

Question ta hotend E3D v6 c'est une vraie ou un clone, il me semble que le capteur de température  (du corps de chauffe) est différent, cylindre et résistance de la sonde différente. Si tu repris le marlin creality pour BLtouch. comment as tu recompilé le firmware creality pour changer les paramètres de e3d v6 ?, as tu trouvé la source du marlin creality avec Bltouch. 

 En compilation je suis très débutant, la première que j'ai faite à partir des sources marlin de Jyers (visual code studio), je n'avais pas remplacé dans le répertoire Marlin, les fichiers config h et adv avec  ceux mis dans  les template E3V2 (pour moi) 3x3 bltouch avant la compilation. (erreur de débutant). donc le BLtouch n'était pas pris en compte.

Si ta sonde de température du corps de chauffe à d'autres caractéristiques que celle d'origine, il faut que tu recompiles avec les modif avant d'imprimer, car tu as un risque d'être trop froid ou d'avoir des surchauffes fatales ou dangereuses.

D'après ta vidéo le cycle de fonctionnement de ton BLtouch à l'air correct (sauf à la fin), ta buse n'a pas l'air d'avoir bloquée sur le plateau. quand il a un problème de mesure il se met normalement à clignoter rouge. (cela m'arrivait plus souvent avec le firmware creality que le jyers.

Question ce blocage à cet endroit est reproductible ou aléatoire ?

Point dur sur l'axe Z ? cela devrait te le faire à d'autres endroits.

A cet endroit sans faire le leveling, peux tu faire un move Z pour que la buse arrive au contact du plateau (ou papier) sans soucis

Si ok, à partir de ce point regardes en faisant un disable steppers si tu ramènes à la main le tête au centre du plateau (vers position homing) si tu n'aurais pas un écart énorme de planéité (au delà de que peut compenser le BLtouch) ?

🙂

Lien vers le commentaire
Partager sur d’autres sites

il y a 15 minutes, hyoti a dit :

Je pense qu'ils ont du déplacer certaines versions de firmware pour E3V2 de la section Ender3 v2 vers acessory firmware. voilà je n'avais pas été voir cette rubrique acessory. ( mais sous Jyers donc!)

Question ta hotend E3D v6 c'est une vraie ou un clone, il me semble que le capteur de température  (du corps de chauffe) est différent, cylindre et résistance de la sonde différente. Si tu repris le marlin creality pour BLtouch. comment as tu recompilé le firmware creality pour changer les paramètres de e3d v6 ?, as tu trouvé la source du marlin creality avec Bltouch. 

 En compilation je suis très débutant, la première que j'ai faite à partir des sources marlin de Jyers (visual code studio), je n'avais pas remplacé dans le répertoire Marlin, les fichiers config h et adv avec  ceux mis dans  les template E3V2 (pour moi) 3x3 bltouch avant la compilation. (erreur de débutant). donc le BLtouch n'était pas pris en compte.

Si ta sonde de température du corps de chauffe à d'autres caractéristiques que celle d'origine, il faut que tu recompiles avec les modif avant d'imprimer, car tu as un risque d'être trop froid ou d'avoir des surchauffes fatales ou dangereuses.

D'après ta vidéo le cycle de fonctionnement de ton BLtouch à l'air correct (sauf à la fin), ta buse n'a pas l'air d'avoir bloquée sur le plateau. quand il a un problème de mesure il se met normalement à clignoter rouge. (cela m'arrivait plus souvent avec le firmware creality que le jyers.

Question ce blocage à cet endroit est reproductible ou aléatoire ?

Point dur sur l'axe Z ? cela devrait te le faire à d'autres endroits.

A cet endroit sans faire le leveling, peux tu faire un move Z pour que la buse arrive au contact du plateau (ou papier) sans soucis

Si ok, à partir de ce point regardes en faisant un disable steppers si tu ramènes à la main le tête au centre du plateau (vers position homing) si tu n'aurais pas un écart énorme de planéité (au delà de que peut compenser le BLtouch) ?

🙂

Salut 🙂 

merci pour ton commentaire complet. Alors pour reprendre point à point, 

Il s'agit d'une buse officielle E3D V6, montée avec un support Aluminium Klemco et les prints BLTOUCH associés. 

Concernant le Firmware, je prenais la dernière version sur marlin bug fix 2.0 et je remplacais bien les différents fichiers. Pour les prints, j'ai pas testé encore car du coup j'ai des soucis de leveling mais oui j'ai repris le fichier de config E3D V6 et monté la temp à 300°c max et 5° min. 

Pour les points dur, je suis d'accord avec toi, du coup j'ai remonté le fin de course sur l'axe 2 et retiré le BL touch pour vérifier et pendant le HOMING pas de soucis, j'ai remonté le BL touch et la paaf rebelotte mais à différent endroit. Parfois ca déconne même au début du levelling.

J'ai revérifier le levelling manuel en ajustant le plateau au zéro de la nouvelle buse mais même toppo ^^ ca me rend fou 

 

je sais plus trop quoi faire.. j'ai trouvé un tuto de JSTECH, je vais voir si ca peut m'aider voir si j'ai pas un bug caché qui rend dingue.. a voir je pense également que j'avais pas effectué la mise à jours de l'écran.. peut être que ca peut venir de la aussi 

Lien vers le commentaire
Partager sur d’autres sites

Bonjour @Ktszo

Pour la version firmware essaye les versions non bugfixe, ces versions correspondent Alpha ou Beta des logiciels donc en développement en gros avec celle là tu aides à débugge, donc cela corrige certains bugs mais en apporter plein d'autres tant que le stade version stable n'est pas atteint.

question : quand le palpeur (la tige du Bltouch est descendue, tu as bien une petite diode bleu allumée à l'intérieur du BL ? sur la vidéo on ne le voit pas mais elle est de faible intensité, d'ailleurs elle reste allumé tout le temps mais quand la dell rouge est allumée on la devine à peine.

Pour ton bed tu as les ressorts de réglages d'origine ou tu les as changés par des jaunes (ils sont nettement mieux pour réglet et garder la planéité du bed stable.

Pour le DWIN_SET c'est à voir, c'est à faire à partir du lecteur de carte microSD de l'écran, 

tu auras le PID de la résistance du corps de chauffe à refaire si ce n'est fait.

sur le dessus du BLtouch  au milieu tu as une petite vis de réglage (petite clé allen je crois) elle ne doit pas être serrée à fond cela joue sur le déclenchement et les mouvements de la tige du palpeur.

Bon courage cela finira par ce faire.

🙂

Lien vers le commentaire
Partager sur d’autres sites

Petit Update de situation

Après une longue et rude bataille, j'ai partiellement réussi à niveler mon plateau. J'ai dans un premier temps procédé par élimination.

1ère étape:

j'ai tout d'abord décider de retirer les modifications effectuées à l'exception du BLTOUCH sur la mainboard, ce qui impliquait donc l'ajout d'un ventilateur 24V sur la broche (K-FAN 2) qui au final ne tourne pas 🤔- mais on reviendra plus tard sur ce sujet.

J'ai donc pris le firmware de JSTECH, effectué les deux petites modifications pour le Hotends E3DV6 à savoir la ligne HEATERS_SENSORS_Min et MAX respecitvement à 5 et 285 ( sachant que je fais pas un tuning auto des PID), puis j'ai effectué la compilation en 5x5 pour l'intégrer à ma ENDER 3v2 4.2.2MB avec la modification de l'écran. 

Résultat : toujours le même problème le leveling ne se fait pas et l'imprimante plante donc obliger de couper et rallumer. 

2ème étape

Je décide de sortir toutes les modifications effectuées en plus du ventilateur. Cela concerne donc mon capteur de fin de filament de la marque Hotends ( le Dual Guard) installé depuis le début car je me dis peut-être que ca vient de la car il n'est pas reconnu par le firmware et ca fait déconner. Et la MIRRRRRRRRRRRRACLE, j'arrive à faire un leveling complet du bed sans interruption et sans bug (je ne vous cache pas que j'avais quelques gouttes de sueurs dans le dos) 😎

 

Maintenant la question c'est d'une part pourquoi ce capteur n'est pas reconnu alors que l'option est censée être activée. j'ai contacté le vendeur pour qu'il me donne ses lignes de codes à ajouter pour voir si ca vient de la. 

Seconde question, pourquoi mon ventilateur ne tourne pas.. j'ai acheté des ventilateur 24V censés être compatibles avec ma MB et j'ai connecté le ventilateur sur la même broche que ceux de l'ancien hotend.. et la mystère, je vais voir si il n'est pas cramé en tester un autre car j'ai du couper et souder n'ayant pas de connecteur JST (sur le ventilo) - ci dessous la photo des connexions ventilo K-fan 1 et K-fan2.

Si vous avez une idée je suis preneur ..

merci à vous 

image.thumb.png.8dbb4cb7fd2112299281ad1ce96414a3.png

Lien vers le commentaire
Partager sur d’autres sites

Bonjour @Ktszo

Bon tu as bien avancé pour le BLtouch, pour le Dualguard c'est étrange puisque tu n'as rien changé côté hard, tu verras ce que te répondra Hotends.fr.

Dans le menu control> advanced settings : as tu bien la case "filament sensor" de cochée ?

Pour ton ventilateur, je suppose que c'est celui qui sert à refoidir le filament lors du print, le ventilo turbine sur ta vidéo.

celui-ci ne fonctionne normalement pas à l'allumage de l'imprimante. (préchauffage oui et selon les gcodes du slicer)

As-tu essayé dans le menu Control> Temperature : Fan . mettre la valeur à 255, il devrait se mettre à tourner, ou alors mauvaise connexion, inversion de fil, HS.

PS sur la vidéo on voit à l'extérieur l'étiquette de ton ventilo turbine, si c'est normalisé en comparant à mon 40x20 turbofan de chez hotends, il devrait aspirer l'air à souffler sur le filament (buse) du côté du radiateur de ton E3D V6 donc de l'air plus chaud. (A retourner si c'est le cas)

Bon s'il ne tourne pas du tout, pas d'importance !!! 😡

Dans le firmware tu as modifié les les lignes Heaters sensor max et min, as tu  bien modifié les caractéristiques de la sonde du corps de chauffe à mettre en type 0 5, tu n'en parles pas, c'est important pour la suite.

🙂

Lien vers le commentaire
Partager sur d’autres sites

HALLLLLLLLLLELLLLLLLLLLLUJAH !!!

Je suis heureux de vous annoncer que non, je ne suis pas Papa, mais que j'ai réussi à enfin paramétrer cette merde ^^ 

Bon dernière mise à jour, effectivement @hyoti tu avais raison, la case n'était pas cochée et donc vu que le capteur était câblé baaah cela foutait la merde et l'imprimante plantait.

Concernant les ventilateurs qui ne fonctionnaient pas effectivement, c'était des ventilo PWM qui se déclenchent à un certains seuil. du coup avec Pronterface et la commande M106S255, j'ai pu vérifier le bon fonctionnement des ventilateurs.🤣🤣

Côté Firmware, j'ai bien suivis le protocole énoncé par E3DV6 donc ca devrait le faire et je pense à terme, je ferai le tuning de PID ! Mais là, je la touche plus, ça fonctionne.  

Pour faire simple, j'ai utilisé les firmwares BLTOUCH de Jstech mais je pense que n'importe lequel des firmware même compilé par ses propres soins depuis marlin ca fait le café. Par contre faire bien attention à débrancher tous les sensors ou autre ajout déjà mis en places pour éviter de galérer (je m'adresse surtout aux novices comme moi  ). De plus, j'ai effectué les modifications pour le montage de l'E3DV6 et j'ai également équipé un tubing capricorn pour que ça "glisse" mieux. 🤣🤣🤣

Je tenais à tous vous remercier pour votre aide, je ne sais pas s'il faut clôturer ou non le post, mais voilà merci a tous. Maintenant, place aux réglages plus précis grâce à ce Hotends, et à tous ces paramètres🤣🤣

Bien à vous les printers !!

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
  • Sur cette page :   0 membre est en ligne

    • Aucun utilisateur enregistré regarde cette page.
  • YouTube / Les Imprimantes 3D .fr

×
×
  • Créer...