Aller au contenu

Filament ABS

slayer-fr

Gcode START et END

Recommended Posts

étant donné que cette question reviens régulièrement,  voici les Gcodes de démarrage et de fin , il y a mieux, il y a pire , mais ils font  très bien leur boulot sur l'anycubic :P

 

voici un gcode de démarrage 

 

;Sliced at: {day} {date} {time}
;Basic settings: Layer height: {layer_height} Walls: {wall_thickness} Fill: {fill_density}
;Print time: {print_time}
;Filament used: {filament_amount}m {filament_weight}g
;Filament cost: {filament_cost}
;M190 S{print_bed_temperature} ;Uncomment to add your own bed temperature line
;M109 S{print_temperature} ;Uncomment to add your own temperature line
G21        ;metric values
G90        ;absolute positioning
M82        ;set extruder to absolute mode
M107       ;start with the fan off
G28 X0 Y0  ;move X/Y to min endstops
G28 Z0     ;move Z to min endstops
G1 Z15.0 F{travel_speed} ;move the platform down 15mm
G92 E0                  ;zero the extruded length
G1 F200 E10             ;extrude 10mm of feed stock
G92 E0                  ;zero the extruded length again
G1 F{travel_speed};Put printing message on LCD screen
M117 Printing...
G5 ;

 

 

Gcode de fin

 

;End GCode
M104 S0                     ;extruder heater off
M140 S0                     ;heated bed heater off (if you have it)
G91                                    ;relative positioning
G1 E-1 F300                            ;retract the filament a bit before lifting the nozzle to release some of the pressure
G1 Z+1.5 E-5 X-20 Y-20 F{travel_speed} ;move Z up a bit and retract filament even more
G28 X0 Y0                             ;move X/Y to min endstops so the head is out of the way
G0 Y180 F3500       ; Ramene le plateau en avant afin de decoller la piece tranquillouuuuuuuu
M84                         ;steppers off
G90                         ;absolute positioning
M107 ;
;{profile_string}

 

 

si un modo peu passé par la est épinglé ce poste ça serais cool

Modifié (le) par slayer-fr
  • Merci ! 4

Partager ce message


Lien à poster
Partager sur d’autres sites

Ha merci c'est vraie que le sujet revient souvent xD

Partager ce message


Lien à poster
Partager sur d’autres sites

vu que les modos , sont un peu fainéant (ne me frapper pas je ne suis pas responsable de ce post , mon compte à du être piraté :P

j'ai re posté ce post dans Tutoriels et améliorations afin qu' il ne sois pas enterré 

donc si une une feignasse de modos :ph34r: passe par la , ben il peu faire le ménage .

bon ok , je sort tous seul  :D avant de me faire tapé dessus pas un modos :(

Partager ce message


Lien à poster
Partager sur d’autres sites

quand tu parle ménage c'est suppression de ton poste ou de ton compte  O.o.

Aller je sort aussi xD 

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 29 minutes, Maxtor a dit :

quand tu parle ménage c'est suppression de ton poste ou de ton compte  O.o.

Aller je sort aussi xD

arrête de donné de mauvaise idée au modo :15_yum:

Partager ce message


Lien à poster
Partager sur d’autres sites

@slayer-frJ'ai bien mis ton gcode start et end dans simplify3D mais en éditant le gcode qu'il m'a créé de mon fichier test voici ce que j'ai :

;Sliced at: {day} {date} {time}
;Basic settings: Layer height: {layer_height} Walls: {wall_thickness} Fill: {fill_density}
;Print time: {print_time}
;Filament used: {filament_amount}m {filament_weight}g
;Filament cost: {filament_cost}

Il devrait pourtant y avoir marqué la date et les autres valeurs, là c'est indiqué {day} {date} {time}...

Au redémarrage de S3D j'ai eu une erreur de XML qui apparaissait à l'écran, et je me suis rendu compte que c'est cette ligne qui cause l'erreur pour le gcode de fin :

G0 Y180 F3500 ; Ramène le plateau en avant afin de décoller la piece tranquillouuuuuuuu

En l'enlevant plus d'erreur, du coup je l'ai remise et cette fois j'ai enlevé les accents et là plus d'erreur

Tu as une idée ?

Modifié (le) par dani31

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour les accents, ça sent le commentaire rajouté pour le post. :ph34r:

Pour les autres lignes, le point virgule indique que c'est un commentaire, du coup je ne sais pas si S3D va chercher à remplacer des variables dans les commentaires.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 40 minutes, Kachidoki a dit :

Pour les accents, ça sent le commentaire rajouté pour le post. :ph34r:

@dani31

oui , j'ai rajouté cette ligne sur le post afin d'expliqué à quoi servais cette ligne , mais sinplify3D  n'aime pas les accent dans les commentaires

j'ai édité le code , comme ça plus de soucis 

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 6 minutes, dani31 a dit :

@slayer-fr @Kachidoki Merci à vous deux.

Tu as oublié d'enlever un accent sur la ligne (décoller) :D

oops , qu'elle étourdi , l'erreur est corrigé

j'ai choppé une bonne crève alors j'ai pas trop les yeux en face des trou en ce moment :/

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai toujours un problème avec simplify3d, une fois le gcode du fichier ouvert avec le bloc notes, il ne me remplace pas les valeurs :

G1 Z15.0 F{travel_speed} ;move the platform down 15mm

Travel speed devrait être remplacé, même en mettant un espace entre le F et le { c'est pareil.

D'autres dans ce cas avec S3D ?

En attendant j'ai laissé le gcode par défaut qui lui fonctionne bien

Modifié (le) par dani31

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Je viens juste pour faire un petit rappelle le poste dans la partit.

Le 07/08/2017 at 19:45, slayer-fr a dit :

Tutoriels et améliorations

 :18_kissing_heart:

Modifié (le) par Maxtor

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant


×