Aller au contenu

Filament ABS

Baltringue

Anet A8 et BlTouch

Messages recommandés

Hello tout le monde, 

J'ai acheté il y a quelque temps un BLTouch et j'avais quelques questions concernant le câblage

Dans cette vidéo https://www.youtube.com/watch?v=gNIv8wmh_dA il ne s'attarde pas vraiment sur le câblage. Mes questions sont les suivantes : 

  • Le branchement doit être fait sur le pin 27 du LCD, du coup quelle en est la conséquence sur le LCD ? 
  • Quel est le moyen le plus "propre" pour piquer ce pin ? Le même que dans la vidéo ? 

Merci d'avance pour vos réponses ;)

Partager ce message


Lien à poster
Partager sur d’autres sites

Ca sera peut-être plus clair ici : https://docs.google.com/document/d/1WL0vmngiRu5Pc4DncJPtxj2xO4xew_d3AjuySBFz0TI/mobilebasic

J'ai fait ce montage comme vu dans la vidéo sans qu'il n'y ait de conséquence (visible) sur le fonctionnement du LCD. Attention de bien vérifier la validité des connexions sous peine de risquer quelques problèmes lors de l'auto-levelling. Personnellement, j'ai soudé quand je pouvais plutôt que de mettre des connecteurs.

Philippe

Partager ce message


Lien à poster
Partager sur d’autres sites

Il n'y a aucune conséquence pour le fonctionnement du lcd, puisqu'il ne l'utilise pas.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 21 minutes, Philippe Chaumont a dit :

Ca sera peut-être plus clair ici : https://docs.google.com/document/d/1WL0vmngiRu5Pc4DncJPtxj2xO4xew_d3AjuySBFz0TI/mobilebasic

J'ai fait ce montage comme vu dans la vidéo sans qu'il n'y ait de conséquence (visible) sur le fonctionnement du LCD. Attention de bien vérifier la validité des connexions sous peine de risquer quelques problèmes lors de l'auto-levelling. Personnellement, j'ai soudé quand je pouvais plutôt que de mettre des connecteurs.

Philippe

Oui j'avais déjà lu ça mais finalement la méthode qui concerne le cable LCD de l'anet A6 est également applicable à l'anet a8 ? 

Je pense que je vais également opter pour cette solution beaucoup plus simple et rapide, merci

@Maeke Merci pour l'info :) 

Modifié (le) par Baltringue

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour l'A6 (ou plutôt l'écran de l'A6), c'est le pin 29, pas le 27.

Machines avec l'écran à 5 boutons: pin 27.

Machines avec l'écran à molette: pin 29 (y compris l'A8 si on lui a mis un écran de A6)

Modifié (le) par Maeke

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est exact, le pin unique sur la platine marqué "Signal" doit être raccordé sur la nappe LCD.

Sur la 2ème version aussi. D'ailleurs on ne peut pas faire autrement sur les CM Anet

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui, la carte Anet est assez limitée, et la changer peut-être une bonne idée, MAIS, Anet a utilisé un câblage très spécifique et tu seras obligé de tout refaire si tu changes la carte.

Partager ce message


Lien à poster
Partager sur d’autres sites

Et voilà BLTouch installé et fonctionnel, seul petit défaut c'est qu'il vibre pas mal lors de l'impression donc ça rajoute un léger bruit 

Si vous avez des astuces je suis preneur 

Modifié (le) par Baltringue

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon désolé du triple post mais c'est pour un autre soucis que je viens 

J'ai suivit l'installation du BL touch https://docs.google.com/document/d/1WL0vmngiRu5Pc4DncJPtxj2xO4xew_d3AjuySBFz0TI/mobilebasic 

Je règle avec la feuille le Z0, je valide et enregistre. Pour finir j'ajoute la fonction dans Cura dans le Gcode pour lancer un auto-leveling (cf code)

G21 ;metric values
G90 ;absolute positioning
M82 ;set extruder to absolute mode
M107 ;start with the fan off
G28 X0 Y0 ;move X/Y to min endstops
G28 Z0 ;move Z to min endstops
G29 ; auto leveling
G1 Z15.0 F9000 ;move the platform down 15mm
G92 E0 ;zero the extruded length
G1 F200 E3 ;extrude 3mm of feed stock
G92 E0 ;zero the extruded length again
G1 F9000
;Put printing message on LCD screen
M117 Printing...

Le problème est le suivant, quand je lance une impression, les 3 points par axes sont check mais quand l'imprimante s'apprête à déposer la première couche de filament, la tête est légèrement trop haute, elle est pas au Z0 que j'ai pu définir avant 

 IMG_20180605_193840.thumb.jpg.f22333118cc60b1dd1c085490dfa9223.jpg 

J'aimerai donc savoir pourquoi :)

Merci d'avance 

Partager ce message


Lien à poster
Partager sur d’autres sites

si je te demandes ligne par ligne c'est pour pouvoir vérifier, en plus la doc Marlin est peut-être périmée.

Partager ce message


Lien à poster
Partager sur d’autres sites

Je l'ai pas de tête donc forcément je vais te faire un copier coller du doc, je suis en train de tout réinstaller (firmware et bltouch) on va voir ce que ça donne 

J'ai imprimé ce support de BL Touch (https://www.thingiverse.com/thing:2915878) mais les lignes de code dans la description me paraissent bizarre

LEFT_PROBE_BED_POSITION 15 + X_PROBE_OFFSET_FROM_EXTRUDER
FRONT_PROBE_BED_POSITION 15 + Y_PROBE_OFFSET_FROM_EXTRUDER
Modifié (le) par Baltringue

Partager ce message


Lien à poster
Partager sur d’autres sites

Vérifies ton câblage, et penses que le pin 27 c'est uniquement pour les imprimantes qui ont le lcd Anet a 5 boutons, pour celle qui ont le lcd Anet à molette (y compris A8 modifiée) c'est le pin 29

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×