Aller au contenu

Filament ABS

sbouloc

Octopi et pi camera

Messages recommandés

Bonjour à tous.

Avant de flasher Marlin sur ma CR-10 S j'ai voulu finir sa config d'octopi et faire quelques tests, histoire de ne pas accumuler les difficultés. Je n'ai pas du attendre longtemps avant d'en rencontrer:

1- je n'arrive pas à faire fonctionner ma camera pi.

J'ai changé le cable hier, elle avait fonctionné pendant un moment, du moins elle était détectée mais aucun streaming dans octoprint. Aujourd'hui plus rien, elle n'est meme plus détectée. Notez qu'elle est bien configurée dans raspi-config.
 

pi@octopi:/root/bin $ vcgencmd get_camera
supported=1 detected=0

Du coup j'ai branché une webcam Logitech et cela a fonctionné du 1er coup. Donc Octoprint n'est pas responsable. Auriez-vous des recommandations pour faire fonctionner cette pi camera?

2- J'ai effectué quelques impressions (Boutons de réglage de plateau, porte-outils, cube de calibration...) et je trouvais les impressions assez réussies avec des réglages standards. Mon cube de 40 mm faisait 40,1mm au final. Ensuite j'ai voulu imprimer un bras de support pour ma camera pi (https://www.thingiverse.com/thing:2594210). Le bras principal a été imprimé sur la hauteur, avec des supports à 0,2 avec 30% de remplissage. L'impression semblait bien se dérouler jusqu'a la moitié de la hauteur. Là, les couches étaient plus espacées (sur env 1cm de hauteur), rendant la pièce inutilisable. Sauriez-vous d'ou peut provenir ce problème.

Merci.

IMG_0284.jpg.c0d80f4bec3566edaf4a810d17fde7e5.jpg

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour dommage ! Jolie impression.. 

Concernant la Pi camera je suis comme toi les 2 que je possède ne fonctionnent plus ! Pourquoi 🙄

Concernant tes pièces :

-Défauts de ton filament à cet endroit là? 

 

-Un de tes moteurs qui chauffe ? 

Moi je serai toi je referais un essai, surtout, n'imprime pas toutes les pièces en même temps !! 

Une par une 😉

Modifié (le) par papa50
  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

@sbouloc

Moi z'aussi je dépucelle l'utilisation de la caméra. Je n'ai pas de PiCam mais une vieille Logitech qui jusqu'à hier marchait bien

Ce matin, a veut rien savoir, c'est les mystères de la formatique.

Pour ton anomalie sur le bras de caméra, j'ai déjà eu le gag : c'était pasque le filament avait été monté/démonté et l'extrémité lâche avait passé sous une spire de la bobine, faisant une sorte de noeud qui de temps en temps freinait le débit.

Evidemment ça se produisait que quand j'avais le dos tourné.

Depuis je fais très gaffe à ce que les spires de filament soient parfaitement libres avant de commencer

Partager ce message


Lien à poster
Partager sur d’autres sites

Moi j'ai également une caméra PI. Elle a 2 défauts majeurs:

1) Le clip qui maintient le cable sur la caméra est de mauvaise qualité. Si le câble bouge d'un demi millimètre: plus d'image. Essaye peut-être de le débrancher/ rebrancher.

2) L'objectif, minuscule, est lui aussi clipsé sur le PCB de la caméra... et bien sûr le clips ne tient pas correctement non plus. Il faut bien appuyer dessus pour que le contact se fasse sinon pas d'image non plus. 

Mis à part ca, la qualité d'image de cette caméra est plutot étonnante, je trouve.

Modifié (le) par Lecoyote
  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 14 heures, Lecoyote a dit :

1) Le clip qui maintient le cable sur la caméra est de mauvaise qualité. Si le câble bouge d'un demi millimètre: plus d'image. Essaye peut-être de le débrancher/ rebrancher.

2) L'objectif, minuscule, est lui aussi clipsé sur le PCB de la caméra... et bien sûr le clips ne tient pas correctement non plus. Il faut bien appuyer dessus pour que le contact se fasse sinon pas d'image non plus. 

C'est étonnant.. Tu as quelle version du RPI et modèle de picam ?

J'ai un Pi 3 Modèle B et Pi 3 Modèle B + et la picam Raspberry Pi v2.1 8 MP 1080p, le tout officiel et je n'ai pas été ennuyé par ce genre de problème 😕 

Pourtant mes RPI et picam était bien sollicités niveaux vibrations.. Surement un problème de nappe, non ?

De même pour l'objectif sur lequel j'ai utilisé, de nombreuse fois, l'outil pour régler le focus.

Perso, le seul truc que je peux reprocher à la picam c'est cette foutu nappe plate...

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Entièrement d'accord avec @shagoy, elle est vraiment pénible cette nappe.

Jamais eu de problèmes non plus avec les différentes caméra que je possède (première génération 5Mégapixels et la V2 8Mégapixels originales et plusieurs copies chinoises y compris en version vision nocturne). La seule caméra qui m'ait posé quelques soucis ces la version noIR avec ses DELs qui demandent elles du courant pour fonctionner et une nappe pas trop longue (au-delà de 60 centimètres mon image était zébrée de rayures). L'alimentation surtout sur les Pi3 doit être à minima de 2,5A et plus si les ports USB sont utilisés.

Pour ceux qui ne connaitraient pas encore et qui sont fluent in english, les différents numéros du magazine MagPI sont disponibles gratuitement en PDF ici .

L'avant dernier numéro ou celui d'avant parle longuement d'Octoprint.

Partager ce message


Lien à poster
Partager sur d’autres sites

je viens de recevoir une nouvelle nappe ainsi qu'une alimentation de 3A:

pi@octopi:~ $ vcgencmd get_camera
supported=1 detected=1


Elle est donc bien détectée et reconnu à présent. Mais je n'ai tjrs aucune image dans octoprint. Elle est également sur enable dans raspi-config.
QQ1 pourrait m'éclairer stp?
Merci.

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai suivi ce tutoriel : 

pi@octopi:~/mjpg-streamer/mjpg-streamer-experimental $ ./mjpg_streamer -i "./input_raspicam.so -fps 20" -o "./output_http.so" 
MJPG Streamer Version: git rev: 821c330ea6bbb5fbed98d48e00aac156e923161b
 i: fps.............: 20
 i: resolution........: 640 x 480
 i: camera parameters..............:

Sharpness 0, Contrast 0, Brightness 50
Saturation 0, ISO 0, Video Stabilisation No, Exposure compensation 0
Exposure Mode 'auto', AWB Mode 'auto', Image Effect 'none'
Metering Mode 'average', Colour Effect Enabled No with U = 128, V = 128
Rotation 0, hflip No, vflip No
ROI x 0.000000, y 0.000000, w 1.000000 h 1.000000
 o: www-folder-path......: disabled
 o: HTTP TCP port........: 8080
 o: HTTP Listen Address..: (null)
 o: username:password....: disabled
 o: commands.............: enabled
 i: Starting Camera
Encoder Buffer Size 81920

Toujours rien dans octoprint après un reboot.

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai pas la solution là de suite à ton pb mais as tu testé un autre tuto déjà ?

Perso j'envisage de suivre celui d'heliox

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour @sbouloc

 Comment as-tu installé Octoprint? Mini-raspbian puis ajout des différents composants logiciels ou à partir de la distribution Octopi (méthode recommandée par la mainteneuse d'Octoprint).

Chez moi, c'était à partir d'Octopi. Différence notable: pas besoin de compiler mjpg-streamer puisque le mainteneur d'Octopi réalise tout le travail. Donc dans le dossier mjpg-streamer-experimental, sur ma distribution il n'y a rien, tout est dans le dossier parent mjpg-streamer.

Pour ton cas, je pense à un problème de chemin d'accès. Octoprint ne sait pas où trouver ce dont il a besoin.

Contenu du dossier /home/pi

pi@octopi:~ $ ls -a
.              build          OctoPiPanel        .profile          .viminfo
..             .cache         .octoprint         .python-eggs
.bash_history  klipper        OctoPrint          rpi-fbcp
.bash_logout   klippy-env     oprint             scripts
.bashrc        mjpg-streamer  .oracle_jre_usage  .selected_editor

Contenu du dossier mjpg-streamer:

pi@octopi:~ $ ls -a mjpg-streamer/
.               input_http.so               mjpg_streamer.h  start.sh
..              input_raspicam.so           output_file.so   TODO
_build          input_uvc.so                output_http.so   utils.c
cmake           LICENSE                     output_rtsp.so   utils.h
CMakeLists.txt  Makefile                    output_udp.so    www
.git            mjpg_streamer               plugins
.gitignore      mjpg_streamer.c             README.md
input_file.so   mjpg-streamer-experimental  scripts

Contenu de mjpg-streamer-experimental:

pi@octopi:~ $ ls -a mjpg-streamer/mjpg-streamer-experimental/
.  ..

Le processus mjpg-streamer est-il actif?

pi@octopi:~ $ ps aux|grep mjpg
pi         828  0.4  0.2  99252  2420 ?        Sl   juin02  63:28 ./mjpg_streamer -o output_http.so -w ./www -i input_raspicam.so -fps 10 -vs -awb flash -ex auto -quality 100 -usestills

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour @fran6p

J'ai fais une installation octopi, mais la camera ne marchait pas dès le début. J'ai donc essayé cette méthode pour y remédier.

Voici mon output
 

pi@octopi:~ $ ps aux|grep mjpg
pi        3323  0.0  0.0   4644   584 pts/0    S+   08:18   0:00 grep --color=auto mjpg

@Phil67 J'ai regardé le tutoriel d'Héliox, mais dans son cas tout fonctionnait dès le départ, sans succès pour moi 🙄

 

EDIT:

Avec tous ces dossier jpeg qui traînaient dans tout les sens, j'ai fini par réinstaller octopi. Après avoir ajouté la caméra dans raspi-config voici ce que j'ai:

pi@octopi:~ $ vcgencmd get_camera
supported=1 detected=1

pi@octopi:~ $ ps aux|grep mjpg
pi         431  1.4  0.1  80844  1716 ?        Sl   12:57   0:05 ./mjpg_streamer -o output_http.so -w ./www-octopi -n -i input_raspicam.so -fps 10
pi         792  0.0  0.0   5896   564 pts/0    S+   13:03   0:00 grep --color=auto mjp

Mais toujours impossible de voir une image dans Octoprint. Meme la commande raspistill ne donne rien

pi@octopi:~ $ raspistill -o image.jpg
mmal: mmal_vc_component_enable: failed to enable component: ENOSPC
mmal: camera component couldn't be enabled
mmal: main: Failed to create camera component
mmal: Failed to run camera app. Please check for firmware updates

Je precise que j'ai fait update, upgrade et reboot au préalable.

Toute suggestion sera la bienvenue.

Merci

Modifié (le) par sbouloc
Complément d'info

Partager ce message


Lien à poster
Partager sur d’autres sites

Alors là, je sèche.

Dans les paramètres d'Octoprint (l'accès Web) concernant la section Webcam tu as bien les paramètres comme sur la copie écran suivante:

1496038949_Parametres-Webcam_CrealityCR10OctoPrint.thumb.png.270e928f1fad5243e1be404c7dd9a8b8.png

Ta ligne de commande retournée via le ps aux indique bien que mjpeg-streamer est lancé. vcgencmd reconnait bien celle-ci. Donc on va tester autre chose.

Que contient ton fichier octopi.txt dans /boot

pi@octopi:~ $ cat /boot/octopi.txt
### Configure whether to automatically resize the SD on first boot
#
# Available options are:
# - yes: perform resize
# - no: don't perform resize
perform_resize="yes"

### Configure which camera to use
#
# Available options are:
# - auto: tries first usb webcam, if that's not available tries raspi cam
# - usb: only tries usb webcam
# - raspi: only tries raspi cam
#
# Defaults to auto
#
#camera="auto"

### Additional options to supply to MJPG Streamer for the USB camera
#
# See https://github.com/foosel/OctoPrint/wiki/MJPG-Streamer-configuration
# for available options
#
# Defaults to a resolution of 640x480 px and a framerate of 10 fps
#
#camera_usb_options="-r 640x480 -f 10"

### Additional webcam devices known to cause problems with -f
#
# Apparently there a some devices out there that with the current
# mjpg_streamer release do not support the -f parameter (for specifying
# the capturing framerate) and will just refuse to output an image if it
# is supplied.
#
# The webcam daemon will detect those devices by their USB Vendor and Product
# ID and remove the -f parameter from the options provided to mjpg_streamer.
#
# By default, this is done for the following devices:
#   Logitech C170 (046d:082b)
#
# Using the following option it is possible to add additional devices. If
# your webcam happens to show above symptoms, try determining your cam's
# vendor and product id via lsusb, activating the line below by removing # and
# adding it as shown examplatory.
#
# If this fixes your problem, please report it back so we can include the device
# out of the box.
#additional_brokenfps_usb_devices=("046d:082b" "aabb:ccdd")

### additional options to supply to MJPG Streamer for the RasPi Cam
#
# See https://github.com/foosel/OctoPrint/wiki/MJPG-Streamer-configuration
# for available options
#
# Defaults to 10fps
#
#camera_raspi_options="-fps 10"
#camera_raspi_options="fps 10 -vs -awb auto -ex auto -quality 100"
camera_raspi_options="-fps 10 -vs -awb flash -ex auto -quality 100 -usestills"

Normalement si tu ne l'as pas modifié, la ligne à utiliser pour une caméra pi est celle ci : camera_raspi_options="-fps 10" (décommente la (enlève les dièse)) puis le plus simple est de rebooter (pas vraiment nécessaire, on peut aussi relancer le service webcamd (situé dans /root/bin) via service webcamd restart. Pour que le flux vidéo soit visible, il est indispensable que le service webcamd soit démarré. On peut le consulter en dehors d'Octoprint via un navigateur (Firefox de préférence!) via http://ip-de-ton-pi-sur-ton-reseau-local/webcam/?action=stream

pi@octopi:~ $ cat /etc/default/webcamd
# Configuration for /etc/init.d/webcamd

# Daemon
DAEMON=/root/bin/webcamd

# Log file to use
LOG=/var/log/webcamd.log

# User to run under
USER=pi

# Should we run at startup?
ENABLED=1

Que donne la commande:

pi@octopi:~ $ ps aux |grep webcamd|grep -v grep
pi         732  0.0  0.3   5364  2952 ?        S    juin02   0:00 /bin/bash /root/bin/webcamd

Le fichier journal est dans /var/log/webcamd.log

pi@octopi:~ $ tail /var/log/webcamd.log
100 frames captured in 8.936383 seconds (11.190210 fps)
100 frames captured in 8.941310 seconds (11.184044 fps)
100 frames captured in 8.936397 seconds (11.190192 fps)
100 frames captured in 8.935759 seconds (11.190991 fps)
100 frames captured in 8.945958 seconds (11.178232 fps)
100 frames captured in 8.937781 seconds (11.188460 fps)
100 frames captured in 8.942708 seconds (11.182295 fps)
100 frames captured in 8.941918 seconds (11.183283 fps)
100 frames captured in 8.936804 seconds (11.189683 fps)
100 frames captured in 8.937102 seconds (11.189309 fps)

As-tu la possibilité de tester une autre camera pi (entourage, club, copain,...) car là j'en perd mon latin (plus pratiqué depuis le bac en 1977 😉 .

Si tout fonctionnait tu devrais avoir une belle copie comme celle-ci (je compatis et espère que d'autres auront des idées pour te dépanner).

1592900864_VueWebcam-CrealityCR10OctoPrint.png.f93c8ba52cae102334959f0cf2840971.png

 

Pour tester si mjpg-streamer fonctionne bien, tu peux aussi via le navigateur en saisissant l'adresse de ton pi et le port 8080 arriver sur la page suivante:

http://ip-pi:8080

MJPG-streamer.thumb.png.95f9d42e27ed63bc2fb1ea96dee51e84.png

Modifié (le) par fran6p
complément information

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 18 heures, sbouloc a dit :

Avec tous ces dossier jpeg qui traînaient dans tout les sens, j'ai fini par réinstaller octopi. Après avoir ajouté la caméra dans raspi-config voici ce que j'ai:


pi@octopi:~ $ vcgencmd get_camera
supported=1 detected=1

pi@octopi:~ $ ps aux|grep mjpg
pi         431  1.4  0.1  80844  1716 ?        Sl   12:57   0:05 ./mjpg_streamer -o output_http.so -w ./www-octopi -n -i input_raspicam.so -fps 10
pi         792  0.0  0.0   5896   564 pts/0    S+   13:03   0:00 grep --color=auto mjp

 

Tu parles d'une webcam logitech dans ton premier post, non ? Si oui, dans ton process et sauf erreur, tu charges la librairie pour une picam (Via input_raspicam.so). Le probleme se situe peut-être de là (?).

Modifié (le) par ShagoY

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour @ShagoY

Non, ce qu'il cherche à faire fonctionner c'est bien une CamPi; comme il n'y arrivait pas (à la faire fonctionner!) il a testé une Logitech pour s'assurer que ce n'était pas un problème lié à Octoprint et ça fonctionnait mais pas sa CamPi (après il ne précise pas laquelle c'est: la V1, la V2, une noIR, une copie chinoise ou une originale)... Je penche de + et + vers un problème matériel; s'il avait mal connecté la nappe (en l'inversant), elle ne serait pas reconnue or elle l'est...

Partager ce message


Lien à poster
Partager sur d’autres sites

@fran6p 

Mes paramètres octoprints sont semblables à ton screenshot.

Voici le contenu de mon octopi.txt:
 

### Configure which camera to use
#
# Available options are:
# - auto: tries first usb webcam, if that's not available tries raspi cam
# - usb: only tries usb webcam
# - raspi: only tries raspi cam
#
# Defaults to auto
#
#camera="auto"

### Additional options to supply to MJPG Streamer for the USB camera
#
# See https://github.com/foosel/OctoPrint/wiki/MJPG-Streamer-configuration
# for available options
#
# Defaults to a resolution of 640x480 px and a framerate of 10 fps
#
#camera_usb_options="-r 640x480 -f 10"

### Additional webcam devices known to cause problems with -f
#
# Apparently there a some devices out there that with the current
# mjpg_streamer release do not support the -f parameter (for specifying
# the capturing framerate) and will just refuse to output an image if it
# is supplied.
#
# The webcam daemon will detect those devices by their USB Vendor and Product
# ID and remove the -f parameter from the options provided to mjpg_streamer.
#
# By default, this is done for the following devices:
#   Logitech C170 (046d:082b)
#   GEMBIRD (1908:2310)
#   Genius F100 (0458:708c)
#   Cubeternet GL-UPC822 UVC WebCam (1e4e:0102)
#
# Using the following option it is possible to add additional devices. If
# your webcam happens to show above symptoms, try determining your cam's
# vendor and product id via lsusb, activating the line below by removing # and
# adding it, e.g. for two broken cameras "aabb:ccdd" and "aabb:eeff"
#
#   additional_brokenfps_usb_devices=("aabb:ccdd" "aabb:eeff")
#
# If this fixes your problem, please report it back so we can include the device
# out of the box: https://github.com/guysoft/OctoPi/issues
#
#additional_brokenfps_usb_devices=()

### Additional options to supply to MJPG Streamer for the RasPi Cam
#
# See https://github.com/foosel/OctoPrint/wiki/MJPG-Streamer-configuration
# for available options
#
# Defaults to 10fps
#
#camera_raspi_options="-fps 10"
camera_raspi_options="-fps 10 -vs -awb flash -ex auto -quality 100 -usestills"

### Configuration of camera HTTP output
#
# Usually you should NOT need to change this at all! Only touch if you
# know what you are doing and what the parameters mean.
#
# Below settings are used in the mjpg-streamer call like this:
#
#   -o "output_http.so -w $camera_http_webroot $camera_http_options"
#
# Current working directory is the mjpg-streamer base directory.
#
#camera_http_webroot="./www-octopi"
#camera_http_options="-n"

J'y ai rajouté la ligne 
camera_raspi_options="-fps 10 -vs -awb flash -ex auto -quality 100 -usestills"
qui n'y figurait pas. J'ai relancé webcams et même rebooté.

Retour de ma commande:

pi@octopi:~ $ ps aux |grep webcamd|grep -v grep
pi         401  0.0  0.3   6856  2940 ?        S    07:45   0:00 /bin/bash /root/bin/webcamd
pi@octopi:~ $ tail /var/log/webcamd.log
Metering Mode 'average', Colour Effect Enabled No with U = 128, V = 128
Rotation 0, hflip No, vflip No
ROI x 0.000000, y 0.000000, w 1.000000 h 1.000000
 o: www-folder-path......: ./www-octopi/
 o: HTTP TCP port........: 8080
 o: HTTP Listen Address..: (null)
 o: username:password....: disabled
 o: commands.............: disabled
 i: Starting Camera
Encoder Buffer Size 81920

Malheureusement, pas d'autre camera pi dispo dans mon entourage.

http://octopi.local:8080/ me retourne une page blanche avec 

Snapshot

Refresh the page to refresh the snapshot
Snapshot

Stream
Stream

 

Je suspectait une défaillance matériel au début, j'ai donc commandé une autre caméra qui devrait arriver d'ici 1 semaine 🙄

@ShagoY
La caméra utilisée est une Raspberry Pi NoIR V2 officielle. Comme l'a fait remarqué @fran6p j'avais utilisé une logitech pour tester uniquement et elle a fonctionné. J'attends une autre caméra car je soupçonne également que ma camera Pi est défectueuse. Mais importer ce matériel est tellement lent d'ici.

En tt cas, merci pour votre aide, ça me permet de replonger dans du Linux après plus de 20 ans 😒. J'attends de régler ce problème avant de me lancer dans l'upgrade du firmware avec Th3d car j'ai un EZABL en route également.

Si vous avez d'autres suggestions n'hésitez pas.

Modifié (le) par sbouloc

Partager ce message


Lien à poster
Partager sur d’autres sites

Tiens nous au courant quand tu auras reçu la nouvelle caméra.

Sur ma machine, c'est une noIR avec ses deux DELs infra en version copie chinoise. Elle fonctionne bien à la seule condition de ne pas mettre une nappe de plus 40 cm (avec une de 60 cm j'avais des vidéos zébrées) et d'adjoindre au pi une grosse alimentation (une 3A).

De mémoire (j'ai encore dans un tiroir mon premier Pi, celui avec une carte SD (pas micro) et deux ports USB et il fonctionne toujours mais je n'en ai plus l'utilité. Les première versions (les 5Megapixels) étaient assez sensibles à l'électricité statique !

Partager ce message


Lien à poster
Partager sur d’autres sites

Je viens de recevoir la 2nd pi NoIR V2. Branchée sur une nappe de 60cm, elle a démarré du 1er coup. Du coup l’autre a fait un vol planné direct dans la poubelle.

A ma grande surprise il y avait un EZABL dans le même colis. Je ne pensait pas les recevoir aussi vite. Je me suis donc enfin lancé dans l’upgrade du firmware TH3D. Et la je dois dire que c’est presque passé comme une lettre à la poste. Je dis « presque » pcq malgré un processus des plus simple au niveau config (3 lignes à décommenter dans configuration.h) et l’upload par câble USB super rapide, ça a finit  par planter car mon ordi n’arrivait pas à bien communiquer avec l’imprimante. Gros coup de flip. Je me retrouve avec un écran tout bleu (celui de l’imprimante) et octoprint qui n’arrive pas à se connecter. Je consulte donc mon ami Google qui m’explique que dans certain cas, c’est du au câble USB. Coup de bol, j’en ai un qui traine dans le coin. Une fois branché, je relance l’upload et au bout de 40 secondes le vois le logo TH3D apparaître sur l’ecran de l’imprimante   Halleluia! Dieu est grand! Je redoutait de le retrouver avec une brique. 

Du coup demain, je m’occuperai de monter et tester l’EZABL. S’en suivra l’impression d’un bon fang. 

Merci encore pour votre aide @fran6p et @ShagoY

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×