Aller au contenu

Filament ABS

Double

[Delta] Création maison [Problème paramétrages]

Messages recommandés

Salut,

 

Je suis Double, j'ai 24 ans et je n'y connais rien du tout en impression 3D mais en faisans quelques recherches et de réflexion sur les imprimantes j'ai réussi à en crée une, plus ou moins a base de récupération.

J'ai fini de la monté, je n'es aucuns plans, tout a été réaliser au fur et a mesure par rapport au pièces que je trouvais..

Donc ma petite Delta sera piloté par une arduino et une ramps 1.4.

Mais maintenant je bloque, je n'arrive pas du tout a faire tout le paramétrages/calibration, ... pour pouvoir faire mes premiers essais 😟

 

Quelqu'un aurai-t-il la gentillesse de m'aider, des tutos ou autres sur marlin, les paramétrages, calibration et le tout sur une delta ?

Je n’arrête pas de chercher sur internet, j'en trouve, j'essaie de suivre les tutos mais a chaque fois y a des choses qui changent, ou sa ne fait pas du tout comme dans les tutoriels, et les trois quart des tutoriels qui existent c'est que pour les cartésiennes..

 

Photo 1

Photo 2

Photo 3

Photo 4

 

D'avance, merci énormément.

Cordialement 

Partager ce message


Lien à poster
Partager sur d’autres sites

Wow je suis très impressionné.

Ça ressemble un peu à ce que j'ai envie de faire à base de bouts de ficelle et de tringles à rideaux >>>>

....Faut que je m'y remette, d'ailleurs.

D'abord on voit pas bien, esque tu as mis 3 endstops en haut de ta structure ?

Et dans Marlin, esque tu as bien précisé que ça serait une Delta, avec toutes les cotes des bras ?

Partager ce message


Lien à poster
Partager sur d’autres sites
youtube drone débutant

Salut,

 

Merci de ton aide 😃

Oui en haut sur chaque axe, j'ai mit un endstops.

En fait, sa fait un moment que je n'avais plus du tout toucher mon imprimante(coté paramétrages m'avait flingué la tête..), donc j'ai encore des fichiers marlin sur mon pc, mais le quel était celui de l'imprimante je ne sais plus du tout, du coup je voudrais repartir depuis zéro avec un fichier vierge. Mais quel version de marlin prendre ?

 

PS: Vais lire ton sujet, je pense que je peut apprendre d'avantages de choses 🙂

 

Merci.

 

EDIT : J'ai télécharger la dernière version de marlin, et pour mettre en mode delta je dois utiliser un des fichier exemple delta, mais je sais pas le quel prendre, il y en a plusieurs :

- Anycubic

- FLSUN

- generic

- Hatchbox_Alpha

- kossel_mini

- kossel_pro

- kossel_xl

Modifié (le) par Double

Partager ce message


Lien à poster
Partager sur d’autres sites

salut 🙂

J'ai fait un tuto sur la calibration pour mon modèle (dans le spoiler tous en bas du premier message). Pour la fichier de config tu prend celui de n'importe quel delta et tu l’édit en fonction de ce que tu a besoin/dispose. D'ailleurs je vois pas de capteur pour l'autoleveling et c'est presque impossible a bien régler sans.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bravo, beau bricolage, mais là ce gente d'attache, ça frise un peu le ridicule à mon avis quant on voit la jolie conception du reste.

190302043621964689.jpg.02b0b0cf90f1dedb76dd4d909b8a42c6.jpg

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

 

Merciàa vous tous.

Oui, effectivement mon bricolage d'attache(une merde) c'est juste histoire de quand sa fonctionnera, j'ai l'intention en premier de lui d'imprimer 3 petit chariots et de remplacer mes équerres et fil de cuivre.

 

Nenex, je vais voir ton tutoriel, et oui effectivement je n'est pas de capteur autoleveling, je n'en est pas acheter car je sais pas trop comment sa fonctionne ni ou le mettre sur mon effecteur :s donc pour le moment je voudrais essayer sans, après si je n'y arrive vraiment pas j'en commanderais un. Merci.

 

J'ai paramétrer un peut mon fichier config.h, j'ai fait quelques petits essais(histoire de voir si sa fonctionne), j'ai juste un petit problème, quand j'ai un axe beaucoup plus bas qu'un autre, au moment de faire un origine ban le premier axe niquel, le deuxième niquel et après arriver au dernier(celui un peu plus bas que les autres axes), ban au moment qu'il accélère pour atteindre le capteur, il débraille, s’arrête et tout est planté. J'ai essayer de faire sa sur un autre axe au lieu du dernier, j'ai le même problème avec tous les axes.. Je pense que sa devrai venir au niveau des accélérations/vitesse ou autres mais je ne sais pas trop lequel des paramètres modifier ?

 

Merci 🙂

Partager ce message


Lien à poster
Partager sur d’autres sites

L'accélération max par défaut est de 3000mm/s2

=> ligne 626 (encore le numéro de sécu de stitch)

https://github.com/MarlinFirmware/Marlin/blob/1.1.x/Marlin/Configuration.h

et un peu plus haut, le max_feedrate:

/**
* Default Max Feed Rate (mm/s)
* Override with M203
* X, Y, Z, E0 [, E1[, E2[, E3[, E4]]]]

*/

#define DEFAULT_MAX_FEEDRATE { 300, 300, 5, 25 }

 
/**
* Default Max Acceleration (change/s) change = mm/s
* (Maximum start speed for accelerated moves)
* Override with M201
* X, Y, Z, E0 [, E1[, E2[, E3[, E4]]]]
*/

#define DEFAULT_MAX_ACCELERATION { 3000, 3000, 100, 10000 }

Pour une delta, les valeurs doivent être identiques pour X,Y et Z donc plutôt

#define DEFAULT_MAX_FEEDRATE { 200,200, 200, 25 }

#define DEFAULT_MAX_ACCELERATION { 2000, 2000, 2000, 10000 }

pour calmer un peu les mouvements

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut a tous,

 

Merci de ton aide, j'ai pu modifier mes vitesses, sa va beaucoup mieux mais des fois quand j'ai un axe trop vers la droite(ou gauche, .., un exemple) et je demande un homing ban sa cale et sa plante encore mais beaucoup moins. En gros les trois chariots montent des que un chariot touche un capteur tout s’arrête, puis un par un descend et remonte(jusque la normal), sauf que par exemple, si j'ai un chariot plus bas qu'un autre, au moment que c'est a son tour de toucher le capteur, ban comme il se retrouve encore loin, il veux allez vite et la sa plante ... 😕

Sauf quand j'ai mon effecteur pile a centre, la j'ai jamais de problème bizarre 😕

 

Du coup j'ai paramétrer un peu aussi mon extrudeur, et j'ai voulu faire des petits essais pour voir se que sa donnais, photo en dessous (à gauche première pièce et droite dernière).

Donc ban j'ai pu améliorer un peu les choses mais bon c'est pas du tout encore sa, quelqu'un aurais des petits conseils ou autres pour m'aider un peu, pour avoir au moins quelque chose de potable 🙂

 

IMG_20190322_173854.jpg

Modifié (le) par Double

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est étrange ce comportement tout de même.

Tu as bien chaque endstop du haut connecté aux X Max, Y Max et Z Max?

Je te cherche le paramétrage de la vitesse de homing:

(celui-ci est en minute: donc si tu part sur une vitesse soft, on peut dire 40mm/s*60s

vers la ligne 1150:

#define HOMING_FEEDRATE_XY (40*60)

#define HOMING_FEEDRATE_Z (40*60)

vers les lignes 790 du Configuration.h

// Feedrate (mm/m) for the first approach when double-probing (MULTIPLE_PROBING == 2)
#define Z_PROBE_SPEED_FAST HOMING_FEEDRATE_Z
 
// Feedrate (mm/m) for the "accurate" probe of each point

#define Z_PROBE_SPEED_SLOW (Z_PROBE_SPEED_FAST / 2)

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 21/03/2019 at 16:01, Double a dit :

.. /.. je n'ai pas de capteur autoleveling, je n'en ai pas acheté car je sais pas trop comment ça fonctionne ni ou le mettre sur mon effecteur

Sur une Delta, le plus simple semble être le captage piézoélectrique, on place 3 pastilles sensibles au choc sous le bed et on vient directement taper avec la buse sur le verre, pas d'offset à trouver, c'est très séduisant.

Ce genre, là >>>

Partager ce message


Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.


  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...