Aller au contenu

Filament ABS

Coordonées de l'imprimante fausse


Baarbiche

Messages recommandés

Bonjour,

Bon, je suis un débutant en informatique et encore plus particulièrement dans l'impression 3D. J'ai acheté une Micro Delta Originale que j'ai monté, etc.

Après la résolution de quelques soucis, me voilà coincer. Les coordonnées X,Y et Z sont faux et quand j'utilise le bouton Home de repeter-host, la tête d'impression vient s'écraser lamentablement sur le sol. J'ai essayé de bidouiller les fichiers EEPROM mais je ne suis arrivé à rien.

Quelqu'un a déjà eu le même soucis ? Ou a une piste ?

Merci d'avance.

Modifié (le) par Baarbiche
Lien vers le commentaire
Partager sur d’autres sites

Salut @Baarbiche,

 

il y a une heure, Baarbiche a dit :

Les coordonnées X,Y et Z sont faux

Qu'est ce qui te permet de dire qu'elles sont fausses ?

 

il y a une heure, Baarbiche a dit :

la tête d'impression vient s'écraser lamentablement sur le sol

C'est à dire ?

Elle se décroche de l'imprimante et elle tombe ?

Elle vient percuter la surface d'impression ?

 

il y a une heure, Baarbiche a dit :

J'ai essayé de bidouiller les fichiers EEPROM

Aie, et qu'as tu fait au juste ?

 

il y a une heure, Baarbiche a dit :

Quelqu'un a déjà eu le même soucis ? Ou a une piste ?

En recherchant parmi les multiples messages du forum, tu pourrais éventuellement trouver réponse à cette question (et probablement la solution à ton problème).

 

🙂

Lien vers le commentaire
Partager sur d’autres sites

Alors tout d'abord merci pour la réponse aussi rapide, 

Il y a 5 heures, Yo' a dit :

Qu'est ce qui te permet de dire qu'elles sont fausses ?

Pour X et Y, je n'en suis pas sur mais pour le Z, il est à 0 alors que la tête d'impression est quasiment en bas de l'imprimante. Et elle ne peux pas remonter par commande manuelle au dessus de celui là.

Il y a 5 heures, Yo' a dit :

C'est à dire ?

Elle se décroche de l'imprimante et elle tombe ?

Elle vient percuter la surface d'impression ?

Oui, elle vient s'écraser sur la surface d'impression exactement comme si elle cherchait à aller plus bas.

Pour les fichiers EEPROM, rien de méchant j'ai essayé de modifier manuellement les valeurs max de Z ect mais j'ai tout annuler quand j'ai vu que ça ne fonctionnait pas.

Il y a 5 heures, Yo' a dit :

En recherchant parmi les multiples messages du forum, tu pourrais éventuellement trouver réponse à cette question (et probablement la solution à ton problème).

Justement, je n'ai rien trouvé comme aide en ligne qui correspond à mon problème. Ensuite, j'ai peut-être mal cherché car je n'arrive pas à formuler exactement ma problématique.

Lien vers le commentaire
Partager sur d’autres sites

Bon,  @Baarbiche.....

Apparemment tu n'as pas pris garde à ça :

Il y a 6 heures, slayer-fr a dit :

.. /.. Bon , Bonjour

Tu devrais.....

Bon, pour apporter une idée....

Il y a 6 heures, Baarbiche a dit :

.. /.. quand j'utilise le bouton Home de repeter-host, la tête d'impression vient s'écraser lamentablement sur le sol

Sur une Delta, à ce que j'en sais, le Home se trouve tout en haut de la structure, d'ailleurs il doit y avoir 3 fins de course, là haut....

Donc si la tête se précipite vers le bas, ça pourrait indiquer que tes moteurs tournent à l'envers.

Regarde si tu peux inverser les connecteurs, sinon ça se trouve dans Marlin

Modifié (le) par Jean-Claude Garnier
Lien vers le commentaire
Partager sur d’autres sites

J’ai pensé au début à ça, mais je me suis rendu compte que quand j’utlise la fonction de mouvement manuel, la buse se déplace dans le bon sens.

Modifié (le) par Baarbiche
Lien vers le commentaire
Partager sur d’autres sites

Bonjour @Baarbiche,

D'après ta description le "home" via repetier host cause le problème, mais le home sur l'imprimante elle même cause-t-il le même problème ?

Que se passe-t-il si tu essaie de calibrer la hauteur en z ?

Le "home" d'une delta est bien en haut, mais la coordonnée 0 se trouve au niveau du plateau. C'est d'ailleurs pour ça qu'il y a une option sur l'imprimante pour régler cette hauteur, pour que le 0 se trouve tout juste au dessus du plateau, et ainsi avoir la meilleure première couche possible. Lorsque la tête monte la coordonnée en z augmente (comme sur n'importe quelle imprimante) jusqu'à atteindre les fin de course

Lien vers le commentaire
Partager sur d’autres sites

Salut,

Il y a 8 heures, BastienX8 a dit :

D'après ta description le "home" via repetier host cause le problème, mais le home sur l'imprimante elle même cause-t-il le même problème ?

Je ne vois pas exactement de quoi tu parles...

Il y a 8 heures, BastienX8 a dit :

Que se passe-t-il si tu essaie de calibrer la hauteur en z ?

Peut importe ce que je donne comme valeur en Z dans le EEPROM, l'imprimante ira toujours chercher sous la zone d'impression en s'écrasant.

J'ai même fait le test d'inverser le contrôle de direction pour l'axe Z mais ça ne lui a fait ni chaud ni froid

Il y a 2 heures, trotro a dit :

Vérifie le branchement des 12 cavaliers sur la carte Teensylu

Ils sont tous bien mis.

Lien vers le commentaire
Partager sur d’autres sites

il y a 54 minutes, Baarbiche a dit :

Je ne sais pas si cela a un rapport, mais quand je connecte mon imprimante à repeter-host, le message suivant apparaît dans les logs: "No start signal detected - forcing start"

je ne pense pas, j'ai le même message lorsque je connecte mon imprimante.

Lien vers le commentaire
Partager sur d’autres sites

Lorsque je parle de l'imprimante elle même, je veut dire sans passer par un ordi, directement sur le lcd.

Quand je démarre l'imprimante et que je lui demande un "retour origine" dans le menu "préparer" (sur le lcd), la valeur Z s'actualise et indique environ 208mm. Si je veut descendre jusqu'au plateau il faut donc que je demande de descendre de 208mm en Z (donc -208) avant d'atteindre le "0". Par contre si mon 0 est réglé trop bas la tête atteindra le plateau avant d'avoir atteint 0. 

Dans tous les cas lorsqu'on demande un "home" à l'imprimante (via le lcd ou l'ordi c'est pareil), les 3 moteurs doivent monter jusqu'à atteindre les fin de course. Si j'augmente la valeur en Z (en contrôle manuel), les 3 moteurs doivent monter. Si je diminue la valeur en Z les moteurs descendent. Et non l'inverse !

J'essaie d'être le plus clair possible 🙂 

Lien vers le commentaire
Partager sur d’autres sites

il y a 18 minutes, BastienX8 a dit :

Lorsque je parle de l'imprimante elle même, je veut dire sans passer par un ordi, directement sur le lcd.

C'est bien ce que je pensais avoir compris mais voilà le soucis, mon imprimante 3D n'est pas équipé d'écran !

Lien vers le commentaire
Partager sur d’autres sites

il y a 21 minutes, BastienX8 a dit :

Dans tous les cas lorsqu'on demande un "home" à l'imprimante (via le lcd ou l'ordi c'est pareil), les 3 moteurs doivent monter jusqu'à atteindre les fin de course. Si j'augmente la valeur en Z (en contrôle manuel), les 3 moteurs doivent monter. Si je diminue la valeur en Z les moteurs descendent. Et non l'inverse !

J'ai regardé et même quand j'inverse la direction de l'axe Z dans les paramètres de repeter-host, quand je diminue la valeur de Z, le chariot monte et inversement. J'imagine que je n'ai pas inverser le sens au bon endroit.

Lien vers le commentaire
Partager sur d’autres sites

Au moins on a trouvé le problème : ton axe z fonctionne à l'envers. Le problème ne viens pas de Repetier mais de l'imprimante, car le retour à l'origine est géré par la carte mère (le logiciel ou l'écran envoie juste la commande "G28" pour demander un retour origine, et la carte mère se charge du reste). 2 possibilités : soit le firmware de l'imprimante inverse les moteurs (mais je ne vois pas comment c'est possible puisque c'est le même pour tout le monde), soit tes moteurs sont branchés à l'envers (je ne connais pas assez bien le circuit électrique pour savoir à quel endroit on peut les inverser). Mais on devrait pouvoir les inverser dans le firmware

Lien vers le commentaire
Partager sur d’autres sites

J'ai essayé de réinstaller les firmware de l’imprimante et j'ai trouvé un truc étrange (c'est peut-être rien) le port COM de mon imprimante est COM3, mais quand je la met en mode programmation pour installer le firmware, elle s'appelle COM4.

Lien vers le commentaire
Partager sur d’autres sites

il y a 31 minutes, Baarbiche a dit :

.. /.. j'ai trouvé un truc étrange (c'est peut-être rien)

En effet, c'est rien. Suivant sur quel porc USB tu la branches, il peut devenir COM3 ou COM4

image.png.88d8bafec6235e5afd69f37b4d816c1e.png

Dans Marlin, ça se trouve là :

image.png.db17fde2f6bfd0976eeb476ffd8d7256.png

Mais pour pouvoir mieux t'aider, il faudrait que tu nous en dises un peu plus sur ton équipement, et sur l'état de tes connaissances en termes de firmouère....

Modifié (le) par Jean-Claude Garnier
Lien vers le commentaire
Partager sur d’autres sites

Révélation

La Micro Delta Rework (> MDR) fonctionne avec smoothieware (fonctionnement différent de Marlin), et comme elle n'est pas à coté de mon ordi je ne l'utilise jamais en USB.

Le plus simple (selon moi) c'est de sortir la carte sd interne de l'imprimante, la brancher sur l'ordi, effacer tout ce qu'il y a dessus puis copier le firmware disponible sur le site (https://www.reprap-france.com/support  microdeltarework > logiciel > configuration > fichier.zip) Avec cette méthode tu es sur de n'avoir aucun résidus

Edit : j'ai oublié que c'est une micro delta originale ...

Modifié (le) par BastienX8
Lien vers le commentaire
Partager sur d’autres sites

Ah mince ! J'ai totalement zappé "micro delta originale"... J'étais parti du principe que c'est une Rework. Du coup je vais aller me documenter car je la connais beaucoup moins bien 😕 

Lien vers le commentaire
Partager sur d’autres sites

Hello,

 

Le 30/03/2019 at 14:27, Baarbiche a dit :

Bonjour,

Bon, je suis un débutant en informatique et encore plus particulièrement dans l'impression 3D. J'ai acheté une Micro Delta Originale que j'ai monté, etc.

Après la résolution de quelques soucis, me voilà coincer. Les coordonnées X,Y et Z sont faux et quand j'utilise le bouton Home de repeter-host, la tête d'impression vient s'écraser lamentablement sur le sol. J'ai essayé de bidouiller les fichiers EEPROM mais je ne suis arrivé à rien.

Quelqu'un a déjà eu le même soucis ? Ou a une piste ?

Merci d'avance.

 

il y a une heure, Baarbiche a dit :

J'avais effectivement complètement oublié de le préciser my bad

Non non, c'est marqué ... @Jean-Claude Garnier 😋😇

 

🙂

  • J'aime 1
Lien vers le commentaire
Partager sur d’autres sites

  • 2 weeks later...

Rebonjour,

Je me demandais si vous n'auriez pas croisé un messie miraculeux arrivant sur un cheval doré transportant avec lui l'idée du siècle.  Je suis pour ma part complètement à cours.

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

  • YouTube / Les Imprimantes 3D .fr

×
×
  • Créer...