Aller au contenu

Filament ABS

Messages recommandés

Bonjour,

J'ai installé un bl touch sur mon ender 3 pro et j'ai un problème assez dérangeant...
Pour information j'ai suivi la procédure proposée par Creality sur le site officiel.

Lorsque je lance un auto home, mon bl touch vient palper le milieu du plateau et se place de telle sorte à ce que la buse soit à z=10 mm de la surface. Le problème c'est qu'une fois qu'il a fait ça, il change l'origine en z ! C'est à dire que ma buse est physiquement à la distance 10 mm du plateau mais pour le logiciel la buse se trouve à la position z=0 ! Donc quand je demande à la buse de d'un millimètre elle vient s'écraser sur le plateau...

De plus, je ne sais pas pourquoi, mais quand je lance une impression sans avoir fait un premier auto-home, la buse descend (trop !!) et vient gratter la surface de mon plateau avant d'arriver au centre et de lancer la procédure de palpation du plateau... résultat les moteurs claquent, la buse gratte, bref rien ne va...

Voici mon Gcode de début d'impression :

; Ender 3 Custom Start G-code
M140 S{material_bed_temperature_layer_0} ; Set Heat Bed temperature
M190 S{material_bed_temperature_layer_0} ; Wait for Heat Bed temperature
M104 S160; start warming extruder to 160
G0 Z10 ;Raise Z
G28 ; Home all axes
M117 Nivellement Auto GO !
G29 ; Auto bed-level (BL-Touch)
G92 E0 ; Reset Extruder
M104 S{material_print_temperature_layer_0} ; Set Extruder temperature
M109 S{material_print_temperature_layer_0} ; Wait for Extruder temperature
G1 Z1.0 F3000 ; move z up little to prevent scratching of surface
G1 X3 Y20 Z0.3 F5000.0 ; move to start-line position
G1 X3 Y200.0 Z0.3 F1500.0 E15 ; draw 1st line
G1 X3.3 Y200.0 Z0.3 F5000.0 ; move to side a little
G1 X3.3 Y20 Z0.3 F1500.0 E30 ; draw 2nd line
G92 E0 ; reset extruder
G1 Z1.0 F3000 ; move z up little to prevent scratching of surface
M117 Allez Printe ma belle !
; End of custom start GCode

J'ai ajouté la ligne G0 z10 dans l'espoir de faire remonter la buse avant de procéder à l'alignement mais rien à faire...

Lien à poster
Partager sur d’autres sites
il y a 8 minutes, Idealnight a dit :

Je ne suis pas un spécialiste des gcode mais cela me parait bizarre de mettre G0 Z10 avant le G28

Sur les machines outil (tour,fraIseuse,centre d'usinage ) le G0 est l'avance rapide

Nos imprimantes ne gères pas le G0, il faut mettre un G1 (avance travail ) suivi de la direction (x/y/z) puis F(l'avance en M/min)

Modifié (le) par Avrel
  • Merci ! 1
Lien à poster
Partager sur d’autres sites

le probe c'est ce qui permet de dire a marlin et donc ton imprimante ou est situé le bltouch par rapport à la buse (hauteur largeur profondeur).

Je trouve ton z-offset très important.

Peux-tu nous décrire de quel façon tu procèdes pour régler le z-offset ?

Lien à poster
Partager sur d’autres sites

Je ne sais pas où trouver cette information...

Pour l'offset j'ai simplement baissé ma buse en z jusqu'à ce quelle touche ma feuille de papier, donc -3.55 mm. Et j'ai ajouté la valeur à l'offset de base qui était de 0.

Maintenant, quand l'auto home est fait, si je place ma buse en z=0.1 mm, elle touche bien ma feuille de papier. Donc ça a l'air de marcher.

Modifié (le) par Tenkaichi
Lien à poster
Partager sur d’autres sites

Quand tu es en home il n'y a pas le z-offset de fait.

1) il faut se mettre en home (avec z-offset a 0 si tu le refais sinon couac)

2) descendre via move axis a 0

3) Réglages du z-offset avec la feuille (a partir de zéro)

4) Store settings

Modifié (le) par Idealnight
Lien à poster
Partager sur d’autres sites

Et bien j'ai l'impression que c'est ce que j'ai fait...

La première fois j'ai fait un auto-home, puis j'ai déplacé la buse en z=0, et à partir de la j'ai continué de la baisser jusqu'à ce que cette dernière touche la feuille.

Et donc la valeur négative obtenue en z correspondait à mon offset (ce dernier était égal à zéro au début).

Je ne vois pas la différence avec ce que tu me dis, désolé 😕

Lien à poster
Partager sur d’autres sites

J'ai pas précisé, une fois à 0 tu sors du menu move axis puis tu vas dans motion -> z-offset

Il y a 18 heures, Idealnight a dit :

Quand tu es en home il n'y a pas le z-offset de fait.

1) il faut se mettre en home (avec z-offset a 0 si tu le refais sinon couac)

2) descendre via move axis a 0

3) Menu Motion -> Z-offset Réglages du z-offset avec la feuille (a partir de zéro)

4) Store settings

Lien à poster
Partager sur d’autres sites

Mais si je change la valeur de mon z-offset ça ne bouge pas ma buse en temps réél. Donc je ne peux pas régler cette valeur de telle sorte à ce que la distance buse - plateau soit bonne?

Modifié (le) par Tenkaichi
Lien à poster
Partager sur d’autres sites

Je ne sais pas comment est fichu ton firmware et donc tes menus.

Tu passes bien par l'écran de l'imprimante ?

Mais logiquement tu as un menu pour régler le z-offset (moi c'est dans control->motion), dans ce menu quand tu vas baisser ou monter la valeur, la buse va bouger mais très peu car c'est un réglage a 0.025 (à titre d'exemple dans move axis le plus précis est 0.1)

Lien à poster
Partager sur d’autres sites

On parle bien du même menu en effet, cependant sur ma ender 3 pro lorsque je change la valeur de z-offset, la buse ne bouge pas... MAIS si je la change, puis que je l'enregistre et que je fais un auto-home cette dernière est prise en compte !

J'ai essayé de la déplacer, j'ai beaucoup modifié la valeur, mais rien ne se passe

C'est bizarre ...

Lien à poster
Partager sur d’autres sites

Ouep, c'est bon j'ai réussi. Bon je vais appliquer ton protocole maintenant !

EDIT : Non en fait ça ne va pas...

J'ai remis mon z-offset à 0. Lorsque je fais mon auto-home avec le bl touch et que je fixe la valeur de z à 0, la buse frotte contre la feuille, mais quand j’essaye d'ajuster le z-offset pour avoir une bonne distance, rien ne bouge... La tête frotte toujours la feuille, même en changeant l'ooffset à +-1mm

Modifié (le) par Tenkaichi
Lien à poster
Partager sur d’autres sites

Mais ça ne va pas régler le problème de l'axe z qui ne bouge pas lorsque je modifie l'offset ?

 

Je viens de voir ça en parcourant le forum :

En gros un mec qui règle son z-offset. Il semble avoir le comportement inverse au miens, c'est à dire que lorsqu'il modifie son z-offset l'axe z bouge. Et quelqu'un lui a répondu ça:

Le 24/05/2020 at 18:12, bernard3D a dit :

Si le réglage du Z offset fait bouger l'axe Z, il y un un bug dans ton firmware ou une erreur de configuration. C'est de ce côté qu'il faut chercher.

Il a donc trifouillé dans le firmware pour désactiver les babystep apparemment

Le 24/05/2020 at 19:18, Stef67 a dit :

bon ben j'ai trouvé mon probleme et donc sa solution.

 

Dans le marlin, configuration.adv.h j'avais activé :

//#define BABYSTEP_ZPROBE_OFFSET          // Combine M851 Z and Babystepping

sur les recommandations du guero loco sur une video mais qui datait du marlin 1.8.

 

Du coup en desactivant cette option mon Probe Z offset ne deplacve plus mon axe.

 

Merci pour l'aide que vous m'avez apporté.

Apparemment mon problème d'axe z qui ne bouge pas lorsque je modifie mon z-offset viendrait de la? Comment avoir accès au firmware de l'imprimante pour vérifier ça?

Lien à poster
Partager sur d’autres sites

Quand tu as ajouté le bltouch tu as du injecter un nouveau firmware, c'est dans marlin qu'il faut le modifier.

Effectivement j'avais oublié cette option, il vaut mieux pouvoir bouger l'axe en step 0.025 via le z-offset qu'en 0.1 via le move axis (a moins que tu es le baby step 0.025 dans move axis)

Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Créer...