Aller au contenu

Filament ABS

  • 0

BTT TF cloud - Ne fonctionne pas


Question

Bonjour,

j'ai installé un BTT TF cloud sur mon ender 3 pro.
J'ai fait la configuration (ip, password, etc) j'arrive bien a envoyé des fichiers mais j'ai 2 problemes :


- Quand j'allume l'imprimante avec le cloud dedans, j'ai un écran bleu, Marlin ne démarre pas...
je dois allumer l'imprimante sans et le brancher après (pas pratique).

- une fois démarré, j'envoi le fichier, l'interface de l'imprimante m'indique card insered, je vais dans la carte pour choisir le fichier, et la j'ai "no card tf" et donc impossible de lancer l'impression 😞

Vous avez une idée ?
merci


ps : voici le firmware que j'utilise :

Ender-3 Pro- 4.2.7-TMC2225 

Marlin2.0.1-BLTouch-V1.1.2(without adapter board)

Modifié (le) par boodinet
Lien à poster
Partager sur d’autres sites

Messages recommandés

  • 0
Il y a 7 heures, Jonathan06 a dit :

Sujet qui m'intéresse car je viens de commander le BTT TF cloud.

Tiens nous au courant si ton problème est résolu.

tu la acheté avec la carte sd ? Car je me demande si c'est pas la le probleme, je possède que des cartes 4-8-16go en micro sd, hors la carte vendu avec fait 128mo et très vieille.
Franchement j'ai tous essayé, changement de firmware, tous les type de branchement possible mais rien a faire, ma CM refuse de détecter ma carte sd quand je passe par le BTT TF.

Lien à poster
Partager sur d’autres sites
  • 0

Salut ! Carte SD bien formaté en FAT 32 avec taille de bloc 4096 ? 

Donc c'est un genre d'adaptateur pour carte SD, il faut peut-être le branché avec au préalable une carte SD dedans ? sinon c comme si y avais pas de carte et cela même si tu met la carte SD après ... ?

Y a pas un petit risque niveau sécurité ? genre si je me connecte a t'on wifi, c un lecteur réseau sans contrôle d'accès ! ?

Mais comment t'a fait pour config le wifi alors il faut bien mètre un fichier SETUP.INI avec le SSID et PASSWORD sur la SD pour cela .... non ? cf : 

Modifié (le) par PPAC
Lien à poster
Partager sur d’autres sites
  • 0
Posté(e) (modifié)

oui j'ai bien formater en fat32, mis le fichier setup en la connectant a mon pc (ca fonctionne)
Puis quand je la branche a l'imprimante, mon pc la detect en réseau et peu envoyer des gcode.

Mais quand je demande a l'imprimante de lire la carte SD pour lancer une impression, il me dit qu'il y en a pas, SD init fail 😞
Et si je place la carte SD sans le BTT TF dans l'imprimante ca marche.

Modifié (le) par boodinet
Lien à poster
Partager sur d’autres sites
  • 0

oky et tu met bien la carte SD dans le BTT TF avant de mètre le BTT FT dans le lecteur de carte SD de l'imprimante ?

a tu nettoyé les contactes sur le BTT FT ?

Modifié (le) par PPAC
Lien à poster
Partager sur d’autres sites
  • 0

Et genre, si tu branche t'on BTT FT avec une carte SD dedans sur un lecteur SD de t'on PC,  t'on PC il dit quoi ? il trouve une carte SD ?

A tu vérif/nettoyés  les contactes sur le BTT FT ?

Car donc GND et 3V3 sont OK ... mais les autre connecteurs  ... ?

http://www.noritake-itron.com/NewWeb/TFT/Hardware/HardwarePg/SDCards.jpg

Modifié (le) par PPAC
Lien à poster
Partager sur d’autres sites
  • 0

Arf donc c vraisemblablement ton lecteur SD d'imprimante qui accepte pas le BTT FT et pas le BTT FT qui bug ...

Et sous t'on PC question type de format de la partition du lecteur que tu a qd tu met le BTT FT : tj fat32 pas de nom de partition trop exotique ? (pas plus de 8chars un nom de volume a la DOS max 8 caractéres pas d'espace pas de caractéres spé ?)

Modifié (le) par PPAC
Lien à poster
Partager sur d’autres sites
  • 0

je vais refaire un test avec un formatage lent en 4096 et changer le nom (qui a des chiffres en se moment), mais je pense pas que ca change quelque chose.
Je pensais a mon firmware, mais j'ai testé avec le Marlin 2.0.x bugfix officiel est j'ai pareil.

 

ca ne fonctionne toujours pas 😞 après je sais qu'il le vend avec une carte TF de 128mo mais j'ai choisi l'option (sans)...
mais impossible d'en trouver sur internet c'est trop vieux lol

Lien à poster
Partager sur d’autres sites
  • 0

ba oui après moi aussi je retombe sur une config du firmware mais alors quelle options activer ? y en a pas temps que cela pour la gestion des SD sous marlin ! LONG_FILE_NAME ? je vois reins d'autre de mémoire mais semble pas cela ! ou alors c une question de version de lib SD ? encore plus étrange si c proche d'un adaptateur mini-SD vers SD ... 

Et si c t une question de si y a une connexion/accées wifi ouverte (parcours/lecture/écriture), y a pas de carte SD de mis a dispo ... car cela créer de pb qd un fichier ai en cours d’écriture ... genre il fraudais bien fermer le lecteur réseau sur t'on PC pour libérer la ressource ?

Que de mystères !

Ou alors c la même que les voltage/ampérage des ports USB les anciens on un +5v avec plus d'ampérage que les nouveau, y a un jumper pour le modifier ... ?

Modifié (le) par PPAC
Lien à poster
Partager sur d’autres sites
  • 0

j'ai refait un test pc éteint, et ca ne fonctionne pas, donc pas lié a la connexion.
j'hésite a acheté une carte tf de 128mo, il les vend aussi chere qu'une 64go -_-

Lien à poster
Partager sur d’autres sites
  • 0

bien éventuellement si sous le droit fr tu pouras utiliser la rétractation sous 14 jours si cela marche pas avec un 128 mo ?

Mais c vite remplie 128 Mo ! même si on utilise "Arc Welder" pour avoir des g-code moins gros .... 

 

Tu n'a pas accès a une autre imprimante 3D pour tester ?

voir même tester avec une imprimante 2D papier qui a un lecteur SD ?

(arf !  pardons !  j'aurais du éditer mon précédant post ... )

Lien à poster
Partager sur d’autres sites
  • 0

Ha le truc trop mystérieux ! et mission-impossible si tu dois tester avec un arduino, un rpi ou une autre carte avec lecteur SD ... 

A tu l'envie et a tu d'autre équipement avec un lecteur SD pour éventuellement déterminer quelle serai la puce de gestion SD qui accepte ce BTT FT ?

Lien à poster
Partager sur d’autres sites
  • 0
Il y a 1 heure, boodinet a dit :

tu la acheté avec la carte sd ? Car je me demande si c'est pas la le probleme, je possède que des cartes 4-8-16go en micro sd, hors la carte vendu avec fait 128mo et très vieille.
Franchement j'ai tous essayé, changement de firmware, tous les type de branchement possible mais rien a faire, ma CM refuse de détecter ma carte sd quand je passe par le BTT TF.

 Oui, Je l'ai acheté avec, mais pas encore recu!

Modifié (le) par Jonathan06
Lien à poster
Partager sur d’autres sites
  • 0
il y a 6 minutes, PPAC a dit :

Ha le truc trop mystérieux ! et mission-impossible si tu dois tester avec un arduino, un rpi ou une autre carte avec lecteur SD ... 

A tu l'envie et a tu d'autre équipement avec un lecteur SD pour éventuellement déterminer quelle serai la puce de gestion SD qui accepte ce BTT FT ?

sur pc j'ai 2 lecteurs de carte aucun probleme. Je crois qu'il va finir a la poubelle lol sniff

Lien à poster
Partager sur d’autres sites
  • 0

Si c t simplement dans configuration.h

Donc comme tu a la SD seul qui marche tu a forcement 

#define SDSUPPORT

mais après SD CARD: ENABLE CRC faut peut être bien le désactiver ? sais tu se que tu a actuellement ?

//#define SD_CHECK_AND_RETRY

 

Sinon dans Configuration_Adv.h y a cela qui semble être exactement le truc a tester en cas de sd init error  

/**
   * SD Card SPI Speed
   * May be required to resolve "volume init" errors.
   *
   * Enable and set to SPI_HALF_SPEED, SPI_QUARTER_SPEED, or SPI_EIGHTH_SPEED
   *  otherwise full speed will be applied.
   *
   * :['SPI_HALF_SPEED', 'SPI_QUARTER_SPEED', 'SPI_EIGHTH_SPEED']
   */
  //#define SD_SPI_SPEED SPI_HALF_SPEED

 

et pour éviter l’écran bleu au démarrage fraudais tester :
  //#define SD_IGNORE_AT_STARTUP            // Don't mount the SD card when starting up
 

Modifié (le) par PPAC
Lien à poster
Partager sur d’autres sites
  • 0

pour l'option :   //#define SD_SPI_SPEED SPI_HALF_SPEED
ca ne change rien 😞

Mais le soucis si je passe par la compilation du firmware mon bltouch ne fonctionne plus.
Il refuse de descendre... il dois y avoir des options a activer mais impossible de trouver.

Quand je passe par le firmware officiel bltouch 4.2.7 et surtout
without adapter board, ca fonctionne (pour le bltouch).
Je suppose qu'il y a une option pour lui dire que les informations endstop Z arrive dans le nouveau port de la CM et non par le port d'origine.

Lien à poster
Partager sur d’autres sites
  • 0

Le Github de BTT indique quel type de carte mère peut utiliser ce module: celle dont le lecteur de carte utilise la communication SPI. Peut-être que la carte Creality communique en SDIO ?

Toujours sur le Github, ils précisent que l'on peut utiliser des cartes SD de capacité supérieure à 128Mo. Au moins un utilisateur d'Ender3 signale que ça ne fonctionne pas 😞

🙂

Modifié (le) par fran6p
Lien à poster
Partager sur d’autres sites
  • 0
Il y a 1 heure, fran6p a dit :

Le Github de BTT indique quel type de carte mère peut utiliser ce module: celle dont le lecteur de carte utilise la communication SPI. Peut-être que la carte Creality communique en SDIO ?

Toujours sur le Github, ils précisent que l'on peut utiliser des cartes SD de capacité supérieure à 128Mo. Au moins un utilisateur d'Ender3 signale que ça ne fonctionne pas 😞

🙂

Si je regardes le schéma de la carte creality ender3, le micro sd est connecté au miso/mosi ATMEGA1284 de la carte mère!! MISO/MOSI c'est du SPI, donc...

https://github.com/RudolphRiedel/CR-10_wiring/blob/master/Ender3_schematic.PDF

Modifié (le) par Jonathan06
Lien à poster
Partager sur d’autres sites
  • 0
Posté(e) (modifié)

  

Il y a 2 heures, fran6p a dit :

Le Github de BTT indique quel type de carte mère peut utiliser ce module: celle dont le lecteur de carte utilise la communication SPI. Peut-être que la carte Creality communique en SDIO ?

Toujours sur le Github, ils précisent que l'on peut utiliser des cartes SD de capacité supérieure à 128Mo. Au moins un utilisateur d'Ender3 signale que ça ne fonctionne pas 😞

🙂

 


j'aimerai bien testé avec une vieille carte TF de 128mo, mais impossible d'en trouver sur internet 😢
les seul que je trouve c'est sur aliexpress avec 1 mois de livraison lol

une idée ?

Modifié (le) par boodinet
Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à cette question…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Créer...