Aller au contenu

Filament ABS

Bltouch z offset


darkcristal

Messages recommandés

Bonjour,

 

j'ai installé un bltouch sur mon ender3 pro et depuis impossible de comprendre comment régler le Z-offset. J'ai suivi 50 tutos sur youtube mais je n'y arrive pas.

La première fois ma buse s'est enfoncée dans le plateau et m'a fait un joli trou ! j'ai été obligé de commander un nouveau plateau.

Je vais dans move axis, je règle mon Z avec ma feuille de papier et je l'ajoute au Z dans motion.

Par exemple si j'ai 0 dans motion et qu'au réglage je trouve -2.8 je positionne mon Z dans motion à -2.8 (+store settings). Je lance ensuite mon impression et la buse est trop haute.

Je recommence, je vais dans move axis, je refais mon Z et je retrouve à nouveau -2.8, sauf que maintenant dans motion Z j'ai déjà -2.8....

 

J'ai reflashé ma carte mère pour repartir de 0 et je tourne toujours en rond, ma buse est toujours trop haute à l'impression. 

 

Pour simplifier mon problème, quelque soit la valeur de mon Z offset dans motion (0, -2 ou -4), je retrouve toujours -2.8 dans control-z offset.

 

Merci pour votre aide, ca fait 2 jours que je suis dessus et je n'y arrive pas. J'ai peur de péter mon nouveau plateau en verre !

Modifié (le) par darkcristal
Lien vers le commentaire
Partager sur d’autres sites

Bonjour,

Via l'écran, je ne l'ai jamais fait. Si ton imprimante est connectée à un PC (et reconnue pas celui-ci via un port série) alors en utilisant un terminal (Pronterface, Octoprint, …) tu peux saisir la suite de commandes Gcode qui devraient te permettre de régler ton Zoffset :

Citation

Instructions de réglage du décalage Z:

0. Préalable, mettre en chauffe le plateau (60° ( M190 S60 )) et éventuellement la buse (170° ( M109 S170 )) pour pouvoir enlever facilement les résidus de filament collés sur celle-ci
1. Effectuer la mise à l'origine des axes de l'imprimante via G28
2. M851 Z0 - Initialiser le décalage en Z à 0 (remise à 0 du Zoffset s'il y en avait un)
3. M500 - Stocker ce réglage en EEPROM
4. M501 - Récupérer les paramètres de l'EEPROM pour les rendre actifs
5. M503 - Afficher les paramètres en cours pour vérifier qu'ils ont bien été pris en compte
6. G28 Z - Mettre à l'origine l'axe Z
7. G1 F60 Z0 - Déplacer la buse au 0 Z
8. M211 S0 - Désactiver les contacteurs de fin de course (pour pouvoir descendre sous le 0)
9. Descendre doucement (pas de 0,01mm) l'axe Z jusqu'à frotter  la feuille de papier (ou la cale utilisée), via l'écran de contrôle ou via d'abord un G91 puis une suite de G1 Z-0.1 F120 (ne surtout pas oublier le G91 avant la commande de déplacement)
10. Noter la valeur affichée de la position du Z sur l'écran du boitier (additionner cette valeur (sans tenir compte du signe négatif (autrement dit prendre la valeur absolue 😉 )) à l'épaisseur de la cale utilisée)
11. M851 Z X.XX (X.XX étant le décalage en Z calculé au point 10 (valeur négative))
12. M211 S1 - Réactiver les limites des contacteurs de fin de course
13. M500 - Sauvegarder ce réglages en EEPROM
14. M501 - Récupérer les paramètres de l'EEPROM pour les rendre actifs
15. M503 -Vérifier une dernière fois que tout a bien été pris en compte

🙂

Lien vers le commentaire
Partager sur d’autres sites

Par l'entremise de l'écran :

  • Monte ton plateau à 60°, et ta buse à 200°
  • Vérifie que ton Z-Offset est à 0
  • Avec l'aide de "Move Z", descend ta buse lentement jusqu'à ce que ton écran indique 0 (position de la buse en Z)
  • retourne dans le menu Z-Offset, et incrémente ton Z-Offset (en négatif), jusqu'à ce que ta buse frotte légerement sur ta feuille de papier
  • fais un Store setting.

Pour avoir un zéro parfait, tu remonte ta buse de quelques millimetres, tu vas dans Z-Offset, et tu soustrait encore un 0,1 à ton Offset (ex.:  de -2.5 à -2.6), pour compenser l'épaisseur approximative de ton papier.

Mais pour ma part, je préfère partir une impression et ajuster en route, avec l'option "Tune".   Tu pourras ainsi soustraire ton 0,1 ou 0,2 selon l'épaisseur de ton filament déposé sur ton plateau. Je trouve ca plus safe, évitant peut-être de scratcher ton plateau.

et n'oublie pas un "Store setting" avant d'éteindre ton imprimante....  

😉

Lien vers le commentaire
Partager sur d’autres sites

Il y a 14 heures, PierreG a dit :

Par l'entremise de l'écran :

  • Monte ton plateau à 60°, et ta buse à 200°
  • Vérifie que ton Z-Offset est à 0
  • Avec l'aide de "Move Z", descend ta buse lentement jusqu'à ce que ton écran indique 0 (position de la buse en Z)
  • retourne dans le menu Z-Offset, et incrémente ton Z-Offset (en négatif), jusqu'à ce que ta buse frotte légerement sur ta feuille de papier
  • fais un Store setting.

Pour avoir un zéro parfait, tu remonte ta buse de quelques millimetres, tu vas dans Z-Offset, et tu soustrait encore un 0,1 à ton Offset (ex.:  de -2.5 à -2.6), pour compenser l'épaisseur approximative de ton papier.

Mais pour ma part, je préfère partir une impression et ajuster en route, avec l'option "Tune".   Tu pourras ainsi soustraire ton 0,1 ou 0,2 selon l'épaisseur de ton filament déposé sur ton plateau. Je trouve ca plus safe, évitant peut-être de scratcher ton plateau.

et n'oublie pas un "Store setting" avant d'éteindre ton imprimante....  

😉

Bonjour PierreG

 

merci pour ton aide. Alors dans l'ordre je fais :

 

- Je chauffe ma buse à 205 et mon plateau à 60.

- Je fait auto home, sur l'écran principal mon Z affiche bien 0.

- Dans "Control" > "Motion" > "Z offset" j'ai -00.00

- Je fais "Prepare" > "Move Axis" > "Move Z"  jusqu'à frotter la feuille et je trouve -3.3

- Dans "Control" > "Motion" > "Z offset" je saisie -3.3

- "Control" > "Store settings" pour sauvegarder la configuration

- J'éteins l'imprimante, je la rallume

- Je vais vérifier dans "Control" > "Motion" > "Z offset" j'ai bien -3.3

- Si je vais dans "Prepare" > "Move Axis" > "Move Z" je suis bien à 0 pour que ma buse frotte la feuille de papier, tout est parfait. En revanche si je fais un "Auto home", ma buse remonte et il faut à nouveau -3.3.

J'ai l'impression que mon auto home me remonte à chaque fois le Z offset...

Lien vers le commentaire
Partager sur d’autres sites

Bon matin (pour moi) @darkcristal...

Quand l'imprimante fait un Auto Home, à la fin du palpage du Z, la buse se place au dessus du plateau, à une certaine hauteur (que je n'ai jamais mesuré).   Quand mon impression commence, la buse descend tout près du plateau et se déplace vers le Home pour faire la ligne de purge.

Donc, c'est probablement normal que la buse reste plus haut que le Z0.

😊

Lien vers le commentaire
Partager sur d’autres sites

Avec un BLTouch, la buse ne descend pas à zero...   lors d'un Home, la tete se déplace vers la gauche pour vérifier le EndStop X, ensuite le plateau recule pour vérifier le EndStop Y, ensuite la tete se déplace au centre du plateau (117, 117), le BLTouche relâcle le capteur (BLTouch vire au bleu) et la tete descend jusqu'à ce que le BLTouch se déclenche (BLTouch vire au rouge).  La tête remonte, le BLTouch relâche un 2e fois le capteur et refait la même descente, mais à vitesse plus lente.  Lorsqu'il a terminé,  la tête se positionne plus haut et attends.

De cette façon, le système sait où est exactement le plateau, et va appliquer ton 3.3 mm lors de l'impression.

Mai je vais vérifier quelle position me donne la tete de mon imprimante (lorsque mon impression sera terminée dans 2 heures) et que le Home est terminé.    Je te reviens avec l'info...

🧐

Lien vers le commentaire
Partager sur d’autres sites

Ta position 0 est défini soit par un endstop ou via le probe pour le bl-touch.

Ensuite le réglage du z-offset qui peut être fait avec ou sans bltouch ne concerne que la précision du Z pour l'impression et non pour le home

Modifié (le) par Idealnight
Lien vers le commentaire
Partager sur d’autres sites

Tel que convenu, je te reviens avec mes résultats d'un Auto-Home (avec 8 hres de retard, je m'en excuse)...

À la fin du Home, ma buse s'est positionnée à 12.65 mm  (position du Z affichée sur l'écran LCD), donc 10 mm + 2.65 mm de mon ZOffset

Alors oui, il y a quelque chose qui cloche avec ton Home...    tu devrais obtenir 13.3 mm comme position du Z à la fin du Home (10mm + 3.3 ).

Lien vers le commentaire
Partager sur d’autres sites

@PierreG Merci pour ton retour , j'ai donc un problème mais je ne sais pas trop où chercher... Chaque fois que je règle mon z-offset et que je fais un auto-home derrière il me re-décale la buse. J'ai essayé plusieurs fois mais je tourne en rond...

@Idealnight Je constate juste que je règle ma buse correctement, je sauvegarde la conf et des que je lance une impression ma buse est a 1cm du plateau...

Lien vers le commentaire
Partager sur d’autres sites

@darkcristal, pour régler un z-offset on doit respecter une méthode, je ne sais pas ce que tu fais donc (le tout a chaud en température):

1) autohome

2) move axis Z -> 0

3) Menu Z-offset -> réglage sur ticket CB -> puis save

As-tu renseigné également ton probe correctement dans marlin ?

Lien vers le commentaire
Partager sur d’autres sites

Posté(e) (modifié)

@Idealnight j'ai noté toute ma procédure plus haut, je viens de tout recommencer et c'est toujours la même chose :

 

 

- Je chauffe ma buse à 205 et mon plateau à 60.

- Je fait auto home, sur l'écran principal mon Z affiche bien 0.

- Dans "Control" > "Motion" > "Z offset" j'ai -00.00

- Je fais "Prepare" > "Move Axis" > "Move Z"  jusqu'à frotter la feuille et je trouve -3.3

- Dans "Control" > "Motion" > "Z offset" je saisie -3.3

- "Control" > "Store settings" pour sauvegarder la configuration

- J'éteins l'imprimante, je la rallume

- Je vais vérifier dans "Control" > "Motion" > "Z offset" j'ai bien -3.3

- Je refais un auto home puis "Prepare" > "Move Axis" > "Move Z" et il faut me faut de nouveau -3.3 pour que ma buse frotte.

- Je continue je mets -6.6 dans "Control" > "Motion" > "Z offset", je sauvegarde

- Je refais un auto home puis "Prepare" > "Move Axis" > "Move Z" et il faut me faut de nouveau -3.3 pour que ma buse frotte.

Mon "Motion" > "Z offset" n'est jamais pris en compte...

 

Quand tu parles de probe c'est quoi exactement ?

Modifié (le) par fran6p
Lien vers le commentaire
Partager sur d’autres sites

euh et elle sort d'où cette procédure ? tu es sur qu'elle est correcte ?

Quand on fait un auto home logiquement la buse est plus haute et non a 0. Est-ce toi qui l'a modifié dans le firmware ?

Tu l'as pris où ton firmware ?

La procédure que je t'ai noté est sure de fonctionner, puisque je l'applique moi même 🙂.

Le probe est a renseigner dans le firmware afin que l'imprimante sache ou se situe la tige du bltouch afin que la buse soit positionnée au centre lors de l'impression.

Lien vers le commentaire
Partager sur d’autres sites

D'accord avec @Idealnight.   La procédure a quelque chose de curieux...

Pourquoi tu n'utilises pas le ZOffset pour descendre la buse jusqu'au frottement, et sauvegarder ensuite ???

Et comme je l'ai mentionné plus haut, après un Auto-Home, ta buse ne se positionne pâs à zéro, mais devrait se positionner à 13.3  (10 mm + le Offset).

As-tu essayer la procédure que je t'ai donné, qui est d'ailleurs très semblable à celle d'Idealnight ??

Est-ce que ton imprimante est reliée à un ordi ?   utilises tu Pronterface ou autre pour communiquer en mode terminal avec ton imprimante ??

Modifié (le) par PierreG
Lien vers le commentaire
Partager sur d’autres sites

J'ai pris le firmware  sur la page du site officiel https://www.creality3dofficial.com/fr/collections/bl-touch/products/creality-bl-touch?variant=16024931139633

J'ai utilisé ce fichier : (2019.11.13)Ender-3 Pro1.1.6BLTouchV3.1PowerLossContinueEnglish.hex

 

Il me semble que ma procédure correspond aux 2 vôtres ou alors j'ai raté quelque chose encore 😞

 

Je n'ai rien modifié sauf la procédure d'installation du bltouch avec le branchement sur le pc pour flasher la carte mere.

Lien vers le commentaire
Partager sur d’autres sites

En fait @darkcristal, il n'y a pas une grosse différence, mais ca peut se jouer au niveau du Firmware...

Plutôt que de trouver ton Offset en utilisant le Move Axis, et enregistrer la valeur dans le Z-Offset;  Met la buse à Z0 avec le Move Axis, et ensuite utilise le controle Z-Offset, pour descendre la buse à -3.3 et enregistrer (à moins que ton interface écran ne te permette pas d'ajuster le Z-Offset live ?).

Au bout du compte, le résultat est le même, mais peut-être que le firmware n'est pas en mesure de le prendre...

Aussi, quand se termine ton Auto-Home, quelle valeur s'affiche en Z sur ton imprimante (sans toucher a quoi que ce soit) ?

Lien vers le commentaire
Partager sur d’autres sites

Si j'utilise le controle Z-offset ma buse ne se déplace pas, je ne peux pas controler qu'elle frotte parfaitement la feuille.

Je mets quand meme -3.3 pour tester + store settings

Je fais auto home et le Z affiche 0... 

Lien vers le commentaire
Partager sur d’autres sites

Tu as bien précisé que tu as une Ender 3 Pro !!

Est-ce que tu sais quelle carte mère possede ton imprimante ??    C'est soit une carte 1.1.X   ou une carte 4.2.2 (ou 4.2.7)

Si c'est une CM 4.2.2, je pourrais te donner une copie de mon propre FW, qui fonctionne avec un BLTouch de Antclabs, v 3.1

🧐

as-tu un écran TouchScreen ??

Modifié (le) par PierreG
Lien vers le commentaire
Partager sur d’autres sites

ah..., le réglage d'un z-offset est plus précis qu'un move axis pour info et on ne fait pas comme cela.

J'ai vu que @fran6p t'a donné la procédure logicielle et que @PierreG et moi t'ont donné la procédure a respecté via écran.

Je sais que ce problème du non mouvement du z via z-offset est connu mais ma mémoire me fait défaut désolé.

Je ne sais plus si cela est lié au firmware ou au branchement voir aux 2 ^^.

Tu as débranché le endstop z ?

Comment as-tu branché ton bltouch ?

Lien vers le commentaire
Partager sur d’autres sites

Bonsoir à tous,

@darkcristal étrange ...

Je peux te certifier que si tu respectes à la lettre la procédure citée par @fran6p postée plus haut (dimanche, 19h10) , il n'y a aucune raison que cela ne fonctionne pas. Je l'ai appliqué moults fois avec succès à chaque essai. Si alors cela ne fonctionne toujours pas, c'est qu'il y a une C.....e dans le firmware.

Edit: @Idealnight étant très rapide, je vois qu'il t'a donné la piste à suivre concernant le débranchement du Z-Endstop.

Modifié (le) par papaone
Lien vers le commentaire
Partager sur d’autres sites

@PierreG J'ai ouvert le boitier et j'ai une CM 1.1.4

@Idealnight Pour l'installation j'ai suivi la procédure vidéo qui est donné sur le site officiel :

Hier j'ai re-ouvert le boitier de ma carte mère pour vérifier les branchements et vérifier si je n'avais pas inversé des fils mais tout me parait bon.

J'ai bien enlevé le endstop z comme spécifié dans la vidéo également.

Concernant le firmware j'ai installé également celui donné sur le site officiel (2019.11.13)Ender-3 Pro1.1.6BLTouchV3.1PowerLossContinueEnglish.hex

Lien vers le commentaire
Partager sur d’autres sites

Mon imprimante étant rangée je ne peux valider le sens de connection des cables bltouch.

Par contre déjà tu n'as pas mis la bague sur le pneufit de la tête et c'est indispensable et au niveau de l'extrudeur aussi il en faut 1.

Tes pins doivent être bien enfoncées sur la carte mère celle entourée de rouge a l'air de travers et pas complètement enfoncée.

Je t'inviterai fortement a lire les tutos du forum, notice de montage de superpat, les tutos de Fran6p notamment quelques réglages a vérifier.

Le firmware fourni par creality est un peu obsolète mais devrait fonctionner, peut-être serait-il judicieux de voir si tu es capable de partir sur un firmware plus récent ?

AS-tu réussi a te connecter avec ton pc via pronterface pour faire les manip proposées par Fran ?

Lien vers le commentaire
Partager sur d’autres sites

@darkcristalJe crois que l'un de tes fils connectés sur l'adapteur de l'écran est inversé....     l'ordre sur le BLTouch est Bleu-Rouge-Jaune, et tu connecte avec Rouge-Bleu-Jaune...

Vérifie que les fils se connecte bien aux bonnes pins :
5V -> 5V  (Rouge)
Gnd -> Gnd  (Bleu)
Signal -> Signal  (Jaune)

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...