Aller au contenu

Filament ABS

Calibrer l'extrudeur


Faf

Messages recommandés

Salut,

Calibrer l'extrudeur me semble plus compliqué sur cette imprimante. On n'a pas accès au renseignement des step/mm?

J'extrude 93.5 mm pour 100 demandés.

je suis un peu perdu...

Si quelqu'un pouvais m'apporter ses lumieres!

Lien vers le commentaire
Partager sur d’autres sites

Salutation

Si l'on parle bien d'une sidewinder X1 "stock" donc non modifié.

en principe tu a cela en stock

#define DEFAULT_AXIS_STEPS_PER_UNIT   { 80.121, 80.121, 399.778, 445 }

Se qui te donne 

M92 X80.121 Y80.121 Z399.778 E445

 

Sinon tu "force" une valeur de steps/mm avant de faire le calibrage comme cela tu a une valeur connue des steps/mm initial pour le calcul des nouveaux steps/mm (et donc pas grave si la valeur que tu force n'ai pas bonne car tu va l'ajuster après ...)

Ex tu fait un M92 E445 avant de faire le/les G1 E100 et tu utilise 445 comme valeur de steps/mm de référence pour les calcules

Modifié (le) par PPAC
Lien vers le commentaire
Partager sur d’autres sites

Salut, 

Il faut connecter ton imprimante à l'ordinateur et utiliser une console pour pouvoir communiquer en Gcode. 

Tu peux utiliser Pronterface ou le moniteur série d'Arduino par exemple ... 

Tu tapes M503 pour connaître la configuration de ton imprimante et le DEFAULT_AXIS_STEPS_PER_UNIT de ton extrudeur  ( normalement 445 d'origine sur les sidewinder X1 ):

381001878_Screenshot-23_06_202120_46_37.png.f157cbccc361dca8c55edc8757a145a8.png

ensuite tu fais (longueur demandée / longueur extrudée) * valeur actuelle soit (100/93.5)*445 = 475.94

Pour entrer la nouvelle valeur tu tapes le gcode : M92 E475.94

Pour enregistrer la modification tu tapes M500

[edit] à priori ça ne fonctionnera pas sur une Sidewinder X1 entièrement d'origine
=> voir la solution évoquée ci-dessous avec le gcode de démarrage 😉

Modifié (le) par Invité
Lien vers le commentaire
Partager sur d’autres sites

Si j'utilise 445 comme valeur initial et que tu a bien 93.5 pour 100mm demandé, je trouve 475.94 comme nouvelle valeur

cf

 

Formule nouveau pas par mm (Steps/mm) = (longueur demandée)*(Valeur actuelle des pas par mm)/(longueur réél moyenne mesurée)=(445) * (100.0) / (93.5)

Nouveau pas par mm (Steps/mm) = 475.93582887700535

 

donc tu fait un

M92 E475.94 
puis tu contrôle "G1 100" donne combien et là tu réutilise 475.94 comme valeur de initial et ainsi de suite ...

 

@leleuf malheureusement il semble que le firmware stock des Sidewinder X1 n'a pas le (Edit 2 ) "M500" ( et non le  M503 mes excuses ) d'activé ... (Edit c cool on a le même résultat 🙂 ouf je ne me suis pas trompé 😉  )

Modifié (le) par PPAC
  • +1 1
Lien vers le commentaire
Partager sur d’autres sites

il y a 11 minutes, leleuf a dit :

les sources ( et donc la configuration ) sont disponibles sur Github ..

Merci pour le lien des sources (j'etait allez chercher sur forum mais c'est vrai il y a un github ...)

et cela contredit se que je disais :

//
// EEPROM
//
// The microcontroller can store settings in the EEPROM, e.g. max velocity...
// M500 - stores parameters in EEPROM
// M501 - reads parameters from EEPROM (if you need reset them after you changed them temporarily).
// M502 - reverts to the default "factory settings".  You still need to store them in EEPROM afterwards if you want to.
//
//#define EEPROM_SETTINGS // Enable for M500 and M501 commands
//#define DISABLE_M503    // Saves ~2700 bytes of PROGMEM. Disable for release!
#define EEPROM_CHITCHAT   // Give feedback on EEPROM commands. Disable to save PROGMEM.

c'est le M500 qui n'est pas activé ...

Il faut donc mettre le "M92 E..." dans le g-code de démarrage des trancheur utilisé pour générer les fichier .gcode afin a chaque impression de bien modifier les steps/mm pour l'extrudeur car perdu a chaque redémarrage de l’imprimante car il ne peux pas être sauvé dans l'eeprom ... (sauf modifier/changer le firmware stock ... )

Modifié (le) par PPAC
Lien vers le commentaire
Partager sur d’autres sites

il y a 6 minutes, PPAC a dit :

Il faut donc mettre le "M93 E..." dans le g-code de démarrage des trancheur utilisé pour générer les fichier .gcode afin a chaque impression bien modifier les steps/mm pour l'extrudeur

Le Gcode M93 n'est pas supporté par Marlin😉

C'est le gcode M92 qu'il faut utiliser dans le gcode de démarrage du slicer ( par exemple M92 E475.94 ) comme dans cette vidéo ou dans cet article

Le mieux ce serait encore de flasher la sidewinder pour être tranquille ... 

Il y a un de très bons topic sur le forum comme ici ou ici  

Lien vers le commentaire
Partager sur d’autres sites

il y a 1 minute, leleuf a dit :

Le Gcode M93 n'est pas supporté par Marlin😉

Arf oui j'ai édité mais tu la vu avant ...  très bien que tu n'ai pas laissé passé cette erreur de ma part ! (je semble les cumuler se soir ...)

et +1 pour flasher mais pas forcement simple les 1er fois il faut bien se documenter.

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...