Aller au contenu

Filament ABS

Chris V.

Remplacer l'interrupteur mécanique de façon sûre

Recommended Posts

Bonsoir. :) 

J'aimerais poursuivre la conception de mon caisson, une étape consiste à pouvoir en gérer l'alimentation électrique depuis mon Raspberry Pi. Pour rappel, j'ai donc un Pi sur lequel tourne OctoPrint. Sur le Pi, j'ai branché un relais quatre voies, plus exactement celui-ci. C'est un système que j'avais appliqué à l'époque où j'avais ma Dagoma D200, et ça fonctionnait plutôt bien : via les menus d'OctoPrint, je pouvais contrôler l'alimentation électrique de l'imprimante et de l'éclairage du caisson. J'aimerais donc reproduire ceci sur mon nouveau caisson. ^_^ 

Mon problème est le suivant : sur la Dago, l'interrupteur ne comportait que deux phases. Assez facile, donc, de savoir où allait quoi sur le relais. ^_^ Sur l'i3c, l'interrupteur est double :

58b34aff0b57e_proCbuilding_instruction.jpg.ee49f7ffeaf88124871e4678cf798ed7.jpg

Par ailleurs, le relais possède ces caractéristiques :

 

Citation

Equipped with high-current relay, AC250V 10A ; DC30V 10A

 

Et l'alimentation fournie avec l'i3C possède celles-ci :

Citation

Input: 115V 2.2A / 230V 1.1A
Output: DC12V 20 A

 

Je me demande donc de quelle façon je pourrais contrôler l'alimentation électrique de l'imprimante sans tout faire griller. :)  Mes cours d'électricité remontent à loin, les notions acquises à l'époque n'ont pas été réutilisées depuis donc à force je finis par douter. C'est bien un interrupteur bipolaire ? Chacun des canaux du relais ne coupe qu'une des phases, faudrait-il donc que j'utilise deux canaux du relais pour couper chacune des deux phases, ou est-ce superflu ?

 

Je préfère donc voir avec vous et profiter de vos conseils. :) 

 

PS : j'ai bien conscience que laisser traîner sur mon réseau local un équipement capable de piloter mon imprimante à distance peut sembler dangereux, j'en ai fort bien mesuré les conséquences et dans tous les cas l'imprimante n'est pas accessible depuis le WAN. Dès lors, on peut zapper ce point en particulier. :P 

Partager ce message


Lien à poster
Partager sur d’autres sites

dans le doute tu mets un relais par phase, ils tiennent 10A chacun ça devrait le faire... enfin je dis ça... je ne suis pas électricien...

Modifié (le) par pascal_lb

Partager ce message


Lien à poster
Partager sur d’autres sites

Bah, au niveau software, je balance deux commandes à WiringPi au lieu d'une, donc ça ne change quasiment rien pour moi. Mais je me pose également la question de savoir si ça peut avoir des conséquences sur le matériel qu'il y ait un léger délai entre l'exécution des deux commandes ? Ça se jouerait en millisecondes, normalement, sauf en cas de bug du Pi pile à ce moment-là. 

*dépose des batteries de 9V et des condensateurs un peu partout autour du sujet pour attirer les électriciens du forum* xD 

Partager ce message


Lien à poster
Partager sur d’autres sites

Je pense qu'il doit y avoir une raison pour mettre un contact par phase mais quoi... j'attends aussi une explication... :)

Partager ce message


Lien à poster
Partager sur d’autres sites

Yo  Voici la réponse !!!

 

Il s'agit bien d'un interrupteur bipolaire.

Que l'on coupe une phase ou les deux n'a pas trop d'importance dans la question fonctionnement !

Mais vus que cela reste quand même des chinoiserie d'alimentation et que la terre y est raccorder l'idée de couper les 2 phases reste une idée de sécuritée !

Que les relais ai un délais entre les deux 1 millième de seconde ou plusieurs seconde ne fera aucun problème !!!  

Si tu préféré une coupure unipolaire tu mets les bleu ensemble et tu coupe le noir via le relais !!

 

voila ;)

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut @le_joebar, merci de tes précisions ! :) Concernant les caractéristiques, si j'ai bien suivi, le relais peut encaisser une tension de 250V 10A par canal, et au niveau de l'interrupteur on a du 12V 20A, c'est bien ça ? Désolé si la question semble con, c'est que j'ai vraiment PAS envie de flinguer mon alim, ma GT2560 ou même mon Pi. :D 

Modifié (le) par Chris V.

Partager ce message


Lien à poster
Partager sur d’autres sites

Ouais donc si j'ai bien compris, si je remplace l'interrupteur par le relais, je flingue le relais, vu qu'il va se prendre 20 A pendant qu'il ne peut en gérer que 10 ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Les 20 A est une valeur théorique pour l'alimentation. L'alimentation consomme ce que lui demande l'imprimante, c’est-à-dire en gros entre 200 et 300 W, cela donne en 230 V en gros 1,2 A. Ton relais peut couper sans problème 10 A donc aussi 1,2A.

Partager ce message


Lien à poster
Partager sur d’autres sites

20A c'est à 12v. Or ici c'est 10A à 30v. Soit loi d'Ohm:

P=UxI

10x30 = 300watts

Si je remène cela à 12v on a:

I=P/U

300/12= 25A donc pas de soucis. Tous cela est en DC.

Dans ton cas, tu veux le mettre avant l'alimentation soit en AC. L'explication de t.vallete te concerne.

 

Le rapport est le même avec le AC

Les 300watts tu les ramène à 230v tu auras

I=P/U

300/230= 1,3A. Pas loin du résultat de 1,1A. Il faut ajouter cos fi dans la formule en AC.

Partager ce message


Lien à poster
Partager sur d’autres sites
à l’instant, celta a dit :

Dans ton cas, tu veux le mettre avant l'alimentation soit en AC. L'explication de t.vallete te concerne.

En fait j'pensais remplacer l'interrupteur mécanique, purement et simplement. Donc en sortie de l'alim, j'suis déjà en continu, non ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Mais l'interrupteur est avant l'alim. Donc en AC.

 

Car en sortie d'alim tu en as plusieurs 12v en DC

 

Il suffit de couper une seule phase avec ton relais. Le positif de préférence.

 

 

Par info, j'ai un raspberry qui gère tout la les leds (2 circuits) et la ventilation du caisson en fonction d'une sonde.

Au début j'avai mis un relais entre l'interrupteur et l'alimentation. Le relais je l'ai branché en NC, relais non activé, le courant passe. Même s'il crame. L'interrupteur permet d'avoir plus de sécurité.

Mais j'avais un soucis d'alimentation 5v du rpi. J'avais trop de trucs à alimenter. Il fallait ajouter une alim 5volts externe pour le relais. Déjà que j'avais une alim 12volts pour les leds rvb. Tu vois le foutoir.

 

J'alimente un autre écran LCD 2004 où j'ai créé des menus avec les personnalisation des couleurs, le reboot du rpi, modifs des seuil de mise en route du ventilateurs en fonction de la température de la sonde etc...

Partager ce message


Lien à poster
Partager sur d’autres sites

Ah oui, j'avais un mauvais schéma en tête. En effet, on est toujours en 230v~. :) 

Bon, j'ferai ça quand j'en aurai marre d'imprimer. :D

il y a 9 minutes, celta a dit :

Le positif de préférence.

Donc le bleu, si le câble est normalisé. :P 

 

Merci pour les infos, les gars ! :) 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour (Ups)

Bon, j'ferai ça quand j'en aurai marre d'imprimer. :D

il y a 25 minutes, celta a dit :

Le positif de préférence.

Donc le bleu, si le câble est normalisé. :P 

En alternatif, il n'y a ni positif ni négatif, cela change 50 fois par seconde.

En monophasé il n'y a qu'une phase. Le "Bleu", c'est le neutre qui doit être relié à la terre de ta maison.

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 5 minutes, t.valette a dit :

En alternatif, il n'y a ni positif ni négatif, cela change 50 fois par seconde. En monophasé il n'y a qu'une phase. Le "Bleu", c'est le neutre qui doit être relié à la terre de ta maison.

 

il y a 3 minutes, celta a dit :

Oups c'est vrai. Je suis resté avec le DC dans la tête.

Pareil ahah ! Désolé @t.valette, c'est @celta qui m'a retourné le cerveau. xD Ouais, j'balance.

il y a 34 minutes, celta a dit :

Au début j'avai mis un relais entre l'interrupteur et l'alimentation. Le relais je l'ai branché en NC, relais non activé, le courant passe. Même s'il crame. L'interrupteur permet d'avoir plus de sécurité.

Mais j'avais un soucis d'alimentation 5v du rpi. J'avais trop de trucs à alimenter. Il fallait ajouter une alim 5volts externe pour le relais. Déjà que j'avais une alim 12volts pour les leds rvb. Tu vois le foutoir.

J'préfère le mettre en NO, comme ça en cas de coupure de courant, l'imprimante reste éteinte. Je préfère ne l'allumer qu'en toute connaissance de cause.

Pour l’éclairage, celui du caisson a son propre secteur, et celui sur les têtes est repiqué sur l'alimentation de l'imprimante. Ceci dit, des soucis d'alimentation 5v, càd ? A part le relais, le Pi ne doit rien alimenter, si ? Enfin, dans ma config', en tout cas, il n'alimente que le relais. 

il y a 37 minutes, celta a dit :

J'alimente un autre écran LCD 2004 où j'ai créé des menus avec les personnalisation des couleurs, le reboot du rpi, modifs des seuil de mise en route du ventilateurs en fonction de la température de la sonde etc...

Grand malade, va ! :o On peut voir, diiiiiis ? :D 

Partager ce message


Lien à poster
Partager sur d’autres sites

5volts du rpi. Faible ampérage.

Lcd 20x4 est branché en 5volts ainsi que l'encodeur rotatif (bouton' rotatif) et le relais l'était aussi.

Trop juste le 5volt interne.

 

Dans ton cas, pour un relais, cela suffit.

 

Je me trouve en voiture en Inde, je rentre là. Et je te poste des photos

 

Je rentre en France samedi. Donc je pourrais te faire une vidéo aussi.

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci pour la précision @pacificbanner. :) 

@celta, ouais franchement j'suis curieux, j'voudrais bien voir. Crée un sujet de présentation de ton i3B, qu'on puisse tous en profiter, si tu le veux. :) 

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant


×