Aller au contenu

Filament ABS

Benjamin/ex-Dagoma

officiel Cura by Dagoma V2 (Windows)

Messages recommandés

Salut

 

Quelqu'un peut il m'eclairer sur une chose : mon imprimante à un palpeur a bout gris et j'ai voulu essayer d’écraser un peu plus ma première couche pour tenter d'ameliorer l'accroche alors dans cura dagoma V2 j'ai voulu appliquer une petite modif d'offset de -0 quelque chose mais au final je me rends compte que cela n'a aucune incidence sur le fichier généré que je mette un offset en - en +,  ou même si je change la surface entre scotch ou builtak... dans tout les cas le fichier généré est identique...

Est ce que c'est normal? Est ce que cela est parce que j'ai coché utilisation du palpeur?

Comment faire dans ce cas?

Partager ce message


Lien à poster
Partager sur d’autres sites
youtube drone débutant

non les fichiers sont rigoureusement identiques a part la date au début et un id a la dernière ligne.

 

le début du fichier dagoma0.g  est ça :

 

M109 T0 S230.000000
T0
;Sliced at: Sat 02-01-2016 15:07:25
;Basic settings: Layer height: 0.2 Walls: 0.8 Fill: 17
;Print time: #P_TIME#
;Filament used: #F_AMNT#m #F_WGHT#g
;Filament cost: #F_COST#
;M190 S70 ;Uncomment to add your own bed temperature line
;M109 S230 ;Uncomment to add your own temperature line
G21        ;metric values
G90        ;absolute positioning
M82        ;set extruder to absolute mode
M107       ;start with the fan off
G28 X0 Y0  ;move X/Y to min endstops
G28 Z0     ;move Z to min endstops
G1 Z15.0 F9000 ;move the platform down 15mm
G92 E0                  ;zero the extruded length
G1 F200 E3              ;extrude 3mm of feed stock
G92 E0                  ;zero the extruded length again
G1 F9000
;Put printing message on LCD screen
M117 Printing...

;Layer count: 185
;LAYER:0
M107
G0 F9000 X86.673 Y84.454 Z0.260
;TYPE:SKIRT
G1 F1020 X96.848 Y90.329 E0.51387
G1 X97.251 Y90.544 E0.53385
G1 X97.635 Y90.717 E0.55227
G1 X98.036 Y90.867 E0.57100

ensuite c'est toute l'impression

Partager ce message


Lien à poster
Partager sur d’autres sites

le modèle se trouve dans le fichier xml_config.xml

tu devrais y trouver ces lignes

;bloc palpeur
;{palpeur}

;bloc Offset
G92 Z3
G91        ;relative positioning  
G1 Z{z_offset}
G90
G92 Z0

La variable {z_offset} est remplacée par la valeur saisie dans l'interface

Cette partie de code est aussi recopiée dans le fichier current_profile.ini dans la partie start5.gcode

donc, si ton xml est correct, supprime ton fichier current_profile et il sera recréé à partir du xml.

 

 

 

 

Modifié (le) par Huggy

Partager ce message


Lien à poster
Partager sur d’autres sites

Ok je comprends.

J'ai vérifié mon XML je retrouve bien le start et le end qui me paraissent correct comment tu l'as mis.

J'ai donc supprimé dans .cura mon répertoire Cura-by-Dagoma-V2 pour regénérer le .ini quand je l'ouvre je retrouve bien le code dans la partie start5.gcode.

Lorsque je re prépare une impression je retrouve toujours ma même entête dans le dagoma0.g qui ne tient pas compte de l'offset.

en comparant je trouve qu'il utilise la section start.gcode et le end.gcode mais pas les numero 5.

 

qu'est qu'il fait qu'il utilise une section ou l'autre?

Partager ce message


Lien à poster
Partager sur d’autres sites

Je vais essayer de tout desinstaller,supprimer tous les fichiers de config qui trainent et reinstaller. j'ai aussi cura normal d'installé parce que j'aurai préféré passer a la version complete quand j'aurai été au point y a peut etre un truc qui coince entre les 2 et j'avais aussi installé la V1 de cura by dagaoma en attendant ma livraison....

 

Ce qui est le plus surprenant finalement c'est que je fais des impressions très correctes c'est juste finalement que je ne controle pas l'offset et que lorsque je vais mette mon builtak j'aimerai bien qu'il en tienne compte... :)

 

Je suis en train de me dire si je copie les start et end de la section 5 dans la section 1 ? bonne idée ou fausse bonne idée?

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Tu dois avoir les deux versions de Cura qui se mélangent les piceaux

J'ai déjà donné l'info ici, pour faire cohabiter plusieurs versions il faut changer le nom dans le fichier c:\program file (x86)\Cura-by-dagoma\Cura\version

moi j'ai mis "Cura by Dagoma V1" pour la V1 et "Cura by Dagoma V2" pour la V2

pour la version non modifiée de Cura il y a déja un N° de version

en faisant ça, les profiles se retrouvent dans des sous-dossiers bien séparés.

Modifié (le) par Huggy

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui oui c'est ce que j'avais fais c'est pour ça que mon répertoire s'appelait  Cura-by-Dagoma-V2  dans le .cura mais bon sa n’empêche y avait quand même quelque chose qui se mélange les pinceaux donc j’ai tout enlevé tout pour être sur d'y voir plus clair. Mais la manip semblait marcher correctement puisque le répertoire se recrée correctement lorsque je le supprime.

 

Donc maintenant en reinstallant unique le cura by dagoma V2  le gcode est correct. je vais pouvoir continuer avec quelque chose de stable.

 

Merci

Modifié (le) par sedemay

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 30/12/2015 at 01:38, PoLoMoD a dit :

solid_layer_thickness :

 - 0.9 = 3 couches pleines de 0.30

- 1 = 5 couches pleines de 0.20

- 1.05 = 7 couches pleines de 0.15

- 1 = 10 couches pleines de 0.10

 

print_speed :

en mode brouillon, vu que la couche est plus épaisse (0.3) il faut réduire la vitesse car le dédit doit etre a son max

 

temp_preci :

augmentation de la température initiale . exemple : pour 20 à 200° on aura 220° ... surement pour faciliter l'extrusion du filament (a confirmer ...)

 

travel_speed :

vitesse de déplacement sans extruder

 

bottom_layer_speed :

vitesse de la couche du dessous

 

infill_speed :

vitesse de remplissage (idem que pour print_speed) "en mode brouillon, vu que la couche est plus épaisse (0.3) il faut réduire la vitesse car le dédit doit etre a son max"

 

inset0_speed :

vitesse des murs extérieurs  (idem que pour print_speed) "en mode brouillon, vu que la couche est plus épaisse (0.3) il faut réduire la vitesse car le dédit doit etre a son max"

 

insetx_speed :

vitesse des murs intérieurs  (idem que pour print_speed) "en mode brouillon, vu que la couche est plus épaisse (0.3) il faut réduire la vitesse car le dédit doit etre a son max"

@PoLoMoD : je reviens sur ce que tu disais sur le paramétre <temp_preci>. J'ai bien vérifié dans le dagoma0.g et effectivement la valeur de temp_preci est bien ajoutée à la temperature réglée dans Cura By Dagoma. Donc pour un profil de filament réglé à 205°C par exemple, on aura 205°C en mode Fin et 225°C en mode Rapide et ça visiblement pas qu'au début puisque dans le dagoma0.g, je ne vois que du M104 S225 en mode Rapide par exemple pas d'instruction de redescendre à 205° plus loin. Je ne comprends vraiment pas ce +20°C ... c'est pour s'adapter à des vitesses de déplacement plus rapide tu crois ? mais du coup si je met 205° pensant être dans la plage de température du fil (190-220) au final en mode Rapide, ça chauffe trop, je suis au dessus, non ?

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 5/1/2016 at 23:20, satchy a dit :

@PoLoMoD : je reviens sur ce que tu disais sur le paramétre <temp_preci>. J'ai bien vérifié dans le dagoma0.g et effectivement la valeur de temp_preci est bien ajoutée à la temperature réglée dans Cura By Dagoma. Donc pour un profil de filament réglé à 205°C par exemple, on aura 205°C en mode Fin et 225°C en mode Rapide et ça visiblement pas qu'au début puisque dans le dagoma0.g, je ne vois que du M104 S225 en mode Rapide par exemple pas d'instruction de redescendre à 205° plus loin. Je ne comprends vraiment pas ce +20°C ... c'est pour s'adapter à des vitesses de déplacement plus rapide tu crois ? mais du coup si je met 205° pensant être dans la plage de température du fil (190-220) au final en mode Rapide, ça chauffe trop, je suis au dessus, non ?

Oui, tu sera effectivement au dessus de la plage en rapide, de 5°, ça se tente, ou tu abaisse un peu ta température de départ...

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

moins ton filament sera chaud, moins il sera liquide .... donc plus dur a extruder .

en mode fin la vitesse est largement réduite, donc si ta buse est a 200° ton filament aura le temps de se "liquéfier" a 200° a 100% a l'entrée de buse .

en mode brouillon la vitesse est beaucoup plus rapide, si tes réglages sont bons en fin a 200°,  il n'en sera pas le cas pour le mode brouillon ... le filament, vu sa vitesse d'extrusion n'aura pas le temps de se "liquéfier" pour 200° a 100% mais plutôt vers les 180° (le filament reste moins longtemps au contact du bloc de chauffe) .

 

en gros, plus ton filament restera dans le bloc de chauffe, plus il prendra la température du bloc .... plus vite il passera, moins il chauffera .... donc on chauffe plus pour palier au débit plus élevé  .

 

EDIT : exemple :

tu peux passer ta mains rapidement au dessus d'une flamme car elle n'a pas le temps de te bruler, plus tu vas la laisser, plus ca va te bruler .

Par contre je ne te conseil pas de passer rapidement ta mains devant un chalumeau, tu te brulera directe car plus chaud qu'une flamme de briquet

 

Modifié (le) par PoLoMoD
  • J'aime 2

Partager ce message


Lien à poster
Partager sur d’autres sites

OK merci @PoLoMoD et @plumcake:D

Je comprends tout à fait cette logique mais je trouve que ça ne colle pas avec l'interface de Cura qui propose un profil par filament avec une temperature et un flow. Et si j'arrive à trouver la bonne temperature et le bon flow en mode brouillon par exemple pour un filament je l'enregistre (en retouchant le xml) et du coup, si j'utilise ce profil avec une autre finition, ca colle pas forcément...>:( !

 

Faut peut être que j'ajuste la valeur du <temp_preci> pour que le profil marche avec toutes les finitions ?

Partager ce message


Lien à poster
Partager sur d’autres sites

L'idéal est de trouver la bonne température nominale en mode Fin, là où elle ne sera pas impactée par le <temp_preci> puis de tester en mode standard et brouillon puis de réajuster si besoin... 

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites
Le ‎10‎/‎01‎/‎2016 at 16:25, Benjamin/Dagoma a dit :

Bonjour à tous,

Pour les gens dont la modification de l'offset dans Cura by Dagoma n'a aucun effet, assurez vous de lancer le logiciel en administrateur et que le fichier XML ne soit pas en lecture seule.

Et bon dimanche ;-)

Bonjour à tous,

Je viens d'acquérir mon imprimante et fait mes premiers essais. Je vous passe ce que j'ai rencontré au montage, ce n'est pas le sujet. Mais, comme plusieurs d'entre vous, je devais régler mon offset et le paramètre dans Cura n'avait visiblement aucune influence. En vous lisant, j'ai été vérifier le xml et le fichier dagoma0.g. En fait, le paramètre n'est pris en compte qui si vous cochez l'option 'autre' pour la surface d'impression. J'ai donc une suggestion à faire dans l'interface.... Soit griser le paramètre 'offset en mm' si l'on coche 'Buildtak' ou ' Scotch 3M', soit additionner 'offset en mm' avec la correction correspondant au type de surface et mettre le résultat dans le fichier dagoma0.g. Mais là, je ferai appel à vos compétences... :)

Merci déjà à tous pour toutes les infos intéressantes que je vais trouver ici...

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci richounet, j'arrive a modifier l'offset directement dans cura by dagoma mainrenant.

Par contre j'ai 2 soucis de plus:

Si je veux forcer la t° en mettant autre pla, ca ne change rien au dagoma0.g quelle que soit la valeur mise...

 

Si il y a un accent dans le chemin de destination du dagoma0.g, il y a un message d'erreur: impossible d'enregistrer (on en parle dans un autre topic mais je le remet ici pour centraliser).

 

Avez vous les mêmes soucis que mmi avec la version standard de cura by D v2?

 

 

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 18 heures, lefresh a dit :

Si il y a un accent dans le chemin de destination du dagoma0.g, il y a un message d'erreur: impossible d'enregistrer (on en parle dans un autre topic mais je le remet ici pour centraliser).

 

Les accents sont généralement à éviter dans les noms de dossiers / fichiers, c'est souvent très mal géré (l'accentuation n'existe que dans certaines langues.

De plus, Cura est à l'origine développé pour une langue anglaise, sans accents (ISO 646 certainement).

Citation

ISO 646-variante de référence internationale (IRV, alias ASCII), standard de compatibilité, sans accent, pour le développement de logiciel en anglais ;

Wikipédia : codage des caractères

Partager ce message


Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.


  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...