Aller au contenu

Filament ABS

Benjamin/ex-Dagoma

officiel Cura by Dagoma V2 (Windows)

Messages recommandés

Il y a 4 heures, Stouf a dit :

Les accents sont généralement à éviter dans les noms de dossiers / fichiers, c'est souvent très mal géré (l'accentuation n'existe que dans certaines langues.

De plus, Cura est à l'origine développé pour une langue anglaise, sans accents (ISO 646 certainement).

Wikipédia : codage des caractères

Oui, par défaut je n'en met jamais.

Sauf que la c'est windows qui me l'a rajouté: "Bibliothèque"  et donc quand tu sauvegarde dans "mes documents", t'es marron.....

Si j'tenais l'con qui a fait sauter l'pont mis cet accent...

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour le problème d'accents, cela vient du tracage par la commande print

il suffi de modifier le fichier c:\program Files (x86)\Cura-by-Dagoma\Cura\gui\sceneView.py

à la ligne 326

remplacer

            print 'Save in : ', targetFilename # Dagoma

par

            print 'Save in : ', targetFilename.encode('utf8') # Dagoma

 

 

Capture_accents.JPG

Modifié (le) par Huggy
  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

@Huggy   prosterne.gif

Ca fonctionne chez moi, merci beaucoup.

@Benjamin/Dagoma  Pourrais-tu transmettre  l'info à l'équipe de développement de Cura stp?

 

Pour le problème d'accents, cela vient du tracage par la commande print

il suffi de modifier le fichier c:\program Files (x86)\Cura-by-Dagoma\Cura\gui\sceneView.py

à la ligne 326

remplacer

            print 'Save in : ', targetFilename # Dagoma

par

            print 'Save in : ', targetFilename.encode('utf8') # Dagoma

 

 

Merci.

Modifié (le) par lefresh

Partager ce message


Lien à poster
Partager sur d’autres sites

Le problème d'accentuation se pose également dans le XML : si on met une option avec un accent (ajouter une option "Renforcé" dans remplissage, par exemple), quand on choisit cette option, Cura n'est pas content.

Du coup, même si l'astuce pour le nom des fichiers/dossiers fonctionne (solution très propre, au passage), le souci est plus étendu que ça... Faudrait forcer le UTF8 de partout dans le code python de Cura... Demain j'irai vérifier si les fichiers source python ont bien l'en-tête qui définit l'encodage, avec un peu de chance c'est aussi simple que ça.

Modifié (le) par Stouf

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour le XML, là aussi cela ne vient pas de Cura mais de la fonction de log rajoutée par Dagoma

l'erreur survient lorsque le programme veut écrire le nom de l'option dans le fichier output.txt

Pour corriger, il y a 4 lignes à modifier, pour Filament, Remplissage, Precision et Surface

dans le fichier c:\program Files (x86)\Cura-by-Dagoma\Cura\gui\mainWindow.py

ligne 1353 : remplacer

        print "Filament : ", self.combo_box_1.GetStringSelection()

par

        print "Filament : ", self.combo_box_1.GetStringSelection().encode('utf8')

ligne 1358 : remplacer

       print "Remplissage : ", self.radio_box_2.GetStringSelection()

par

        print "Remplissage : ", self.radio_box_2.GetStringSelection().encode('utf8')

ligne 1361 : remplacer

        print "Precision : ", self.radio_box_1.GetStringSelection()

par         print "Precision : ", self.radio_box_1.GetStringSelection().encode('utf8')

ligne 1381: remplacer

        print "name : ", profile.getProfileSetting('printing_surface_name')

par

        print "name : ", profile.getProfileSetting('printing_surface_name').encode('utf8')

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Suite au fil initié par @Thomas concernant la limitation à 235°C, je me suis aperçu que lorsqu'on saisit une température d'impression, celle-ci n'est pas prise en compte.

Si vous choisissez "Autre PLA", la zone de saisie pour la température est activée mais malheureusement aucun évènement n'est associé à ce contrôle et le calcul n'est pas actualisé.

Lorsqu'on clique sur le bouton, la température est enregistrée dans le profile mais trop tard car après le calcul. Au pire si vous cliquez une deuxième fois, ça marchera

La modif est trop compliquée pour la poster ici, je la transmets à Dagoma. 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

Je n'ai pas encore reçu ma D200 (jeudi si tout va bien), mais je me pose déjà une petite question concernant le logiciel.

Pourriez-vous me dire les rôles des deux dernières cases que l'on peut cocher :

  • Support pour l'impression ?
  • Amélioration de la surface d'adhésion ?

Similairement, dans l'application l'offset (si besoin) que l'on peut saisir est seulement positif ?
Si oui, dans le cas d'un offset négatif il faudra se rendre dans le xml directement ?

Par ailleurs, on peut "orienter la caméra" dans le logiciel (faire tourner le bloc et non pas la pièce) ?

Merci d'avance pour vos réponses !

__
zazeur

Modifié (le) par zazeur

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 29 minutes, zazeur a dit :

Salut @zazeur, mes réponses en commentaire de ton post :

Bonsoir,

Je n'ai pas encore reçu ma D200 (jeudi si tout va bien), mais je me pose déjà une petite question concernant le logiciel.

Pourriez-vous me dire les rôles des deux dernières cases que l'on peut cocher :

  • Support pour l'impression ?
    Les "supports" sont des espèces de colonnes qui vont être automatiquement générées par Cura sous des zones à imprimer "dans le vide"
    tu pourra "dégraffer" très facilement ces colonnes tout de suite après impressions... exemple avec un de mes yoda :

    12278686_10208088565121442_4367614173303
    12274713_10208088565081441_4704026709981

     
  • Amélioration de la surface d'adhésion ?
    Comme son nom l'indique, cette option va améliorer, en l'augmentant, la surface d'une première couche, plus généralement appelée Raft (radeau)
    A cocher pour imprimer une pièce présentant une faible surface d'accroche par rapport à sa taille... Exemple avec mon impression d'un casque de StormTrooper
    où seuls le menton et la nuque ne touchent le plateau, Cura à automatiquement généré une surface d'accroche plus importante autour de ces contacts là, éliminant le risque de voir la pièce ce décoller en cours d'impression...


    12241324_10208037614207701_3287768984701
  •  

Similairement, dans l'application l'offset (si besoin) que l'on peut saisir est seulement positif ?
Si oui, dans le cas d'un offset négatif il faudra se rendre dans le xml directement ?

Par ailleurs, on peut "orienter la caméra" dans le logiciel (faire tourner le bloc et non pas la pièce) ?

Oui, tu peux tout faire "bouger" !! Une fois que tu as charger un fichier et qu'il aparait sur le plateau :

- Clic gauche pour sélectionner la pièce et faire apparaitre 3 icones qui te permettrons de la faire pivoter sur tous les axes, de jouer sur son echelle, de la dupliquer en miroir sur les 3 axes
- Clic gauche maintenu en te déplaçant déplacera dans le plan XY la pièce sur la plateau
- La molette te permet de zoomer-dézoomer
- Clic droit fait apparaitre le menu contextuel proposant plein d'action que je te laisse le soin de découvrir
- Clic droit maintenu en te déplaçant fera tourner la caméra

En espérant avoir répondu à tes questions...

Merci d'avance pour vos réponses !

__
zazeur

 

Modifié (le) par plumcake

Partager ce message


Lien à poster
Partager sur d’autres sites

Coucou Plumcake,

Merci d'avoir expliqué des choses qui peuvent paraitre évidentes pour certains et de ne pas avoir envoyé bouler un débutant.

C'est très honorable de ta part ...

A+

Max

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut @plumcake,

Merci pour cette réponse très complète et imagée !

Bizarre que je n'avais pas réussi à faire tourner la caméra si simplement.
Enfin, pas de soucis, ça fonctionne maintenant.

Concernant les deux options (support / surface), c'est normal que cela n'apparaisse pas à la prévisualisation ?
Ça permettrait d'avoir une bonne idée de ce qui serait imprimé en supplément (emplacement et quantité, visuellement) :S

Enfin, j'ai une dernière petite question que j'avais oublié hier.
Dans le coin inférieur droit on voit des données :
1454517194-dag.png

Je comprend que la première ligne correspond au temps requis. Mais qu'en est-il des deux autres ?

2.
Longueur de fil requis et son équivalent en poids ?
Si oui, ne serait-ce pas incorrect pour l'un ou l'autre ?
En effet si je calcul pour une bobine de 750g cela voudrait dire qu'elle contient 750/9*2,91 = 242,5m de fil.
Je n'en ai pas encore eu sous les mains, demain. Mais ça me parait énorme en terme de longueur. Enfin, ça doit être car je ne me rends pas bien compte de ce que ça "consomme".

3.
Pas la moindre idée pour le coup.

Merci d'avance pour vos réponses !

Bonne soirée.

__
zazeur

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 6 heures, zazeur a dit :

Salut @plumcake,

Merci pour cette réponse très complète et imagée ! YAPADEKOI !

Bizarre que je n'avais pas réussi à faire tourner la caméra si simplement.
Enfin, pas de soucis, ça fonctionne maintenant. On passe tous à côté de certaines choses !!

Concernant les deux options (support / surface), c'est normal que cela n'apparaisse pas à la prévisualisation ?
Ça permettrait d'avoir une bonne idée de ce qui serait imprimé en supplément (emplacement et quantité, visuellement) :S
Cura by Dagoma a été voulu le plus simple possible, pour aller à l'essentiel, peut être le besoin d'en afficher plus n'a pas été ressenti, ça ne me choque pas.
Au départ, tu peux t'y fier les yeux fermé, et le jour où tu sera confronté à une impression que cette version ne pourra "honoré" ou que tu souhaites mettre les mains un peu plus dans le camboui des paramètres, tu te tournera alors vers la version non customisé, perso j'en suis revenu et ce Cura by Dagoma v2 agrémenté de quelques profils complémentaires me convient parfaitement pour le moment ! A toi de te faire une opinion à l'usage.

Enfin, j'ai une dernière petite question que j'avais oublié hier.
Dans le coin inférieur droit on voit des données :
1454517194-dag.png

Je comprend que la première ligne correspond au temps requis. Mais qu'en est-il des deux autres ?
Longueur de fil requis et son équivalent en poids ?
Si oui, ne serait-ce pas incorrect pour l'un ou l'autre ?
En effet si je calcul pour une bobine de 750g cela voudrait dire qu'elle contient 750/9*2,91 = 242,5m de fil.
Je n'en ai pas encore eu sous les mains, demain. Mais ça me parait énorme en terme de longueur. Enfin, ça doit être car je ne me rends pas bien compte de ce que ça "consomme".

Le calcul se tient, sachant que pour 1kg de PLA Ø1.75, tu as environ 330m de filament...
Une bobine de 750gr donne bien presque 250m, du coup, 9gr fait à peine plus de 2.91m.
Certes, c'est pas ua poil de cul près mais ça donne une idée !
Idem pour le temps, je ne me suis pas amusé à chronométrer pour de vrai, mais c'est à peu près ça...

3.
Pas la moindre idée pour le coup.
Et bien en toute honnêteté, pas la moindre idée non plus de à quoi peuvent bien correspondre ces valeurs !!

Merci d'avance pour vos réponses ! YA(toujours)PADEKOI !

Bonne soirée.

__
zazeur

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Dans le fichier XML est indiqué le prix au kilo et le prix au mètre (ne me demandez pas pourquoi)

le premier est à 46 €/kg et le second 1.75€/m

on retombe bien sur les valeurs 0,41 € et 0,51€

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 6 heures, Huggy a dit :

Oui !!! le coup de massue O.o

coup de massue 9_9 Il faudrait ajouter le temps fois le prix du kWh fois la consommation de la bête (avec ou sans lit chauffant) pour que ça commence à piquer un peu.

Partager ce message


Lien à poster
Partager sur d’autres sites

Par contre je sais pas si vous avez le soucis aussi. Je me suis décidé à tester le polyflex que j'ai reçu y a pas longtemps, j'ai fait quelques tests d'impressions et le résultat était dégueulasse. Heureusement grâce à octoprint on a un aperçu de la température d'impression et j'ai vu que la tête était à 250°c pour ce fil. J'ai checké sur le site de polymaker et ils donnent entre 220 et 235 pour les t° d'impressions. Du coup je suis descendu à 225°c et ça a été tout de suite beaucoup mieux. Y à que moi ou pour vous aussi ça vous arrive d'avoir des températures incohérente avec le fil utilisé?

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui dans le XML, le polyflex est à 230°C,  si tu choisis le mode rapide ça rajoute 20°C donc 250°C

par contre en normal ça ne rajoute rien

Modifié (le) par Huggy

Partager ce message


Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.


  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...